Author Topic: Media Director lost Media Drives after Update - Core/Hybrid Sees/Plays Them OK  (Read 832 times)

rocketlynx

  • Veteran
  • ***
  • Posts: 136
    • View Profile
After a successful update of the latest 810-Beta-2 release, my Core/Hybrid can still see and play all of my Media (ripped DVD Movies and Music) stored on my (2) 1.5TB drives in my Core, however, after updating my Diskless MD in my Family Room, all works the same except, it no longer can play Movies or Music.  It sees all of the media, including the artwork and info, however, when I select any Movie or Music file, it never starts and sometimes I can catch an error in the upper left of the display that says "file not found".  I've checked and the libdvdcss2 and w32codecs are still installed.  I can even insert a DVD movie or a music CD into the CD-DVD R/W drive in the Media Director and the movie or CD will play correctly as before which proves it's not a libdvdcss or w32codecs problem.

I've tried rebuilding the MD from the Admin and it did not work, I then tried rebuilding the Diskless image on the core and deleting and recreating the MD from scratch and I ended up with the same problem, a Media Directory that can see everything, even my cameras, but still can see all of my Media, just can't start or play anything.

If anyone has had the same problem or has a solution, short of reinstalling the entire Core and system, please help.

Thanks for all of the LinuxMCE support in the past,

Charles
« Last Edit: June 01, 2010, 05:52:00 pm by rocketlynx »

gadget

  • Veteran
  • ***
  • Posts: 136
    • View Profile
Dont know if it is related but see this thread.

forum.linuxmce.org/index.php?topic=9873.0

gadget

rocketlynx

  • Veteran
  • ***
  • Posts: 136
    • View Profile
This completely fixed it. Below, for reference,  is the quote and the link and below that is the pertinent information from the reply in the link that corrected the problem.

Dont know if it is related but see this thread.

forum.linuxmce.org/index.php?topic=9873.0

gadget

 * WARNING: This changes the default samba behaviour. For security
    reasons, it is no longer possible to use wide links and UNIX
    extensions at the same time. After applying this security update, wide
    links will be disabled automatically as UNIX extensions are turned on
    by default. If wide links are required, you may re-enable them by
    adding "unix extensions = no" to the [global] section of
    the /etc/samba/smb.conf configuration file.

Apparently LinuxMCE depends on that feature, so try changing unix extensions = yes to unix extensions = no in the /etc/samba/smb.conf config file.  If that fixes it, don't forget to update the template in /usr/pluto/templates/smb.conf.template as well.

I changed unix extensions = yes to unix extensions = no in the /etc/samba/smb.conf config file on the core and then changed unix extensions = yes to unix extensions = no in the /etc/samba/smb.conf config file on the media directors and rebooted the whole system and that corrected the media director's ability to play media (movies and music) again.

Thanks Zaerc and Gadget for your guidance and support. Great system!

Regards,
Charles

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5476
  • DOES work for LinuxMCE.
    • View Profile
This fix has been applied to recent snapshots, so this shouldn't surface again.

-Thom

rocketlynx

  • Veteran
  • ***
  • Posts: 136
    • View Profile
This fix has been applied to recent snapshots, so this shouldn't surface again.

-Thom

Thom, as always, your help and support is very much appreciated.

Charles