Author Topic: Mythtv upgrade 0.23 - video frame buffering failed too many times  (Read 3713 times)

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Hi All,

Having a few issues after the 0.23 update - wondering if anyone can help.

I can watch live TV, but only for a minute or two. After that it crashes to the error "video frame buffering failed too many times".

Using a HDhomerun on a Hybrid. Was working fine until the upgrade from 0.22 to 0.23.

I tried deleting and reading the cards, rescanning channels just in case (100% signal btw). Reload/Reboot. No change.

Checked the mythtv backend logs and see this error a lot, assuming it might be the cause?
Code: [Select]
2010-05-28 23:47:02.143 MainServer::HandleVersion - Client speaks protocol version 56 but we speak 50!
Does this means I have some backend/front end mismatch?

I dumped a few more lines in pastebin if this makes sense to anyone:
http://pastebin.com/R0wYpxEr

Any ideas?

Cheers,
WR

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #1 on: May 28, 2010, 05:06:52 pm »
Quote
2010-05-28 23:47:02.143 MainServer::HandleVersion - Client speaks protocol version 56 but we speak 50!

This indicates your pluto_mythtv_plugin is the wrong version. (hasn't been updated)

Maybe try installing it manually.


HTH

Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #2 on: May 29, 2010, 04:38:29 am »
Thanks Tim,

I tried:
Code: [Select]
sudo apt-get install -f pluto-mythtv-plugin?

And get is this:
Code: [Select]
Reading package lists... Done
Building dependency tree
Reading state information... Done
pluto-mythtv-plugin is already the newest version.
The following packages were automatically installed and are no longer required:
  libx264-79 libmath-round-perl
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.

"pluto-mythtv-plugin is already the newest version"

Does this mean it is already correct or is there another way to install the plugin?

EDIT: just realised it appears to be the client which is 56, and the backend which is 50?

Can I run sudo apt-get install mythtv-backend or will that break it further?

EDIT 2: Tried sudo apt-get install mythtv-backend, no change... grrr.

Anyone got any suggestions? Guess I might have to reinstall...

Cheers,
WR
« Last Edit: May 29, 2010, 04:15:49 pm by wombiroller »

theteju

  • Veteran
  • ***
  • Posts: 134
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #3 on: May 29, 2010, 07:04:13 pm »
what type of tuner card do you have?

MANDINGO

  • Guru
  • ****
  • Posts: 204
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #4 on: May 30, 2010, 05:17:28 am »
wombiroller

jump into the irc and lets fix this issue

Thanks
Mandingo
For a Current List of Plug and Play Capture Cards/Devices
http://wiki.linuxmce.org/index.php/Capture_Cards

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #5 on: May 30, 2010, 11:32:28 am »
Hey theteju - as above using a HDhomerun on a Hybrid.

Thanks Mandingo. I'll try and track you down :-)

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #6 on: June 01, 2010, 06:18:03 pm »
wombiroller:
I have had the same messages in different mythtv versions in lmce. The solution has always been very simple ..... leave it alone.

I come back to it after an hour or so and it just works. Not really a fix but it has worked for me and others.
http://forum.linuxmce.org/index.php?topic=9857.0
Barney

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #7 on: June 02, 2010, 07:38:36 am »
wombiroller:
I have had the same messages in different mythtv versions in lmce. The solution has always been very simple ..... leave it alone.

I come back to it after an hour or so and it just works. Not really a fix but it has worked for me and others.
http://forum.linuxmce.org/index.php?topic=9857.0
Barney

Thx b4rney. It hasn't fixed it for me I am afraid. I have been trying off and on for ~2 weeks... regular as clockwork :(

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1396
  • If it ain't broke, tweak it
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #8 on: June 02, 2010, 03:09:19 pm »
This probably isn't going to be helpful, but just thought I'd mention it in case it helps us with the bigger picture.

I see this error message if I start myth, and the initial channel is one that is not currently playing any shows e.g. BBC3 during the day. However, if I change the channel straight away (before the error comes up), I don't see the error.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #9 on: June 02, 2010, 03:57:18 pm »
nah - thanks, but it was all screwed up. I went to watch a recording today and every recording since the upgrade to 0.23 seems to have switched, half way through the recording - to another channel! Weird.

Anyway - I just downloaded a new snapshot and am half-way through the setup wizard... hopefully that will be the end of it :)

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #10 on: June 04, 2010, 03:32:13 am »
Hi All,

Having a few issues after the 0.23 update - wondering if anyone can help.

I can watch live TV, but only for a minute or two. After that it crashes to the error "video frame buffering failed too many times".

Using a HDhomerun on a Hybrid. Was working fine until the upgrade from 0.22 to 0.23.

I tried deleting and reading the cards, rescanning channels just in case (100% signal btw). Reload/Reboot. No change.

Checked the mythtv backend logs and see this error a lot, assuming it might be the cause?
Code: [Select]
2010-05-28 23:47:02.143 MainServer::HandleVersion - Client speaks protocol version 56 but we speak 50!
Does this means I have some backend/front end mismatch?

I dumped a few more lines in pastebin if this makes sense to anyone:
http://pastebin.com/R0wYpxEr

Any ideas?

Cheers,
WR


I had this error when I was screwing around with things I shouldn't, and it was due to me telling LMCE not to use sda1. Evidently it is very particular about where it records. It looks like your issue is different, but thought I would throw it out there. Could watch tv for a minute, then it would throw that error. I am also using the hdhomerun.
I never quit... I just ping out.

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Mythtv upgrade 0.23 - video frame buffering failed too many times
« Reply #11 on: June 04, 2010, 11:06:58 am »
Thx l3mce. Yeah I had not changed the recording locations. Anyway - I have installed the snapshot from the 1st June. While I am still working through some issues trying to get everything up and running, the HDhomerun is now working with no crashes. Yay! :)