Author Topic: Tester for updateMedia id3 unicode fix needed  (Read 3908 times)

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Tester for updateMedia id3 unicode fix needed
« Reply #15 on: June 20, 2010, 09:53:54 pm »
We need to be sure that any tags we write in the web admin, get written to the files, especially stuff that does not fit in the schema, such as media type/subtype. This is critical.

The format of these GEOB tags is data passed in from SerializeClass

-Thom

murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Re: Tester for updateMedia id3 unicode fix needed
« Reply #16 on: June 23, 2010, 07:52:37 pm »
Next one. Video and empty mp3 files shouldn't crash any more.

UpdateMedia.gz (1.5 MB)

does not go through for all files.....UpdateMedia.log doesn't contain any entries.

Only first file is processed

sudo -u root /usr/pluto/bin/UpdateMedia -d \"/home/public/data/audio/ST31000525SV (sdd1) on dcerout [469]/a-z/Ina Müller\"
« Last Edit: June 28, 2010, 11:47:30 pm by murcel »

KingCrab

  • Regular Poster
  • **
  • Posts: 45
    • View Profile
Re: Tester for updateMedia id3 unicode fix needed
« Reply #17 on: June 27, 2010, 08:17:49 pm »
I want to say thanks to all who are helping me testing this stuff!

There was a bug with reading of user defined urls. Should be fixed and in addition flac pictures should work now, too.

UpdateMedia.gz (1.5 MB)


murcel

  • Guru
  • ****
  • Posts: 198
    • View Profile
Re: Tester for updateMedia id3 unicode fix needed
« Reply #18 on: June 28, 2010, 09:04:18 pm »
I want to say thanks to all who are helping me testing this stuff!

There was a bug with reading of user defined urls. Should be fixed and in addition flac pictures should work now, too.

UpdateMedia.gz (1.5 MB)


this file is working now, but please check your pm.

cfernandes

  • Guru
  • ****
  • Posts: 291
    • View Profile
    • my company web site
Re: Tester for updateMedia id3 unicode fix needed
« Reply #19 on: July 17, 2010, 09:43:07 pm »
hi ,

i have some errors  like this

5      07/17/10 16:39:55.564        # PlutoMediaFile STARTED: dir /home/public/data/audio file Alexandre Pires - Eva, Meu Amor.mp3 <0xb636d6c0>
10      07/17/10 16:39:55.564        # ID3FileHandler::LoadAttributes: loading 0 attributes in the attribute file /home/public/data/audio/Alexandre Pires - Eva, Meu Amor.mp3 <0xb636d6c0>
10      07/17/10 16:39:55.598        # LoadPlutoAttributes: pluto attributes loaded (from id3 file - general object tag) 0 <0xb636d6c0>
/usr/pluto/bin/UpdateMedia: symbol lookup error: /usr/pluto/bin/UpdateMedia: undefined symbol: _ZNK6TagLib5ID3v218PopularimeterFrame5emailEv