Author Topic: [SOLVED] Mythtv problem after update  (Read 3493 times)

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
[SOLVED] Mythtv problem after update
« on: May 23, 2010, 05:00:23 am »
Hia,
today i did an apt-get update & upgrade, and after that, mythtv is not working anymore.
When i start TV, i get the message "MythTV seems to have died. I'm trying to reset it now"
Anyone got this problem?
Code: [Select]
08      05/23/10 0:04:04.428            Received Message from 21 (OnScreen Orbiter / Living) to 10 (Media Plug-in / Living), type 1 id 74 Command:Bind to Media Remote, retry none, parameters: <0x727b2b90>                                    
08      05/23/10 0:04:04.428              Parameter 2(PK_Device):  <0x727b2b90>                                        
08      05/23/10 0:04:04.428              Parameter 3(PK_DesignObj):  <0x727b2b90>                                      
08      05/23/10 0:04:04.428              Parameter 8(On/Off): 0 <0x727b2b90>                                          
08      05/23/10 0:04:04.428              Parameter 25(PK_Text):  <0x727b2b90>                                          
08      05/23/10 0:04:04.428              Parameter 39(Options):  <0x727b2b90>                                          
08      05/23/10 0:04:04.428              Parameter 45(PK_EntertainArea): 1 <0x727b2b90>                                
08      05/23/10 0:04:04.428              Parameter 63(PK_Text_Synopsis):  <0x727b2b90>                                
08      05/23/10 0:04:04.428              Parameter 159(PK_Screen):  <0x727b2b90>                                      
08      05/23/10 0:04:04.448            Received Message from 21 (OnScreen Orbiter / Living) to 50 (USB UIRT 0038 / Living), type 1 id 687 Command:Set Screen Type, retry none, parameters: <0x72fb3b90>                                        
08      05/23/10 0:04:04.448              Parameter 48(Value): 0 <0x72fb3b90>                                          
05      05/23/10 0:04:22.011            Socket::ReceiveData 0xa1a0fb8 failed, bytes left 0 start: 2230000 1: 0 1b: 0 2: 0 2b: 0 m_Socket: 171 Incoming_Conn Socket 171 127.0.0.1EVENT 32 T=13 Event #32 <0x697a0b90>                            
05      05/23/10 0:04:22.011            Socket::ReceiveString2 ReceiveData failed m_Socket: -1 Incoming_Conn Socket 171 127.0.0.1EVENT 32 T=13 Event #32 <0x697a0b90>                                                                          
05      05/23/10 0:04:22.011            TCPIP: Closing connection to 32 (Router Dev #0) 0xa1a0fb8 m_Socket: -1 <0x697a0b90>                                                                                                                    
05      05/23/10 0:04:22.011            Router::RemoveAndDeleteSocket 0xa1a0fb8 32 <0x697a0b90>                        
05      05/23/10 0:04:22.011            Socket::ReceiveData 0xa1b4568 failed, bytes left 0 start: 2230000 1: 0 1b: 0 2: 0 2b: 0 m_Socket: 173 Incoming_Conn Socket 173 127.0.0.1EVENT 32 T=13 Event #32 <0x6a7a2b90>                            
05      05/23/10 0:04:22.011            Socket::ReceiveString2 ReceiveData failed m_Socket: -1 Incoming_Conn Socket 173 127.0.0.1EVENT 32 T=13 Event #32 <0x6a7a2b90>                                                                          
05      05/23/10 0:04:22.011            TCPIP: Closing connection to 32 (Router Dev #0) 0xa1b4568 m_Socket: -1 <0x6a7a2b90>                                                                                                                    
05      05/23/10 0:04:22.011            Router::RemoveAndDeleteSocket 0xa1b4568 32 <0x6a7a2b90>                        
05      05/23/10 0:04:28.054            Socket::ReceiveData 0xa1b4bf0 failed, bytes left 0 start: 2320000 1: 0 1b: 0 2: 0 2b: 0 m_Socket: 171 MythPluginSocket <0x9d9fbb90>                                                                    
01      05/23/10 0:04:28.054            MythBackEnd_Socket::Close <0x9d9fbb90>                                          
01      05/23/10 0:04:28.106            MythBackEnd_Socket::SendMythString sent MYTH_PROTO_VERSION 56 but error getting response <0x9d9fbb90>                                                                                                  
01      05/23/10 0:04:28.106            MythBackEnd_Socket::Connect couldn't send MYTH_PROTO_VERSION m_bConnected=false <0x9d9fbb90>                                                                                                            
01      05/23/10 0:04:28.106            MythBackEnd_Socket::ProcessSocket error reconnect 0 <0x9d9fbb90>                
05      05/23/10 0:04:28.158            Socket::ReceiveData 0xa1b4568 failed, bytes left 0 start: 2320000 1: 0 1b: 0 2: 0 2b: 0 m_Socket: 171 MythPluginSocket <0x9d9fbb90>                                                                    
01      05/23/10 0:04:28.158            MythBackEnd_Socket::Close <0x9d9fbb90>                                          
01      05/23/10 0:04:28.212            MythBackEnd_Socket::SendMythString sent MYTH_PROTO_VERSION 56 but error getting response <0x9d9fbb90>                                                                                                  
01      05/23/10 0:04:28.212            MythBackEnd_Socket::Connect couldn't send MYTH_PROTO_VERSION m_bConnected=false <0x9d9fbb90>                                                                                                            
05      05/23/10 0:04:28.266            Socket::ReceiveData 0xa1b4bf0 failed, bytes left 0 start: 2320000 1: 0 1b: 0 2: 0 2b: 0 m_Socket: 171 MythPluginSocket <0x9d9fbb90>                                                                    
01      05/23/10 0:04:28.266            MythBackEnd_Socket::Close <0x9d9fbb90>                                          
01      05/23/10 0:04:28.319            MythBackEnd_Socket::SendMythString sent MYTH_PROTO_VERSION 56 but error getting response <0x9d9fbb90>                                                                                                  
01      05/23/10 0:04:28.319            MythBackEnd_Socket::Connect couldn't send MYTH_PROTO_VERSION m_bConnected=false <0x9d9fbb90>                                                                                                            
01      05/23/10 0:04:28.319            MythBackEnd_Socket::SendMythString failed to reconnect <0x9d9fbb90>            
01      05/23/10 0:04:28.319            MythTV_PlugIn::ConfirmMasterBackendOk -- lost communication with it.  Forcing it to die <0x9d9fbb90>
08      05/23/10 0:04:28.320            Received Message from 39 (MythTV Plug-In / Living) to 15 (App Server / Living),type 1 id 67 Command:Spawn Application, retry none, parameters: <0x9f1feb90>
08      05/23/10 0:04:28.320              Parameter 13(Filename): /usr/pluto/bin/ForciblyKillProcess.sh <0x9f1feb90>
08      05/23/10 0:04:28.320              Parameter 50(Name): killmyth <0x9f1feb90>
08      05/23/10 0:04:28.320              Parameter 51(Arguments): mythbackend <0x9f1feb90>
 
TIA,
Paulo

« Last Edit: May 24, 2010, 08:17:56 pm by pw44 »

MANDINGO

  • Guru
  • ****
  • Posts: 204
    • View Profile
Re: Mythtv problem after update
« Reply #1 on: May 23, 2010, 06:45:16 am »
We are in the process of migrating to .23 and had a few bugs to workout

Please hold out as we will make the announcement for it, some of the files are not in the repo as off yet.

if you cant wait a few hours !!!!!!! yes i said a few hours then you know where to find us
in the channels

Thanks

Mandingo 
For a Current List of Plug and Play Capture Cards/Devices
http://wiki.linuxmce.org/index.php/Capture_Cards

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Mythtv problem after update
« Reply #2 on: May 23, 2010, 12:19:03 pm »
No problem.. i can wait till is done.
Thx!

vbman1

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Mythtv problem after update
« Reply #3 on: May 23, 2010, 12:44:29 pm »
does this mean mythtv is fixed???

bongowongo

  • wants to work for LinuxMCE
  • **
  • Posts: 826
    • View Profile
Re: Mythtv problem after update
« Reply #4 on: May 23, 2010, 01:40:16 pm »
That could mean that.
Still waiting for latest working snapshot to testdrive it.

MANDINGO

  • Guru
  • ****
  • Posts: 204
    • View Profile
Re: Mythtv problem after update
« Reply #5 on: May 23, 2010, 08:52:21 pm »
 ;D

Yes mythtv is fixed

Thanks

Mandingo
For a Current List of Plug and Play Capture Cards/Devices
http://wiki.linuxmce.org/index.php/Capture_Cards

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Mythtv problem after update
« Reply #6 on: May 24, 2010, 12:56:40 am »
Hi Mandingo, thx for the info.
Which myth packages shall be updated?
I had the preferences file in /etc/apt (for 0.22) and removed this preferences file.
After an apt-get update and apt-get upgrade, no packages were upgraded, only the pluto-myth.
Is there anything else that should be upgraded?
TIA

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: Mythtv problem after update
« Reply #7 on: May 24, 2010, 01:03:43 am »
Hi Mandingo, thx for the info.
Which myth packages shall be updated?
I had the preferences file in /etc/apt (for 0.22) and removed this preferences file.
After an apt-get update and apt-get upgrade, no packages were upgraded, only the pluto-myth.
Is there anything else that should be upgraded?
TIA

Hi

I found the same thing..
However when I did a "apt-get dist-upgrade" it did pull down the myth packages.
Due to the version rename your system that it is downgrading from 22 to 23..
I just said yes and it was happy to install.
I ran into a DB problem that was fixed. Just follow this link. http://svn.linuxmce.org/trac.cgi/ticket/690
Hope this helps
C

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Mythtv problem after update
« Reply #8 on: May 24, 2010, 01:43:03 am »
Hi,
did not work for me... still with 0.22 (mythbackend MythTV Branch    : branches/release-0-22-fixes and mythfrontend MythTV Branch    : branches/release-0-22-fixes)
TIA

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: Mythtv problem after update
« Reply #9 on: May 24, 2010, 02:56:29 am »
Did you remove your pinnning?
under /etc/apt/ there is a preferences file. If you open that is there anything about myth in there?
If there is remove it and the update and dis-upgrade.
See if that worked.
C

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Mythtv problem after update
« Reply #10 on: May 24, 2010, 03:16:38 am »
yes, i did, and also runned apt-get dist-upgrade.....
no luck.... :(

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: Mythtv problem after update
« Reply #11 on: May 24, 2010, 04:12:03 am »
you have run a apt-get update first? right.

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: Mythtv problem after update
« Reply #12 on: May 24, 2010, 06:12:14 am »
I just want to confirm the new mythtv version is ok, I removed the following lines from "/etc/apt/preferences" on Core & Mds
Code: [Select]
Package: mythtv mythtv-frontend mythtv-backend mythtv-common mythtv-database mythtv-transcode-utils mythweb libmyth-perl
Pin: version 2:0.22*
Pin-Priority: 1001
Then run apt-get update & apt-get dist-upgrade, and my new version is
Code: [Select]
mythtv-backend = 0.23-0.1
mythtv-common = 0.23-0.1
mythtv-database = 0.23-0.1
mythtv-doc = 0.23-0.1
mythtv-frontend = 0.23-0.1
mythweb = 0.23-0.0
Cheers |[BEER]
Charlie,

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: Mythtv problem after update
« Reply #13 on: May 24, 2010, 06:40:06 am »
I just want to confirm the new mythtv version is ok, I removed the following lines from "/etc/apt/preferences" on Core & Mds
Code: [Select]
Package: mythtv mythtv-frontend mythtv-backend mythtv-common mythtv-database mythtv-transcode-utils mythweb libmyth-perl
Pin: version 2:0.22*
Pin-Priority: 1001
Then run apt-get update & apt-get dist-upgrade, and my new version is
Code: [Select]
mythtv-backend = 0.23-0.1
mythtv-common = 0.23-0.1
mythtv-database = 0.23-0.1
mythtv-doc = 0.23-0.1
mythtv-frontend = 0.23-0.1
mythweb = 0.23-0.0

Jipp that looks good.
C

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Mythtv problem after update
« Reply #14 on: May 24, 2010, 12:38:10 pm »
I'm getting the following error on apt-get update output.
Can this be related with th non upgrade top 0.23?

Code: [Select]
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/universe/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.46 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/universe/non-free/binary-i386/Packages.gz  404 Not Found [IP:91.189.88.46 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/universe/contrib/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.46 80]

E: Some index files failed to download, they have been ignored, or old ones used instead.