Author Topic: DHCP leases Foscam IP camera problem  (Read 28114 times)

ladekribs

  • Veteran
  • ***
  • Posts: 83
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #45 on: December 09, 2010, 08:48:30 pm »
Hi,

In PW44 case his camera communicates via the "Wifi AP: D-Link DWL-2100AP" ie ARP nefore it is linked to the core, that might be the reason it works for him.

guess you already figured that out :-)

by the way it worked to use an external demo camera as you said barney

br stefan
« Last Edit: December 09, 2010, 08:50:38 pm by ladekribs »

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1393
  • If it ain't broke, tweak it
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #46 on: December 09, 2010, 09:41:17 pm »
@pw44 - could you please confirm whether your Foscams are wired or wireless please? I assumed you were talking wired.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #47 on: December 09, 2010, 09:42:54 pm »
My foscam is wireless connected.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1393
  • If it ain't broke, tweak it
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #48 on: December 09, 2010, 10:36:54 pm »
OK. I am trying to do this wired.

It would seem that setting static IPs has not worked for me. When I apply the static IP, the following is generated...

IP Addr - 192.168.80.139
Subnet Mask - 255.255.255.0
Gateway - 192.168.80.1
DNS Server - 192.168.80.1

...but it doesn't solve the problem. If I try to put in the Gateway and DNS1 (86.28.XXX.X and 194.168.4.100 respectively, from web admin), then the web page/utility gives me the error - this has been the cause of that error all along.

Why is 86.28.XXX.X an "illegal" gateway?

Cheers,
Matt.
« Last Edit: December 10, 2010, 12:01:30 pm by purps »
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

ladekribs

  • Veteran
  • ***
  • Posts: 83
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #49 on: December 10, 2010, 08:40:32 am »
@purps because you want the traffic to go to your core, not to the dns server

br Stefan

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1393
  • If it ain't broke, tweak it
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #50 on: December 10, 2010, 11:57:17 am »
So would you say that the Gateway and DNS Server that was automatically specified by the Foscam utility...

Gateway - 192.168.80.1
DNS Server - 192.168.80.1

...is correct? If not, is there anything else I can try?

Cheers,
Matt.

EDIT: In web admin the Gateway and DNS1 are 86.28.XXX.X and 194.168.4.100 respectively.
« Last Edit: December 10, 2010, 12:10:06 pm by purps »
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

ladekribs

  • Veteran
  • ***
  • Posts: 83
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #51 on: December 10, 2010, 12:30:26 pm »
these looks correct:

IP Addr - 192.168.80.139
Subnet Mask - 255.255.255.0 - masking: what is left on the rightmost dot is outside(mostly internet) and right of dot is inside
Gateway - 192.168.80.1 - where you want all traffic to go(you want all to go via the core)
DNS Server - 192.168.80.1 - core will act as a proxy for your inside clients requests.

one test we could do is to setup a std kubuntu server with the same dhcp server as in linuxmce installed and see if the foscam fails the same way.

I will also test port forwarding on the local net


BR Stefan

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1393
  • If it ain't broke, tweak it
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #52 on: December 10, 2010, 01:02:42 pm »
Thank you for confirming, Stefan.

I can therefore confirm that setting up static IPs (for a wired setup) does not work.

I have a funny feeling that it would probably work on a standard Kubuntu server, as Barney has it working using a normal router; an approach that I now have no choice but to take in order to get this working before Christmas.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #53 on: December 10, 2010, 04:42:45 pm »
Purps,

My camera has been rock solid on my external router for two days now. Using fixed IP address (set in the foscam web admin) on my external network, with a wired connection.

Are you still getting errors when you try to set the static IP on the camera?

Barney

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1393
  • If it ain't broke, tweak it
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #54 on: December 10, 2010, 04:56:34 pm »
Hi Barney,

I am going to attempt the external router approach next; I have little choice. Hopefully it will work (not that I don't trust you ;)).

Regarding the error, see my previous post...

Quote
It would seem that setting static IPs has not worked for me. When I apply the static IP, the following is generated...

IP Addr - 192.168.80.139
Subnet Mask - 255.255.255.0
Gateway - 192.168.80.1
DNS Server - 192.168.80.1

...but it doesn't solve the problem. If I try to put in the Gateway and DNS1 (86.28.XXX.X and 194.168.4.100 respectively, from web admin), then the web page/utility gives me the error - this has been the cause of that error all along.

Why is 86.28.XXX.X an "illegal" gateway?
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #55 on: December 10, 2010, 05:03:02 pm »
@Matt,

Sorry ... missed that.

Your gateway (and usually dns) needs to be on the same subnet, but I guess you figured that out already!

@stefan ... I'd be interested to see the results of a standard kubuntu dhcp server test. Another useful tool I just read about is arpwatch. Just in case it is an arp problem.

Barney

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1393
  • If it ain't broke, tweak it
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #56 on: December 10, 2010, 07:41:50 pm »
Truth be told Barney, I am not familiar with many of these terms. So what you and Stefan are saying is that the gateway and DNS basically need to be in the format 192.168.XXX.X, and not the "external looking" one.

I will try it using 192.168.80.1 for the gateway and use DNS1 from web admin for DNS on the Foscam, but I don't have much hope.

FYI I noticed on the utility that you run in windows that there is an option (when you right-click on the camera) to "flush ARP". Not sure if that's relevant, but thought I'd mention it.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #57 on: December 10, 2010, 09:53:00 pm »
Hi Matt,

It is confusing. In LMCE we often refer to internal and external networks. The internal address is always 192.168.80.X. This is the internal subnet used by LMCE.

When we talk about the external network we actually mean the home adsl network. In your case I think your home network is 192.168.4.X.

Confusingly these are both private networks.
http://en.wikipedia.org/wiki/Private_network

You need to attach the camera to the external network.

This means an ip address in the 192.168.4.X network.
Subnet mask 255.255.255.0
Gateway 192.168.4.100
DNS 192.168.4.100

The 192.168.4.100 is your cable modem which acts as your gateway/dns server.
Hope this helps.
Barney

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1393
  • If it ain't broke, tweak it
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #58 on: December 11, 2010, 10:54:23 am »
Well the camera is working, on the external network as you described. Very glad that it is working (thank you!), but frustrated at the same time that we couldn't get it working on the internal network.... and now I've got to go out an buy another wireless access point also.

I am curious as to why you suggested 192.168.4.X. for my home network? Is this based on the DNS1 address I found in web admin? What does that have to do with my home network? Not having a go at you, I am genuinely curious!

My Netgear router admin page is accessed via 192.168.1.1, so I put this in for both gateway and DNS - is that the wrong way to do it? Whilst it is working now, I don't want it to be unreliable because I messed up the settings! Subnet 225.225.225.0 as per usual and the actual IP 192.168.1.X.

Cheers,
Matt.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Re: DHCP leases Foscam IP camera problem
« Reply #59 on: December 12, 2010, 03:33:54 am »
I picked up a few foscams to test this problem with. On mine, I can watch the mjpeg stream directly in a browser by going to <ip_address>/videostream.cgi from any computer in the network.
However, it will not work at all under motion wrapper (I do have several other mjpeg cameras running fine under motion wrapper also). For these foscams, I only get a gray screen saying that the connection has been lost.

I have been doing a lot of reading on ARP problems - there is a good read here:
http://linux-ip.net/html/ether-arp.html

ARP Flux is apparently a common problem when running multiple network cards in linux.  I have tried both setting static ARP table entries as well as setting the arp_filter sysctl with no luck - but it does seem that there is a problem specifically in LinuxMCE's handling of these ARP requests. Surely there has to be a networking wizard here that could chime in and help us fix this permanently!