Author Topic: PXE boot VirtualBox 3.1.6  (Read 2015 times)

TonyBryan

  • Regular Poster
  • **
  • Posts: 26
    • View Profile
PXE boot VirtualBox 3.1.6
« on: May 12, 2010, 09:47:30 pm »
Hi, can anyone help me with a PXE network boot issue.  I've configured a very simple PXE-boot virtual machine using VIrtualbox 3.1.6.  However, it fails on boot with the following messages:

Code: [Select]
IP-Config: no response after 60 secs -giving up
/init: .: line 1: can't open /tmp/net-eth0.conf
Kernel panic - no syncing: Attempting to kill init!
atkbd.c: Suprious NAK on isa0060/serio0. Some program might be trying access to hardware directly

Screen shot also attached if that helps.  Anyone know what's up?

wierdbeard65

  • Guru
  • ****
  • Posts: 449
    • View Profile
    • My Quest
Re: PXE boot VirtualBox 3.1.6
« Reply #1 on: May 12, 2010, 09:55:32 pm »
I had this problem with a real MD. I think it is usually caused by the PXE kernel not having the correct driver installed for the NIC.

In my case a later snapshot fixed it, but if you have a look at http://wiki.linuxmce.org/index.php/Unrecognized_NIC you might get some clues  ;)
Paul
If you have the time to help, please see where I have got to at: http://wiki.linuxmce.org/index.php/User:Wierdbeard65

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1374
  • If it ain't broke, tweak it
    • View Profile
Re: PXE boot VirtualBox 3.1.6
« Reply #2 on: May 13, 2010, 01:24:59 pm »
In the network options for the MD, the options I use are...

Attached to: Bridged Adapter
Name: Eth0

...and then in advanced...

Adapter Type: PCnet-AST III (Am79C973)


Some of the options will either not work at all, or begin to PXE boot and than flake out, but this config seems to work.

I will say that once everything is installed and running, I find the install to be a bit ropey, for example the mouse doesn't seem to respond to clicks (although you can move it, albeit a bit jerky sometimes), but keyboard seems to work. I also can't change channels in myth, either with the keyboard or the mouse - oooo, I'll try my N800 in a minute, see if that give me any joy!

In 0710, this setup worked perfectly, I don't know what's changed.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps