Author Topic: [Solved] internal network ETH0:1 ?  (Read 1385 times)

Zerk

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
[Solved] internal network ETH0:1 ?
« on: May 11, 2010, 12:38:37 am »
8.10 beta
2 network cards both identical
External is on eth0
but internal is showing eth0:1
as is will not comunicate on internal network with any of my devices (windows pc, DNS-321, MD diskless boot
had a similer issue before som time ago but just whent to etc/udev/70-persistent-net.rules and change there the eth0:1 to eth0 but now it seems different could be because last time had this problem was alpha
it dosnt show the 2 interfaces as i remeber it did in alpha only the eth0

i then whent to etc/network/interfaces and changed eth0:1 to eth1 i then lost access to webadmin and internet on the core so that was a step in wrong direction i then changed back and am back to square 1 no internet or communication on internal network

70-persistent-net.rules

Code: [Select]
# This file maintains persistent names for network interfaces.
# See udev(7) for syntax.
#
# Entries are automatically added by the 75-persistent-net-generator.rules
# file; however you are also free to add your own entries.

# PCI device 0x10ec:0x8139 (8139too)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="00:0a:cd:19:20:94", ATTR{type}=="1", KERNEL=="eth*",
NAME="eth0"

Interfaces
Code: [Select]
auto lo
       iface lo inet loopback

auto eth0
iface eth0 inet dhcp
auto eth0:1
iface eth0:1 inet static
       address 192.168.80.1
       netmask 255.255.255.0

im not shure where to go from this point any help would be greatly appreciated  :)


 
« Last Edit: May 12, 2010, 08:58:21 pm by Zerk »

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: internal network ETH0:1 ?
« Reply #1 on: May 11, 2010, 04:40:19 am »
One of your network cards was not detected, so it thinks that the system is in single-nic configuration.

Please replace the card that is not detected via the kernel (look at dmesg | grep "eth0") to see which one was found, and reinstall.

-Thom

Zerk

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Re: internal network ETH0:1 ?
« Reply #2 on: May 12, 2010, 07:51:14 pm »
 Thanks Thom removed and reinserted the card an now it shows and entery in the 70-persistent-net.rules
would lite up when eth cable was insterted didnt think faulty install

followed the instructions http://wiki.linuxmce.org/index.php/Single_to_Double_NIC
for switching from single to double Nic

when changing etc/network/interfaces from eth0:1 to 1 reboot and it just changes back
still learning linux myself where would i find kunbuntu's device list or control panel? to make a final check the card is properly installed

thanks Zerk


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: internal network ETH0:1 ?
« Reply #3 on: May 12, 2010, 08:00:06 pm »
For best results, Please follow my advice and do a complete reinstall.

-Thom

Zerk

  • Regular Poster
  • **
  • Posts: 40
    • View Profile
Re: internal network ETH0:1 ?
« Reply #4 on: May 12, 2010, 08:54:08 pm »
 Missed a step its working perfect now
missed the network settings in admin for the eth0 change to eth1 under device tree
thanks for the help Thom now have net access on the windows pc's and is picking up all my devices fine  ;D

i just hate to give up


DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: [Solved] internal network ETH0:1 ?
« Reply #5 on: May 26, 2010, 04:32:30 pm »
Hi, Im still learning MCE, I used 0710 but just a stupid question.......is two nics prefered in 0810?

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: [Solved] internal network ETH0:1 ?
« Reply #6 on: May 26, 2010, 05:00:55 pm »
Yes.