Author Topic: Orbiter phone not setting up sip account correctly in 8.10?  (Read 901 times)

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Orbiter phone not setting up sip account correctly in 8.10?
« on: March 26, 2010, 11:36:01 pm »
I hate to pile on with possible problems because I just loaded 8.10 and have seen glimpses of what it could be--and I really like it.

Having been impressed with the you tube video about using the phone from the orbiter I ponied up for one. It indeed installed itself. Also impressed with how easily my broadvoice account went in. However, when I dialed in from outside, I kept getting a series of recorded messages from asterisk telling me to leave a message and nothing happening on the orbiter screen.

Went to look at the orbiter in the Wizard \ Devices \phones and they looked OK. Then went to Advanced \Configuration \Phone Setup and looked at their extensions. Confusingly, there was no sip set up "This phone is using "" Technology" with no fields to fill in--even though it showed it in the Wizard file. Tested with asterisk, looked at the devices database under asterisk table in mysql, tried to call from a generic sip phone on the system to the orbiter and concluded they had never been set up properly. Strangely, you could call the sip phone from the orbiter or even call out from the orbitor through broadvoice but you could not call it from anywhere.

Went back to the Wizard, deleted  the orbiter and added another one associated with that MD. Now you can call it from SIP phone and if you designate it as the extension to call on the inbound route from broadvoice it will ring.

However, if you go back to using the custom app on the inbound route of linuxmce-custom,102,1 it goes back to dropping you into voicemail when you call from the outside.

Went and looked at that /etc/asterisk/extensions_pluto_dial.conf where that app takes you and indeed it is trying to dump you into "Local/@trusted,15" instead of "voice-menu-pluto-custom,s,1"

Is anyone else experiencing this and is there a work around? Or is that just where things stand for now?

Many thanks.

sambuca

  • Guru
  • ****
  • Posts: 443
    • View Profile
Re: Orbiter phone not setting up sip account correctly in 8.10?
« Reply #1 on: March 27, 2010, 12:10:35 am »
Not knowing any details about the telecom functions, from my perspective it seems http://svn.linuxmce.org/trac.cgi/ticket/315 seems to be relevant. It's one of the last real blockers for 810.
If you can provide any details or are willing to help test this function, please add a note to the ticket or contact possy on the irc channel ( #linuxmce-devel@freenode ).

br
sambuca

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile
Re: Orbiter phone not setting up sip account correctly in 8.10?
« Reply #2 on: March 28, 2010, 04:13:28 pm »
I'm certainly happy to help test.
Here is what I did to fix it:

Figured what the heck and did a complete reinstall to see if I could duplicate it. BTW, this is a big mistake because once 8.10 is installed in my case I had to completely wipe the disk to the point that LMCE thought I was from "Eastern Kentucky." Also kind of tricky if you are trying to set it up with a fixed ip at ETH0--it needs a dhcp id there so it can download stuff.

Finally got LMCE to install. Did the Wizard only to the point of having a user and a room. Went into network and straightened out ETH0. Then went into Wizard and set up Broadvoice. Bingo, system worked as it was supposed to although the settings for SIP did not show the secret and were no longer SIP5061 but just SIP.

My first thought is that this version is incredibly hardware dependent in getting it to work. The first time around I did not have a sound card and tried to use snd-dummy after asterisk was set up. This may have caused hiccups as in this install I had the sound card in from the start.

During install, I also froze the whole system twice when it went to look at the PCI bus to determine what is there until I removed a firewire card that had been successfully installed in 7.10. Perhaps all the devices have not yet been included...

Finally, perhaps in my trying to switch the network around before the system had gone through all its background processes, mythtv did not fully install to the point that I was getting:

ERROR 1049 (42000): Unknown database 'mythconverg'

after searching around a bit, I decided what the heck again and did a

apt-get dist-upgrade

which identified that mythtv needed to be installed again

after that did a
/etc/init.d/mythtv-backend stop


and then

 mysqlcheck -c -uroot -p mythconverg

and everything looked fine.

Hope this helps someone else.


LmceCape

  • Veteran
  • ***
  • Posts: 65
    • View Profile
Re: Orbiter phone not setting up sip account correctly in 8.10?
« Reply #3 on: May 12, 2010, 12:54:52 pm »
Hi there, I am having the same problem with asterisk "This phone is using "Technology" with no fields to fill in". I have reinstalled twice now and found the same problems. Ticket #567 by felpouse, suggests removing "$DEVICE_SECRET=$DEVICE_EXT" from sync_pluto2amp.pl. which seemed to fix the problem once deleting all the extensions from within freepbx and running the sync_pluto2amp.pl from the command line. I also had to change the line that reads
"chown asterisk.asterisk -R /usr/share/asterisk" /etc/asterisk/*" to
"`chown www-data.asterisk /usr/share/asterisk/agi-bin/*`;" and
"`chown asterisk.asterisk /etc/asterisk/*`;"
and added
"AMPASTERISKUSER=www-data"
"AMPASTERISKGROUP=asterisk"
to the bottom or the /etc/amportal.conf file.

Speakinhouse from the check.wml page calls me but no sound broadcasts to the core or MDs' but if I call extension 998 it works fine. (Zaptel modules are installed and loaded).

Another issue is that I have one MD running through HDMI but there is no sound on the Orbiter Telephone.

and lastly is the Motion Wrapper that fails on a Quick Reload but is fine on a core reboot. (b4rney has the same issue)

any info or direction would be great.
Thanks
Lmcecape




But, once you do a regen all orbiters it sets the extensions back to ""Technology" with no fields to fill in".