Author Topic: connecting to a Nas  (Read 3526 times)

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
connecting to a Nas
« on: May 03, 2010, 05:43:11 pm »
I'm having the hardest time connecting Lmce to my nas.  I'm using Openfiler, It's been up and running long before lmce was introduced to the network so I'm thinking the problem is with lmce and not my nas.  Lmce detected my nas and allowed me to set it up.  I have full access to everything on the nas so i created an account with read only access to most and write access where i want it.  I entered the credentials into lmce when it found my nas and i selected use lmce default file structure... which ever is the recommended setting but i still can't see my nas.  My nas has public full access for everyone shares and restricted shares to specific users, I can't get to any of them.  On a side note, during one of my attempts to get it working I deleted my nas from lmce, waited for lmce to detect it again, this time i didn't set it up with a user name or password (i was shooting for the public shares).  A couple hours later the MD in my kitchen failed and was displaying a samba error message that i can't remember, at the same time all the other mds froze up.  I restarted the core and it failed with the same errors as the kitchen MD.  I was able to get far enough into booting for web admin to work and my google search revealed it was a samba authentication error. Using web admin I added a user name and password for my nas and it's shares, rebooted the core and it booted fine, I haven't seen this error since.  That tells me the Lmce sees the nas, and it's authenticating, but it's just not doing anything with the nas.  Can someone point me in the right direction here? 

Thanks in advance!!

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: connecting to a Nas
« Reply #1 on: May 04, 2010, 01:07:53 am »
Not sure if it's related but have you done the samba fix (assuming you are using 810).
http://forum.linuxmce.org/index.php?topic=9873.msg68125#msg68125

I created a folder on the nas to which lmce has full access and it created the file structure within that folder. It works fine for me.

Hope this helps.
Barney

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: connecting to a Nas
« Reply #2 on: May 04, 2010, 05:53:46 am »
Did you happen to put files inside the folder structure you created?

Again, seems like you didn't read any instructions.

-Thom

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
Re: connecting to a Nas
« Reply #3 on: May 04, 2010, 06:05:40 pm »
I'm sorry Thom but you don't seem like a happy person, I think you need a hug, you should start working on that.  This is the second time you've attacked me for no apparent reason.  I guess we can cyber fight if you want but I'm kind of a busy guy, I can think of a million other things I'd rather do with my time.

Back to the nas, I just looked through the post about the samba fix and it doesn't apply to me.  My nas has an empty share that I created just for lmce, I have shares with data on it and I have an ubuntu and windows 2008 file server (waiting to be decommissioned), Lmce sees all of my shares and appears to be logging in successfully but doesn't do anything with the shares.  I've tried with both static and dhcp addresses for the nas, and both private and public shares.  The only thing I didn't try was removing my nas from the domain.  It's not always easy joining Openfiler to my domain so I'm saving that one for last. I'm thinking even though it's a linux box being joined to the domain is maybe blocking something.  My Kubuntu laptop and macbook connects to all my shares ratter easily so i doubt this is the problem but any input on this would be appreciated.   

Don't get confused I only want to use my Nas (Openfiler) and I only want to use the one share I created. Just for testing I tried to connect to all my file shares in hopes that one would work.  I'm desperate here, I need some direction.

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: connecting to a Nas
« Reply #4 on: May 04, 2010, 06:29:07 pm »
If LMCE did see the shares, it should have attempted to create a directory structure on the target share. Did it do this?

-Thom

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
Re: connecting to a Nas
« Reply #5 on: May 06, 2010, 09:44:21 pm »
Okay, my area had a partail power outage for over 14hours two days ago!!  It's sad how much i'm dependant on technology!  I just got around to playing with this again today.  My core is not creating folders on my shares.  I removed my nas from the domian, I even deleted the share and partition from my Nas and recreated it with a different name.  I created a x64 windows server 2008 enterprise vm and I created a share just for testing, I tried it both on and off the domain.  Brand new share, brand new server(not the windows server i tried before), lmce detected the server, then the share, but it didn't create the folder structure and it isn't using it. 

Please help me!! :( What could I be missing?

fastie81

  • Veteran
  • ***
  • Posts: 136
  • SSDD
    • View Profile
Re: connecting to a Nas
« Reply #6 on: May 06, 2010, 11:13:29 pm »
Hi

I am using FreeNas and I had endless problems with mine.
Every time I try to connect it to LMCE it sort of messed up my setup to a point where my MD's did not want to boot.
So what I did. I know it is not the best but it works. Can't ask for more.
1) I made samba share with no security on the shares on my NAS.
2) I let LMCE pick them up and then set every share as public. yes I know I can have private section on this.
Give LMCE a reboot and wait for the db to be updated and all sweet I have my data on lmce.
Everything is behind a firewall so the security is not that bad, but would change it at some point where I am in the mood to brake everything again.
If that helps.
PLease let me know if you got it setup with security.
Chris
 

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
Re: connecting to a Nas
« Reply #7 on: May 07, 2010, 06:12:00 pm »
I've basically done that already but i did it again to your instructions and it didn't help.  I did notice something strange however while playing around last night.  I didn't create any shares on the core, not deliberately anyways, but last night the core found itself.  I ran through the automated setup found in the wiki, I selected use lmce folder structure, it's displaying the share the way the wiki describes EXCEPT for the folder structure.  When I open a share to the core I see Home, My folder, my wife's folder, and a public folder.  If I drill into any of those 4 folders I'll eventually see a folder that represents the share on the core but once in that folder there is nothing.  I was expecting to see music, video, pictures, etc since i selected use lmce file structure.

Any Thoughts?

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
Re: connecting to a Nas
« Reply #8 on: May 14, 2010, 07:29:19 pm »
Does anyone have any thought on this:

Fri, 14 May 2010 12:48:00 -0400 Checking \\00:1a:a0:01:8b:65\lmce
mount error 127 = Key has expired
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

I don't know how i didn't notice this before but when i run "sudo /usr/pluto/bin/Configure_1837.sh -d <device number>" I get the message above along with other information.  I googled mount error 127 = Key has expired and it appears to be an authentication issue and most fixes came about after adjusting the user name and password.  There are also other fixes that i just don't understand but it doesn't look like they apply.  The share lmce is a public share and for testing there is no security on the nas itself.  From my ubuntu netbook, after clicking on Connect to server, All i need to do is type in the server name and click connect, it would connect to the nas and display all shares.  All public shares are accessible.  This is just my test that the nas and share doesn't require anything special to be used. 

In webmin "Password Required" is unchecked, and there is nothing in the username or password fields.  I don't understand how ubuntu can connect without a username and password but lmce gives an authentication error.  This is a wild swing in the dark but is it possible that web admin is displaying something other than what's being used?  I've renamed the shares and deleted and readded the nas from lmce a couple times so i doutb it but is it possible?  Where would I check?

Please guys, this is the final component to my system.  I'm pretty sure i got the hvr 2250 working as i was able to watch channel 3 & 4.  All i need is my nas and for time warner to reconnect the digital cable.  Any help or suggestions with the nas would be greatly appreciated.   

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
Re: connecting to a Nas
« Reply #9 on: May 21, 2010, 07:51:09 pm »
ccoudsi - you said in a different post you'ld try to help me with this.  How did you get the Dlink you were having trouble with working?

My nas is an installation of Openfiler http://openfiler.com/ with cifs shares.  It was joined to the domain but now it's sitting by itself with public access to everything.  Kubuntu and Ubuntu can connect and write to the shares with out any problems by simply providing the name of the nas.  I really don't know where the problem is but I'm shying away from samba and the actual shares.  As I said the the other post I couldn't create the file structure on the internal HD in the core.  But then again The error i posted above appears to be a authentication error, but all the shares are public and doesn't require a password.  This is just weird.  All I can think is it's using credentials without my knowledge.  I tried installing the samba plug-in again but it didn't help since it's already installed, i don't know how to uninstall it or if i should uninstall it. 

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: connecting to a Nas
« Reply #10 on: May 21, 2010, 08:10:06 pm »
=>> klovell
Are you using any raids on your system (SW,HW)??
I will setup a basic NAS using Openfiler this weekend and I'll let you know the results and "how to" if it works.
Cheers |[BEER]
Charlie,

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: connecting to a Nas
« Reply #11 on: May 23, 2010, 06:06:01 am »
>>Klovell

Here's what I did today, I setup OpenFiler on VM without the documentation, they need ($40) for it !!!
I attached my configuration FYI, from what I saw, it only works with LDAP server or MS active directory, because I couldn't access it from my Windows workgroup (MSHOME) and I couldn't create users that match LinuxMCE, so I switched from "MSHOME" to "Linuxmce" to give it a shot, and what I found out that after LinuxMCE detected the shared folder, and installed neccessary SW, it didn't create LinuxMCE directory structure, because it does not have write access, using "username=openfiler & password=password" .
 
Here device 141 is OpenFiler, using "XFS" file system
Code: [Select]
dcerouter_1005373:/mnt/device# ls -l
total 4
dr-xr-xr-x 2 root root    0 2010-05-22 19:42 141
drwxrwxrwx 8 root root    0 2009-12-19 17:10 34
drwxr-xr-x 8 root root 4096 2010-05-22 20:27 59
dcerouter_1005373:/mnt/device# /usr/pluto/bin/StorageDevices_StatusRadar.sh background
Sat, 22 May 2010 20:34:07 -0700 Device 33 (192.168.80.129) is online trying each of samba kids to see it they are still available
Sat, 22 May 2010 20:34:07 -0700 ----------------- DEVICE 34 1 (unchanged)
Sat, 22 May 2010 20:34:07 -0700 Device 140 (192.168.80.150) is online trying each of samba kids to see it they are still available
Sat, 22 May 2010 20:34:09 -0700 Share 141 (storage.openfiler-2gb.test) is not mountable with the username/pass that i have
Sat, 22 May 2010 20:34:09 -0700 ----------------- DEVICE 141 0 (unchanged)
Sat, 22 May 2010 20:34:10 -0700 ----------------- DEVICE 59 1 (unchanged)
Sat, 22 May 2010 20:34:15 -0700 Device 33 (192.168.80.129) is online trying each of samba kids to see it they are still available

« Last Edit: May 23, 2010, 06:08:56 am by ccoudsi »
Cheers |[BEER]
Charlie,

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
Re: connecting to a Nas
« Reply #12 on: May 30, 2010, 09:09:22 pm »
Okay, Thank You for doing all of this.  I wasn't expecting screen shots and the whole 9 yards... I applaud you.  Also, I'm sorry for the delayed response, I've been away on vacation for the past week.  I dropped my laptop in the resort pool day one of my vacation, this kind of weird random shit could only happen to me. 

I just compared your setting with mine and the only difference was the password you were using.  I didn't think to use the admin password for openfiler itself.  I though that was just for the web gui and ssh NOT the shares.  After adding the admin password for openfiler to the nas device in LMCE, I ran that detection script and it found and configured the shares.  It didn't ask me for any other passwords, I'm assuming because the shares are public.  I checked the core by connecting to \\name of core\public\videos, I saw only one folder in there that represented a share on my nas.  The problem is there were 2 shares detected and configured by LMCE but I'm assuming that's because I told lmce to only use one automatically.  I then check the share on the Nas that i created just for lmce, It did add the folder structure to the share.  I thought this was great and i was about to celebrate so I checked under the video section on one of my MD's to see if any of the videos from the share with data on it that was detected and configured would display.  They were all in there and i was able to play them.  This all lasted until i reloaded the router.  I then restarted the core but they didn't come back.  Any thoughts on that?

To recap. 
It found all shares but i only configured 2.  One has data the other was blank.  LMCE created the file structure on the blank and displayed it on the path above, I set the blank to use automatically.  The other share with data was available but not visible and it was not setup to be used automatically.  immediately following a reload router both stopped working. 

ccoudsi

  • Guru
  • ****
  • Posts: 244
    • View Profile
Re: connecting to a Nas
« Reply #13 on: May 30, 2010, 09:29:20 pm »
>>Klovell
I can't find where you can add users. That's why I stopped working on this, especially no documentation on how to configure, are you using LDAP server???

As far reloading the router, I dont have problem with my NAS in this regards, but currently with my D-Link NAS, I have to power up my LinuxMCE network first then power up the NAS second, other than that my MD's will not boot.
« Last Edit: May 30, 2010, 09:35:10 pm by ccoudsi »
Cheers |[BEER]
Charlie,

klovell

  • Guru
  • ****
  • Posts: 205
    • View Profile
Re: connecting to a Nas
« Reply #14 on: May 30, 2010, 10:27:53 pm »
I can get you the Admin guide, that's no problem.  I was using AD then i switch it to a ldap vm i have running.  Openfiler will pull in the list of users and groups from the ldap or AD server and you'll be able to select them only if you select controlled permissions vs public.  You probably didn't see any of that if you didn't create the share as that step has to come first.  I'll give that much, Openfiler is NOT the easiest to setup but the head ache is definitely worth it.

First click, Block devices, select a physical drive and add a partition, then click Volume group and create a Volume, Then click Add Volume, select the volume group you just created and configure a volume using the form at the bottom of the screen.  Even though the volume group i created is already selected from the drop down menu I have to click Change to actually go to it.  BTW - this is all under the Volumes tab and the physical drive must be raw unused space.  If there is no unpartitioned space on the disk you wont be able to use it. 

Then Click on the Shares tab and you'll see the volume you just created.  Click on the volume, type a name then click create sub folder, click on the folder you just created and select  make share.  Now click on the share and you'll have options for the share.  If you leave "Override SMB/Rsync share name:" blank you'll have a weird folder name when you navigate to the nas, I selected public guest access for the lmce share.  For my other shares i used controlled access and it will display the list of groups and names it grabbed from the ldap or ad.  You also need to select access for the network. NOTE: you have to click update for each section in this area separately.

If you don't know already, click on System and scroll all the way down to network access configuration.  I'm pretty sure the name is just for organization and doesn't need to be anything official.  For network 192.168.80.0 or what ever your range is, you can also put in a specific ip address.  I added the Ip of my cores external nic and the ip range on the internal just in case.  Then type your netmask and select share from the drop down list.   

I hope this helps clear up openfiler, i just stepped out but i can get you the admin guide when i get home.  I think it's to big to email so I'll probably just put it on my FTP.