Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Dap-P

Pages: 1 2 [3] 4 5 6
31
Developers / Re: Need help!
« on: November 12, 2013, 01:15:06 am »
You made me think about that "world" comment...
Should there be a VPN client in qorbiter, well perhaps)))

Is there already a feedback of the device type (android, ios, phone, tablet) when first connecting? or should there be an option in the web admin for creating these different scenarios?

In my opinion, the scenarios should be more based on device type, instead of brand. ie: phone, tablet, full blown md
The more i think about this, i think there are only 2 different types, mobile, and full blown md.

What about bluetooth? The md can detect the bluetooth mobile device, and automaticly place it in the correct room.

Just thinking out loud,
Anton

32
Users / Re: Need some dedicated testers.
« on: November 12, 2013, 12:24:21 am »
I think that there need to be a good set of instructions on how to do the 'upgrade'
With that, most issues would/should not happen

Anton

33
Users / Re: Need some dedicated testers.
« on: November 11, 2013, 11:05:42 pm »
Tried to access :

http://192.168.80.1/lmce-admin/setEa2.php?d=138 (138 is my new qorbiter device)

response:
Code: [Select]
Installation is 1037024
Connection Found, Starting
Checking for existing mobile orbiter room
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''Room' WHERE PK_Room = '7'' at line 1

Deleted the qorbiter device again
so i did a full sqlcvs update
Made a new qorbiter device, now i have a Mobile Orbiters room.

Still have the EA in the room i select in the webadmin, should this be set to Mobile Qoribters room?

Anton

34
Users / Re: Need some dedicated testers.
« on: November 11, 2013, 10:35:27 pm »
Ok, i deleted qorbiters,
Did apt-get update, upgrade
Did sqlcvs update for device templates? is it correct?

downloaded the new setupqoribter.sh
got an error, typo on line 13... 1 too many spaces... fixed that, ran the script
Code: [Select]
dcerouter_1037024:~#  sudo /tmp/./setupQorbiter.sh
/tmp/./setupQorbiter.sh: line 13: export: `=': not a valid identifier

Tried to find a new qt build, but it wasn't there. so i connect with build 76.
enter new device ID, eveything connects. Only notice that when i now start qorbiter, it starts in room ::

Will test, and report back if needed

Anton

Edit: stupid me the room problem existed because i didn't reload the router) now fixed
There is no Mobile Qorbiters room, do i have to manually add this room?

35
Developers / Re: Need help!
« on: November 10, 2013, 07:54:24 pm »
Langston,

in my opinion, all mobile devices can be added to multiple ea's in 1 room. But i would like to see this room 'hidden' in all other orbiters, and on the mobile device you can only select your own device.

I have no idea is this is possible, and what would be needed. just want to share my opinion.

At the moment i have very little spare time, but i would like to volunteer. I dont know much about mysql, but i know i can learn about it.

Anton

36
Users / Re: Need some dedicated testers.
« on: November 06, 2013, 10:33:12 pm »
Found a bug :

While i was connected to my other wifi connection, i started qorbiter.
It couldn't connect to LMCE, which is correct, cause it is on another network.

While qorbiter is running, i changed my wifi connection to the LMCE network.
qorbiter connects, but doesn't display all the letter on the buttons,

Button's would read "L ghts" "Me  a" for the "Lights" and "Media" button, other buttons do this also
And even some buttons don't have text at all

-Anton

37
Users / Re: Need some dedicated testers.
« on: November 06, 2013, 01:03:53 am »
I saw this before, just never said it here, but i like to use the "filename sort" browsing, but when i am in some folder, i cannot get back to the upper level. i just get an empty screen with only a back button, and qorbiter often crashes.

Maybe it is my setup, because i only have nfs and smb fileshares connected, and no local media on my core.

Anton

38
Installation issues / Re: New install, Squeezeboxes not working
« on: November 03, 2013, 06:48:39 pm »
Finally had the chance to test this.
Today i hooked up my Squeezebox 2 via ethernet. it got detected by LMCE, configured in a room (my bathroom) and tried to play music from the orbiter. no luck....

So i recreated the device manually, only now with the squeezeslave template. and yes, it works!
Via ethernet, and via wifi!

Anton

39
New update :

Now it is only 1 script

Added a show function, this will display all local radio stations, with their Url's and Genre

Anton

Edit: Somehow i broke the script... i will check it now
Edit 2: I think it is working again
I had to readd the tail -n1 for some commands, apparently the insert_last_id somehow returned multiple lines

40
Users / Re: Best Approach to Controlling a Network Device
« on: October 30, 2013, 11:49:21 pm »
Code: [Select]
linuxmce@dcerouter:~/CodingWork/XBMC$ curl -i -X POST -H "Content-Type: application/json" -d "{\"jsonrpc\": \"2.0\", \"method\": \"Player.GetActivePlayers\", \"id\": 1}" http://192.168.80.150:80/jsonrpc
HTTP/1.1 200 OK
Content-Length: 65
Content-Type: application/json
Date: Tue, 29 Oct 2013 23:15:30 GMT

{"id":1,"jsonrpc":"2.0","result":[{"playerid":1,"type":"video"}]}

I know a little about capturing data from scripts, this is as i would do this:
playerid=$(curl -i -X POST -H "Content-Type: application/json" -d "{\"jsonrpc\": \"2.0\", \"method\": \"Player.GetActivePlayers\", \"id\": 1}" http://192.168.80.150:80/jsonrpc | grep playerid | awk -F'playerid":' '{print $2}' | awk -F',' '{print $1}')

something like this should capture the player id in a variable called playerid

Anton

41
New update

Added a description to the script,
added the -ss flag, and removed tail -n1
added the Download Url to a variable
in the delete script added a loop, so that it reads all urls, and checks that in the database


In general, would it be wise to add multiple files to the same radiostation? Now i just grab the first one.

Anton

42
Users / Re: Need some dedicated testers.
« on: October 29, 2013, 11:53:48 pm »
Updated pushed...


now if i could remember what i did.

*changed the phone homescreen to make buttons bigger
*added ability to get screenshot to smokey
*added zoom & aspect for video in smokey
*added a fallback screen for mediatypes that dont have a details page implemented yet.
*added support for browsing photos.

*found ugly bug that happens when its reset repeatedly.
*so far unable to reproduce the crash when power button is pressed.

Things i notice:
- Start of app is faster
- Still a crash when i use Display On, or Display Off from the power menu
- Media test button does not work anymore
- Dont see any pictures / photos
- Buttons are the same size
- Screenshots work
- Zoom and Aspect work
- In general the app feel much faster

Anton

43
My mistake...

Here are the correct ones:


44
What does not look right?
to me it seems correct, i do the insert, and last_insert in 1 command, with the output in $PK_File var

it even works for me

Anton

45
I thought it would work that way, when i realised it didn't work as plan. thanks!!!

Here 2 new scripts,
 - add radiostations with select_last_id
and
 - delete radiostations

Anton

Pages: 1 2 [3] 4 5 6