Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - dextaslab

Pages: [1] 2 3 ... 6
Users / Re: Airplayer device as Audio for a room?
« on: December 03, 2014, 02:04:34 pm »
Oh I see airplayer provides a destination for other non-Linuxmce devices...? Turns out the cheap devices (soundmate M1) run openwrt, I just have to get squeezeslave and alsa compiled for them.

Cheers, yeah it would be a good future feature, but after watching the weather temperature demo (very well explained), its out of my league.

Users / Airplayer device as Audio for a room?
« on: November 28, 2014, 06:09:10 pm »
Hi, The summary of what I cant work out is to be able to use a physical airplay compatible device to stream audio/music for a room, that can be controlled from an orbiter. I read a while ago that it should be possible because of the way the airplay plugin works - data goes to the DCE and gets directed to the airplay devices (scripts) on the MDs. So I figured create a faux "AirPlay Audio Player" and put in the IP and/or Mac of the physical device.

I see that I can only create them under Orbiters, which the room doesn't have. Before I go any further am I wasting my time and completely wrong all together? Can I perhaps use the "AirPlay Audio Player" template as a base for what I want?


Users / Re: Raspberry Pi as a MediaDirector
« on: September 29, 2014, 04:38:04 am »
Has anyone tried this using the Banana PI?
1GB RAM, 1GHZ CPU and 1Gb NIC would help with some performance issues. I believe it's compatible, just more expensive.
With the sata port you could almost use it as a core.


Users / Re: extra drive in core 12.04
« on: September 01, 2014, 03:15:53 pm »
Formated MD's the drive to ext4 and it was detected fine.

Users / Re: extra drive in core 12.04
« on: September 01, 2014, 02:15:47 pm »
I did notice the fresh install of 12.04 it didn't pickup my software raid as it did in 10.04 and 8. I didn't think anything of it because that's what I wanted.

Come to think of it, it also didn't prompt to use the HDD's in my MD's either. Again not an issue for me, because I'm not using them.

root@moon67:~# fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
240 heads, 63 sectors/track, 20673 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xe6c4e6c4

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   312575759   156287848+   7  HPFS/NTFS/exFAT

Users / Re: Can I control a DLNA device (SONY TV) from Linuxmce?
« on: August 18, 2014, 02:18:11 pm »
This code is good, just needs some modification to work:

The registration code connects and prompts for registration on the TV (PS I have a KDL-40EX520)

Users / Re: Can I control a DLNA device (SONY TV) from Linuxmce?
« on: August 17, 2014, 09:41:41 am »
Hi, I know this is an old topic, but... Most* Sony TV's (2011+) with network cards can be controlled using the Sony Virtual Remote  (v1.2 is the latest I could find). It uses IRCC (some kind of UPNP or DLNA derivative) to communicate with the TV:

 <command name="Power" type="ircc" value="AAAAAQAAAAEAAAAVAw==" />
  <command name="Display" type="ircc" value="AAAAAQAAAAEAAAA6Aw==" />
  <command name="VolumeUp" type="ircc" value="AAAAAQAAAAEAAAASAw==" />
  <command name="VolumeDown" type="ircc" value="AAAAAQAAAAEAAAATAw==" />
  <command name="Mute" type="ircc" value="AAAAAQAAAAEAAAAUAw==" />

The virtual remote works fine after it's paired to the tv. I'm just trying make a device template to accommodate it... If anyone can point me in the right direction it would be appreciated  ;D

Users / WIFI RGB/W Lights
« on: February 15, 2014, 02:25:01 pm »
Hi, I have purchased some RGB LED lights which can be controlled using a central controller that accepts basic UDP network packets to make it change.

These are mine (v2):
They are also sold under the mi-light and easybulb brand names - although I believe they use slightly different commands depending on version.

I tried to create a template and made a basic ruby script to turn them on similar to this:

require 'socket'
socket =
socket.send([0x22, 0x00, 0x55].pack('C*'), 0, '', 50000)

I have tried a few different things and was wandering where I was going wrong? The icon to turn them on/off appear in the orbiters but they dont react to the orbiters. I also believe they don't report status (on/off, etc..) they only accept commands.


Users / Re: Is anyone using the Game Player?
« on: February 15, 2014, 02:12:30 pm »
Yeah, and I use and old XBOX controller as the game-pad

Users / Re: RAID question
« on: February 02, 2013, 11:14:52 pm »
It did for mine

Feature requests & roadmap / Temperature displays in motion cams
« on: January 19, 2013, 06:10:53 pm »
I've done this the manual way so I know it's possible and probably not "too hard" to implement - I guess...
I have some home-brew temperature sensors attached to the devices that control my webcams and they work (to some degree) with LinuxMCE's motion-wrapper. If using linuxMCE supported temperature probes I imagine it would be pretty easy to go:

If room has security cameras and temperature probes run this: /usr/bin/wget –delete-after “$CAMERANUMBER/config/set?text_left=$ROOMNAME – $TEMPERATURE"

This was part of the manual solution I used: /usr/bin/wget –delete-after “ Temp – $CONDITIONS c”

Which produces this image (text is at bottom left):

I've done a vague writeup here if anyone is interested:


Users / Re: Pluto_media over 5,5GB?
« on: December 12, 2012, 11:02:19 am »
No sure about everyone else but I use the drive for backups and other files, and to stop it checking those folders I use %.folderlock files so it skips checking them; eg: "Backups.folderlock"


Users / Webcam Viewing on Orbiter freezes
« on: December 02, 2012, 12:42:54 pm »
I had a quick look before to see if anyone else has this issue; I have 2 USB webcams setup  but when viewing the live feed on the windows orbiters the screen often locks up or often the screen does not present an image (I don't mean the grey one that has a time stamp). Other than that issue the webcams work fine for recording.
I can view the webcams through the web interfaces for each for as long as I want and they work fine. Using Linuxmce 10.04 and has been happening for a while.


Developers / Re: lmce-admin redesign ?
« on: November 10, 2012, 02:59:57 pm »
Just a little thing, wizards are good for the first time or two through a system. After that they are an excise and an annoyance.
Agreed, although if they have a 'skip' or 'manual configure' button, everyone's happy :-)

Users / Re: LinuxMCE community, lets talk.
« on: November 10, 2012, 02:35:34 pm »
For Christmas this year (or next) I want Linuxmce to give me:
1. One Android app on my phone that allows me to use everything that Linuxmce has to offer securely and remotely (latency permitting). Eg; view security footage, Make a SIP call, view files, etc.. Possibly like a background service?
2. I would also like to have a complete live backup option; 1 that backups up root, data/media, and the database to a baremetal recovery without having to turn it off and have down time while it pushes data over the network/external drive.
3. qOrbiters on MD's please.


Pages: [1] 2 3 ... 6