Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - brononius

Pages: 1 2 [3] 4 5 6
31
Wiki / Wiki RSS updates
« on: September 04, 2012, 01:28:05 pm »
I'm using 'Google Reader' to keep up to date with a lot of sites.
Also for the wiki page of LinuxMCE.

But for this, i've got a lot (very lot) of updates about articles...
Is there a way to limit this?

Maybe only new articles should be announced?

32
Wiki / Add/edit page on wiki
« on: August 30, 2012, 03:53:15 pm »
Hey,

I'm trying to write (mainly for myself) a page that explain the use of LinuxMCE with my home automation (eib).
Main reason behind it is to understand the setup and links between EIB-adresses/devices/events...
The work in progress can be found on http://oniriabe.dyndns.org:1111/intranet/index.php/weetjes/linux/linuxmce/254-eib

Still need to add/test some chapters, check the vocabulary...
Once it's completed I want to share it on the wiki pages. But I was wondering what i do best:
  • Create an user page?
  • Create/update an existing page?
  • Contact a moderator

33
Installation issues / [SOLVED] Add a new Hard Disk
« on: August 26, 2012, 09:58:49 am »
Hey,

I'm trying to add an extra hard drive to my system. But LinuxMCE won't get it...
My first disk is a SSD 60GB for the system (working perfectly), my second one is a SATA 1TB.
I have followed http://wiki.linuxmce.org/index.php/Add_an_additional_hard_drive. I just needed to add xfs in the procedure?

  • Insert the disk (no format, partitions....)
  • sudo fdisk /dev/sdb
  • Options n - 1 (defaults)
  • sudo apt-get install xfsprogs xfsdump  (since by default mkfs.xfs isn't possible)
  • sudo mkfs.xfs /dev/sdb1
  • rebooted
  • Waited for about 10 minutes


Some additional information:

sudo fdisk -l
Code: [Select]
Disk /dev/sda: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000a16a7

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        6994    56174592   83  Linux
/dev/sda2            6994        7298     2438145    5  Extended
/dev/sda5            6994        7298     2438144   82  Linux swap / Solaris

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0009cadb

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1      121601   976760001   83  Linux

sudo df -h
Code: [Select]
Filesystem            Size  Used Avail Use% Mounted on
rootfs                 53G   26G   25G  51% /
none                  1.5G  372K  1.5G   1% /dev
/dev/disk/by-uuid/8beeb5ef-c123-4095-a54f-d9119e9dbeeb
                       53G   26G   25G  51% /
none                  1.5G     0  1.5G   0% /dev/shm
none                  1.5G  384K  1.5G   1% /var/run
none                  1.5G     0  1.5G   0% /var/lock
none                  1.5G     0  1.5G   0% /lib/init/rw

Can i do something to force it to pick up the hard disk?

34
Users / DeviceGroup
« on: August 23, 2012, 06:53:10 pm »
Hey,

I'm trying to configure my lightbuttons to act as a kind of 'away' / 'home' status.
For this, i add several buttons in a Device group. And with advanced Events, i'm trying to configure this now.
But when i select the DeviceGroup, and try to switch on a light. It doesn't work.
Am I doing something wrong with the Devicegroup?

In the log, i see the buttons coming in. So this part is working.

/var/log/pluto/DCErouter.log
Quote
001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:49.576           Received Message from 273 (K Eetplaats 3x / Eetplaats) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:51.551           Received Message from 273 (K Eetplaats 3x / Eetplaats) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:53.118           Received Message from 273 (K Eetplaats 3x / Eetplaats) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:55.441           Received Message from 277 (K Inkom 3x / Inkom) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>
07      08/23/12 18:45:56.943           Received Message from 277 (K Inkom 3x / Inkom) to -1001 (unknown / ), type 2 id 9 Event:Sensor Tripped, retry none, parameters: <0xa95efb70>


35
Users / [SOLVED] Events: Stop ringing extension
« on: August 20, 2012, 08:29:49 pm »
I'm trying to create an event that allows me to ring all phones once somebody is at the front door.

I can get it to ring, but i just want it to ring 2~3 times. Any idea how i can do that?
Is there somewhere an (detailled) explanation of the different options?
For example what can i do with the strings?  :-\


My (failed) test:
  • Respond to Event
  • What device?: doorbell
  • Commands:
  •      Asterisk PBX_Application: Extension 206 (fe)
  •      LinuxMCE Delay: 4
  •      Asterisk PBX_Hangup: noidea (extension?)



36
Installation issues / Can't change security devices anymore
« on: August 20, 2012, 08:46:32 am »
Hey,


I was adding manual my light buttons in the security part. I'm using the template 1624 (doorbell) for this. Everything went well from device 241 till 297.

When i add a template afterwards, it's been added.
But when i change the name and assign a port channel, it isn't been updated anymore.
I even can't delete the device anymore?
I can still add devices.
I've got 298 ~ 310 'empty' devices now.

Other devices (fe light switches) can be updated.
But none of the security devices... Even the IPcamera's in here can't be updated anymore?


Any idea what's going on? What i can do to solve this?

Restart / reboot of LinuxMCE didn't bring a solution...  :-X

37
Users / Bulk import
« on: August 14, 2012, 08:03:44 am »
I'm having a lot of switches in my home (light bulb, power outlets, switches...). And of course, i can add them one by one. But this would take hours. So I'm wondering if there isn't a way to import them in bulk into linuxmce.

Can i insert them 'simply' in the database from fe a csv? Or are their different places that are impacted?  ???

An example of a csv could be:
descriptiontemplatecontrolledlocationchannel
Light kitchen37EIBDKitchen1/1/1|1/2/1
Light bedroom37EIBDBedroom1/1/3|1/2/2
Light office37EIBDOffice1/1/3|1/2/3
Lightswitch kitchen 1x1624EIBDKitchen2/1/1
Lightswitch kitchen 2x1624EIBDKitchen2/1/2
Lightswitch kitchen 3x1624EIBDKitchen2/1/3
Lightswitch kitchen 4x1624EIBDKitchen2/1/4
Lightswitch bedroom 1x1624EIBDBedroom2/1/5



38
Users / House down / up...
« on: August 13, 2012, 08:33:22 pm »
Hey,

I'm able to control my 'eib buttons' with the template doorbell.
I can finally switch on a light bulb through LinuxMCE. Cool.

I now want take it to the next level.
When i push 3x the button on my backdoor, i want to shutdown everything (lights, outlets...).
When i push the button 3x again, i want to powerup everything (lights, outlets...).

What do i use for this? A kind of 'respond to events' and select all switches?
Or should i use a kind of 'away' status?

39
Wiki / Contact writer(s)
« on: August 13, 2012, 03:40:21 pm »
Hey,

It would be maybe nice if we can contact the (original) author of a manual.

Fe i'm trying out the EIB module for the moment. http://wiki.linuxmce.org/index.php/EIB/KNX. I see that the person who wrote this, tried the 'input' module. But i can't get it working. So i would like to send him a small message to have additional info. Of course, i could use the forum, but maybe it's interesting to send a link of the topic to the original author as well?

Or am i looking wrong...

40
Users / # Images for a room limited?
« on: August 02, 2012, 02:53:55 pm »

Is there somewhere a limit to the number of rooms/images?

i'm having about 25 rooms.
And for about 15 rooms i want to add an image.

For 12 rooms, it worked. But suddently, i can't add images to it?
  • I thought there was something wrong with those images, so i re-used a 'working' image. No luck.
  • Maybe something wrong with those rooms? So i create an extra one, no luck.

Any idea why i can't upload any (room)images anymore?

41
Users / Change a template
« on: July 31, 2012, 02:26:37 pm »
Hey,

Today, i've created my EIB connection through the old fashion way (install by console bladibladibla...).
Now i seen that Foxi352 wrote a EIBD wikiwhere EIB is integrated in version 10.04.

My question now is, can i change the template of my current EIB?

This without loosing all child device for this?
Since i've got about 60 switches and so, it would be nice that i don't have to recreate them all... ;)

42
Users / [SOLVED] Prefix, dialplan in 1004
« on: July 31, 2012, 10:23:24 am »
Hey,

Is there a way to update/change the dialplan under LinuxMCE 1004?
I would like to control/limit my outgoing calls to only national ones.

So i need something in the form of:
  • fixed number: 01 234 56 78
  • cell phones: 0123 45 67 89

And since its a small home, an outgoing prefix is also a bit 'much'... ;)

43
Installation issues / [SOLVED] IP Camera in 1004
« on: July 25, 2012, 09:34:30 am »
Hey,

I've got some IPCAM02 running, and i want them to add in LinuxMCE.
But don't succeed to it. :$

I've tried adding them 'surveillance camera' as a 'generic motion ip camera - 1916' and as an 'advanced IP camera'. But couldn't get a image running.
Does anybody has an example what i need to add?
Fe i'm adding the IP, the MAC, the username (admin) and password.

Next to it, i found in http://wiki.linuxmce.org/index.php/Monitor_surveillance_cameras that you also could motion wrapper.
But couldn't find this in 1004.
Is it still in there, another location...?


ps a manual for the IPCAM is located here: http://download.chinavasion.com/download/CVLM-I122.pdf

Thanks!!!

44
Installation issues / [solved] 10.04 / asterisk / creating phones
« on: July 24, 2012, 03:30:56 pm »
Hey,

I'm trying to install some phones in 10.04. I've got a bunch of cisco 7940 & 7960 phones that have SIP installed on.
In LMCE, i go to 'Wizard'  > 'devices' > 'phones'.

I add following information for the first phone
  • Phonename: office
  • Location: office
  • sip password: sip
  • IP adress: 192.168.2.231
  • MAC: 11:22:33:44:55:66
The phone is properly configured.
A SIP112233445566.cnf is created.

Now i'm adding a second phone:
  • Phonename: bedroom
  • Location: bedroom
  • sip password: sip
  • IP adress: 192.168.2.232
  • MAC: 11:22:33:44:55:77

When i now check the tftpboot folder, a SIP112233445577 is created.
But the webpage seems to keep refreshing?  >:(

Next i'm checking with the command top in a console. And i see that some scripts keep returning. They disapperar, coming back...
  • db_phone_config
  • configure_cisco

And the files in the folder tftpboot are recreating the whole time?

Any idea what's going on?
Not sure what to do (beside rebooting the server)... ???

45
Help Wanted / Q24U IP Camera
« on: July 02, 2012, 12:30:29 pm »
Does anybody has experience with the Q24U IP Camera?
I can buy some camera's for 60 euro's / piece. But of course, they should work with linuxmce... ;)

Pages: 1 2 [3] 4 5 6