Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - brononius

Pages: [1] 2 3 ... 26
1
Installation issues / Re: Qorbiter creates a lot of Generic Proxy Orbiter?
« on: September 22, 2014, 06:11:16 pm »
I've done this morning an update. So I should be pretty up-to-date. ;-)

Damned, maybe time that I invest some time to upgrade to 12?

2
Installation issues / Qorbiter creates a lot of Generic Proxy Orbiter?
« on: September 22, 2014, 05:58:09 pm »
Finally found the time to get my phones (android) back up with LinuxMCE.

When I add an qorbiter following http://wiki.linuxmce.org/index.php/Android_Orbiter, my linuxMCE goes nuts (I think). In no time, I've got about 20 'Generic Proxy Orbiters'. Not sure why he does that, or if it's normal. And when I try to connect with my phone, I keeps on saying 'please wait'.

I've got also the feeling that when I do a regen or full regen on the server, it's done in about 1 sec. So I don't think that it's doing a lot.


In the logs, i've got:


Quote from: more /var/log/pluto/668_LaunchProxy_Orbiter.sh.log
== ATTEMPT FRESH START ==
1   09/22/14 17:52:19   /usr/pluto/bin/Spawn_Device.sh 668 (spawning-device)   7678 Dev: 668; Already Running list: 15,16,18,19,29,30,180,385,398,400,402,404,587,606,607,608,611,612,659,660,66
1,662,663,664,665,666,667,
== FRESH START ==
1   09/22/14 17:52:19   /usr/pluto/bin/Spawn_Device.sh 668 (spawning-device)   device: 668 ip: localhost cmd_line: LaunchProxy_Orbiter.sh
0   09/22/14 17:52:19   668 (spawning-device)   Entering 668
========== NEW LOG SECTION ==========
1   09/22/14 17:52:19   668 (spawning-device)   Starting... 1
1   09/22/14 17:52:19   668 (spawning-device)   Found /usr/pluto/bin/LaunchProxy_Orbiter.sh
05   09/22/14 17:52:19.934      Connection for client socket reported NEED RELOAD IP=::ffff:127.0.0.1, device 668 last error 2 <0xb77d6740>
05   09/22/14 17:52:19.938      void ClientSocket::Disconnect() on this socket: 0x98c9d88 (m_Socket: 6) <0xb77d6740>
Return code: 2
2   09/22/14 17:52:19   668 (spawning-device)   Device requests restart... count=1/50 dev=668
Mon Sep 22 17:52:19 CEST 2014 Restart
========== NEW LOG SECTION ==========
1   09/22/14 17:52:27   668 (spawning-device)   Starting... 1
1   09/22/14 17:52:27   668 (spawning-device)   Found /usr/pluto/bin/LaunchProxy_Orbiter.sh
05   09/22/14 17:52:28.056      Connection for client socket reported NEED RELOAD IP=::ffff:127.0.0.1, device 668 last error 2 <0xb76e0740>
05   09/22/14 17:52:28.060      void ClientSocket::Disconnect() on this socket: 0x866ad88 (m_Socket: 6) <0xb76e0740>
Return code: 2
2   09/22/14 17:52:28   668 (spawning-device)   Device requests restart... count=1/50 dev=668
Mon Sep 22 17:52:28 CEST 2014 Restart
.........



And help is much appreciated!

3
Users / What Android app to use
« on: July 29, 2014, 09:13:11 am »
Hey,

Before, I used an android app to control my home. But I can't seem to find this app anymore.  ???

The only app I can find is the qorbiter. But honestly, this doesn't have a good GUI for a smartphone (LG Nexus 5). I tried to change the skins, but it keeps returning to the 'red-like' skin. fe When I want to select a room, I need to scroll and scroll and scroll, and I see a lot of ID of devices I prefer not to see. The floor layout is so small it's not usefull.

So any hints where I can find the old app, or if I can change a setting in order to have a more userfriendly GUI with the qorbiter?

4
Users / Re: Samba issue
« on: June 27, 2014, 12:27:19 pm »
you've updated the samba server

I can't recall that I've done it specially for something. Just some apt-get updates, and I'm playing around with backuppc.

For me, it's working now, and I don't have so many users, so it's a quick solution.
But if I can do/test anything, let me know...

5
Users / Re: Samba issue
« on: June 27, 2014, 10:02:35 am »
Not sure if this is the solution, but it seems to help to run 'smbpasswd -a'

Quote
smbpasswd -a pluto_brientje
   password:
   Retype new SMB password:
Added user pluto_brientje.



Afterwards, i'm able to login with the samba clients.

6
Users / Re: Samba issue
« on: June 27, 2014, 09:13:32 am »
After raising the log level, this is a bit more information:

Quote from: more log.clientPC
[2014/06/27 09:06:42,  3] smbd/map_username.c:188(map_username)
  Mapped user Brientje to pluto_brientje
[2014/06/27 09:06:42,  3] auth/auth.c:222(check_ntlm_password)
  check_ntlm_password:  Checking password for unmapped user [clientPC]\[Brientje]@[clientPC] with the new password interface
[2014/06/27 09:06:42,  3] auth/auth.c:225(check_ntlm_password)
  check_ntlm_password:  mapped user is: [CORIUS]\[pluto_brientje]@[clientPC]
[2014/06/27 09:06:42,  3] smbd/sec_ctx.c:210(push_sec_ctx)
  push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 1
[2014/06/27 09:06:42,  3] smbd/uid.c:428(push_conn_ctx)
  push_conn_ctx(0) : conn_ctx_stack_ndx = 0
[2014/06/27 09:06:42,  3] smbd/sec_ctx.c:310(set_sec_ctx)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 1
[2014/06/27 09:06:42,  3] smbd/sec_ctx.c:418(pop_sec_ctx)
  pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
[2014/06/27 09:06:42,  3] auth/auth_sam.c:282(check_sam_security)
  check_sam_security: Couldn't find user 'pluto_brientje' in passdb.
[2014/06/27 09:06:42,  2] auth/auth.c:320(check_ntlm_password)
  check_ntlm_password:  Authentication for user [Brientje] -> [pluto_brientje] FAILED with error NT_STATUS_NO_SUCH_USER
[2014/06/27 09:06:42,  3] smbd/error.c:60(error_packet_set)
  error packet at smbd/sesssetup.c(122) cmd=115 (SMBsesssetupX) NT_STATUS_LOGON_FAILURE
[2014/06/27 09:06:42,  3] smbd/process.c:1459(process_smb)
  Transaction 3 of length 142 (0 toread)
[2014/06/27 09:06:42,  3] smbd/process.c:1273(switch_message)
  switch message SMBsesssetupX (pid 20548) conn 0x0
[2014/06/27 09:06:42,  3] smbd/sec_ctx.c:310(set_sec_ctx)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2014/06/27 09:06:42,  3] smbd/sesssetup.c:1404(reply_sesssetup_and_X)
  wct=12 flg2=0xc807
[2014/06/27 09:06:42,  2] smbd/sesssetup.c:1360(setup_new_vc_session)
  setup_new_vc_session: New VC == 0, if NT4.x compatible we would close all old resources.
[2014/06/27 09:06:42,  3] smbd/sesssetup.c:1160(reply_sesssetup_and_X_spnego)
  Doing spnego session setup
[2014/06/27 09:06:42,  3] smbd/sesssetup.c:1202(reply_sesssetup_and_X_spnego)
  NativeOS=[] NativeLanMan=[] PrimaryDomain=[]
[2014/06/27 09:06:42,  3] smbd/sesssetup.c:786(reply_spnego_negotiate)
  reply_spnego_negotiate: Got secblob of size 40
[2014/06/27 09:06:42,  3] libsmb/ntlmssp.c:62(debug_ntlmssp_flags)
  Got NTLMSSP neg_flags=0xe2088297
[2014/06/27 09:06:42,  3] smbd/process.c:1459(process_smb)
  Transaction 4 of length 474 (0 toread)
[2014/06/27 09:06:42,  3] smbd/process.c:1273(switch_message)
  switch message SMBsesssetupX (pid 20548) conn 0x0
[2014/06/27 09:06:42,  3] smbd/sec_ctx.c:310(set_sec_ctx)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2014/06/27 09:06:42,  3] smbd/sesssetup.c:1404(reply_sesssetup_and_X)
  wct=12 flg2=0xc807
[2014/06/27 09:06:42,  2] smbd/sesssetup.c:1360(setup_new_vc_session)
  setup_new_vc_session: New VC == 0, if NT4.x compatible we would close all old resources.
[2014/06/27 09:06:42,  3] smbd/sesssetup.c:1160(reply_sesssetup_and_X_spnego)
  Doing spnego session setup
[2014/06/27 09:06:42,  3] smbd/sesssetup.c:1202(reply_sesssetup_and_X_spnego)
  NativeOS=[] NativeLanMan=[] PrimaryDomain=[]
[2014/06/27 09:06:42,  3] libsmb/ntlmssp.c:745(ntlmssp_server_auth)
  Got user=[Brientje] domain=[clientPC] workstation=[clientPC] len1=24 len2=222
[2014/06/27 09:06:42,  3] smbd/map_username.c:188(map_username)
  Mapped user Brientje to pluto_brientje
[2014/06/27 09:06:42,  3] auth/auth.c:222(check_ntlm_password)
  check_ntlm_password:  Checking password for unmapped user [clientPC]\[Brientje]@[clientPC] with the new password interface
[2014/06/27 09:06:42,  3] auth/auth.c:225(check_ntlm_password)
  check_ntlm_password:  mapped user is: [CORIUS]\[pluto_brientje]@[clientPC]
[2014/06/27 09:06:42,  3] smbd/sec_ctx.c:210(push_sec_ctx)
  push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 1
[2014/06/27 09:06:42,  3] smbd/uid.c:428(push_conn_ctx)
  push_conn_ctx(0) : conn_ctx_stack_ndx = 0
[2014/06/27 09:06:42,  3] smbd/sec_ctx.c:310(set_sec_ctx)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 1
[2014/06/27 09:06:42,  3] smbd/sec_ctx.c:418(pop_sec_ctx)
  pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
[2014/06/27 09:06:42,  3] auth/auth_sam.c:282(check_sam_security)
  check_sam_security: Couldn't find user 'pluto_brientje' in passdb.
[2014/06/27 09:06:42,  2] auth/auth.c:320(check_ntlm_password)
  check_ntlm_password:  Authentication for user [Brientje] -> [pluto_brientje] FAILED with error NT_STATUS_NO_SUCH_USER
[2014/06/27 09:06:42,  3] smbd/error.c:60(error_packet_set)
  error packet at smbd/sesssetup.c(122) cmd=115 (SMBsesssetupX) NT_STATUS_LOGON_FAILURE
[2014/06/27 09:06:48,  3] smbd/process.c:1459(process_smb)
  Transaction 5 of length 142 (0 toread)
[2014/06/27 09:06:48,  3] smbd/process.c:1273(switch_message)
  switch message SMBsesssetupX (pid 20548) conn 0x0
[2014/06/27 09:06:48,  3] smbd/sec_ctx.c:310(set_sec_ctx)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2014/06/27 09:06:48,  3] smbd/sesssetup.c:1404(reply_sesssetup_and_X)
  wct=12 flg2=0xc807
[2014/06/27 09:06:48,  2] smbd/sesssetup.c:1360(setup_new_vc_session)
  setup_new_vc_session: New VC == 0, if NT4.x compatible we would close all old resources.
[2014/06/27 09:06:48,  3] smbd/sesssetup.c:1160(reply_sesssetup_and_X_spnego)
  Doing spnego session setup
[2014/06/27 09:06:48,  3] smbd/sesssetup.c:1202(reply_sesssetup_and_X_spnego)
  NativeOS=[] NativeLanMan=[] PrimaryDomain=[]
[2014/06/27 09:06:48,  3] smbd/sesssetup.c:786(reply_spnego_negotiate)
  reply_spnego_negotiate: Got secblob of size 40
[2014/06/27 09:06:48,  3] libsmb/ntlmssp.c:62(debug_ntlmssp_flags)
  Got NTLMSSP neg_flags=0xe2088297
[2014/06/27 09:06:48,  3] smbd/process.c:1459(process_smb)
  Transaction 6 of length 474 (0 toread)
[2014/06/27 09:06:48,  3] smbd/process.c:1273(switch_message)
  switch message SMBsesssetupX (pid 20548) conn 0x0
[2014/06/27 09:06:48,  3] smbd/sec_ctx.c:310(set_sec_ctx)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2014/06/27 09:06:48,  3] smbd/sesssetup.c:1404(reply_sesssetup_and_X)
  wct=12 flg2=0xc807
[2014/06/27 09:06:48,  2] smbd/sesssetup.c:1360(setup_new_vc_session)
  setup_new_vc_session: New VC == 0, if NT4.x compatible we would close all old resources.
[2014/06/27 09:06:48,  3] smbd/sesssetup.c:1160(reply_sesssetup_and_X_spnego)
  Doing spnego session setup
[2014/06/27 09:06:48,  3] smbd/sesssetup.c:1202(reply_sesssetup_and_X_spnego)
  NativeOS=[] NativeLanMan=[] PrimaryDomain=[]
[2014/06/27 09:06:48,  3] libsmb/ntlmssp.c:745(ntlmssp_server_auth)
  Got user=[brientje] domain=[clientPC] workstation=[clientPC] len1=24 len2=222
[2014/06/27 09:06:48,  3] smbd/map_username.c:188(map_username)
  Mapped user brientje to pluto_brientje
[2014/06/27 09:06:48,  3] auth/auth.c:222(check_ntlm_password)
  check_ntlm_password:  Checking password for unmapped user [clientPC]\[brientje]@[clientPC] with the new password interface
[2014/06/27 09:06:48,  3] auth/auth.c:225(check_ntlm_password)
  check_ntlm_password:  mapped user is: [CORIUS]\[pluto_brientje]@[clientPC]
[2014/06/27 09:06:48,  3] smbd/sec_ctx.c:210(push_sec_ctx)
  push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 1
[2014/06/27 09:06:48,  3] smbd/uid.c:428(push_conn_ctx)
  push_conn_ctx(0) : conn_ctx_stack_ndx = 0
[2014/06/27 09:06:48,  3] smbd/sec_ctx.c:310(set_sec_ctx)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 1
[2014/06/27 09:06:48,  3] smbd/sec_ctx.c:418(pop_sec_ctx)
  pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
[2014/06/27 09:06:48,  3] auth/auth_sam.c:282(check_sam_security)
  check_sam_security: Couldn't find user 'pluto_brientje' in passdb.
[2014/06/27 09:06:48,  2] auth/auth.c:320(check_ntlm_password)
  check_ntlm_password:  Authentication for user [brientje] -> [pluto_brientje] FAILED with erro
r NT_STATUS_NO_SUCH_USER
[2014/06/27 09:06:48,  3] smbd/error.c:60(error_packet_set)
  error packet at smbd/sesssetup.c(122) cmd=115 (SMBsesssetupX) NT_STATUS_LOGON_FAILURE
[2014/06/27 09:07:04,  0] lib/util_sock.c:539(read_fd_with_timeout)
[2014/06/27 09:07:04,  0] lib/util_sock.c:1498(get_peer_addr_internal)
  getpeername failed. Error was Transport endpoint is not connected
  read_fd_with_timeout: client 0.0.0.0 read error = Connection reset by peer.
[2014/06/27 09:07:04,  3] smbd/sec_ctx.c:310(set_sec_ctx)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2014/06/27 09:07:04,  3] smbd/connection.c:31(yield_connection)
  Yielding connection to
[2014/06/27 09:07:04,  3] smbd/server.c:849(exit_server_common)
  Server exit (failed to receive smb request)

7
Users / Samba issue
« on: June 27, 2014, 07:06:39 am »
Hey,

Last days, I played around with the users and the group they belong to. And did also some apt-get udpates. And now I can't login anymore with samba protocol. Apparantly the user don't exist anymore?

The clientPC = Windows 7 & Linux Mint 17
The user = brientje

Quote from: grep brientje log.ClientPC
  check_ntlm_password:  Authentication for user [Brientje] -> [pluto_brientje] FAILED with error NT_STATUS_NO_SUCH_USER
  check_ntlm_password:  Authentication for user [Brientje] -> [pluto_brientje] FAILED with error NT_STATUS_NO_SUCH_USER
  check_ntlm_password:  Authentication for user [Brientje] -> [pluto_brientje] FAILED with error NT_STATUS_NO_SUCH_USER
  check_ntlm_password:  Authentication for user [Brientje] -> [pluto_brientje] FAILED with error NT_STATUS_NO_SUCH_US..........

Quote from: grep brientje /etc/samba/usermap.txt
pluto_brientje = brientje

Quote from: grep brientje /etc/samba/smbpasswd
pluto_brientje:10001:DD4D27348EDCBEBA93E28745B8BF4BA6:3D83FDBC71EF25E316C6BADA8AFF8D19:[U          ]:LCT-00000001:,,,


Quote from: grep brientje /etc/passwd
brientje:x:1001:1003:Brientje User,,,:/home/brientje:/bin/bash
pluto_brientje:x:10001:10001:,,,:/home/user_2:/bin/false

Quote from: id -a brientje
uid=1001(brientje) gid=1003(brientje) groups=1003(brientje),1001(public)

Quote from: id -a pluto_brientje
uid=10001(pluto_brientje) gid=10001(pluto_brientje) groups=10001(pluto_brientje),1001(public),1003(brientje)


Any idea / suggestion?

8
Users / Re: "Respond to events" is 'empty' after restore
« on: May 20, 2014, 09:38:42 am »
I'm a bit embarrassed to say this. But i've found the issue...

I've installed LinuxMCE 8.10.
And did a recovery (mysql -u root -p pluto_main < pluto_main.dump) of a LinuxMCE version 10.04

So I've lost 3 day because I entered the wrong (old) cd.  :-\
You've got no idea how stupid I feel myself...

9
Users / "Respond to events" is 'empty' after restore
« on: May 19, 2014, 06:52:56 am »
Hey,

I just had to reinstall my linuxmce server... A OS failure disk...  :-X
But no prob, i've got a backup. ;)

I just restored all data, and put the databases back in place.
But to my surprise, the 'respond to events' are empty when you look in the admin page. All other settings seem to be corect.
When I check the database itself, I see that the the table 'pluto_main'-'Eventhandler' contains all my created events.

Any hints what I've forgot/did wrong?

10
Users / EIB: relay hangs in scenario?
« on: November 28, 2013, 05:53:18 pm »
Hey,

I'm using now for about 2 years linuxmce to control my home automation. And it works greats... ;)
But this week, when I trigger my 'house sleep' scenario, a relay hangs. Before, I used this scenario almost daily.


The strange this is, that with console (groupswrite ip:127.0.0.1 3/1/81 1), I can normally control the relay.

But when I runs the scenario with that relay, the relay doesn't switch of completely? I need to manually give it an extra push. But when I check the status then in linuxMCE, this relay is still in the 'on/1' status.

Any idea?


11
Users / Re: Heating Boiler Viessman
« on: November 02, 2013, 08:07:26 am »
I found Vitogate to be too expensive for what it can do.

I agree with you. The prices i'm finding are about 700 euros, and this only to convert the signals?
But I must say that each time a look at eib hardware (fe the network convertor), i've got this feeling.  ???

And you're correct that once you've setup the heating, it should be fine.
But i was thinking of let all things work together. Fe heating down, windows open, shutters down...
This way, I would first play a bit with windows/shutters/... to control the temperature. And if this isn't enough, the heating can kick in.
But I agree, the heating should be able to cope with it on his own. Nevertheless it would be great to have 1 control center for all...


12
Users / Re: Heating Boiler Viessman
« on: October 31, 2013, 05:32:55 pm »
Whatever we can?  ;)

I was thinking about changing temperature, reading the temperature...
And in later phase playing with temperature, closing windows...

13
Users / Heating Boiler Viessman
« on: October 31, 2013, 03:37:32 pm »
Hey,

I would like to take a next step with LinuxMCE, namely connection my heating boiler (Viessman) with my server.
I saw that Viessman has a model to connect with EIB.

Do you guys think this will work with LinuxMCE? Or are there other solutions?

14
Users / Re: Events log
« on: October 11, 2013, 03:09:15 pm »
Based on this, i've created a small script that follows the logs, and put the most important info (for me) into a seperate log file.
Below you can find to commands. One to log the 'tripped sensors', and one to log the phonecalls. I'll see if i can find other intresting things to have in my 'filtered events log'.

Code: [Select]
#Log the triggered events
tail -f /var/log/pluto/DCERouter.log | awk '/Sensor Tripped/ {sub(/\(/,"",$8); sub(/)/,"",$12); sub(/Event:/,"",$22); sub(/,/,"",$23);print strftime("%Y-%m-
%d %H:%M:%S")," - Sensors: ",$8,$9,$10,$11,$12," - ",$22,$23 | "tee -a /var/log/events.log"}' &

#Log the phonecalls
tail -f /var/log/asterisk/full | awk '/Call completed to/ {sub(/Local\/0/,"",$9); sub(/@trusted/,"",$9);print strftime("%Y-%m-%d %H:%M:%S")," - Phone:", $6,
 $7, $8, $9 | "tee -a /var/log/events.log"}' &

This will return you following log:
more /var/log/events.log
Quote
2013-10-11 14:31:19  - Sensors:  K Sonar1 10x / FrontDoor  -  Sensor Tripped
2013-10-11 14:35:30  - Sensors:  K Button1 2x / Kitchen  -  Sensor Tripped
2013-10-11 14:35:30  - Sensors:  K Button1 1x / LivingRoom  -  Sensor Tripped
2013-10-11 15:06:20  - Phone: Call completed to 01534855


If you want to use it, it's possible that you'll need to change some parameters (like $8,$9,$10...). This is a first version, so it's rather 'raw' for my own intrest.
  • Basiclly, the first part (DCERouter.log) tells you what log file to check.
  • The second part (Sensor Tripped) tells you where to keep an eye on.
  • The third part (print xxxxxx) gives the 'result' back.
  • The last part (events.log) tells you where the results will be kept.

15
Users / Re: Events log
« on: October 09, 2013, 11:13:56 am »
Just a thought, but it would be a nice feature that a kind of log-level could be created.

fe
loglevel 12: all details (all below + debug)
loglevel 10: system stuff (all below + system alerts)
loglevel 7: external triggers (all below + incoming calls and so)
loglevel 6: user triggers (all below + manual push of lights and so)
...

But I think that this will be a huge change to the systems, no?  :-\

So I guess that I'll see to create a kind of script that keeps an eye on the dcerouter.log and that copies some info to another log file...
Or if there are other suggestions, let me know...

Pages: [1] 2 3 ... 26