Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - WhateverFits

Pages: 1 ... 3 4 [5] 6 7 ... 16
61
Users / Re: Radio Thermostat owners: can you help me out on new driver?
« on: September 04, 2013, 05:47:36 am »
I noticed that errors have a tendency to disable the device in LMCE so good error handling is a must.  ;D

Let me know what you have and I'll see what I can help with too.

62
Users / Re: Need some dedicated testers.
« on: September 04, 2013, 05:45:54 am »
That's the requester IP address and yes, all on my core.

This is what I get and it looks like yours.

{"device":{"device":null},"params":[{"type":"int","Command":"192","CommandParameter":"97","CommandHint":"Normally when a device is turned on all the inputs and outputs are selected automatically. If this parameter is specified, only the settings along this pipe will be set.","CommandDescription":"PK_Pipe"},{"type":"string","Command":"192","CommandParameter":"98","CommandHint":"Normally when a device is turned on the corresponding \"pipes\" are enabled by default. if this parameter is blank. If this parameter is 0, no pipes will be enabled. This can also be a comma seperated list of devices, meaning only the pipes to those devic","CommandDescription":"PK_Device_Pipes"}]}

63
Users / Re: Need some dedicated testers.
« on: September 04, 2013, 03:37:04 am »
I don't have IRC available right now so here goes:

Code: [Select]
192.168.80.130 - - [03/Sep/2013:18:21:48 -0700] "GET /lmce-admin/index.php HTTP/1.1" 200 969 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:21:51 -0700] "GET /lmce-admin/skins/android/Splash.qml HTTP/1.1" 200 2131 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:21:51 -0700] "GET /lmce-admin/skins/android/qmldir HTTP/1.1" 200 505 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:21:52 -0700] "GET /lmce-admin/skins/android/SplashView.qml HTTP/1.1" 200 2093 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:21:52 -0700] "GET /lmce-admin/skins/android/fonts/Sawasdee.ttf HTTP/1.1" 200 86410 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:21:52 -0700] "GET /lmce-admin/skins/android/tablet/default/img/icons/backgrounds/bedroom.png HTTP/1.1" 200 1038673 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:21:52 -0700] "GET /lmce-admin/skins/android/StatusRow.qml HTTP/1.1" 200 2937 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:21:52 -0700] "GET /lmce-admin/skins/android/ConnectionBox.qml HTTP/1.1" 200 5094 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:21:52 -0700] "GET /lmce-admin/skins/android/ExistingOrbiters.qml HTTP/1.1" 200 2618 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:21:52 -0700] "GET /lmce-admin/skins/android/NewOrbiterButton.qml HTTP/1.1" 200 2255 "-" "Mozilla/5.0"
192.168.80.130 - - [03/Sep/2013:18:22:05 -0700] "-" 408 0 "-" "-"

Looks like all 200's and a 408. I am 100% up to date too.

64
Users / Re: Radio Thermostat owners: can you help me out on new driver?
« on: September 04, 2013, 03:09:20 am »
Here you go!

Code: [Select]
{"model":"CT50 V1.94"}
Code: [Select]
{"uuid":"5cdad4fdb577","api_version":113,"fw_version":"1.04.84","wlan_fw_version":"v10.105576"}
Code: [Select]
/}ir_baffle get set
/datalog get x
/dehumidifier get set
/ext_dehumidifier get set
/errstatus get x
/eventlog get x
/fmode get set
/fan_ctime get set
/help get x
/hold get set
/humidity get x
/hvac_recovery get set
/hvac_settings get x
/humidifier get set
/led x set
/lock get set
/model get x
/night_light get set
/override get x
/power get set
/beep x set
/uma x set
/pma x set
/temp get x
/differential get set
/time/day get x
/time/hour get x
/time
Code: [Select]
{"eventlog":[["hour","minute","relay","temp","humidity","ttemp"],[17,46,64,74.50,0,73],[17,51,64,74.50,0,73],[17,56,64,75.00,0,73],[18,1,64,75.00,0,73],[18,6,64,75.00,0,73]]}

65
Users / Re: Need some dedicated testers.
« on: September 04, 2013, 02:42:44 am »
I deleted my LinuxMCE folder and then updated everything I could, ran the script you just mentioned, and I get a screen that looks like this:

66
Users / Re: My thermostat template died
« on: September 04, 2013, 02:22:02 am »
Glad I could help start this going! I was out of town for the past few days and didn't see these posts. Feel free to PM me if you need some help ASAP as I don't read the board every day.

67
Users / Re: My thermostat template died
« on: August 27, 2013, 12:23:09 am »
I really don't get my toes stepped on easily so feel free to do whatever you see that works best. Need help with your template? Want to combine them into a single template? Want to combine manufacturer names? Anything I can do to help, just let me know. If the code is very similar, it would be nice to investigate how to combine them but not necessary since they are small drivers.

68
Users / Re: My thermostat template died
« on: August 06, 2013, 08:15:58 am »
Thanks so much Thom! I'm still learning all these finer points and now I know much better what to do. Also, I've been watching some of your videos and love them! I've never quite figured out a few different things and now I think I've got them.

69
Developers / Re: Transmission torrent on LinuxMCE
« on: July 30, 2013, 11:29:21 pm »
OK, well, working with version control systems is a bit of a paradigm shift if you haven't worked with them before.

Normal practice is, of course, to always work with the latest version. In this situation, you cannot as you already started. So, if there are files that you overlaid that you didn't make changes to but somebody else did, simply delete that file and run "svn update" and it will bring back the latest version of the file instead of the version that you changed inadvertently. Run "svn status" to get a list of all modified files. Then you can go through that list and do some basic sanity checks to be sure you are only checking in what is necessary.

I hope that helps!

70
Ahhh!! Good debugging!  :D

71
Users / Re: At Home with LinuxMCE: Photos
« on: July 30, 2013, 09:12:48 pm »
Nice! Reminds me... I need to set up some gaming on my system! I have a huge number of MAME ROMs that need to be put to good use.

72
Developers / Re: Transmission torrent on LinuxMCE
« on: July 30, 2013, 08:42:46 pm »
Get the source tree for the website:
http://wiki.linuxmce.org/index.php/Source_Code

It will be under the web folder in the subversion tree.

Unpack your file over the top of the stuff there. Then do:

svn diff > patchfile

and make sure it actually worked and then create a ticket here:
http://svn.linuxmce.org/

and attach the file. Don't forget to post your ticket number back here so people know about it quicker.  ;D

73
Users / My thermostat template died
« on: July 30, 2013, 08:33:28 pm »
So, I've got a 3M50 thermostat and I wrote and submitted a template for it. Approved and applied. It looks good. Well, I just had to wipe out my machine (painful story involving our local power company) and all of my little devices around the house are popping up and populating themselves nicely with the DHCP detection. I so love that!

Now, here is the problem. All of the commands exist in the table InfraredGroup_Command with FK_InfraredGroup=6097 and the template exists in DeviceTemplate as PK_DeviceTemplate=2254 but here comes the problem: It has FK_InfraredGroup=6096 and the InfraredGroup table has neither 6096 nor 6097. I do believe that this is originally my fault as I think I made a bad SqlCVS submission when I originally submitted this. In any case, I'm clueless how to proceed. Should I manually create the entry in InfraredGroup and get everything tied together properly and submit that? Or is there a better way?

Thanks!

74
Developers / Re: Chromecast
« on: July 29, 2013, 11:49:36 pm »
Jury is out still...

$35 and possibly can stream to it like a squeezebox. I'm reading the APIs and checking to see if that is possible. Maybe...

75
Yeah, that looks like it is running as root so it should have permissions. Do a ps and look for the motion executables and check who they are running as. That's odd.

I've seen screen show up as SCREEN for a while now but I first noticed it on LinuxMCE since it makes such heavy use of screen. Very strange.

Pages: 1 ... 3 4 [5] 6 7 ... 16