Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - joerod

Pages: 1 ... 8 9 [10] 11
136
Users / apt-get update; apt-get upgrade
« on: August 16, 2010, 01:13:58 am »
I'm not sure if I'm doing something incorrectly, but when I run "apt-get update"  on my md I get the follow at the end:
Quote
Fetched 11.9kB in 2s (4946B/s)
Reading package lists... Done
W: GPG error: http://packages.medibuntu.org intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
W: You may want to run apt-get update to correct these problems

then when I type "apt-get upgrade"  I get the following:

Quote
root@moon88:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  libxine-dev libxine1 libxine1-all-plugins libxine1-bin libxine1-console libxine1-dbg libxine1-ffmpeg libxine1-gnome libxine1-misc-plugins
  libxine1-plugins libxine1-x
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.

I did manually install a xine patch a while back (altho I don't think that has anything do with the message I'm receiving now from apt-get)

joerod,

Your problem is related to xine. Not vdpau as demux of audio/video is done i software and not hw.
The demuxed video data is passed to gpu through vdpau and hence offloaded from cpu.

As TSCHAK pointed out we have a version of Xine that is unable to demux newer matroska containers in current release because we are unable to get vdr to run with the my backported version. I have started to look at how to port vdpau to xine 1.1.18.1. It´s a huge job that need to be done manually.
If you do not use vdr your problem can be solved either by installing the updated xine 1.1.16.3 with mkv backports as suggested or by building your own xinelib >1.1.17.
Unfortunately any version newer of xine than 1.1.16.3 do not have vdpau because the Xine devel team decided to focus on upcoming version 1.2 instead.
Before you ask I can say that v1.2 is not a possible road due to so much dependencies on newer libraries and also because 1.2 is not abi compatible with 1.1.x releases.

/niz23



I'm not sure what I'm doing wrong or if this even a problem, but and feedback is appreciated.

Thanks.

137
Users / Re: Hulu Desktop Update
« on: August 15, 2010, 09:32:53 pm »
awesome, thanks.

138
Users / Re: Hulu Desktop Update
« on: August 15, 2010, 03:34:17 am »
so should this be considered the official way to update  the app? or should I install it to the core and the mds will just work like magic?

139
Installation issues / Re: Asus M3N78-VM Audio via HDMI use to work
« on: August 15, 2010, 03:31:46 am »
I have the same motherboard and although I've been having some other issues with hd playback the hdmi sound seems to be working.  I recently did the apt-get update for the new xine, but everything still works as expected (with hdmi sound output); I can't seem to turn up or down the volume and like I said some wierd hd playback issues.  but I do get sound output.

140
Installation issues / Re: Xine, x264, VC1 (mkv), and VDPAU
« on: August 15, 2010, 03:24:52 am »
well, I definately have some that will play on one md but not on another (I get sound but no audio) I also have one or two that only play sound and both mds and all my videos play in windows.  I'm going to look further into it to make sure I'm not doing something wrong and I'll let you guys know.

Thanks a lot for the feedback.

141
Installation issues / Re: Xine, x264, VC1 (mkv), and VDPAU
« on: August 14, 2010, 12:43:16 pm »
is anyone else still having problems with just some mkv or mp4s? is there any way I can add newer containers to the compatibility list?

142
Installation issues / Re: Xine, x264, VC1 (mkv), and VDPAU
« on: August 03, 2010, 04:40:50 am »
how do I apply that update?

143
Users / Re: Hulu Not Working
« on: July 29, 2010, 05:34:49 pm »
hah, yes? yes what?

Well, I seem to have the same issue.  I get a black screen where a video should be playing.  However, I don't have to kill the process; I can still access the menu and try to select another video, but have the same results.  Sometimes a comercial will play (specifically with the movie trailers section) but after the comercial I get black screen; and its blank where the movie title should be. 

I haven't actually tried firefox; but I know with a win32 box it works fine in IE.  (hulu desktop doesnt work on the win32 box either)

144
Users / Re: Flash / Youtube not working out of the box
« on: July 26, 2010, 03:46:47 pm »
yea it wasn't working for me a while back when I did the install and this did the trick... I guess something needs to be fixed in the install-script.

Hmm I had this problem and did :
Code: [Select]
wget http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_10_linux.deb
dpkg -i install_flash_player_10_linux.deb
rm install_flash_player_10_linux.deb
and Hulu works now

Although I guess Hulu has a different problem now...

145
Installation issues / Re: Xine, x264, VC1 (mkv), and VDPAU
« on: July 25, 2010, 07:15:17 pm »
yea, I noticed I couldn't switch audio tracks... that would be a cool feature.  Is VDR better for ATSC than myth? BTW (the patch works really well for all the mkv files I couldn't play before, but) I have some videos that don't work ever since the mkv patch that did work before.  Any ideas on why this would happen?

146
Installation issues / Re: Xine, x264, VC1 (mkv), and VDPAU
« on: July 20, 2010, 10:03:57 pm »
this updated xine that I posted above doesn't play the mkv files?

Quote
IF you want the new xine, you will have to forcefully install the debs
they are located here: http://tschak.homelinux.com/deb/
install them all at the same time, with dpkg
keep in mind however, that you are on your own
we can't provide any support for these packages, as we are still working things out with it relating to what I mentioned above.

if you do not know how to install packages by hand with dpkg
much less how to install a batch of them at the same time
either (a) google it or (b) forget it
the mplayer player will be removed.
we will remove it from the build soon.


147
Installation issues / Re: Xine, x264, VC1 (mkv), and VDPAU
« on: July 19, 2010, 10:27:27 pm »
Sorry man I didn't really understand that... but mplayer shouldn't be used... xine should be used to play everything.  Make sure that your movie is not classified as "Linuxcmce Blueray Disc" and make sure it does not have a m2ts extention... I think those two conditions will cause the video to be played with mplayer instead of xine.

148
Installation issues / Re: Xine, x264, VC1 (mkv), and VDPAU
« on: July 17, 2010, 03:28:30 am »
OK, I'm not entirely sure this has anything to do with the problem as I see it probably has more to do with vdpau than xine but here is a conversation I had that may help a bit...

I asked: whats the recommend way to get mkv and other h264 codecs to work?

[Fri Jul 9 2010] [21:00:48] <TSCHAKeee>
first, a correction
what you're experiencing has nothing to do with h.264
we supply h.264 codecs already, as part of ffmpeg
and an appropriate GPU can decode them on-card via VDPAU
with that said, what you're experiencing
is the fact that you're downloading pirated movies off bittorrent
(don't deny it)
which are using a newer MKV encapsulation
MKV is a container format
we do have an updated xine, which niz23 has backported the demuxer from the upcoming xine release
however, we do not currently supply them as part of the build
because they break VDR
at least until we can rebuild vdr-sxfe to properly handle the new xine libs
IF you want the new xine, you will have to forcefully install the debs
they are located here: http://tschak.homelinux.com/deb/
install them all at the same time, with dpkg
keep in mind however, that you are on your own
we can't provide any support for these packages, as we are still working things out with it relating to what I mentioned above.

if you do not know how to install packages by hand with dpkg
much less how to install a batch of them at the same time
either (a) google it or (b) forget it
the mplayer player will be removed.
we will remove it from the build soon.


This got video and sound to work correctly.... kinda... I'm working on it; but it does seem to work

149
OK, I'm not entirely sure this has anything to do with the problem as I see it probably has more to do with vdpau than xine but here is a conversation I had that may help a bit...

I asked: whats the recommend way to get mkv and other h264 codecs to work?

[Fri Jul 9 2010] [21:00:48] <TSCHAKeee>
first, a correction
what you're experiencing has nothing to do with h.264
we supply h.264 codecs already, as part of ffmpeg
and an appropriate GPU can decode them on-card via VDPAU
with that said, what you're experiencing
is the fact that you're downloading pirated movies off bittorrent
(don't deny it)
which are using a newer MKV encapsulation
MKV is a container format
we do have an updated xine, which niz23 has backported the demuxer from the upcoming xine release
however, we do not currently supply them as part of the build
because they break VDR
at least until we can rebuild vdr-sxfe to properly handle the new xine libs
IF you want the new xine, you will have to forcefully install the debs
they are located here: http://tschak.homelinux.com/deb/
install them all at the same time, with dpkg
keep in mind however, that you are on your own
we can't provide any support for these packages, as we are still working things out with it relating to what I mentioned above.

if you do not know how to install packages by hand with dpkg
much less how to install a batch of them at the same time
either (a) google it or (b) forget it
the mplayer player will be removed.
we will remove it from the build soon.


This got video and sound to work correctly.... kinda... I'm working on it; but it does seem to work

150
Installation issues / Re: Xine, x264, VC1 (mkv), and VDPAU
« on: July 16, 2010, 12:41:31 am »
Any updates to this topic?

Pages: 1 ... 8 9 [10] 11