Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - valent

Pages: 1 ... 22 23 [24] 25 26
346
Users / Re: play HD video on slow hardware via VDPAU...
« on: March 16, 2009, 03:02:22 pm »
Given that a Xine lib based media player is the primary device for media playing on Media directors wouldn't your efforts be better placed rebuilding XinePlayer with a newer version of xinelib that supports VDPAU?

I don't have any real advice for your actual problem, sorry. Was the compile successful? Or any warnings to speak of?

I want first to check that my hardware works with VDPAU and new NVidia driver, and this process in unobtrusive to LinuxMCE playback and if I mess something it doesn't interfere with LinuxMCE playback. If I mess something up with xinelib then I need to reinstall the whole LinuxMCE and that I'm still not ready to do :)

So if anybody can replicate these easy steps so we can together find what is going on here, and the whole community would benefit from this.

I'm recompiling it again and will report any errors, but it is trivial for anybody with NVidia card to try this and you will not interfere with existing mplayer or xine binaries.

UPDATE:
I have recompiled mplayer again and there are quite a few warnings but no fatal errors that are unusual... so I can't figure out why I still have no vdpau support with this patched mplayer. Could somebody please try it also.

Cheers,
Valent.

347
Users / Re: Has Fiire gone under?
« on: March 16, 2009, 12:40:19 am »
Yup, Fiire is no longer with us, and hasn't been for some time. While the Systems Integrator had been fulfilling orders until last week, Fiire's management left the building over a year ago.

Don't fret though, forces are at work to provide a replacement for the community. ;)

-Thom


Can you give us some more details?

Has anyone tried Nokia N95 as it has gyroscope and costs almost the same and has some nice features also like bluetooth and wifi :)

348
Users / play HD video on slow hardware via VDPAU...
« on: March 16, 2009, 12:36:09 am »
Hi, if you haven't seen some previous threads that this will be a nice surprise for you. If you have issues playing HD video because you have too slow CPU there is a way to accelerate and offload the task of decoding HD video to graphics card (it has to be NVidia chip). This method is know as VDPAU.

You also need MPlayer with appropriate patch and latest NVidia 180.xx drivers.

I tried this compile guide:
http://blog.avirtualhome.com/2009/02/10/compile-mplayer-with-vdpau-support-on-ubuntu/

But still after compiling MPlayer I have no support for VDPAU :(

Here is how I tried it:
1st step: Install latest NVidia nv driver (this isn't covered by this guide)

2nd step compile mplayer with support for VDPAU:
wget ftp://download.nvidia.com/XFree86/vdpau/mplayer-vdpau-3532130.tar.bz2
tar xvjf mplayer-vdpau-3532130.tar.bz2
cd mplayer-vdpau-3532130/
./checkout-patch-build.sh
cp mplayer-vdpau/mplayer ../
cd ..
wget http://samples.mplayerhq.hu.nyud.net/V-codecs/h264/nature_704x576_25Hz_1500kbits.h264
wget http://samples.mplayerhq.hu.nyud.net/V-codecs/WVC1/FlightSimX_720p60_51_15Mbps.wmv

now to play test video:
./mplayer -vo vdpau -vc ffh264vdpau nature_704x576_25Hz_1500kbits.h264

mine mplayer fails :(

and when I check to see what video output drives it supports there is no mention of VDPAU :(

./mplayer -vo help
MPlayer dev-SVN-r28348-4.1.3 (C) 2000-2009 MPlayer Team
CPU: Unknown CPU Typ (Family: 6, Model: 10, Stepping: 0)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE
Available video output drivers:
   sdl   SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
   fbdev   Framebuffer Device
   fbdev2   Framebuffer Device
   v4l2   V4L2 MPEG Video Decoder Output
   cvidix   console VIDIX
   null   Null video output
   mpegpes   MPEG-PES to DVB card
   yuv4mpeg   yuv4mpeg output for mjpegtools
   tga   Targa output
   pnm   PPM/PGM/PGMYUV file
   md5sum   md5sum of each frame


Any ideas?

349
Users / Re: How did you end up here, using LinuxMCE?
« on: March 14, 2009, 09:49:50 am »
the video... and i'm so green it's my first linux install, but I'm hooked on the dream!

I do happen to be a great designer, IMHO, coder, not much at all - but I'd love to help the project and make it look nicer..i'm not sure how to get involved but am open.

rvetruba this project needs designers much more than coders IMHO ;)
Any help is really appreciated... I'm amazed at graphic design of some open source projects, for example XBMC has a beautiful interface. LinuxMCE is not bad but not as slick as XBMC or some other projects out there...

Just my 2c ;)

350
Compatible Products & Services / Re: Z-Wave european web shop?
« on: March 12, 2009, 03:52:26 pm »
Thank you both!

351
Compatible Products & Services / Z-Wave european web shop?
« on: March 11, 2009, 02:49:03 pm »
Hi, I would like to automate lighting and also setup security for my apartment using Z-Wave devices.

Where in Europe can I get affordable Z-Wave light switches, door and PIR sensors, dimmers, etc...
I looked on ebay and there are no Chinese Z-Wave devices, too bad, because they usually have really good prices and ship free of cost to any country!

Where do you buy your stuff? I'm in Croatia so if there are some dealers in Slovenia, Italy or Hungary I can also go there...

Cheers,
Valent.

352
Compatible Products & Services / Re: Z-Wave Products
« on: March 11, 2009, 02:44:28 pm »
Will you have more zwave sensors, light switches, etc... ?

353
Installation issues / Re: LinuxMCE 710 Subtitles
« on: March 11, 2009, 09:39:38 am »
Only reason I still use XBMC on my XBOX and not new and shiny LinuxMCE is because of the titles...

354
Users / Re: nvidia-ion-atom
« on: March 10, 2009, 09:33:49 am »
I would love to see next LinuxMCE work on Ion platform with full 1080p via Nvidia VDPAU, that would be so sweet :)

355
Feature requests & roadmap / Re: NVidia VDPAU API
« on: March 10, 2009, 09:07:04 am »
From what I have read it is trivial to enable VDPAU in MythTV and mplayer. MythTV supports VDPAU only thing needed during the compile is --use-vdpau option.

MPlayer needs to be patched and of you go :)

I don't see why it wouldn't go in LinuxMCE ASAP because it gives s real benefit to users of Nvidia cards that support VDPAU. Is there a way I can help this gets implemented? I'm not a developer but if somebody gives me some tasks I can handle I would like to help.

356
Users / Re: xine and subtitles
« on: January 16, 2009, 09:03:21 pm »
Did you have any progress on subtitles working?

357
Users / Re: Multi-language Video Playback with mkv / Matroska files
« on: January 16, 2009, 08:54:27 pm »
I would also be really gratefull if somebody would share their knowledge on how to play multi-language mkv files. I have LinuxMCE installed on XBOX1 and they made it really simple.

358
Users / still no luck with LinuxMCE :(
« on: December 02, 2008, 09:37:33 pm »
I have tried 4 graphic cards and I still have no luck with UI2 :(

I had these
Matrox G450 - worked great for SD movies, only UI1 :
ATI 9600 - worked also with HD movies, only UI1 :(
NVidia GeForce Ti4200 - UI1 only :(
NVidia GeForce 7300 - won't start X unless using vesa driver :(

I have now Nvidia 7300 with latest nvidia drivers when X start to load monitor just goes to stand by, everything works because I can still login through ssh and ping the LinuxMCE  - so it is not frozen.

Please help me because I'm going nuts... I guess I have been spoiled by Fedora and not needing to go through these tedious tasks of mangling xorg.conf...

Here is my xorg.conf s below so please yell if you see something obviously wrong :)
http://fpaste.org/paste/1276

and also yell if you see error messages in this X.org log file that would point to some obvious error:
part1: http://fpaste.org/paste/1277
part2: http://fpaste.org/paste/1278

Thank you in advance,
Valent.

359
Installation issues / Re: It can be done!
« on: November 25, 2008, 10:12:32 am »
I have the right ones because when I tried to install other two the installer complained that my card works only with nvidia 96.43.07 driver. Any other suggestions?

360
Users / Re: Anybody using NVidia Geforce TI 4200
« on: November 25, 2008, 07:36:35 am »
Thank you for your reply,
I installed NVIDIA-Linux-x86-96.43.07-pkg1.run package with nvidia 96.43.07 driver. But X fails to start when I edit my xorg.conf and put nvidia instead of nv driver.

Could you please share your xorg.conf and even if possible add an entry in wiki pages that this card works with UI2 - that would be very helpful. If I got it working I'll put on wiki makes a mini howto.

Cheers from Croatia,
Valent.

Pages: 1 ... 22 23 [24] 25 26