Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - golgoj4

Pages: 1 2 [3]
31
Developers / About Metadata
« on: October 30, 2010, 04:33:09 pm »
Hello All,

If your interested in compiling or just checking out the code (warning - im very new to c++) it can be found @ http://gitorious.org/linuxmce-autotagger. Whenever i push it to the server, it should be able to compile and run. There is also a binary called 'autotagger' that should be ready to go stand alone.

Beta version 1.1
-Takes 2 different command line arguments:
    -The path in quotes "/home/public/data/videos/test/"
    -The file number of the directory. This can be located in mediaFilesSync in the webadmin. Whenever you mouse over a link to a file, it shows you the file number (as its part of the link)

Test if you have a chance on a smaller media set (or large if your brave). In my testing the biggest impact is sustained db activity over %50 while running over larger lists of files. And this is the reason its specifically NOT recursive. So wherever you direct it, files should be there and not in a subdir.


Thanks for taking the time to read and test. Hopefully this can be integrated in the near future so our media will get tagged automagically.
-golgoj4

32
Users / How do you feel about
« on: June 05, 2010, 05:03:30 pm »
Changing the names of your files?

As i get a little better with c++, and a little more understanding of updateMedia, im considering extending updateMedia to work with theTVDB.com and imdb.com. The main issue i see however, is filenames. There would be a general format like for tv something along the lines of Show.season.episode.extension (ex SGU.S01.E19.avi) and movies like name.year.extenson (ex Top.Gun.1986.avi). I dont really know how people have their collections organized, how big the collections are on average or really anything else about people's libraries so please provide some feedback. Im more than likely going to try my damnedest to integrate this into updateMedia somehow, and i'd like to get an idea of how people store and categorize their libraries outside of the way i normally do it. For me, this would require a lot of file re-naming, but im up to it for metadata that will be automatically grabbed instead of needing to do it from the webadmin (although its a lot simpler now to do so).

thanks in advance
golgoj4.

33
Users / Batch media subtype
« on: May 28, 2010, 04:06:18 am »
Nothin major, just added to the 'edit directory attributes' screen in the webadmin to allow

setting of mediasubtype (std def, 720, 1080)
setting of fileformat (movies, dvd, tv shows)

this should make tagging larger amounts with these attributes of file a bit easier.

-golgoj4

file gets copied to '/var/www/lmce-admin/operations/mediaBrowser/'

created a trac ticket - http://svn.linuxmce.org/trac.cgi/ticket/705

34
Users / [Solved]Cant access files all of the sudden!
« on: May 24, 2010, 06:21:49 pm »
So this morning, im trying to access my resume's stored on the core. And I cant. From any system in the house. Or anything stored under my specific user or anything at all. These files still appear to be there because i can browse to them via the webadmin. I seriously need help on this because pretty much anything useful to me is stored there and now its completely inaccessible except to make sure its still there. The only major system change i've made was to try and fix mythtv...which im regretting now.

suggestion or anything would really be helpful because right now i dont even know how im going to try and get what i need.

golgoj4

35
Users / Need testers - updated 10-1
« on: February 14, 2010, 05:25:55 am »
Hello all,

Latest Version
-Multi-language support
-Sets Media type 'Tv Shows' and media subtype. Subtype is selectable between: Standard Def, HD 720, and HD 1080
-Single File, Batch, and Tv Specials

If no-one else can think of any bugs, im planning on opening a trac ticket and ask possy nicely to add it.

Zips are located here
http://langstonball.com/linuxmce-topmenu-31/25-software/59-tvdb-addition-to-the-webadmin

Installation:
unzip in the root directory, files should land in the appropriate place.

Also. please, pretty please:
if you hit an error, please let me know 3 things:
1. what language you are using
2. what the filename is
3. the error reported.

Thank you to the folks who have been providing feedback so far! Keep it coming and thanks for taking the time.
there is a limit to filesize, so i posted elsewhere:

This should run on 0710 and 0810

36
Users / Broadvoice wiki article
« on: January 29, 2009, 03:57:44 pm »
http://wiki.linuxmce.org/index.php/Broadvoice

Can this article be re-written to seperate the experiences from the setup? With them being intertwined, it may be difficult for new users to figure out the proper steps.

Also, if you could include the need for the gen-sip device in addition to any broadvoice branded boxes and why thats VERY important. If we inform our users properly, the shouldn't need broadvoice tech support to get up and running. Tschak was actually the one that set me straight on proper setup as broadvoice tech support was useless.

Thanks
golgoj4

37
Users / SoCal Linux Expo
« on: January 23, 2009, 08:19:32 pm »
Hello All,

I was recently contacted by someone from the SoCal Linux Expo that was interested in having us (the LinuxMCE project) put together a booth.

This sounds like an awesome idea to me as I wasnt able to participate in linuxTag and this is in my backyard (the location is only about 15 min away from me)

The main reason im posting this topic is that i'd like to see who else would be interested in this. Im contacting the organization committee to find out what is needed from us in addition to the specifics.

What I can do:
-Supply a MD (or core) with TV (tube not flatscreen)
-Supply an extra av device to demonstrate streaming to and from other devices.
-Supply an ata for voip
-free time :)

Once I get the information back from organizers, I will hopefully have a better idea of whats needed. In the mean time, anyone who has an interest please let me know if your interested here.

Please keep in mind, there is less than a month from now until the expo. Something to keep in mind. Also, if any of the linuxTag vets have any suggestions, im ALL ears.



38
Users / MythTV Problems
« on: June 20, 2008, 08:18:51 pm »
Issue started yesterday after my core was reset. Didnt notice any update but then i wasnt looking for them. But for some reason now, myth doesnt record anything other than what I am watching.

-Cant record from mythweb
-can do it from the myth gui on screen -just says 'record' then forgets about it
-cant do it from UI2 either with gyr mouse. red dot  dissapears

needless to say im a bit miffed because i *HAVE NOT* been messing with the system for a while now. Anyone have any ideas on what i should look at as a possible cause?

i get this in the dce router log when i press record twice, pressing once only shows up on myth gui, pressing twice shows up on dce router and myth on screen gui

Code: [Select]
08 06/20/08 11:17:21.779 Received Message from 28 (USB UIRT 0038 / Langstons Room) to 10 (Media Plug-in / Langstons Room), type 1 id 102 Command:Record, retry none, parameters: <0xab027b90>
08 06/20/08 11:17:21.780 Received Message from 28 (USB UIRT 0038 / Langstons Room) to 44 (MythTV Player / Langstons Room), type 1 id 102 Command:Record, retry none, parameters: <0xa0bf6b90>
08 06/20/08 11:17:21.780   Parameter 41(StreamID): 1002 <0xa0bf6b90>

thoughts?

39
Users / Playlist Editor - Rewrite
« on: April 16, 2008, 01:59:00 am »
Hey all,

So im making a new playlist editor. And I would like the community's input.

This started when LON22 created the batch assign script. I liked it because it let me organize the media a little bit faster than go through every single file.

Which brings us to the playlist editor. I wanted to add some functionality to it as well as make it run just a little faster.

blah blah blah.

The 1st incarnation is done* and I was looking on some input from the community on a couple things:

  • Colors and layout. I am not a graphic designer. Nor do I claim to be. So if any suggestions on the look and feel would be awesome.  My main goal was to get it working first, make it pretty second.
  • Coding. This isnt as important right now but by the time this is done, it will need to be added into the webadmin so its organized with the rest webadmin. Problem is, im having some difficulty there, so if anyone has any suggestions, please let me know.

I dont see how to add a file here so i'll just post the link to where it is. The instructions are on that page, but i'll say them here too.

   1. Copy into the /var/www/  directory
   2. Unzip
   3. Point browser to the directory on your core. EX: http://dcerouter/DDMB/
   4. All files need to be in the same folder.
   5. After that,  flame me for bad coding.  :P

Thats about it.

Note: This should'nt break your system or existing playlists. If anything, there may be an issue with the playlist ordering. If you recieve an error, its because it was fixing something in the background. Performing the same action that gave an error should would the second time because any issues with playlist order will have been fixed. There is one error that i have yet to track down which involves funky characters in the filename. Nothing breaks, just tells you there was an error.

Also, it was updated on 4-16-08, minor issue with adding playlists.

Link http://langstonball.com/component/option,com_docman/task,cat_view/gid,33/Itemid,37/

40
Users / Problems with Insteon and x10
« on: February 27, 2008, 05:48:36 pm »
Posting this thread to figure out whats going on with the 2412s plm I purchased.

Followed instructions as per the wiki.

Currently, its connected like this

plm into wall socket ---> serial to usb adapter ----> usb input on core.

Error log
Code: [Select]
01 02/23/08 1:23:10.223 Receive string failed in HandleRequestSocket 18:ReceiveData failed Command_Impl1 Dev #114 <0xb6094b90>
01 02/23/08 10:08:08.655 Receive string failed in HandleRequestSocket 18:ReceiveData failed Command_Impl1 Dev #114 <0xb609bb90>
01 02/23/08 22:41:01.339 Receive string failed in HandleRequestSocket 18:ReceiveData failed Command_Impl1 Dev #114 <0xb6045b90>
01 02/23/08 22:47:08.163 Receive string failed in HandleRequestSocket 18:ReceiveData failed Command_Impl1 Dev #114 <0xb60abb90>
01 02/26/08 23:28:31.751 Error while calling method: Cannot call class method: cmd_350
01 02/26/08 23:28:32.740 Error while calling method: Cannot call class method: cmd_350
01 02/26/08 23:28:33.252 Error while calling method: Cannot call class method: cmd_350
01 02/26/08 23:28:51.408 Error while calling method: Cannot call class method: cmd_350
01 02/26/08 23:28:51.871 Error while calling method: Cannot call class method: cmd_350
01 02/26/08 23:30:11.520 Error while calling method: Cannot call class method: cmd_350
01 02/26/08 23:30:12.007 Error while calling method: Cannot call class method: cmd_350

DDamron, please let me know if i need to post anything else to help figure this out.

Interfaces


Device data



ps. nm the BSG fanboyism  :D

41
Users / Building LinuxMCE the hard way
« on: February 14, 2008, 09:00:59 am »
Sorry to any admins, normally I donut post this stuff but I really couldn't resist.

http://www.computerworld.com.au/index.php/id;396147352;pp;2 <---computerworld story
http://hardware.slashdot.org/article.pl?sid=08/02/14/0419227&from=rss <---slashdot article, mainly funny for the comments.

'...the outgoing Linux Australia group president's hacked home, in which just about anything from watering the lawn, to opening his blinds, or checking the mail can be controlled through a software environment.'

Maybe we should send this guy a quick install DVD... I personally like the sub-dermal RF-ID chip.

sorry if this is in the wrong place, but theres no general discussion area.

42
Users / FM radio cards
« on: January 01, 2008, 02:54:50 am »
So i have this hauppage wintv pvr mce-500. Tuner works great. Plug and play. But i listen to a lot of over the air radio too.

Long story short, I have tried everything I know (which aint much) and the fm function appears to work but there is no sound. i've tried various things like Radio, Gnomeradio fm-tools. all with the same result. No sound. And there is no sound output jack on the hauppage card so i cant loop it back to the input on the board sound card. Any suggestions on what I should do would be greatly appreciated. My end goal is to eventually use this as a scenario in lmce. so I can listen to radio without tying up my receiver, and hopefully use it in a multi room setup.

card - hauppage wintv pvr mce-500
board - asus m2npv-vm mobo
im running lmce 0704

help!


43
Users / USB-Uirt and scenarios
« on: November 11, 2007, 08:40:19 pm »
Ok, so I just received mine on Friday.  I have been trying to get it to work properly since then. Maybe someone here can answer a couple of questions for me.

1. How do you set up scenarios? Its really confusing with all the random commands in the scenario page. Do i need to create a cheat sheet and learn every single one? Is there an easier way to tell it what to turn on and off? Currently, nothing works right except the volume.  :(

2. Why would my usb-uirt send the right code once, then stop working after that?

3. this is related to the scenarios again. is there an explicit way to tell it what to do and when?

 Believe when I say i have been pouring over the wiki, but the info there is really just not complete. hopefully someone here can explain to me how to get this working properly.

44
Users / Media Library gone mad!
« on: October 27, 2007, 11:40:50 pm »
A little problem I've been having.

I tried to use the automated media cover art feature, but something happened and now it has mis labeled my entire collection. I've just re-installed the entire system (kubutu live cd & 2 install disc process) but the library seems to have not been erased. I suppose i should have re-formatted it as well eh?

Anyways, my question is, where is this media information stored. Someone mentioned that I could access the db locally, but how. Also, it seems to want to overrule me on data after I attempt to fix incorrect information. I can go through a long list and see them back the next day with the incorrect information.

Any Ideas?


Pages: 1 2 [3]