Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - schaferj

Pages: 1 ... 7 8 [9]

I'd like for my core to also be the main home server and eliminate other power hungry servers.  So I'd like the core to handle client authentication (as a samba pdc) and better firewall / security / privacy / parental control.  However, I don't want to break lmce or cause upgrade incompatibilities as the old pluto code still seems entangled with the underlying kubuntu.

Please share any recommendations / experiences you've had in modifying the core dcerouter networking configs.

In several previous installs, I attempted to change some things with bad results.

Current setup is running OK with core at (changed default).  (some of the help in the webadmin is not found - and I suspect this change may be the cause).

I'd also like to change the dcerouter smb & hostname (from dcerouter to something_else) and the workgroup from linuxmce to schafer (which is my house net default).  Will this break anything or will it be reset by the lmce database?  And it would also be nice if the media directors (moonxx) could be in the same workgroup as well rather than the "pluto" workgroup.

Bottom line minimum would prefer to have all clients in the same workgroup with samba primary domain controller and dans guardian content filter on the core.

Please your experiences.

And if the best answer is to run ipcop or something on a dedicated box upstream from the core (, and that samba pdc is better off on it's owe 'buntu server (  That's good to know as well and is my current and default setting.

much thanks,

Users / Re: Sucess Stories?
« on: September 17, 2007, 04:39:02 pm »

quick thoughts:

I have a good core hybrid on a Asus P4P800 E Deluxe intel 875 / 865, socket 478.
mobo firewire to sony xl1b (200 dvd jukebox)
and four media directors on ASUS M2NPV-VM mobos.
smb shares mounted from external servers.

I suggest always creating a core hybrid (vs a pure core) since it make troubleshooting so much easier.


Users / Re: Sony VAIO XL1B3 Jukebox failure
« on: September 15, 2007, 01:25:06 am »

There's a weath of knowledge on the "Unofficial VGP-XL1B2 Thread"
including - "Alignment issues with VGP-XL1B - how to fix" at:

I have had issues with the jukebox, but it now seems to be working.



Finding the ASUS M2NPV-VM known-compatible mobo has been a godsend after messing with pluto for a year with limited success.  The "video" text on the wiki should be required reading for anyone insterested in lmce or pluto.

One drawback to the menpv-vm is that it has only two PCI slots.  Not a problem in the mds, but in the core, you add one gig ethernet card and one WinTV-PVR-150 MCE and that's it.

I appreciate your suggestions on known-compatible ATX mobos with more PCI slots.


Developers / Re: small patch for auto.PlutoStorageDevices
« on: August 17, 2007, 07:11:25 am »
much thanks! 

My lmce core finds the servers and the share, but does not find the media files...

How do I apply this patch?

thanks again,

Users / media files resync error - maplock?
« on: August 17, 2007, 03:46:35 am »

The media finder does not seem to be working for shared folders, so I ran pluto-admin -- files & media -- media files sync -- mediaFilesSync on  /home/public/data

but it errors off with:

"Cannot find self in maplock!"

Appreciate any insight.

much thanks,

executeLog extract:

05   08/16/07 21:21:20.880      # PlutoMediaFile STARTED: dir /home/public/data/pictures/flickr/2007/07 file 21 <0xb6b8f6d0>
05   08/16/07 21:21:20.880      Parent folder already in the database: /home/public/data/pictures/flickr/2007/07/21 <0xb6b8f6d0>
05   08/16/07 21:21:21.531      # PlutoMediaFile STARTED: dir /home/public/data/pictures/flickr/2007/07/13 file 796781968.jpg <0xb6b8f6d0>
Writing: PK_Attr = 30      *
Don't know yet how to save tag with PK_Attr = 30 and value *
05   08/16/07 21:21:21.619      # PlutoMediaFile STARTED: dir /home/public/data/pictures/flickr/2007/07/13 file 802864464.jpg <0xb6b8f6d0>
Writing: PK_Attr = 30      *
Don't know yet how to save tag with PK_Attr = 30 and value *
05   08/16/07 21:21:21.629      # PlutoMediaFile STARTED: dir /home/public/data/pictures/flickr/2007/07 file 13 <0xb6b8f6d0>
05   08/16/07 21:21:21.629      Parent folder already in the database: /home/public/data/pictures/flickr/2007/07/13 <0xb6b8f6d0>
01   08/16/07 21:21:24.515      Cannot find self in maplock! (0x80b07b4) (>2) alarm: AlarmManager.cpp:102  <0xb6b8eb90>
ready to dump locks using logger: 0x80b0858
05   08/16/07 21:21:24.535      Dumping 1 locks <0xb6b8eb90>
05   08/16/07 21:21:24.535      finished check for exceptions <0xb6b8eb90>
05   08/16/07 21:21:24.535      OL: (0x80b07b4) (>1) alarm AlarmManager.cpp l:87 time: 9:21:24p (0 s) thread: 3065575120 Rel: Y Got: Y <0xb6b8eb90>

Installation issues / Re: Fiire Station specs anyone looked inside
« on: August 16, 2007, 03:43:06 pm »

Compatible Products & Services / Re: LinuxMCE Min. Requirements
« on: August 16, 2007, 03:02:33 pm »

the demo video text has a good description:

Core: "The computer consisted of an ASUS m2npv-vm motherboard BIOS version 0901, AMD Athlon 64 X2 3600+ CPU, 80GB hard drive, Realtek 8139 as the 2nd network card, 1GB RAM, generic CD/DVD, keyboard used only to to install"

MD same mobo with only the one built-in NIC, 512kb RAM & less CPU is ok.

Anyone know what mobos are in the fiire products?


Installation issues / lmce 0704 hang after reboot??
« on: August 10, 2007, 09:35:47 am »
on reboot, my core hangs after the kubuntu blue scroll bar completes.

Console displays:

Ubuntu 0704 dcerouter tty1
dcerouter login:                   /etc/samba/      ----

And then it hangs there (for hours).  As I recall, when it booted correctly, several more msgs scrolled by and then x started and the lmce launcher.

Any ideas / plans / 'things to check' appreciated.

much thanks, joseph


I suggest that lcme be able to be installed on top of freespire 2.  freespire 2 is built on ubuntu 704 with kde, so it should be straightforward and freespire includes the option of installing all the proprietary components.

Freespire 2:
is essentially kubuntu + legally licensed proprietary sw:
LCME 704 is built on kubuntu 704, so it seems like a very good fit.

Linux MCE includes:

media & entertainment with a server for music, movies and tv shows, plus a PVR and DVD Player,
a home automation system to control everything in the home with touch-screen tablet and Bluetooth mobile phone controllers,
a phone system with video conferencing,
a security system that feeds you live video on your mobile phone when something happens, and lets you speak to visitors through your stereos, and
a home PC solution.

Does anyone know if Freespire built on kubuntu or directly on ubuntu?




Installation issues / linux mce 2 over freespire 2?
« on: July 31, 2007, 12:15:41 pm »
BLUF:  I tried to install lmce 2rc over freespire 2rc and cd cache failed - but I got that far.

Freespire 2:
is essentially kubuntu + legally licensed proprietary sw:

right click install was not available, so I executed:
/media/CDROM# dpkg -i mce_installer_2_0.1_1.i386.deb

that worked (noted xorg missing in diff.list) and put the lmce install icon on the desktop.
disk one hd cache worked, but failed on disk 2 cache as described in earlier post.

Anyone else have any luck with this?  Seems like a natural fit.

Installation issues / Re: RC1: USB ports switch ON/OFF continuously
« on: July 31, 2007, 12:03:11 pm »
I had this problem with pluto.  Solution was to move the usb hub to a windows box to serve the media files.

Pages: 1 ... 7 8 [9]