Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - chriss

Pages: 1 ... 3 4 [5] 6 7 ... 10
61
Just enhanced the patch to do filtering of arbitrary attributes in mediaFileSync, i.e., it becomes possible to show only items with/without a certain attribute.

see patch here http://svn.linuxmce.org/trac.cgi/attachment/ticket/47/filter_mediaFileSync.0810.patch

br,
/chriss

62
Users / Re: Suspend to RAM
« on: January 08, 2009, 03:41:05 pm »
I remember trying killing all SCREEN processes and then running the launch manager again from a script but for some reason this was not 100% bulletproof. I will revisit this soon when I have time. Any better ideas?

Just an idea: why not extend the launch manager to kill all devices before suspending and restart all devices after resuming? all the logic should be there (start/stop MD) just need to somehow connect it to suspend/resume.
Seems a cleaner solution - however I haven't researched it before.

/chriss

63
In my case I have several templates I've contributed to older Mantis system and since it's unclear what will happen with those contributions

bulek,

I'm not part of the dev team myself so I can't say for sure, but in the Trac Wiki the devs wrote
Quote from: http://svn.linuxmce.org
Trac can import the Mantis tickets automatically, but we decided this is not a good idea since we will want to review each ticket from Mantis.
so I think that the tickets are not lost.

You can check for your contributions on http://sqlcvs.linuxmce.org/sqlcvs/, too and if I remember correctly, the mantis system still exists and you can apply for access to the old mantis system.

just my 2c
/chriss

64
Users / Re: Playing files with "special chars" (äöü) on MDs fails
« on: December 17, 2008, 10:22:48 am »
hari,

you know that using spaces, special chars and umlauts in filenames is not the best practice?
Well, I think, if a file system and the applications support those characters, I should be able to use them without problems  ;D

zaerc,
Does the file exist under that exact name and path on your MD, or does it get mangled somehow?
thanks for this hint. This is exactly the problem. I was about to dig into this but sambuca already came up with a solution.

sambuca,
thank you very much. I will try that!

/chriss

EDIT: just verified the solution. works perfect :) thanks again. I'll post this to trac to have it included in 0810

65
Users / Playing files with "special chars" (äöü) on MDs fails
« on: December 16, 2008, 06:21:10 pm »
Hi,

just discovered a strange behavior. Files with umlauts or other special characters in the file name fail to play on my MDs but are playing fine on the core (where they are stored).

Error in DEClog:
Quote
08      12/16/08 17:45:22.982           Received Message from 36 (.[36;1mXine Player / Wohnzimmer.[0m) to 33 (.[36;1mOnScreen Orbiter WZ / Wohnzimmer.[0m), type 1 id 809 Command:.[35;1mDisplay Alert.[0m, retry none, parameters: <0x7d079950>
08      12/16/08 17:45:22.982             Parameter 9(Text): File not found: /home/public/data/audio/Nils Landgren - Christmas With My Friends/10 - Nils Landgren - Gläns över sjö och strand.mp3 <0x7d079950>
08      12/16/08 17:45:22.982             Parameter 70(Tokens): xine_player_message <0x7d079950>
08      12/16/08 17:45:22.982             Parameter 182(Timeout): 10 <0x7d079950>
08      12/16/08 17:45:22.982             Parameter 251(Interruption): 0 <0x7d079950>
08      12/16/08 17:45:22.983           Received Message from 23 (.[36;1mXine Plug-in / Arbeitszimmer.[0m) to 36 (.[36;1mXine Player / Wohnzimmer.[0m), type 1 id 38 Command:.[35;1mStop Media.[0m, retry none, parameters: <0x5782e950>
08      12/16/08 17:45:22.983             Parameter 41(StreamID): 1001 <0x5782e950>
08      12/16/08 17:45:22.983             Parameter 42(MediaPosition):  <0x5782e950>
05      12/16/08 17:45:23.094           .[33;1mConnect() failed, Error Code 111 (Connection refused)).[0m <0x5a834950>

Any ideas why this is going wrong? I hope I don't have to rename all of those files...  :-\

Thanks,
/chriss

66
Users / Re: How to properly tag episodes?
« on: December 15, 2008, 05:31:13 pm »
Thom,
thanks for the input. Got them tagged and will leave it like this. just wasn't sure if I'm doing something wrong.
any hints on what needs to be done to enable this? probably in the orbiter code!?! guess I need to setup a build environment first...

@skeptic, cirion, thanks for describing your workarounds.

67
Users / How to properly tag episodes?
« on: December 15, 2008, 08:42:50 am »
Hi,

just wondering if the orbiter is currently able to handle episodes?
Maybe I'm doing something wrong... I have a couple of episodes which do all have the same title attribute but different episode names. I expected the orbiter to show the title only once and go to a new screen showing the episodes after selecting the title. Instead the orbiter shows every episode on the first screen, i.e. I see the same title several times. BTW, when selecting a video, the orbiter does not show the episode on the details screen either.
Am I doing something wrong or is this a bug/missing feature?

BR
/chriss

68
Developers / Re: Annoucement: Getting cover art and attributes from IMDB
« on: December 14, 2008, 10:06:00 pm »
Zaerc,

thanks for applying my patches!

/chriss

69
Developers / Re: Annoucement: Getting cover art and attributes from IMDB
« on: December 14, 2008, 06:10:20 pm »
Ok, I submitted the patch to Trac [1]. If you want to try it, you should also consider patching a small bug [2] (which appears on Amazon scans, too). It is working without any problems on my systems, however, use it at your own risk ;)

I'll appreciate any kind of feedback and suggestion.

Bye,
/chriss


[1] http://svn.linuxmce.org/trac.cgi/ticket/53
[2] http://svn.linuxmce.org/trac.cgi/ticket/52

70
Developers / Re: Annoucement: Getting cover art and attributes from IMDB
« on: December 14, 2008, 05:42:47 pm »
Is there a link to the code that we can download and try?

Freyman, if you are referring to the IMDB code please be patient. I'm still cleaning up a few things and will prepare a patch soon.


71
Developers / Re: Annoucement: Getting cover art and attributes from IMDB
« on: December 14, 2008, 12:50:58 am »
how did you get around their tos? or did they open up a new api?

I just tried the first IMDB PHP library I found (http://sourceforge.net/projects/imdbphp/) and it works well.  ;D

72
Developers / Re: Annoucement: Getting cover art and attributes from IMDB
« on: December 13, 2008, 03:12:02 pm »
BTW, it's quite slow ATM, see attached log output (50s for 20 IMDB items).

73
Developers / Annoucement: Getting cover art and attributes from IMDB
« on: December 13, 2008, 03:10:40 pm »
Hi *,

I added an option to get my movies tagged with IMDB. It's basically working (see pictures attached) but still needs some fine tuning I think.

Cheers,
/chriss

74
Well, after all it's just a hack. However, I can spend some more work on this to have the label of the checkbox in the language files and maybe even allow for filtering other attributes as well, e.g., files without title/performer/...

If it is of interest for the upcoming releases I'll create a ticket in trac.

Bye,
Chriss

75
Hi guys,

I'm tagging all my media since a couple of weeks and since it was annoying to always skip through the already tagged media in webadmin I made this small hack to the mediaFileSync module. It adds a checkbox right next to "Show attributes" saying "Show only files without cover art" and this is exactly what it does: just hide all directories/files that already have cover art attached.

If you would like to use it, just copy the attached file mainMediaFilesSync.php to /var/www/pluto-admin/operations/mediaBrowser and make sure to backup the original file. I took the file from my stock 0710 installation.

Cheers
/Chriss

edit: I attached a patch, too, if this is of any help.

Pages: 1 ... 3 4 [5] 6 7 ... 10