Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bulek

Pages: 1 2 3 [4] 5 6 ... 60
46
We have released an update that replaces the Orbiters progress screen with a much improved one;

We replaced the X11 progress screen/bars with SDL progress bars similar to the one you see on startup on UI1 already (as you probably noticed, you don't see it on UI2 - it was disabled in code). Now in UI1 & UI2 we have a single progress screen design that has a much improved visual layout and is based on SDL rather than the old 'bolted' on X11 progress window. These progress windows are displayed by the Orbiter during a regen or a reload router.

More updates on the way... new ZWave binary & a new Dianemo UI Skin...

All the best


Andrew

Hi,

thanks for efforts. If I may add, there are still some things that at least I'd like to have them differently regading UI (I'm using Dianemo (dark) skin) :
1. UI1: Media button that displays current media name is in gray color on virtually black background - and cannot be seen...
2. On interactive floorplans all texts are written in white, so one should have really dark backgrounds to see anything... Any chance to give choice of black or white to user ? I had black colour on 7.10 and visibility was better.
3. I miss more floorplans on UI1 (only 4 currently - there are approx 350 parameters flowing from home automation to Dianemo and I miss more floorplans - there are 8 floorplans on UI2)
4. On UI2 floorplans are still overlapped (this is the same as it was for me on 7.10). That means that when you click on some light on floorplan, you get "fast movie of all floorplans" and then the right one shows....

Hope this helps a bit,

regards,

Bulek.




 

47
Users / Re: Command Line System Queries
« on: March 16, 2012, 11:51:55 am »
Thanks for wiki page.

I'd like to ask additional question : can I check what is happening in certain Entertainment zone (whether media is playing, or no,...) ?

Thanks in advance,

regards,

Bulek.

48
Users / Re: Command Line System Queries
« on: March 15, 2012, 10:06:41 pm »
Please add your knowledge to wiki page. This might be interesting also to others....

For me also...

Thanks,

regards,

Bulek.

49
Users / Re: [Dianemo S] Phone system configuration
« on: March 15, 2012, 11:25:06 am »
My biggest problem is getting pluto/dianemo to understand what I did in FreeBPX! I'll wait for the wiki, hopefully that will help ...

You shouldn't change too much in Freepbx as parts are generated by Dianemo/LMCE scripts. I remember Radu said not to touch extensions (although passwords are trivial and make system vulnerable)... What I changed in Freepbx is only trunk settings and took care so incoming phone calls come to proper extension. The rest is up to Dianemo....

HTH,

regards,

Bulek.

50
Users / Re: Can we get another Dianemo centric board under LinuxMCE
« on: March 15, 2012, 02:08:16 am »
I agree,

I'll put [Dianemo] in Subject if it will be specific to Dianemo.

Regards,

Bulek.

51
Users / Can we get another Dianemo centric board under LinuxMCE
« on: March 13, 2012, 10:23:24 am »
Hi,

those two systems are different in many details, so I think it would be good to separate Dianemo specific discussions into separate board not to confuse all other less experienced users...

Can we make new Dianemo board under LinuxMCE ?   I think it would be better for all of us.

I just found out that I can do it - but would still like to hear other member's opinions.

Regards,

Bulek.

52
Users / Re: [Dianemo S] Phone system configuration
« on: March 13, 2012, 10:20:54 am »
Hi,

I remember that I had to fix few things and got telephony in some kind of "working state". I think that some of basic Asterisk debugging skills should be used... First of all, enter asterisk shell with "asterisk -vvvvvvvvvvvvvvvrgc" and from there you can check "sip show registry" state of your SIP trunks, then "sip show peers" your extensions, etc...

Then also in shell you can get debug messages when you try to make a call - then try to locate warnings, errors. You can even get more messages by "tail -f /var/log/asterisk/messages"

I've found my notes and instructions what I needed to fix my system - hope they will help, although they should get into updates soon :
Quote
had to change :
[19.2.2012 3:12:08] tiniahouse: add this below to /etc/asterisk/extensions_custom.conf
[19.2.2012 3:12:11] tiniahouse: [incoming-sip-calls]
include => ext-did

#include extensions_pluto_dial.conf

; ###########################################################################
; PLUTOs "trusted" context
; ###########################################################################
[trusted]
include => from-internal
[19.2.2012 3:12:25] tiniahouse: comments :
[19.2.2012 3:14:05] tiniahouse: I have SIP trunk to my provider on dedicated network card... For some reason, all incoming calls (even from trunk) end in from-sip-external context that is basically meant for anonymous incoming calls... so it's pretty restricted and all I got was "out of service" annoucement...
[19.2.2012 3:15:47] tiniahouse: So I created my own context (first two lines) and also made this context default. That lowers security level, but we already have passwords being the same as extension number... Now, when call comes in, if it's for DID, then it goes to coresponding incoming route - that's first step I made
[19.2.2012 3:17:15] tiniahouse: Now, my telephony is organized in this manner : I route all incoming calls to one dummy Dianemo user (housephone)... Why ? Cause I don't need to have more users and then I have to switch statuses for all of them... So we have housephone and calls are routed according to its state...
[19.2.2012 3:19:18] tiniahouse: so at the end of incoming route, there is a dial for Local channel 307@.... and 307 is virtual extension for user housephone... That was not working cause 307 and all other user extensions were not visible in dialplan... For some reason file with them is not included in any other config files.... So that explains 3rd line
[19.2.2012 3:21:18] tiniahouse: Then I got to proper housephone user, but calling more users at once (according to routing setup in admin page) was not working, cause calls are made as 202@trusted - trusted context was unknown in my system (it's only synonim for context from-internal - so that explains last lines
[19.2.2012 3:22:33] tiniahouse: I also had to change /etc/asterisk/sip_general_custom.conf ,where I changed from-sip-external to my new context incoming
[19.2.2012 3:22:38] tiniahouse: -sip-calls....
[19.2.2012 3:23:34] tiniahouse: Also, there are files missing in /usr/share/asterisk/agi-bin  - those with pluto-... in front of them (I compared to my 7.10 system)...
[19.2.2012 3:23:57] tiniahouse: Now also incoming calls are working ok in my house... Did you follow me ?

Sometimes I just wonder how Dianemo users use telephony... :)

HTH,

regards Bulek.

53
Installation issues / Re: Very high pings on internal network
« on: February 21, 2012, 09:03:30 am »
Hi,

probably this is not the cause, but I remember that I had to change MTU on my network with similar symptoms..

Regards,

Bulek.

54
Users / Re: How to setuo sccp.conf and use SCCP under Asterisk
« on: December 12, 2011, 03:56:36 pm »
I have (among others) a 7970, this is the sscp.conf. The 7970 has 2 lines. One especially for a door bell.

....

Thanks for response and info. How is your doorbell connected to asterisk - is it just ordinary extension ? Is this setup different from setup where doorbell call comes in and goes to other phones by nornal call routing ?

Thanks in advance,

regards,

Bulek.

55
Feature requests & roadmap / Re: Internal network control
« on: December 10, 2011, 10:08:50 pm »
Hi,

I have this one on my to-try-list :
http://www.opendns.com/home-solutions/parental-controls#family

HTH,

regards,

Bulek.

56
Users / Re: How to setuo sccp.conf and use SCCP under Asterisk
« on: December 08, 2011, 09:25:13 pm »
I have one 7970, that is working fine under 810 using SCCP. I just used the instructions in with Wiki after a fresh install.

CDM

Hi,

thanks for response. Could you please post some more details about how it looks (Asterisk version, your /etc/sccp.conf ) ??

It will help me a lot...

Regards,

Bulek.

57
Users / Squeezeslave to speaker selector to 4 audio zones ?
« on: December 04, 2011, 02:45:58 pm »
Hi,

I'm using squeezeslave that is amplified in MArantz receiver on multiroom channel and then connected to Speaker selector ESS. I'm currently using it in this way :
- I've put squeezeslave in certain room. When I start playing, MArantz is also properly switched on and set to proper input. But I have to manually enable speakers that are active in speaker selector...

I wonder if I could set up Squeezeslave in such manner, that it would be visible as player in 4 entertainment areas and when I start playing in certain zone, everything should be setup automatically (including ESS) ?

Thanks in advance,

regards,

Bulek.

58
Users / Re: Supported USB Web cams
« on: December 04, 2011, 09:08:31 am »
Hi,

I had two logitech Quickcams connected (3000 and 4000), but driver was always complaining and they simply don't work for me... Not sure what is the problem...

HTH,

regards,

Bulek.

59
Developers / Re: Linphone video call for future
« on: December 01, 2011, 02:26:56 pm »
I'd just add my opinion,

linphone already supports video for quite some time. We use it of embedded orbiter phones...

I still stand, that video telephony would be killer app for such systems...

Regards,

Bulek.

60
Users / How to setuo sccp.conf and use SCCP under Asterisk
« on: November 30, 2011, 01:16:33 am »
Hi,

I've 3 7970 phones and they worked quite ok under 7.10. I'd like them to work under newer versions of LMCE - they also support a lot of various features that can be put in config file. But when I take a look at this config files, they all seem a bit cryptic for me.

Does anyone know of any document that would (shortly) explain features & settings of sccp channel under asterisk ?

Regards,

Bulek
 

Pages: 1 2 3 [4] 5 6 ... 60