Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - bulek

Pages: [1] 2 3 ... 12
1
Users / Running LinuxMCE on low power system (Odroid and similar) ?
« on: February 07, 2016, 12:05:38 pm »
Hello,

I'll probably try to establish LinuxMCE core for my home - currently I'm running Dianemo, but that's another story... My plan is to do it in low power sense...

I've got pretty interesting suggestions from users running core on ODROID devices. These really seem to be interesting option. But I'm also curious about other lower power options.

I've failry complex system in my house - have 3  Cisco 7970 phones, doorphone, lower automation layer from Cybrotech with integrated heat pump, ventilation, lighting, irrigation, sauna, bathtub, almost any other existing device,..., video surveillance with 4 analog cameras, whole house media&audio with two channels via Marantz SR5600 and speaker selektor, few MDs, one on main TV and 17 inch touchscreen in living room as a main system control)... Over 300 variables flowing between lower layer automation from Cybrotech and LMCE. Currently integration is made via Perl implementation of LMCE device.

ODROID suggestion is really interesting to me, but I'm curious how this fits complexity stated above ?

I'd be really happy to read more details about those setups... In the mean time I have few quick questions :
- how do you cope with video surveillance, large media disk, asterisk, large SQL database, ... ?
- do you have also MDs on cores (I'm quite happy with simpler MD on core - using UI1 on main touchscreen) ?
- I guess you use RPis v2 for MDs - are they full blown MDs? Can you start media on them from Orbiters ? Is RS232 TV control supported ?

One idea is to divide system and have video surveillance on separate system (one of chinese good products) and lessen the burden on those cores...

Maybe there is also option of full blown PC, but still on lower power side ? Any suggestions ?



Thanks in advance,

regards,

bulek.


2
Hello,

as a long time Dianemo user (I think right from the start of Pluto system) and getting more and more dissapointed with Dianemo system.

I'm not sure what is happening with the company, but for quite some time I cannot use Dianemo to efficiently control my house anymore...

We have UI1, newer UIs, HTML5 Orbiter but none covers system completely and they all seem to be in some kind of half working state - the main point is that I cannot access all features of the system using any of them (I could use UI1 on main touch screen to access custom scenarios, then HTML5 Orbiter for audio control, but it seems kind of silly to do so).

Short description of my system :
- i have full blown home automation system using system from Cybrotech on lower (home automation) level. I've written my own integration interface that works perfectly and connects to Dianemo bidirectionally. Beside common devices (lighting, ...), system also integrates heat pump, AIR ventilation, Sauna, whole house music (two channels using Marantz SR 5600), whole house internal phone system (3x Cisco phones with color touchscreens). There are around 400 parameters flowing bidirectionally between higher and lower level of the system.

We have main touchscreen that runs UI1. Why? Because this was one of the first UIs available and concerning access to custom scenarios is the only one allowing access also to HVAC, Media, Phone and Security scenarios and also all floorplans. But for quite some time, control of Audio doesn't work anymore in UI1. It's hard to explain to my family (wife), why audio system cannot be controlled from UI1 (this happend when Dianemo has changed music server).

I've considered newer UIs for touchscreen, but as far as I know, none of them allows access to custom scenarios in Hvac, Media, Phone and Security scenarios. Audio works, but we cannot set blinds up/down, set Sauna on/off, Kids one touch call to grandma, etc... I've even write my own web based GUI to cover most of  defficiencies, but integration of multimedia control is harder.

I've also considered HTML5 Orbiter, but it seems restricted in similar way - not all (better said majority) custom scenarios are accessible and it still seems unfinished also on other features (e.g. audio volume control, video, floorplans other than media, ...).

I'd kindly ask if someone from Dianemo can explain to us, what is happening currently, what are plans for future development and how is Dianemo progressing ?

For now, (as far as I'm concerned) it's only usable for not so many devices and only for certain type (lighting is probably the only one supported properly - by access to custom scenarios and floorplan)...

I'm not sure how many full blown systems are running Dianemo, but I cannot imagine how to setup such whole house system with those restrictions in UIs. Other systems are progressing much and I feel restricted by using Dianemo. Sorry to say this, but it simply feels outdated, specially user interfaces that don't follow common progress anymore...


Hopefully, you're already working on system and all defficiencies are already solved or being worked on.... But please, let us know about it...

Thanks in advance,

regards,

Bulek.

3
Users / How to deny certain MAC address for dhcp ?
« on: April 26, 2015, 11:56:44 am »
Hi,

I'd like to add certain MAC address to be ignored by dhcp. Have two questions:
- what is needed to add to dchcpd.conf ?
- any way to add this change to  survive network settings change via admin page ?

Thanks in advance,
regards,
Bulek.

4
Users / ELO touchscreen calibration (Dianemo,LMCE)
« on: January 26, 2015, 02:52:21 am »
Hello,

page on wiki says that calibration for this screen can only be made manually by guessing...

Anyone aware of any other option to properly calibrate ELO touchscreen in current Dianemo or LMCE system ?

Thanks in advance,
regards,
Bulek.

5
Hello,

we haven't used Firefox as embedded web browser extensively... But now my wife discovered few sites about cooking& recipes and now my task is to bring it to Dianemo (probably similar also applies for LMCE).


I wonder if I can make embedded Firefox more touch screen friendly ?  The biggest problems are small buttons, sliders at the side, etc...
Is there any possibility (config options) to increase those little widgets to be more usable on touch screen ? 
Any other workaround to bring web sites to main touch screen ?

Thanks in advance,
regards,
bulek.


6
Hello,

quite some time Audio media playing feature has not been working for us. When we tried to start Audio, got errors about non-existing Entertainment Area. Radu gave me advice to try new skin and it seems that Audio is not working anymore under UI1 skin. I know this skin is old, but we've been using it all the time on our main touchscreen.

Now to retain Audio features, we have to move to newer skins, but we got quite dissapointed, cause newer skins don't support some vital screens - at least for us. Our house is fully automated one and we have practically everything automated (also fully integrated Ventilation system, Heat Pump and whole house audio system with two channels and 5 audio zones).

To be able to control such a beast, we had created a lot of scenarios, that are showed in separate buttons on UI1 main screen (see attachment). We have at least 12 such scenarios for each main category (listed in left column). Also we liked quad view camera screens - we have two such screens, one for internal and one for external cams.
But we're a bit said, cause newer skins seem to be not supporting mentioned features anymore. Only Lighting button brings you to Lighting scenarios, but in our system this is only smaller part of all scenarios.

I think that those screens are really important for a system that appears to be full automation solution for residential use. My family members got used to those buttons (scenarios), even our grandma stayed with us for a few days and she used some additional scenarios created especially for her quite extensively.

Currently, we will probably keep UI1 and sacrifice Audio, but we would like to start discussion about this matter. We feel that perhaps we're not the only missing those features. We would also like to hear opinion from Dianemo - is it changing its focus to more media oriented system ?

Thanks in advance for discussion,

regards,

Bulek.

7
Users / MOVED: Raspberry Pi as UPnP player under Dianemo
« on: February 10, 2014, 11:30:10 pm »

8
Marketplace / MOVED: Raspberry Pi as UPnP player under Dianemo
« on: February 10, 2014, 11:27:15 pm »

9
Users / Raspberry Pi as UPnP player under Dianemo
« on: February 10, 2014, 11:26:06 pm »
Hello,

I'm trying to setup RPi with raspbmc as UPnP player that can be controlled  from Dianemo.

Have three short questions :

1. What do I put into /etc/pluto/media_config.conf for RPi ? Is this right ?
Code: [Select]
#XBMC RPi
Room=12:        AudioDev=412; VideoDev=412; KeepScreenOnForOSD=no

2. How to troubleshoot setup it it isn't working ?

3. If I want to start media from XBMC GUI - what is the proper way to get media from Dianemo ? UPnP server LS doesn't provide video files, also music files are not working for me, should Samba be used for this ?

Thanks in advance,
regards,
Bulek.



10
Users / Huge query in pluto_media : taking my disk down to crawling
« on: September 20, 2013, 09:51:05 am »
Hi,

I've posted a thread about freqent crashes when clicking on Video button on main Orbiter screen... Crash came out of data not being available in reasonable time - and cause is that my disk is so slooow...

But I guess this is not the HW problem, but more SW. if I do this :
Code: [Select]
hdparm -tT /dev/sda
/dev/sda:
 Timing cached reads:   3548 MB in  2.00 seconds = 1771.32 MB/sec
 Timing buffered disk reads:  10 MB in  3.17 seconds =   3.15 MB/sec

When this happens, I get frequent crashes in media browsers on Orbiter, have unresponsive Orbiter (needs 30+ secs to get from screensaver to Orbiter screen), etc....

When second parameter is >60MB/sec, everything is working much faster and ok...

Now what is slowing my disk down ?
when I do
Code: [Select]
iotop -oP I see that mysqld is producing massive amount of disk writes and reads (I always thought this is pretty normal, till Radu didn't check his machines and we compared...) - approx. 5-10 M/s...

when I check what mysql is doing with :
Code: [Select]
mysql
show full processlist;

I see that there is a massive sql query going on, probably taking all that massive amount of disk accesses...

Quote
|   594 | root   | localhost | pluto_media    | Query   |  1623 | Sorting result | SELECT PK_File, Path, Filename, INode,
MAX(PSC_MOD) As CurrentDbAttrDate,
(1000000 * SUM(BOOKMARKS) + 10000 * SUM(ATTRIBUTES) + 100 * SUM(LONG_ATTRIBUTES) + SUM(PICTURES)) AS CurrentDbAttrCount,
(SUM(ATTRIBUTES) + SUM(LONG_ATTRIBUTES)) AS HasAttributes,
AttrDate AS OldDbAttrDate, AttrCount AS OldDbAttrCount, ModificationDate AS OldFileDate,
Source
FROM
(
        (
                SELECT PK_File, Path, Filename, INode, Source, Missing,
                        AttrDate, AttrCount, ModificationDate,
                        MAX(IF(Bookmark.psc_mod IS NULL,CAST('0000-00-00 00:00:00' AS DATE), Bookmark.psc_mod)) AS PSC_MOD,
                        COUNT(Bookmark.PK_Bookmark) AS BOOKMARKS,
                        0 AS ATTRIBUTES, 0 AS LONG_ATTRIBUTES, 0 AS PICTURES
                FROM File
                LEFT JOIN Bookmark ON Bookmark.FK_File = PK_File
                WHERE 1 = 1 AND (Path LIKE '/home/public/data%' OR (Path = '/home/public' AND Filename = 'data' )  OR Path LIKE '/home/user_1/data%' OR (Path = '/home/user_1' AND Filename = 'data' )  OR Path LIKE '/home/user_2/data%' OR (Path = '/home/user_2' AND Filename = 'data' )  OR Path LIKE '/home/user_3/data%' OR (Path = '/home/user_3' AND Filename = 'data' )  OR Path LIKE '/home/user_4/data%' OR (Path = '/home/user_4' AND Filename = 'data' )  OR Path LIKE '/home/user_5/data%' OR (Path = '/home/user_5' AND Filename = 'data' )  OR Path LIKE '/home/user_6/data%' OR (Path = '/home/user_6' AND Filename = 'data' )  OR Path LIKE '/home/user_7/data%' OR (Path = '/home/user_7' AND Filename = 'data' )  OR Path LIKE '/home/user_8/data%' OR (Path = '/home/user_8' AND Filename = 'data' )  )  AND Missing = 0
                GROUP BY PK_File, Path, Filename, INode,  AttrDate, AttrCount, ModificationDate
        )
UNION
        (
                SELECT PK_File, Path, Filename, INode, Source, Missing,
                        AttrDate, AttrCount, ModificationDate,
                        MAX(IF(Attribute.psc_mod IS NULL,CAST('0000-00-00 00:00:00' AS DATE), Attribute.psc_mod)) AS PSC_MOD,
                        0 AS BOOKMARKS,
                        COUNT(PK_Attribute) AS ATTRIBUTES,
                        0 AS LONG_ATTRIBUTES, 0 AS PICTURES
                FROM File
                LEFT JOIN File_Attribute ON File_Attribute.FK_File = PK_File
                LEFT JOIN Attribute ON File_Attribute.FK_Attribute = PK_Attribute
                WHERE 1 = 1 AND (Path LIKE '/home/public/data%' OR (Path = '/home/public' AND Filename = 'data' )  OR Path LIKE '/home/user_1/data%' OR (Path = '/home/user_1' AND Filename = 'data' )  OR Path LIKE '/home/user_2/data%' OR (Path = '/home/user_2' AND Filename = 'data' )  OR Path LIKE '/home/user_3/data%' OR (Path = '/home/user_3' AND Filename = 'data' )  OR Path LIKE '/home/user_4/data%' OR (Path = '/home/user_4' AND Filename = 'data' )  OR Path LIKE '/home/user_5/data%' OR (Path = '/home/user_5' AND Filename = 'data' )  OR Path LIKE '/home/user_6/data%' OR (Path = '/home/user_6' AND Filename = 'data' )  OR Path LIKE '/home/user_7/data%' OR (Path = '/home/user_7' AND Filename = 'data' )  OR Path LIKE '/home/user_8/data%' OR (Path = '/home/user_8' AND Filename = 'data' )  )  AND Missing = 0
                GROUP BY PK_File, Path, Filename, INode,  AttrDate, AttrCount, ModificationDate
        )
UNION
        (
                SELECT PK_File, Path, Filename, INode, Source, Missing,
                        AttrDate, AttrCount, ModificationDate,
                        MAX(IF(LongAttribute.psc_mod IS NULL,CAST('0000-00-00 00:00:00' AS DATE), LongAttribute.psc_mod)) AS PSC_MOD,
                        0 AS BOOKMARKS, 0 AS ATTRIBUTES,
                        COUNT(PK_LongAttribute) AS LONG_ATTRIBUTES,
                        0 AS PICTURES
                FROM File
                LEFT JOIN LongAttribute ON LongAttribute.FK_File = PK_File
                WHERE 1 = 1 AND (Path LIKE '/home/public/data%' OR (Path = '/home/public' AND Filename = 'data' )  OR Path LIKE '/home/user_1/data%' OR (Path = '/home/user_1' AND Filename = 'data' )  OR Path LIKE '/home/user_2/data%' OR (Path = '/home/user_2' AND Filename = 'data' )  OR Path LIKE '/home/user_3/data%' OR (Path = '/home/user_3' AND Filename = 'data' )  OR Path LIKE '/home/user_4/data%' OR (Path = '/home/user_4' AND Filename = 'data' )  OR Path LIKE '/home/user_5/data%' OR (Path = '/home/user_5' AND Filename = 'data' )  OR Path LIKE '/home/user_6/data%' OR (Path = '/home/user_6' AND Filename = 'data' )  OR Path LIKE '/home/user_7/data%' OR (Path = '/home/user_7' AND Filename = 'data' )  OR Path LIKE '/home/user_8/data%' OR (Path = '/home/user_8' AND Filename = 'data' )  )  AND Missing = 0
                GROUP BY PK_File, Path, Filename, INode,  AttrDate, AttrCount, ModificationDate
        )
UNION
        (
                SELECT PK_File, Path, Filename, INode, Source, Missing,
                        AttrDate, AttrCount, ModificationDate,
                        MAX(IF(Picture_File.psc_mod IS NULL,CAST('0000-00-00 00:00:00' AS DATE), Picture_File.psc_mod)) AS PSC_MOD,
                        0 AS BOOKMARKS, 0 AS ATTRIBUTES, 0 AS LONG_ATTRIBUTES,
                        COUNT(FK_Picture) AS PICTURES
                FROM File
                LEFT JOIN Picture_File ON Picture_File.FK_File = PK_File
                WHERE 1 = 1 AND (Path LIKE '/home/public/data%' OR (Path = '/home/public' AND Filename = 'data' )  OR Path LIKE '/home/user_1/data%' OR (Path = '/home/user_1' AND Filename = 'data' )  OR Path LIKE '/home/user_2/data%' OR (Path = '/home/user_2' AND Filename = 'data' )  OR Path LIKE '/home/user_3/data%' OR (Path = '/home/user_3' AND Filename = 'data' )  OR Path LIKE '/home/user_4/data%' OR (Path = '/home/user_4' AND Filename = 'data' )  OR Path LIKE '/home/user_5/data%' OR (Path = '/home/user_5' AND Filename = 'data' )  OR Path LIKE '/home/user_6/data%' OR (Path = '/home/user_6' AND Filename = 'data' )  OR Path LIKE '/home/user_7/data%' OR (Path = '/home/user_7' AND Filename = 'data' )  OR Path LIKE '/home/user_8/data%' OR (Path = '/home/user_8' AND Filename = 'data' )  )  AND Missing = 0
                GROUP BY PK_File, Path, Filename, INode, AttrDate, AttrCount, ModificationDate
        )
) AS FILE_UNION
WHERE 1 = 1 AND (Path LIKE '/home/public/data%' OR (Path = '/home/public' AND Filename = 'data' )  OR Path LIKE '/home/user_1/data%' OR (Path = '/home/user_1' AND Filename = 'data' )  OR Path LIKE '/home/user_2/data%' OR (Path = '/home/user_2' AND Filename = 'data' )  OR Path LIKE '/home/user_3/data%' OR (Path = '/home/user_3' AND Filename = 'data' )  OR Path LIKE '/home/user_4/data%' OR (Path = '/home/user_4' AND Filename = 'data' )  OR Path LIKE '/home/user_5/data%' OR (Path = '/home/user_5' AND Filename = 'data' )  OR Path LIKE '/home/user_6/data%' OR (Path = '/home/user_6' AND Filename = 'data' )  OR Path LIKE '/home/user_7/data%' OR (Path = '/home/user_7' AND Filename = 'data' )  OR Path LIKE '/home/user_8/data%' OR (Path = '/home/user_8' AND Filename = 'data' )  )  AND Missing = 0
GROUP BY PK_File, Path, Filename, INode, AttrDate, AttrCount, ModificationDate |

My first question (dillema) is whether I'm chasing a ghost here and this is pretty normal or is there something to be checked further...

I'm on Dianemo S, but I guess this part of the system is pretty similar to LMCE also...

Any advice would help me a lot. My system is useless when this happens and it happens quite often (or all the time)...

Thanks in advance,

regards,

Bulek.

Edit: I think that Radu found the origin of this query (or similar one when we talked about it) here :
http://svn.linuxmce.org/trac.cgi/browser/trunk/src/UpdateMedia/MediaState.cpp    line 59....



11
Users / Dianemo S (maybe LMCE): problem with large video collection ?
« on: April 30, 2013, 12:13:19 am »
Hi,

I'm spotting frequent crashes when I try to enter Video collection media browser. I always try this on main Screen Orbiter... I get either really slow response for first screen or even get DCERouter crash, cause obviously mysql query didn't finish in planned time and DCERouter restarts...

Anyone with similar size of collection? Any other advice ?

Regards,

Bulek.

12
Users / Dianemo S: Logitech Media Server and tags problems
« on: April 16, 2013, 12:32:08 pm »
Hi,

I'm not sure to what extent this also applies for LMCE, but I'm having a lot of problems under Dianemo S that currently switched to Logitech Media Server as internal music system...

First of all, the main problem is that my collection is not properly tagged and I'm waiting for option to use it via Folder structure... But that's another story... I'm trying to tag my collection as much as possible correctly, but have problems...

I've tagged few folders with mp3, wav and flac files. Then I tried to use LMS to rescan library and encountered following problems :
1. LMS behaves strange when you do only "scan for new and changed" media files. It finds all files, but when it should end scan it waits there forever... I have to abort scan. What I've learned is that it's recomendable to do full rescan each time...

2. if I scan only specific folder then all tag data seem to appear correctly on LMS (I'm not doing anything on Dianemo yet)... But when I do rescan of whole library (all folders) then my data from specific folder don't appear anymore... There are few errors about incorrect tag values on some files, but I guess this shouldn't interfere with files that are correctly tagged... But obviously something is wrong...

Anyone with same or similar problems ? Any advice ?

Thanks in advance,

regards,

Bulek.

13
Hi,

I've upgraded to 11.10 and see that my MD won't power off completely. It stays with command line screen on and says "halted", but doesn't completely poweroff...

Any advice, what to check or fix ? It used to work under 10.10...

Thanks in advance,

regards,

Bulek.

14
Hi,

I'm looking at DCERouter log but just cannot find command that switches Orbiter to "Single Camera View" screen with live picture from certain camera device...

Does anyone know how to do this ?

Thanks in advance,

regards,

Bulek.

15
Hi,

I'm trying to setup speech announcements under Dianemo 11.10 and have problems. I remember from 10.10 and LMCE 7.10 that similar problems were present, perhaps they exist also on recent releases of LMCE.

I have following questions and would be glad to hear your experiences/opinions :


1. It seems that tts wav files are properly generated, but it seems like they are shortened when played as audio... Also if another speech announcement is triggered it overlaps with the first one - it seems like no queue is used here ? I'm not sure, but maybe generation of wav file and play media command are too close in time (?) :

Quote
08      03/29/12 21:42:10.596           Received Message from 0 (unknown / ) to 18 (Text To Speech / Living Room), type 1 id 253 Command:Send Audio To Device, retry none, parameters: <0x5373ab70>
08      03/29/12 21:42:10.596             Parameter 9(Text): This is a test and wonderfull time. <0x5373ab70>
08      03/29/12 21:42:10.596             Parameter 103(List PK Device): 22 <0x5373ab70>
08      03/29/12 21:42:10.596             Parameter 254(Bypass Event):  <0x5373ab70>
08      03/29/12 21:42:10.596             Parameter 276(Dont Setup AV):  <0x5373ab70>

08      03/29/12 21:42:10.627           Received Message from 18 (Text To Speech / Living Room) to 10 (Media Plug-in / Living Room), type 1 id 43 Command:MH Play Media, retry none, parameters: <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 2(PK_Device): 22 <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 13(Filename): /home/public/data/tts/0.wav <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 29(PK_MediaType): 0 <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 44(PK_DeviceTemplate): 0 <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 45(PK_EntertainArea):  <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 116(Resume): 1 <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 117(Repeat): 0 <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 253(Queue): 0 <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 254(Bypass Event): 0 <0x45506b70>
08      03/29/12 21:42:10.627             Parameter 276(Dont Setup AV): 0 <0x45506b70>



2. I've setup two speech announcements and delay command for DCERouter for 1min in between, but speech commands are send one after another :
Quote
08      03/29/12 21:16:14.415           Received Message from 62 (Windows XP PC/tablet (Horiz) / Living Room) to 18 (Text To Speech / Living Room), type 1 id 253 Command:Send Audio To Device, retry none, parameters: <0x4b40cb70>
08      03/29/12 21:16:14.415             Parameter 9(Text): This is a test of speech synthesis. I hope you can hear and understand me clearly. <0x4b40cb70>
08      03/29/12 21:16:14.415             Parameter 103(List PK Device): 22,356 <0x4b40cb70>
08      03/29/12 21:16:14.415             Parameter 254(Bypass Event):  <0x4b40cb70>
08      03/29/12 21:16:14.415             Parameter 276(Dont Setup AV):  <0x4b40cb70>
08      03/29/12 21:16:14.417           Received Message from 62 (Windows XP PC/tablet (Horiz) / Living Room) to 2 (DCERouter / Living Room), type 1 id 257 Command:Delay, retry none, parameters: <0x4b40cb70>
08      03/29/12 21:16:14.417             Parameter 102(Time): 300000 <0x4b40cb70>
08      03/29/12 21:16:14.419           Received Message from 62 (Windows XP PC/tablet (Horiz) / Living Room) to 18 (Text To Speech / Living Room), type 1 id 253 Command:Send Audio To Device, retry none, parameters: <0x4b40cb70>
08      03/29/12 21:16:14.419             Parameter 9(Text): I'm speaking again after 5 mins. I hope you can hear me. <0x4b40cb70>
08      03/29/12 21:16:14.419             Parameter 103(List PK Device): 22,356 <0x4b40cb70>
08      03/29/12 21:16:14.419             Parameter 254(Bypass Event):  <0x4b40cb70>
08      03/29/12 21:16:14.419             Parameter 276(Dont Setup AV):  <0x4b40cb70>




3. "Send Audio to Device" command for Text&Speech device has parameters I don't clearly understand :
Quote
# 254 Bypass Event (bool)
# 276 Dont Setup AV (bool)
Anyone knows some more details about this ?



4. When I try to make speech announcement during media play, then things get pretty messy. Audio stops playing, speech announcement is not heard at all, then media continues but media screen gets empty (no files in playlist), media floorplan has some empty colour rectangles and media button shows like nothing is played. Anyone with similar experience ?
It also seems that media is not paused, but after short interval, next song from playlist is played - with not enough time to play announcement:
Quote
08      03/29/12 21:42:10.956           Received Message from 23 (Xine Plug-in / Living Room) to 22 (Xine Player / Living Room), type 1 id 37 Command:Play Media, retry none, parameters: <0x4a901b70>
08      03/29/12 21:42:10.956             Parameter 29(PK_MediaType): 4 <0x4a901b70>
08      03/29/12 21:42:10.956             Parameter 41(StreamID): 1002 <0x4a901b70>
08      03/29/12 21:42:10.956             Parameter 42(MediaPosition):  <0x4a901b70>
08      03/29/12 21:42:10.956             Parameter 59(MediaURL): /home/public/data/tts/0.wav <0x4a901b70>

.... and then really soon next song ....

08      03/29/12 21:42:10.996           Received Message from 23 (Xine Plug-in / Living Room) to 22 (Xine Player / Living Room), type 1 id 37 Command:Play Media, retry none, parameters: <0x4a901b70>
08      03/29/12 21:42:10.996             Parameter 29(PK_MediaType): 4 <0x4a901b70>
08      03/29/12 21:42:10.996             Parameter 41(StreamID): 1001 <0x4a901b70>
08      03/29/12 21:42:10.997             Parameter 42(MediaPosition):  <0x4a901b70>
08      03/29/12 21:42:10.997             Parameter 59(MediaURL): /home/public/data/audio/Media [30]/FAMILY/Lesnik Marjana/Best of/Lesnik Marjana - Best of - Zasnubi me.mp3 <0x4a901b70>

40 ms is clearly not enough to play speech announcement.




Thanks in advance,

regards,

Bulek.

Pages: [1] 2 3 ... 12