Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - caiman

Pages: 1 ... 6 7 [8]
Developers / Re: Nokia 770 Orbiter
« on: August 15, 2007, 05:04:52 pm »
Thanks to both of you !

Indeed, xterm showed that it was missing libsdl-ttf, which the deb package had not forced me to install. I have installed it but still get an error related to the fonts:

Code: [Select]
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  45 (X_OpenFont)
  Serial number of failed request:  8
  Current serial number in output stream:  10

progressing :-)

I have tried copying /usr/share/fonts/truetype/msttcorefonts/ from the core, but no luck.

Developers / Re: Nokia 770 Orbiter
« on: August 15, 2007, 12:02:46 am »
Hi Michael,

Nokia 770 here, OS 2007-hacker edition fresh install. I'll give some links to try answer the queries above...

I have activated red pill (, added the maemo repository and maemo extras repository (

then I installed the orbiter for OS2007 (plutohomeorbiter-, using the deb on the same page for the dependencies.

The orbiter installed fine, but when I launch it, it says " PlutohomeOrbiter - loading" for a few seconds, then nothing happens.

Any idea how to troubleshoot this ?


Installation issues / Re: Finding GC100
« on: August 03, 2007, 11:16:09 am »
I had trouble getting the gc100 recognized. Some troubleshooting led me to find that there was a bug in the gc100 install script that came with LMCE 1.1-b2, so that it would not detect the MAC address of the gc100. So I have made some dirty hacks to hardcode the MAC address, you can find the info in the post here: (comments section)
I should file a mantis for this, but I don't know if I am the only one with that same prob.

Users / Re: Upgrade slimserver
« on: July 24, 2007, 01:16:18 pm »
Same for me, what I want is the N800 skin...

Users / Re: stupid questio - Can LinuxMCE record from my dvb-t card?
« on: July 15, 2007, 04:23:14 pm »
LMCE includes MythTV and using this you should be able to view and record from a DVB card, if your model is supported.

In the admin site, going to Advanced->Configuration->Phone setup you end-up on the asterisk management portal. This page: gives you some example of configurations for known Voip providers.

Of course this doesn't add them in the list in the MCE guy, but at least you can add any provider you like.

hope this helps

Users / LMCE upgrade procedure
« on: July 09, 2007, 08:10:11 pm »
Many users are now on 1.1 beta2 and are investing a lot of efforts to configure their home, asterisk and cover art, or maybe some custom drivers...

Once the next version of LMCE comes out, what will the upgrade procedure be in order to get a "clean" install without loosing all the settings ?

I know it's hard to say when the release is not even out, but this can be seen as a feature request... for documentation :-)

Users / Upgrade slimserver
« on: July 09, 2007, 08:07:25 pm »
I would like to upgrade to the latest stable version of slimserver (

Is it ok to do so, or would this break the pluto-slimserver-plugin ?

Users / Re: CoverArt
« on: July 08, 2007, 10:53:49 pm »
I confirm, by replacing all occurrences of  FK_File to CoverArtScan.FK_File, it works.
Thank you 1000 times !
Is there a bug filed already so it gets fixed in the next release

Hi Bobpaul,

so far I'm running as you suggested the orbiter on display :1 and KDM on display :0, two separate servers.
This does what I need as I can easily switch from one to the other, though there are still some glitches: alpha blending does not work and the flicker background is not visible. I'll try to swap the displays.

Anyway, the original question of starting the core automatically without X is still very interesting.

Users / /etc/pluto.conf options
« on: June 14, 2007, 06:18:44 pm »
most of the options in /etc/pluto.conf are quite obvious.
But I'm wondering what's the meaning of these ?

Display = 0
It it the X display? Meaning, one could use this to run the orbiter on a separate head ?

SharedDesktop = 1

DesktopActivated = 1


thanks Cj_MaN, that's useful info.

I'm still not clear how to start the core services without user intervention while still running KDM.

Indeed, the dedicated LMCE scenario you mention above uses /usr/pluto/bin/, which starts X and then /usr/pluto/bin/lmce_launch_manager. What I am looking for is a normal KDM start, but have the pluto core services running in the background.

The /etc/pluto.conf autostart options you mention relate to the launch-manager, which is a graphical application that requires the user to enter root credentials when started as a user (e.g. with KDM autologin).

The /etc/event.d/media-center-startup script calls /usr/pluto/bin/, which seems to leave some services behind (e.g. slimserver)

What's the correct way to do it ?

I have the same problem and would like to rephrase the question as follows:

on an Hybrid installation (1.1 beta2), how can we start the core services from the init scripts ?


if Beta 1 installation went fine, is there a reason to upgrade to beta 2 ?
Or actually re-install beta2, since there is no upgrade procedure yet ?

Pages: 1 ... 6 7 [8]