Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - mcenovice

Pages: [1]
I believe you created packages for Fedora 12 & 13 . which one would be best to try for Fedora 16?

i tried this afternoon to get linuxmce 1004.. everything installed ok. NIC also working out of the box.
Only problem is ofcourse my network card, which is not NVIDea. so avwizard is not coming up and error. can no start 'x'.

but with ctrl-f2 i am able to start "startx' and to go to webadmin.
there i see the controls and navigation for mce.. but adding any zwave devices fails - device not added -check is MCE is running..

is there any way to avoid or to diable the graphics portion ? startx is running fine.

or would you advice still the fedora 16 with one of your packages ?

thanks very much for your advice

thanks. But will your packages work for example for Fedora 15 ? ( i already tried 13, but the install iso did not continue after the first question, which seems to be a general problem. 12 iso worked without problems)
i am mainly intested in the home automation portion of LinuxMCE with ZWave.. just trying to get some light control and scenes etc.

one step furhter - two step back.

installed the header files with command

rpm -ivh kernel-header-

1:kernel headers ######################  100%

However, when trying to install the driver

[root@fedor /]# cd r8168-8.026.00
[root@fedor r8168-8.026.00]# make clean modules

i now get:

make -C src/ clean
make[1]: Entering directory `/r8168-8.026.00/src'
make -C /lib/modules/ SUBDIRS=/r8168-8.026.00/src clean
make[2]: gcc: Command not found
make[2]: Entering directory `/usr/src/kernels/'
  CLEAN   /r8168-8.026.00/src/.tmp_versions
make[2]: Leaving directory `/usr/src/kernels/'
make[1]: Leaving directory `/r8168-8.026.00/src'
make -C src/ modules
make[1]: Entering directory `/r8168-8.026.00/src'
make -C /lib/modules/ SUBDIRS=/r8168-8.026.00/src modules
make[2]: Entering directory `/usr/src/kernels/'
/usr/src/kernels/ stack protector enabled but no compiler support
make[2]: gcc: Command not found
  CC [M]  /r8168-8.026.00/src/r8168_n.o
/bin/sh: gcc: command not found
make[3]: *** [/r8168-8.026.00/src/r8168_n.o] Error 127
make[2]: *** [_module_/r8168-8.026.00/src] Error 2
make[2]: Leaving directory `/usr/src/kernels/'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/r8168-8.026.00/src'
make: *** [modules] Error 2

i have tried in the mean time to install GCC, but there i run also into dependency errors.
on cloog.ppl, which leads into dependency on libppl.sp.7 which i can not find anywhere.

since i installed FC12 from the ISO DVD, it seems that the CD does not contain everything needed to compile etc.
is there an easier way to get the full installation for FC12, so that i can compile the network driver and try too install the packages you created for Linuxmce ?

Thanks for the help.

Hi Hari,

thanks for that.  I have been searching, but is there a way to install the kernel header without an active internet connection?

I had a new try with the new set of instructions.. unfortunately no luck

following occurs after executing:

sudo ./


check old driver and unload it.
build the module and install
make: *** /lib/modules/ No such file or directory. stop
make[1]: *** [clean] Error 2
make: *** [clean] Error 2

same thing happens when executing :make clean modules

make -C /lib/modules/ SUBDIRS=/r8168-8.026.00/src
make: Entering unknown directory
make: *** /lib/modules/ No such file or directory. stop
make: levaing unknown directory
make[1]: *** [clean] Error 2
make[1]: leaving directory `/r8168-8.026.00/src`
make: *** [clean] Error 2

it seems the build directory is missing ? any ideas ?

Hi Hari,

I have been searching the internt  for a solution.

have found the following :

sudo apt-get install linux-headers-$(uname-r)
sudo aptitude install build-essential
tar xvfs r8168-8.018.00.tar.bz2  (should be the new driver probably r8168-8.026.00.tar.bz2)
cd r8168-8.018.00/
sudo ./
sudo reboot

have not had time to try it out yet.. will do so soon

Hi Hari,

thanks for looking at the issue. Pulling my hair out to get a linuxmce to work on this machine..

issue is similar as something posted a long time ago in the general forum. I copied that below. for me its a different directory, but similar errors are occuring for me. error 2..
I get up to the command: make clean modules and then similar as below occurs.. (but with different directory). i can post the exact when i am home.

make -C /lib/modules/2.6.18-1.2798.fc6xen/build SUBDIRS=/usr/local/src/r1000_v1.05/src modules
make: Entering an unknown directory
make: *** /lib/modules/2.6.18-1.2798.fc6xen/build: no that file or directory。 stop。
make: Leaving an unknown directory
make[1]: *** [modules] error 2
make[1]: Leaving directory `/usr/local/src/r1000_v1.05/src'
make: *** [modules] error 2

maybe i have to install the driver differently? i saw somewhere a suggestion to do ": sudo ./ but i have not tried it..

in my quest to get Linux home automation to work on my low power Mini board of Intel D525MW, i am now trying to install the mini install based upon Fed 12.
Fedora 12 installs fine, but now i have an issue that the NIC Realtek 8111/ 8168B does not work anymore.

I have checked the forums and it seems to be a general problem, also with Fed 13.
several attempts to install the new driver from Realtek did not work yet.
get error msgs when executing "make clean modules"..
found  /linux-networking-3/how-to-install-the-rtl-8168-8111-driver-555491/ describing the same issue, but did not come up with a solution.

anyone any suggestions on how to continue with the mini install ?  would like to be able to use Linux and zwave for home automation.. but sofar not much luck..
i am not a expert in Linux, but do know my way around with the command line..


sofar i have tried to install the complete Linux MCE version 810. This one failed during the install with the message "installing Firefox".. seems to be a know issue.
tried to install fedora 13 with ISO download - this one failed to load - apparently due to know issues on gigabit motherboards ?
now tried to install fedora 12, but blocked due to NIC realtek 8111....

Thanks. I will look into it.


I have been very interested in home automation with Zwave and recently i saw the possibility to use LinuxMCE as a software tool for that. I would like to install just the home automation portion on a low power consumption server (like the Intel MD525MW).
I have downloaded the LinuxMCE 810 ISO and installation of Unbuntu went well. I had some issues with the realtek NIC, but this i have been able to fix.
However, the MCE installation did not work out well. The AVwizard did start, but after choosing the basic options, my ubuntu is completley reconfigured. i do not see the MCE starting and also my network manager disappeared. so no internet anymore.

I am new to the Unix world, but i assume the problem might be with the fact that Linuxmce is requirng a NVIDIA card ?
is it possible to install just the home automation portion of  LinuxMCE for Zwave ?
Or has anyone succeede to make linuxMCE 810 work on a low power motherboard without Nvidia ?


Pages: [1]