Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Dap-P

Pages: [1] 2 3 ... 7
1
Users / Re: question about internet radio
« on: Today at 12:55:51 am »
Phenigma,

I created a Trac ticket, #2342.
Could you take a look at it?

Anton

2
Users / Re: question about internet radio
« on: April 18, 2015, 11:58:00 pm »
Hey Phenigma, I asked for an account. As soon as I have it I will create a ticket, with the files.
Thanks)

Anton.

3
Users / Re: question about internet radio
« on: April 18, 2015, 11:44:38 pm »
@Phenigma If someone could provide me with credential for trac, then i can make a ticket.

Meanwhile i did another update on the webpage,

I added a default sort function (Thanks Golgoj4), made some new labels, and added a delete function.

For people who want to try, please backup the origional file (which was working)
radioscript.sh (from my previous post) goes to /usr/pluto/bin/
internet_radio.php goes to /var/www/lmce-admin/operations/mediaBrowser/

4
Users / Re: question about internet radio
« on: April 16, 2015, 01:22:41 pm »
UPDATE:

I've had some time to work on this, so I've added logo support in the radioscript.sh, and i adapted the webpage a little.
These are minor changes, but i need some feedback on the webpage.

To get the logo's automagicly, you have a run the radiostation.sh script with the delete option, en then you can add them via the webpage, or via radioscript.sh

Both new files are attached in this post.

For people who want to try, please backup the origional file (which was working)
radioscript.sh goes to /usr/pluto/bin/
internet_radio.php goes to /var/www/lmce-admin/operations/mediaBrowser/

5
Users / Re: question about internet radio
« on: March 26, 2015, 10:00:40 pm »
I also dont know who made that page in the web-admin, but i made that script. I dont know if it is adapted to be used with the webadmin.

But the webadmin page is on my to-do list, please be patient a little longer.

Regards,
Dap-P

6
Users / Re: LinuxMCE suddenly rings
« on: December 23, 2014, 03:41:57 pm »
You could try to use 'netstat' and see where these connections are coming from.

If you dont have port 5060 forwarded, and you have a firewall rule, it must from somewhere in your internal lan, or from the core itself.


-Anton

7
Users / Re: Automatic adding Internet Radio streams to LinuxMCE
« on: November 17, 2014, 11:54:09 am »
Would you mind if we took what we there and added a simple interface in the web admin?

-golgoj4

Sure) If it is not finished by the time i have time  ;) , i will pick up where you guys left off.

Anton.

8
Installation issues / Re: 12.04 Client Machines Can't Browse Some Websites
« on: November 14, 2014, 01:43:40 pm »
MTU 576 is the minimum size for IPv6, maybe that has something to do with it?

I know IPv6 can automatically adjust the MTU size, for an unfragmented end-to-end connection

Anton.

9
Users / Re: NAS - FreeNAS, LMCE or something else?
« on: November 14, 2014, 01:24:00 pm »
I find the synology software very good. But the hardware is very expensive imho.

Recently i migrated my FreeNAS server to http://xpenology.com/ which is a x64 variant of the Synology software.
You can run this on any 64-bit PC, and in my opinion works perfectly.

Anton.


10
Users / Re: Automatic adding Internet Radio streams to LinuxMCE
« on: November 14, 2014, 01:02:51 pm »
What was the final disposition of this. Does someone want to make it into a formal device so users dont have to hit a forum to enable the feature?
-golgoj4

Soon i will have the time to finish this. in a couple months.


11
Users / Re: VPN (Need a place for my notes)
« on: February 10, 2014, 05:38:22 pm »
I am not sure if a VPN on the internal network will work in any circumstance, with this setup
Can you try from outside your LinuxMCE network?

Anton

12
Users / Re: VPN (Need a place for my notes)
« on: February 09, 2014, 06:15:44 pm »
After some more testing, these are my findings:

in /etc/ipsec.conf 2 lines need to change
rightsubnet=vhost:%priv into rightsubnet=vhost:%priv,%no
rightprotoport=17/%any into rightprotoport=17/0

If someone can test this (also with an iphone/ipad)
If it is not working on an apple device, can you add the following lines in the "conn L2TP-PSK" section of /etc/ipsec.conf
dpddelay=10
dpdtimeout=90
dpdaction=clear
And see if it is working?

ofcourse you need to enable the port in the firewall also,
iptables -A INPUT -m policy --dir in --pol ipsec -p udp --dport 1701 -j ACCEPT
to allow l2tp traffic out of the ipsec tunnel
and allow udp port 500 and 4500 in the webadmin

Anton

13
Users / Re: VPN (Need a place for my notes)
« on: February 09, 2014, 04:24:50 pm »
After some more research, the only thing that seems to need a change is the ipsec.conf.
Better said, only the last line in /etc/ipsec.conf
If you change that from
Code: [Select]
rightprotoport=17/%any to
Code: [Select]
rightprotoport=17/0 it seems to work for me.

i've tried changing the template (/usr/pluto/templates/ipsec.conf.tmpl) But if i then use the webadmin to configure things, it leaves me with an empty /etc/ipsec.conf file.

Is there somebody that can confirm changing this line is a working solution?

14
Users / Re: VPN (Need a place for my notes)
« on: February 03, 2014, 12:52:09 am »
I've been able to setup VPN with android clients, after some fiddling with the conf files

For now, i use these :
/etc/ipsec.conf http://paste.ubuntu.com/6864517/
/etc/xl2tpd/xl2tpd.conf http://paste.ubuntu.com/6864407/
(just replace the listen-addr with your external interface ip)

And a password without special characters in /etc/ppp/chap-secrets

Still need to find out what settings are actually necessary for the setup.

Anton

15
For wireless connectivity, perhaps this site can also help you:
http://www.cyberciti.biz/faq/debian-linux-wpa-wpa2-wireless-wifi-networking/

Anton

Pages: [1] 2 3 ... 7