Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - polly

Pages: [1] 2
Developers / Slow and steady ... moving from Trac to Gitlab
« on: August 10, 2015, 12:09:14 pm »
Hey ...

just wanted to let you guys know that i'm done with "trac to gitlab" and "svn to git" migration.
There is already a cronJob running once a day at 8:30am CEST pulling all data over from trac and svn.

From now on, testing begins! :-)
Let me know if you found anything weird or missing tickets and notes/changelogs.

For most users i was able to map their trac usernames to gitlab users.
I tried to merge the users as much as i could. So if i found a user in trac which had the same name in the forum, but a different e-mail i went with the forum account.

If you are not sure if/which of your accounts is still there use the forgot password feature in Gitlab.

For now Gitlab is READ ONLY! ... this will be changed as soon as everybody is happy and comfy with GIT.

LinuxMCE Gitlab installation:

Gitlab Android App:

Gitlab iPhone App:

From now on, CronJob will update tickets and repos once a day. then we have at least 4 weeks of testing and playing. After that the devs decide when switch completely to git.

Let me know if you have any issues!



Users / - responsive + light redesign
« on: February 01, 2015, 07:54:17 pm »
Hey ...

i spent the recent weeks in getting the website as much responsive as possible.

What was done:
- Redesign, which was required to get a proper responsive layout going.
- jQueryUI replaced by Zurb's Foundation

Please test the website.
If i dont get any issue reports i will put the website online :-)

/etc/hosts entry required to test:

Thanky you!


Users / Webserver maintenance
« on: January 11, 2015, 08:01:48 pm »
Hey ...

just upgraded following:

- SMF Forum to 2.0.9
- Mediawiki to 1.24
- TYPO3 to latest bugfix release 6.2.9
- Piwik to 2.10.0
- Debian packages updated

I have done backups for Forum and Wiki.

In case you find something missing let me know!

FYI, i'll keep on trying to get LDAP integrated. It works for Wiki, TYPO3, Piwik. But SMF Forum LDAP-Extension is still not working.


Wiki / Forum and wiki server upgrade on 25.10.2013
« on: October 22, 2013, 10:08:41 pm »

the server running wiki and forum on is quite a bit outdated.
So the i plan to do a major upgrade to most recent debian version on friday, 25.10.2013 (starting at 19.00 CEST).

i try to keep the downtime to a minimum.

how come?
i  wanted to do a upgrade to the wiki and setup a apache solr search coz' me and others complaining about finding anything in the wiki but php version is to old for the latest wiki version.
maybe more in case this worked ;-)


Developers / re-design
« on: May 14, 2013, 01:14:24 am »

currently working on a new design for
Joomla will be replaced by TYPO3.

this is my current design:

thoughts? suggestions? etc.... are welcome!


Users / Update 10.04 to 12.04 = success (at least to me)
« on: March 13, 2013, 11:42:43 pm »
Hey ...

i upgraded my LMCE 810 to LMCE 1204 and from the current point of view it was a success story for me as a semi skilled programmer.

With the help of Google i was able to fix all the install issues i had.

Here is what i roughly did:

For now i couldn't find any big issue ... i'm not using any special equipment, currently its more a HTPC than a home automation system.

Parts of the System i tested till now:
  • VDR works
  • both network cards work
  • NVIDIA graphics works
  • AvWizard detected audio correctly and played sounds nicely

i expected the upgrade driving me nuts, but it was quite easy ... :-)

thoughts and questions are welcome :-)


Users / MAC: Boot an Install from DVD
« on: December 12, 2012, 01:53:56 pm »

i have my own MacMini 2010 and access to different Macs.
I cant boot into Live from DVD anymore.
DVD is detected and boots up but is stuck while loading "radvd" ....

No idea whats going on.

But if you have a Mac it would be great to hear your experience using the DVD.



Developers / lmce-admin redesign ?
« on: November 09, 2012, 10:04:49 pm »
Hey ...

i just wanted to start a discussion about about the current state of lmce-admin.
i think it does a good job, but the interface looks old and web admin could be more fancy in the GUI point of view ...

posde pointed out that the architecture is great.

What i can do:
- jquery (javascript)
- css
- html ... a little php
- .... learn learn learn ....

The goal is to improve the interface of lmce-admin and give it better wizards with a more "human" description.
After installing, lmce-admin imo is the next step to simplify things, and make configuration a lot easier.

This does not mean i will/can do it... ;-)


Users / qOrbiter add stylesheet.qss
« on: November 04, 2012, 05:09:32 pm »

i read about adding a stylesheet to Qt Apps.

This would be really useful/handy for me when it comes to orientation change, and little adjustments depending on the device.

How can i load a stylesheet into qOrbiter?



Users / qOrbiter Loading component Failed
« on: November 04, 2012, 05:04:46 pm »
I'm editing the *.qml files using Qt Creator on Mac via Samba.
My Tablet is a Acer Iconia A210. Skins are located on the Core (is given by qOrbiter, i guess).

i tried to add a file under compontents/*
Therefore "Clock.qml" to "Clockdate.qml"in components/

Added this code to Screen_1qml
Code: [Select]
            anchors.right: parent.right
            anchors.rightMargin: scaleX(40)
            anchors.verticalCenter: headerbg.verticalCenter

while Loading qOrbiter, a "./adb logcat" debug information from the device gives me:
Code: [Select]
D/Qt      ( 4504): finishing load
D/Qt      ( 4504): screenScreen_1.qml loaded.
D/Qt      ( 4504): Starting timecode...
D/Qt      ( 4504): opening connection to  ""
W/Qt      ( 4504): Clockdate is not a type
D/Qt      ( 4504): Starting timecode...
D/Qt      ( 4504): Time code running, moving on.
D/Qt      ( 4504): "Starting screen switch"
D/Qt      ( 4504): "About to call screenchange()"
D/Qt      ( 4504): "Done call to screenchange()"
D/Qt      ( 4504): "20:44:43::DCERouter Responded to Register with OK"
D/Qt      ( 4504): loading page from network
D/Qt      ( 4504): finishing load
D/Qt      ( 4504): screenScreen_205.qml loaded.
D/Qt      ( 4504): Starting timecode...
D/Qt      ( 4504): Time code running, moving on.
D/Qt      ( 4504): Screen Changed:
D/Qt      ( 4504): setFullScreen true
D/Qt      ( 4504): setFullScreen true
D/NetdConnector(  186): RCV <- {601 limit alert globalAlert wlan0}
D/NetdConnector(  186): SND -> {bandwidth setglobalalert 2097152} {null}
D/NetdConnector(  186): RCV <- {200 Bandwidth command succeeeded}
D/NetdConnector(  186): RSP <- {200 Bandwidth command succeeeded}
D/Qt      ( 4504): "Starting screen switch"
D/Qt      ( 4504): "About to call screenchange()"
D/Qt      ( 4504): "Done call to screenchange()"
W/Qt      ( 4504): Clockdate is not a type
D/Qt      ( 4504): Command to change to:Screen_1.qml failed!
D/Qt      ( 4504): Screen Changed:
V/Sensors (  186): void cb_onMotion(uint16_t)
W/ActivityManager(  186): Activity destroy timeout for ActivityRecord{410cfea0 org.linuxmce.qorbiter/org.kde.necessitas.origo.QtActivity}

How can i add a qml to the components folder and load it?

Thanks for your help.


Users / qOrbiter Android - change skin
« on: October 25, 2012, 10:18:32 am »

just bought a Acer Iconia A210 Tablet for qOrbiter skinning stuff....

Now i want to have my own skin based on default skin.

What i tried:
 - duplicate "default" in /var/www/lmce-skin/skins/android/tablet/
 - change "skindir" in Style.qml
 - change "skin" in config.xml to the name of the duplicated default folder

This ends up in a crashing qorbiter while its trying to load the skin.
If required, i can provide some device debug information in a few hours...


Users / qOrbiter - loading Skin issue
« on: October 21, 2012, 07:29:28 pm »

qOrbiter is building fine.
When i select an Orbiter i get "... uses incompatible Qt library. (4.8.2) [release] ..."

How can i ge around this problem?


Users / Mac USB Boot gpxe - PXE booting MacMini
« on: September 16, 2012, 03:45:32 pm »

i managed build a usb stick that boots gPXE on a Mac!

What it does is it boots into refit and refit boots up syslinux which is booting GPXE.KRN.
Not 100% sure if this description is correct, but it works for me!

Here is my little manual:


Users / qOrbiter Skin - first design
« on: September 04, 2012, 12:13:37 am »

i'm working on my own qOrbiter skin.
Currently i'm playing with Photoshop get the basic design.

here you will find a few screens with a little description:

Would be great to read your comments ...


Installation issues / wii remove cursor hover wrong menu item
« on: January 10, 2012, 11:24:59 pm »

my Wii Mote works pretty good on 1004.
When i hover a menu item some other (random) menu item is marked as hoverd (red outline) and sometimes jumping around.

see the video its better than my description  :-)

i followed the instructions here:

Is there a way to fix this issue?

Thanks in advance


Pages: [1] 2