Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - piusvelte

Pages: [1]
I followed the wiki for setting up a wiimote, and am using the ir functionality, which makes this MD a incredible upgrade to my current setup using an xbox with XBMC. When the MD boots into the orbiter, and I connect a wiimote, I can only scroll through the bottom left 1/4 of the screen. Others have noted this problem as well.

For me the resolution was to use the default ir_ptr (with the tildes "~") and to add the xorg.conf lines described here.

Code: [Select]
Section "InputDevice"
        Identifier      "Wiimote"
        Driver          "evdev"
        Option          "Name"          "Nintendo Wiimote"
and to the ServerLayout section
Code: [Select]
InputDevice     "Wiimote" "AlwaysCore"
Also, I removed the mac address so that any of my wiimotes can connect. So far, so good. Now if I can get sound from my Audigy card, I can start using this MD!

hen I went through the A/V Wizard, I select SPDIF Coax and Y for both Dolby Digital and DTS. The fix was to then go into the admin site, change the sound card to "Audigy", Uncheck the "Use AC3/DTS pass-through" and reboot the media director. Everything sounds good now and since figuring out how to get scrolling to work with my Wiimote and sensor bar, I can retire my aging Xbox based Xbox Media Center! Thanks!

Don't bother reading anything past this...

Yes, I have searched, read and tried several things to resolve this.

I have a netbooting md, with an Audigy card, connected to a Dolby Digital and DTS capable Sony receiver via S/PDIF Coaxial. When I run the AVWizard, I get sound for DD, but not for DTS. I've read that DTS is not possible on Linux with Audigy. When I try to play a movie, there's a crackle, and then no sound. I've started KDE, heard the start up music, unmute Optical Raw in alsamixer, no joy. I tried unmuting the other Optical setting, again with no sound in movies. What are the steps to set up an audigy 1 (not platinum) card for full LinuxMCE functionality?

Thank you!

Users / CD install fail
« on: March 23, 2009, 06:58:03 pm »
I have a fresh install of kubuntu on my first media director, and have the cd iso's dl'd. When I double click the installer, it recognizes my core and starts the install but fails at installing pluto-app-server. The message is that it can't find the package. I've enabled multiverse, universe and restricted repositories and have been searching for which repository that the package is in with no luck. Which repository is needed, or what should I try?
Thank you!

Users / dhcp not serving ip's
« on: March 21, 2009, 07:36:30 pm »
I just added a second nic to my core, using the wiki instructions, which appears to have worked, though the mac address on the web admin networkin configuration page didn't update. I'm posting this from the core, but none of the machines on my network are getting ip's from dhcp. I've checked the box, set the range, for both pluto and non-pluto devices, and clicked save. The core restarts, but no device gets an ip. I've setup reserved ip's by adding my wap's and mac addresses to the devices, that's how to reserve an ip, correct? How do I get dhcp working? Thank you!

Users / linuxmce, samba and openldap
« on: March 19, 2009, 02:36:17 pm »
What should be the owner:group on files in /home/public/*? Thank you!

I'm trying to get my new dedicated core setup as my domain controller, with dns, and holding network user's home directories. In the process, I'm also trying to copy my media file from my retiring server to the core, which is where I'm now running into a problem. I don't seem to have access to the public share on my network,  without authenticating to ldap, and the linuxmce user is a local account, not in ldap. I can authenticate to mount the public share using an ldap account, but then I don't have permissions to write to the directories (videos...). How do I integrate linuxmce (users, devices...) with openldap on the same box? Also, why are the home directories set to force user = root, and group = public?

Thank you!

Here's my smb.conf file:
Code: [Select]
## @FileType: Pluto Sectioned Config File ##
## @Version: 2 ##
## @KeepSections: ##
## @RemoveSections: ##

## BEGIN : Domain and Hostname

workgroup = EMMAN
server string =
netbios name =

## END : Domain and Hostname
smb ports = 139
log level = 2
invalid users = root
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
encrypt passwords = true
socket options = TCP_NODELAY
dns proxy = no
# passwd program = /usr/bin/passwd %u
# passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
username map = /etc/samba/usermap.txt
unix extensions = yes
security = user

#ldap setup
passdb backend = ldapsam:ldap://localhost/
obey pam restrictions = no
ldap admin dn = cn=admin,dc=emman,dc=local
ldap suffix = dc=emman, dc=local
ldap group suffix = ou=Groups
ldap user suffix = ou=Users
ldap machine suffix = ou=Computers
ldap idmap suffix = ou=Users
; Do ldap passwd sync
ldap passwd sync = Yes
passwd program = /usr/sbin/smbldap-passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *all*authentication*tokens*updated*
add user script = /usr/sbin/smbldap-useradd -m "%u"
ldap delete dn = Yes
delete user script = /usr/sbin/smbldap-userdel "%u"
add machine script = /usr/sbin/smbldap-useradd -w "%u"
add group script = /usr/sbin/smbldap-groupadd -p "%g"
delete group script = /usr/sbin/smbldap-groupdel "%g"
add user to group script = /usr/sbin/smbldap-groupmod -m "%u" "%g"
delete user from group script = /usr/sbin/smbldap-groupmod -x "%u" "%g"
set primary group script = /usr/sbin/smbldap-usermod -g "%g" "%u"
#end ldap

comment = public files
browseable = yes
writable = yes
create mask = 0777
directory mask = 0777
path = /home/public/data
public = yes
        read only = no

comment = shared home files
browsable = yes
writable = yes
## BEGIN : Home Hosts Allow
### END : Home Hosts Allow
path = /home
public = no
guest ok = no
force user = root
        force group = public
        create mask = 0774
        directory mask = 0775
        inherit acls = yes
        inherit uid = yes
        inherit owner = yes
        inherit permissions = yes

## BEGIN : User Shares

## END : User Shares

## BEGIN : InternalStorageDevices

## END : InternalStorageDevices

I added my ldap users to the local public group and am now copying over my media.

Pages: [1]