Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - schaferj

Pages: [1]
Users / beta update the MDs?
« on: August 13, 2009, 08:57:11 pm »

We were very happy to see news of the monster 0810 beta update on 10 August and 12 August. 

In previous beta installs, we have reinstalled from scratch and this time we'd like to try the update procedure at

On dcerouter we do:
Code: [Select]
sudo apt-get update
sudo apt-get dist-upgrade

Will this update the media directors as well or do we need to chroot into them and execute the apt-get update / upgrade for each?

much thanks,

Users / MD pxe boot - call failed: 13 - Retrying nfs mount - SOLUTION
« on: March 07, 2009, 08:15:58 am »

My family room MD has been working for many more than a year, but tonight I rebooted the core and the MD just runs in a loop -

         mount call failed: 13 ... Retrying nfs mount

until it drops into busybox.  I tried rebooting several times and tried running:

         # exportfs -ra

on the core/hybrid as suggested in an earlier post, but it did not work.

I searched the forum and wiki and found earlier mentions of similiar issues at: and

Looks like others have had similiar issues, but I haven't found a resolution.

A brute force solution may be to delete the md from the core and redo, but I'd like to hear other ideas first.
much thanks,

Users / Prevent deletion of media files for some users
« on: March 04, 2009, 09:16:19 pm »
I recall a discussion of this issue earlier, but the only reference I found on forum or wiki was from

which suggested simply changing the underlying file permissions / attributes to read only.

My understanding is that this will prevent the media update features from working as well.

Is it possible to configure a setting to prevent some users from deleting files?

I may play with file persmissions to see if perhaps we can use the group for read only and the owner for rw - but would appreciate any advice from those who have already solved this.

much thanks,

Users / NFS media share mounting experience & issues
« on: February 24, 2009, 01:51:19 am »
I appreciate any advice on solving a file share issue I’ve been wrestling with for several weeks.
Bottom-line-up-front is I’d like advice on using NFS. 
Is it correct that nfs shares (unlike smb/cifs shares) must be installed manually via the webgui?

I’ve had qualified success which I’ll describe below.  NFS shares do not seem to be auto discovered and mounted like samba shares.

I’d like to get this solved and then add to the wiki.

I followed the advice at in the New Media Navigation Facility thread by Roy at
and the wiki at:
(with exceptions since my server was solaris with zfs / nfs instead of linux)

I also looked at trying to force a persistent mount with messagesend, but did not pursue.

I succeeded in copying about 1.5TB of videos to a new NAS with a smb / cifs share.  However it had intermittent issues and I had trouble with the share disappearing and since my server could do nfs as easily as smb / cifs, I decided to try nfs.
(The smb share failure was unrelated to linuxmce – if interested see  )
I’m going to split the details into several posts
  • This is Post 1
    Post 2 is how I set up zfs / nfs share on the server
    Post 3 is how I mounted on linuxmce
    Post 4 is an attempt at manually mounting in a new mount point


Users / Windows Client?
« on: December 17, 2007, 06:40:39 pm »
What's the best way play music from lmce (core) on a windows box? 

Suggestions on ways to play videos on a windows box are welcome as well.

I understand that we can use an orbiter running on windows to control other media directors, I would like to play media directly on the windows machine other than by simple file sharing.

much thanks!


Two quick questions.

1)  I've ripped a few dvd in lmce and they have nice cover art and meta data, but they are 7-8Gb in size.  Any thoughts on making them much smaller while retaining the meta data?

2) Ripping inside lmce results in good meta data.  How can you import or add this data to files ripped elsewhere?

Our forum has good info on the iso / dvd issue

And some discussion on dvd jacket cover art



I've finally loaded 190+ dvds into the xl1b and most have correct cover art when browsing video.

However, in the manage drives area, only the first few dvds are listed (with title and the rip, play, eject, id buttons in the blue row).  The rest have an empty black row with only the number and no title and none of the buttons.  So after the first few, I can't perform any operations (ID, rip, eject) on individual disks.

The only way to eject disks is with the hardware button on the front which ejects LIFO and the "ALL" buttons for ID & eject on the manage drives page.

The data is there, it just is not displaying properly on the manage drives page for the sony xl1b.  I know this because during several long "ALL eject" sessions (they eject FIFO), the missing ones blue rows fill in as the first ones are ejected.

So, anyone know how to get this to display properly so I can avoid the long trial and error of eject all and better manage the media?

much thanks,


I'd like for my core to also be the main home server and eliminate other power hungry servers.  So I'd like the core to handle client authentication (as a samba pdc) and better firewall / security / privacy / parental control.  However, I don't want to break lmce or cause upgrade incompatibilities as the old pluto code still seems entangled with the underlying kubuntu.

Please share any recommendations / experiences you've had in modifying the core dcerouter networking configs.

In several previous installs, I attempted to change some things with bad results.

Current setup is running OK with core at (changed default).  (some of the help in the webadmin is not found - and I suspect this change may be the cause).

I'd also like to change the dcerouter smb & hostname (from dcerouter to something_else) and the workgroup from linuxmce to schafer (which is my house net default).  Will this break anything or will it be reset by the lmce database?  And it would also be nice if the media directors (moonxx) could be in the same workgroup as well rather than the "pluto" workgroup.

Bottom line minimum would prefer to have all clients in the same workgroup with samba primary domain controller and dans guardian content filter on the core.

Please your experiences.

And if the best answer is to run ipcop or something on a dedicated box upstream from the core (, and that samba pdc is better off on it's owe 'buntu server (  That's good to know as well and is my current and default setting.

much thanks,


Finding the ASUS M2NPV-VM known-compatible mobo has been a godsend after messing with pluto for a year with limited success.  The "video" text on the wiki should be required reading for anyone insterested in lmce or pluto.

One drawback to the menpv-vm is that it has only two PCI slots.  Not a problem in the mds, but in the core, you add one gig ethernet card and one WinTV-PVR-150 MCE and that's it.

I appreciate your suggestions on known-compatible ATX mobos with more PCI slots.


Users / media files resync error - maplock?
« on: August 17, 2007, 03:46:35 am »

The media finder does not seem to be working for shared folders, so I ran pluto-admin -- files & media -- media files sync -- mediaFilesSync on  /home/public/data

but it errors off with:

"Cannot find self in maplock!"

Appreciate any insight.

much thanks,

executeLog extract:

05   08/16/07 21:21:20.880      # PlutoMediaFile STARTED: dir /home/public/data/pictures/flickr/2007/07 file 21 <0xb6b8f6d0>
05   08/16/07 21:21:20.880      Parent folder already in the database: /home/public/data/pictures/flickr/2007/07/21 <0xb6b8f6d0>
05   08/16/07 21:21:21.531      # PlutoMediaFile STARTED: dir /home/public/data/pictures/flickr/2007/07/13 file 796781968.jpg <0xb6b8f6d0>
Writing: PK_Attr = 30      *
Don't know yet how to save tag with PK_Attr = 30 and value *
05   08/16/07 21:21:21.619      # PlutoMediaFile STARTED: dir /home/public/data/pictures/flickr/2007/07/13 file 802864464.jpg <0xb6b8f6d0>
Writing: PK_Attr = 30      *
Don't know yet how to save tag with PK_Attr = 30 and value *
05   08/16/07 21:21:21.629      # PlutoMediaFile STARTED: dir /home/public/data/pictures/flickr/2007/07 file 13 <0xb6b8f6d0>
05   08/16/07 21:21:21.629      Parent folder already in the database: /home/public/data/pictures/flickr/2007/07/13 <0xb6b8f6d0>
01   08/16/07 21:21:24.515      Cannot find self in maplock! (0x80b07b4) (>2) alarm: AlarmManager.cpp:102  <0xb6b8eb90>
ready to dump locks using logger: 0x80b0858
05   08/16/07 21:21:24.535      Dumping 1 locks <0xb6b8eb90>
05   08/16/07 21:21:24.535      finished check for exceptions <0xb6b8eb90>
05   08/16/07 21:21:24.535      OL: (0x80b07b4) (>1) alarm AlarmManager.cpp l:87 time: 9:21:24p (0 s) thread: 3065575120 Rel: Y Got: Y <0xb6b8eb90>

Installation issues / lmce 0704 hang after reboot??
« on: August 10, 2007, 09:35:47 am »
on reboot, my core hangs after the kubuntu blue scroll bar completes.

Console displays:

Ubuntu 0704 dcerouter tty1
dcerouter login:                   /etc/samba/      ----

And then it hangs there (for hours).  As I recall, when it booted correctly, several more msgs scrolled by and then x started and the lmce launcher.

Any ideas / plans / 'things to check' appreciated.

much thanks, joseph


I suggest that lcme be able to be installed on top of freespire 2.  freespire 2 is built on ubuntu 704 with kde, so it should be straightforward and freespire includes the option of installing all the proprietary components.

Freespire 2:
is essentially kubuntu + legally licensed proprietary sw:
LCME 704 is built on kubuntu 704, so it seems like a very good fit.

Linux MCE includes:

media & entertainment with a server for music, movies and tv shows, plus a PVR and DVD Player,
a home automation system to control everything in the home with touch-screen tablet and Bluetooth mobile phone controllers,
a phone system with video conferencing,
a security system that feeds you live video on your mobile phone when something happens, and lets you speak to visitors through your stereos, and
a home PC solution.

Does anyone know if Freespire built on kubuntu or directly on ubuntu?




Installation issues / linux mce 2 over freespire 2?
« on: July 31, 2007, 12:15:41 pm »
BLUF:  I tried to install lmce 2rc over freespire 2rc and cd cache failed - but I got that far.

Freespire 2:
is essentially kubuntu + legally licensed proprietary sw:

right click install was not available, so I executed:
/media/CDROM# dpkg -i mce_installer_2_0.1_1.i386.deb

that worked (noted xorg missing in diff.list) and put the lmce install icon on the desktop.
disk one hd cache worked, but failed on disk 2 cache as described in earlier post.

Anyone else have any luck with this?  Seems like a natural fit.

Pages: [1]