Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - rebelkiller

Pages: [1] 2 3 ... 6
1
Users / Re: 1404 is now considered our primarly development version
« on: January 17, 2016, 02:14:45 pm »
Sounds good!
Will there be an "update" function to migrate to a newer version?

To update an fully configured running version to a blank new one would be very time consuming (at least for me)...

2
Problem still exists. I need help.

- I tried several settings for onscreen-orbiter (english, german, basic, titanium blue, nomal 4:3, 16:9 etc.) with full regeneration afterwards.
- Fonts have been installed

Text is still missing on the rpi2. On the other MDs text is showing.

There must be something wrong on the core, too:  My whole lmce installation is setup in german language. On the onscreen orbiters all of the autogenerated scenarios have no "Umlaute" (ä,ü,ö). In manually created scenarios there are "Umlaute" and the german "ß".

How can I fix this?

Thank you


3
Hello there,


on my rpi2 ("normal" disked rpi2-MD, 31723) text ist partially missing.

The buttons do have the correct text. But what is missing:

- all media pages do not have a text (file names, disk drive entries, channel names etc.)
- the loading screen right before onscreen orbiter is showing (during router reload or reboot) does not have text
- the little text box at the top left corner of the screen showing after MD start in onscreen orbiter does not have text either.

I already tried different skins. Currently i am using basic skin.

I think it could be a missing font.

Which fonts are have to be installed?
Any other ideas?

Greets

Bernd

4
Installation issues / Re: Raspberry pi 2 installation -> HDMI CEC problems
« on: December 13, 2015, 03:20:03 pm »
okay. HDMI command are getting used by lmce now.

But using the Panasonic remote is not very responsive. Something is slowing down. About 0.5 - 1 second after a key is pressed the command will be executed on the on screen orbiter.

any ideas how to optimize this?

Greets

Bernd

5
Installation issues / Re: Raspberry pi 2 installation -> HDMI CEC problems
« on: November 25, 2015, 07:49:52 pm »
I noticed package update to 31661 (core), the rpi2-packages are still 31597 (on the MD itself)... Correct?

6
I have exactly the same issue with no third network adaptor.

7
Installation issues / Re: Raspberry pi 2 installation -> HDMI CEC problems
« on: November 22, 2015, 07:16:37 pm »
 I randomly tapped on the remote.... Some buttons I pressed twice.

9
Installation issues / Re: Raspberry pi 2 installation -> VDR problems
« on: November 18, 2015, 10:58:47 am »
Ok, I will try getting this to work. Let's be more specific:  :)

* Don't use any xine based vdr plugin on the relevant MD
=> Should I remove those packages from MD? Removal vdr-plugin-xineliboutput will result in removing pluto-vdr...

* Add the rpihddevice plugin
=> ok
* Make sure to start VDR with the rpihddevice in suspend mode
=> which conf-file must be edited?
* Change StartVDRClient.sh to activate the rpihddevice
=> we are talking about this line in StartVDRClient.sh, right?
Code: [Select]
/usr/bin/vdr-sxfe $XINE_IP --reconnect --post tvtime:method=use_vo_driver --fullscreen --tcp --syslog --verbose

I must be something like

Code: [Select]
/usr/bin/vdr $XINE_IP -P rpihddevice

* Find out what the name of the xwindow is that the rpihddevice creates (xwininfo -tree -root is your friend)
=> ok
* amend the vdr player device for the rpi to bring that xwindow to the front (web admin change)
=> which web admin device must be added?


Thanks!


Greets
Bernd

10
Installation issues / Re: Raspberry pi 2 installation -> HDMI CEC problems
« on: November 18, 2015, 10:47:52 am »
Quote
I have a panasonic tv and a Denon AVR with a pulse-eight adaptor (I have tested rpi as well).  My panasonic remote presses have never been sent along the CEC bus.

Watching cec-client messages on the rpi2-MD I *can* see button presses from the Panasonic's TV remote .
I have another rpi2 with an OpenElec OS. Connecting it the same way as rpi2-MD to the Panasonic (tx-p50-gw30) and the Denon AVR 2310 it works ootb (Navigating through OpenElec menus, channel up, channel down, volume up volume down etc. is all working as expected).

It must be a LMCE-issue. I do not really know where to look at...



11
Installation issues / Raspberry pi 2 installation -> HDMI CEC problems
« on: November 17, 2015, 08:20:59 pm »
Hello!

 did fresh installation of jessie on my rpi2. I want to use HDMI-CEC with my rpi2, Panasonic-Plasma and DENON AVR.

Testing with cec-client gives the right outputs (addresses, Vendors etc.). So basically I it is a working setup. (A further test with a another rpi2 and a recent KODI/Openelec installation HDMI works OOTB). So I assume that there are no incompatibilities between the devices.

I followed instructions in the wiki regarding pulse eight adaptor and give the right(?) address entries of those three devices in webadmin. COM port of the CEC-Adaptor is left blank. I set the Audio/Videos pipes and reloaded the core.

Now on the rpi2 MD my TV remote does not show any reaction on button presses.


Partially the log of CEC_Adaptor:

Code: [Select]
========== NEW LOG SECTION ==========
1       11/17/15 18:43:52       143 (spawning-device)   ^[[1;00mStarting... 1^[[1;00m
1       11/17/15 18:43:52       143 (spawning-device)   ^[[1;00mFound /usr/pluto/bin/CEC_Adaptor^[[1;00m
05      11/17/15 18:43:53.646           ^[[33;1mConnect() failed, Error Code 111 (Connection refused))^[[0m <0x76f64000>
05      11/17/15 18:43:54.648           ^[[33;1mConnect() failed, Error Code 111 (Connection refused))^[[0m <0x76f64000>
05      11/17/15 18:44:19.104           ^[[33;1mNo COM Port specified. Trying autodetect.  Please set a port in the Interfaces section of Web Admin, or re-detect device.^[[0m <0x76f64000>
01      11/17/15 18:44:21.298           ^[[31;1mCECCommand: CALLBACK! From: 0, To: 4, set=1, Opcode: 135/device vendor id, Parm1=0, sParms: ''^[[0m <0x7640d450>
01      11/17/15 18:44:21.299           ^[[31;1mCECCommand: CALLBACK! VendorID     : 0/Unknown^[[0m <0x7640d450>
05      11/17/15 18:44:27.624           ^[[33;1mCreating child 144^[[0m <0x76f64000>
05      11/17/15 18:44:27.625           ^[[33;1mNote: Device manager has attached a device of type 2303 that this has no custom event handler for.  It will not fire events.^[[0m <0x76f64000>
05      11/17/15 18:44:27.625           ^[[33;1mNote: Device manager has attached a device of type 2303 that this has no custom handler for.  This is normal for IR.^[[0m <0x76f64000>
05      11/17/15 18:44:27.625           ^[[33;1mCreating child 146^[[0m <0x76f64000>
05      11/17/15 18:44:27.625           ^[[33;1mNote: Device manager has attached a device of type 2304 that this has no custom event handler for.  It will not fire events.^[[0m <0x76f64000>
05      11/17/15 18:44:27.625           ^[[33;1mNote: Device manager has attached a device of type 2304 that this has no custom handler for.  This is normal for IR.^[[0m <0x76f64000>
05      11/17/15 18:44:27.625           ^[[33;1mCreating child 147^[[0m <0x76f64000>
05      11/17/15 18:44:27.625           ^[[33;1mNote: Device manager has attached a device of type 2306 that this has no custom event handler for.  It will not fire events.^[[0m <0x76f64000>
05      11/17/15 18:44:27.625           ^[[33;1mNote: Device manager has attached a device of type 2306 that this has no custom handler for.  This is normal for IR.^[[0m <0x76f64000>
01      11/17/15 18:47:06.215           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:47:08.273           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:47:10.328           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:47:12.383           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:47:14.437           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:47:16.492           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
...
01      11/17/15 18:48:12.012           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:48:14.073           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:48:16.127           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:48:18.183           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:48:20.237           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:48:22.293           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:48:24.352           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
01      11/17/15 18:48:26.407           ^[[31;1mCECCommand: CALLBACK! Unhandled!^[[0m <0x7640d450>
05      11/17/15 18:56:21.696           ^[[33;1mlibCEC: unhandled response received: opcode=0 initiator=e destination=0 response=0^[[0m <0x7640d450>
05      11/17/15 18:56:21.792           ^[[33;1mlibCEC: unhandled response received: opcode=8c initiator=e destination=0 response=0^[[0m <0x7640d450>
05      11/17/15 18:56:22.604           ^[[33;1mlibCEC: unhandled response received: opcode=84 initiator=4 destination=f response=0^[[0m <0x7640d450>
05      11/17/15 18:56:22.904           ^[[33;1mlibCEC: unhandled response received: opcode=47 initiator=4 destination=0 response=0^[[0m <0x7640d450>
05      11/17/15 18:56:23.087           ^[[33;1mlibCEC: unhandled response received: opcode=8f initiator=4 destination=0 response=0^[[0m <0x7640d450>
01      11/17/15 18:56:23.638           ^[[31;1mCECCommand: CALLBACK! From: 0, To: 4, set=1, Opcode: 135/device vendor id, Parm1=0, sParms: ''^[[0m <0x7640d450>
01      11/17/15 18:56:23.639           ^[[31;1mCECCommand: CALLBACK! VendorID     : 0/Unknown^[[0m <0x7640d450>
05      11/17/15 18:56:23.791           ^[[33;1mlibCEC: unhandled response received: opcode=87 initiator=4 destination=f response=0^[[0m <0x7640d450>
05      11/17/15 18:56:24.280           ^[[33;1mlibCEC: unhandled response received: opcode=89 initiator=4 destination=0 response=0^[[0m <0x7640d450>


Some ideas?

Thank you!


Greets
Bernd

12
Installation issues / Raspberry pi 2 installation -> VDR problems
« on: November 17, 2015, 08:03:02 pm »
Hello,
I just wanted to give a feedback to a fresh rpi2 installation. I updated my LMCE-installation (Core and MD) today (31620).

Basically installation process works fine.
I am using VDR. I have still problems getting VDR to work:

Here are my observations:
- vdr-plugin-remotetimers is not getting installed -> apt-show cache shows it as a virtual package?
- adding e-tobi-repos for VDR in sources.list fixed installation von remotetimer-plugin
- in /etc/vdr/conf.d I had to manually edit some config files (e.g. video directory, disabling lirc as it fires error messages in syslog etc.)

Now that VDR-client is starting and running I still get a black screen when pressing TV on the rpi2-Orbiter. I don't really find out where the problem is.

Maybe some can help.


/var/log/syslog from rpi-MD after pressing TV on the orbiter:


Code: [Select]
...
Nov 17 19:53:30 moon127 vdr: [31046] loading /var/lib/vdr/themes/lcars-default.theme
Nov 17 19:53:30 moon127 vdr: [31046] starting plugin: remotetimers
Nov 17 19:53:30 moon127 vdr: [31046] starting plugin: streamdev-client
Nov 17 19:53:30 moon127 vdr: [31046] starting plugin: svdrpservice
Nov 17 19:53:30 moon127 vdr: [31046] starting plugin: xineliboutput
Nov 17 19:53:30 moon127 vdr: [31098] Remote decoder/display server (cXinelibServer) thread started (pid=31046, tid=31098, prio=high)
v 17 19:53:30 moon127 vdr: [31046] no DVB device found
Nov 17 19:53:30 moon127 vdr: [31095] reading EPG data from /var/cache/vdr/epg.data
Nov 17 19:53:30 moon127 vdr: [31046] initializing plugin: remotetimers (1.0.2): Timer eines anderen VDR bearbeiten
Nov 17 19:53:30 moon127 vdr: [31095] epg data reader thread ended (pid=31046, tid=31095)
Nov 17 19:53:30 moon127 vdr: [31046] initializing plugin: streamdev-client (0.6.1-git): VTP Streaming Client
Nov 17 19:53:30 moon127 vdr: [31046] initializing plugin: svdrpservice (1.0.0): SVDRP client
Nov 17 19:53:30 moon127 vdr: [31046] initializing plugin: xineliboutput (2.0.0-cvs): X11/xine-lib Ausgabe-Plugin
Nov 17 19:53:30 moon127 vdr: [31046] new device number 1
Nov 17 19:53:30 moon127 vdr: [31046] [xine..put] cTimePts: clock_gettime(CLOCK_MONOTONIC): clock resolution 0 us
Nov 17 19:53:30 moon127 vdr: [31046] [xine..put] cTimePts: using monotonic clock
Nov 17 19:53:30 moon127 vdr: [31046] [xine..put] RTP SSRC: 0x7392389b
Nov 17 19:53:30 moon127 vdr: [31046] setting primary device to 1
Nov 17 19:53:30 moon127 vdr: [31046] assuming manual start of VDR
Nov 17 19:53:30 moon127 vdr: [31046] SVDRP listening on port 2001
Nov 17 19:53:30 moon127 vdr: [31046] setting current skin to "lcars"
Nov 17 19:53:30 moon127 vdr: [31046] loading /var/lib/vdr/themes/lcars-default.theme
Nov 17 19:53:30 moon127 vdr: [31046] starting plugin: remotetimers
Nov 17 19:53:30 moon127 vdr: [31046] starting plugin: streamdev-client
Nov 17 19:53:30 moon127 vdr: [31046] starting plugin: svdrpservice
Nov 17 19:53:30 moon127 vdr: [31046] starting plugin: xineliboutput
Nov 17 19:53:30 moon127 vdr: [31098] Remote decoder/display server (cXinelibServer) thread started (pid=31046, tid=31098, prio=high)
Nov 17 19:53:30 moon127 vdr: [31098] [xine..put] cXinelibServer priority set successful SCHED_RR 2 [1,99]
Nov 17 19:53:30 moon127 vdr: [31097] remotetimers update file watcher thread started (pid=31046, tid=31097, prio=high)
Nov 17 19:53:30 moon127 vdr: [31098] [xine..put] Binding server to 127.0.0.1:37890
Nov 17 19:53:30 moon127 vdr: [31097] remotetimers update file watcher now monitoring '/var/lib/video.00/.update'
Nov 17 19:53:30 moon127 vdr: [31098] [xine..put] Listening on port 37890
Nov 17 19:53:30 moon127 vdr: [31098] [xine..put] Listening for UDP broadcasts on port 37890
Nov 17 19:53:30 moon127 vdr: [31098] [discovery] BROADCAST: VDR xineliboutput DISCOVERY 1.0#015#012Server port: 37890#015#012Server address: 127.0.0.1#015#012Server version: xineliboutput-2.0.0-cvs#015#012#015
Nov 17 19:53:30 moon127 vdr: [31094] video directory scanner thread ended (pid=31046, tid=31094)
Nov 17 19:53:30 moon127 vdr: [31093] video directory scanner thread ended (pid=31046, tid=31093)
Nov 17 19:53:30 moon127 vdr: [31046] [xine..put] cXinelibDevice::StartDevice(): Device started
Nov 17 19:53:30 moon127 vdr: [31046] cTimeMs: using monotonic clock (resolution is 1 ns)
Nov 17 19:53:30 moon127 vdr: [31046] switching to channel 1 (Aristo.TV)
Nov 17 19:53:30 moon127 vdr: [31046] info: Kanal nicht verfügbar!
Nov 17 19:53:30 moon127 vdr: [31046] [xine..put] cXinelibOsd::CanHandleAreas(): Device does not support ARGB
Nov 17 19:53:32 moon127 vdr: [31046] setting watchdog timer to 60 seconds
Nov 17 19:53:32 moon127 vdr: [31046] OSD size changed to 720x576 @ 1,42222
Nov 17 19:53:32 moon127 vdr: [31046] [xine..put] cXinelibOsd::CanHandleAreas(): Device does not support ARGB
...

I know that channel 1 not available in this example. LMCE should show at least "nosignal" but it does not.


When starting "StartVDRClient.sh" from the command line I am getting some error messages:

Code: [Select]
Starting Linux Video Disk Recorder: vdr - seems to be running already.
220 moon127 SVDRP VideoDiskRecorder 2.2.0; Tue Nov 17 19:59:20 2015; UTF-8
250 Key "Ok" accepted
221 moon127 closing connection
vdr-sxfe 2.0.0-cvs  (build with xine-lib 1.2.6, using xine-lib 1.2.6)

Automatic reconnection enabled
Post plugins: tvtime:method=use_vo_driver
Fullscreen mode
Protocol: TCP
Verbose mode

VDR server not given, searching ...
Found VDR server: host 127.0.0.1, port 37890
Loaded configuration from file '/root/.xine/config_xineliboutput'
Benchmarking memcpy methods (smaller is better):
        libc memcpy() : 196590365

...
load_plugins: plugin /usr/lib/xine/plugins/2.5/xineplug_decode_spucmml.so found
load_plugins: plugin /usr/lib/xine/plugins/2.5/xineplug_decode_spu.so found
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
vo_vdpau: Can't create vdp device : No vdpau implementation.
video_out_dxr3: Failed to open control device /dev/em8300-0 (No such file or directory)
libva info: VA-API version 0.36.0
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
video_out_vaapi Error : vaInitialize(): unknown libva error
video_out_vaapi vaapi_init : error init vaapi
video_out_xv: Xv extension is present but I couldn't find a usable yuv12 port.
        Looks like your graphics hardware driver doesn't support Xv?!
video_out_opengl: Testing for hardware accelerated direct rendering visual
video_out_opengl: Didn't find any
vo_opengl2 : compiling shader yuv420_frag
vo_opengl2 : compiling shader yuv422_frag
vo_opengl2: initialized.
audio_alsa_out : supported modes are 8bit 16bit 24bit 32bit mono stereo (4-channel not enabled in xine config) (4.1-channel not enabled in xine config) (5-channel not enabled in xine config) (5.1-channel not enabled in xine config) (a/52 and DTS pass-through not enabled in xine config)
...

Available SPU decoder plugins:   dxr3-spudec spudec spuhdmv spucc spucmml spudvb sputext
params.c:OpenConfFile() - Unable to open configuration file "/root/.smb/smb.conf.append":
        No such file or directory
added interface eth0 ip=192.168.80.2 bcast=192.168.80.255 netmask=255.255.255.0
xine: found input plugin  : VDR (Video Disk Recorder) input plugin
unknown option in get_option: 4100
input cache plugin disabled
xine: found demuxer plugin: XVDR demux plugin


Press Esc to exit

av_offset=0 pts
setterm: argument error: 'off'
video_out_opengl2: b 0 c 128 s 128 h 0 [ITU-R 470 BG / SDTV]
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  72 (X_PutImage)
  Serial number of failed request:  203
  Current serial number in output stream:  234
vdr-sxfe: Kein Prozess gefunden
Restarting Linux Video Disk Recorder: vdr.


...


Thanks for your help.



Greets

Bernd

13
Users / Advanced_IP_Camera => eventmethod "httpserver"?
« on: November 11, 2015, 09:21:52 pm »
Hello there,

I'm using an IP Camera with Advanced_IP_Camera DT. I want to use the camera as motion detector so I need events.
As described in the wiki there are three eventmethods that can be used for motion detecting.

urlpoll method is working but polling interval ist too slow. For example: When someone goes by and polling interval is set to 10 seconds results in an empty picture.  :)

I am trying to optimize that. My camera is capable of sending http events. So my camera can send notifications directly to the core (as a http message). But I am not quite sure how to get it to work.


Here are my questions:

1. webadmin settings:
In camera DT I have to set "eventMethod1=httpserver". What about "eventURL1"? What about "eventInterval"?

In child motion detector I have to chose "method=1" and "triggerMethod=pattern". the "patternOn" and "patternOff" will get the message patterns I specified in the camera.


2. camera settings:
To which server address do i have to send event notifications? -> just "192.168.80.1"?


Thanks for your help.

Bernd

14
Installation of libcec2 did the job. Now I have both, libcec2 and libcec3. VDR is working.


I'm using yavdr (testing-repo) 2.2.0 with no problems. Before updating I did not set back to the standard repos.

I would say: problem solved.


Thank you guys!


Greets

Bernd

15
Code: [Select]
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  libsoxr0 linphone-common libosip2-4 xcompmgr pluto-photo-screen-saver pluto-pnp-detection
  lmce-usb-gamepad lmce-squeezeslave pluto-irbase beep pluto-hald libconfuse-common pluto-add-software
  pluto-libresolution pluto-x-scripts pluto-orbiter wmctrl squeezelite pluto-shiftstate
  pluto-hal-device-finder pluto-simplephone lsscsi lmce-avwizard-skin-basic libconfuse0 libexosip2-4
  liblinphone3 libmediastreamer0 libmpg123-0 pluto-messagetrans libgraphicsmagick3 pluto-mcr-remote
  libortp8 pluto-app-server
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden Pakete werden ENTFERNT:
  libcec3 lmce-cec-adaptor lmce-hybrid lmce-md-meta pluto-avwizard
Die folgenden NEUEN Pakete werden installiert:
  libcec2
0 aktualisiert, 1 neu installiert, 5 zu entfernen und 0 nicht aktualisiert.
Es müssen 214 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 10,0 MB Plattenplatz freigegeben.
Möchten Sie fortfahren [J/n]?

Installing libcec2 will remove some lmce/pluto-packages...

Pages: [1] 2 3 ... 6