Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - trippleg

Pages: [1] 2
Users / Re: Web Orbiter Ulta Blank Buttons
« on: May 01, 2012, 11:12:01 pm »
1004  I have done a full regen, but no dice.


Users / Web Orbiter Ulta Blank Buttons
« on: April 25, 2012, 09:05:09 pm »
I have created a web orbiter for my Smart phone using the Ulta skin.  The orbiter seems to generate fine with the exception of not displaying any text on the displayed buttons.  It works correctly when I switch it to the Titanium Blue skin.  Anyone have any ideas on where to start troubleshooting this problem?



Users / Tutorial added to wiki for Insteon Venstar Thermostat
« on: February 09, 2012, 12:33:16 am »
I just added a small how to for the Insteon Venstar Thermostat to the wiki.  Go easy on my it is my first stab at it  :)


Users / Re: Insteon 2412U
« on: February 08, 2012, 10:37:04 pm »
You may want to run it in a VM.  that is what I am doing  ;D


Users / Re: Insteon 2412U
« on: February 04, 2012, 02:01:32 am »
I believe it still sends individual codes to the insteon device, not scenes. That being said users have the ability to add that functionality by modifying the existing code.  I was looking at mister house, but the 2412n is not supported, so I went with lmce and created a template for it and added support for the venstar thermostat by modifying the existing python code using the link you provided in your post.

I did not think about sending scenes directly to the insteon, and i dont recall seeing the plm codes to do that, but I think it would be a good feature to add. Wish I could be more help.


Users / Re: Insteon 2412U
« on: February 03, 2012, 06:14:07 pm »

Since you're appearantly familiar with the PLM code, could you tell me/us if it presently supports Insteon scenes?  If so, would it support creating a scene in LinuxMCE that gets pushed into the devices, or merely triggering a scene that already exists in the devices (e.g. Manually linked scenes)?




I have focused mainly on the Thermostat Functionality, not lighting yet, but will in the future.  From what I can tell scenes are setup directly through LinuxMCE. It takes the place of the insteon software. So scenes will be defined within the web interface of LinuxMCE.


Users / Re: Insteon 2412U
« on: February 03, 2012, 01:46:03 am »
Thanks trippleg

Thanks aviator

Just an FYI users are better off using the existing plm Ruby code contained within the source rather than the one on the wiki. I have submitted changes that add functionality for the venstar thermostat.

Users / Re: Insteon 2412U
« on: February 02, 2012, 06:41:16 am »
It works for the 2412n as well now. I have not had time to figure out the wiki, but when I get a free moment I will add a tutorial for using the be Venstar thermostat as well.

Users / Copying a thermostat template a bit of help
« on: December 01, 2011, 05:22:25 pm »
I copied the Thermostat template 4  to a new one to add Insteon support, and for some reason it shows in the template "No test commands supported for this climate device"
Can someone point me in the right direction to fix this?  The original Thermostat template shows test commands.



Users / Temperature display in orbiter?
« on: November 19, 2011, 03:47:21 pm »
I am installing an Insteon thermostat, and was wondering if there is a way to display the current temperature in the web orbiter from the device state field?



Users / GSD Error anyone know how to fix it?
« on: November 17, 2011, 05:06:05 pm »
I am trying to send a heating command and get the following error.

Code: [Select]
GSD-Sleep Post 280 : 0 <0xb7113b90>
05 11/17/11 7:55:31.169 _QueueProc Post - 280 : 0 <0xb7113b90>
05 11/17/11 7:56:27.069 GSDMessageTranslator isCmdImplemented = false <0xb5910b90>
05 11/17/11 7:56:27.072 #### Pre-Process Queue = 1 <0xb5910b90>
05 11/17/11 7:56:27.105 _QueueProc Pre - 280 : 0 <0xb7113b90>
05 11/17/11 7:56:27.106 GSD-Sleep Pre 280 : 0 <0xb7113b90>
05 11/17/11 7:56:27.106 Process Queue = 1 <0xb7113b90><0xb5910b90>



Users / A bit of help with some code...
« on: November 17, 2011, 12:57:52 am »
I am trying to log an event and assign a template id once a string is found.  I am modifying existing code, but I can not figure it out.  Right now it assigns all devices to template 4, but I only want to assign 0x6B to template 4.  Below is the code.

Code: [Select]
when 0x05 # Climate Control
case $childdatabases[insteonID][0][2..3].hex
when 0x00; @work += 'Broan SMSC080 Exhaust Fan'
when 0x01; @work += 'Simplehomenet EZTherm'
when 0x02; @work += 'Broan SMSC110 Exhaust Fan'
when 0x03; @work += 'Venstar RF Thermostat Module'
when 0x04; @work += 'Simplehomenet EZStat Thermostat'
when 0x6B; @work += 'Venstar RF Thermostat Module'
@work += "\t\t4" # Set Template 4

any ideas??



Users / Best Practice for templates? Create one or mod existing?
« on: November 16, 2011, 09:06:23 pm »
I am working on the Insteon PLM for 2412n adding thermostat compatibility the code change should work for the Insteon powerlinc modem as well.  I have most of it working now, but the generic thermostat template is missing some items.  Should I add the items to the generic template and submit it for change, or create a new one.  It is missing 3 elements.


Users / Re: Help retrieving template id for ruby script
« on: November 15, 2011, 09:28:36 pm »
I have this code in the Tellstick code:

 cmdTo           = cmd.devidto_                                            # Device ID in LinuxMCE
 devPort         = device_.childdevices_[cmdTo].devdata_[12]  # 12 contains a port/channel
 childType       = device_.childdevices_[cmdTo].devtemplid_    # Template ID to know type of device

Hope it helps.


Can you tell me what childType returns?  Is it numeric, or string.  I have the same variable defined above.  I am using
when childtype == 4 #used when Device is Thermostat
Is this the correct way to use this variable.

Is there a way to test the code prior to placing it into the template?

Sorry for the noob question.  I am new to both Linuxmce and Ruby. 


Users / Help retrieving template id for ruby script
« on: November 15, 2011, 08:55:22 pm »
I am modifying the following code and I can not figure out how to get the template id for the child I am sending the command to. I added childtype, but I fear it is incorrect. I need the template id because the command to send it a little different from the default command.

Code: [Select]
#### Written by Dan Damron
#### #760 Send Command to Child ####

@insteonID = id.chomp.split('.')
@parameters = parameters
@command = pk_command
@cmd = cmd
childtype =device_.childdevices_[cmdTo].devtemplid_ # find out device type

log('#760:id=' + id.inspect)
log('#760:parameters=' + parameters.inspect)
log('#760:pk_command=' + pk_command.inspect)
log('#760:cmd=' + cmd.inspect)
### ok, I get the insteonID in @insteonID
# pk_command has one of THREE values, 192, 193, or NOTHING
# when I click 50%, I get in parameters: 76
# but NOTHING in pk_command.

case pk_command

when '193' #OFF
when childtype == 4 #used when Device is Thermostat
param = {'Command' => 'SndIns',
'Parameter1' => @insteonID[0],
'Parameter2' => @insteonID[1],
'Parameter3' => @insteonID[2],
'Parameter4' => '0F',
'Parameter5' => '6B',
'Parameter6' => '09'} #OFF
when childtype != 4 #used when Device not Thermostat
param = {'Command' => 'SndIns',
'Parameter1' => @insteonID[0],
'Parameter2' => @insteonID[1],
'Parameter3' => @insteonID[2],
'Parameter4' => '0F',
'Parameter5' => '13', #OFF
'Parameter6' => '00'}
$cmdqueue << param



Pages: [1] 2