Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - FedExGuy

Pages: [1]
Users / Re: Zotac MAG ION Nettop
« on: February 11, 2011, 08:25:53 pm »
I am running 15 Zotac MAG HD-NS01's they have no Fan. These units are in an industrial environment subject to extremes of heat and cold ( Northern California ) and HIGH Dust Levels ( FedEx and Customer Boxes ). They have been running approximately 6 months now no problems at all.

But they were VERY Difficult to get setup, the drivers that Zotac provides do not work on Linux 8.10 and since LinuxMCE does not work on newer Linux distro's I was up a creek with no paddle. As a result I am so far completely unable to get Audio through HDMI and was forced to use an external audio cable. Linux 8.10 does not recognize the internal WiFi at all so all HAD TO BE Hard wired even though I installed 8 WiFi routers (802.11 N ) just for that purpose. I hard wired 4500 Feet of Cat 5 this is a 500,000+ Sq/Ft Building.

In order to setup for netboot you have to go into the BIOS Setup - in the SouthBridge setup is the option for PXE Boot ROM Support. You have to enable it then save your settings and reboot back into the BIOS Setup a second time to set network as the first boot option ( it does not show up in the boot options menu until after a reboot ). I have a crazy bug that is really a trivial issue but it is confusing - it seems that randomly over long periods of time ( weeks ) a new drive will be found on one of my MD's so far about 7 have found drives and the others do not. I have not gone through to try and get these drives setup because the idea of having all of my media spread across 15 MD's just would not work ( these MD's will go out eventually due to the environment ).

I am eagerly awaiting the upgrade to a newer Linux Distro.

Feature requests & roadmap / Re: Commercial Use
« on: January 31, 2011, 01:07:20 am »
I will stop by the IRC channels - it will be definitely be a blast from the past for me, I haven't been on IRC since the 90's, I am glad to see that mIRC is still around.
Unfortunately I can not access IRC at work so my time on it will be limited. Even if I were to go thru or around the proxy, the traffic would be noticed.

Feature requests & roadmap / Re: Control PLC with LinuxMCE?
« on: January 31, 2011, 12:57:18 am »
Yes a GSD works just fine for bi-directional communication between LinuxMCE and a PLC. We
use an RS232 to PLC connection here for high speed imaging barcode scanners at over 3500 packages per hour with no data loss at all.

I can definitely post examples of some of my PLC program on this forum, but better yet tell me what PLC your planning on using and I'll provide examples tailored to that system.

Feature requests & roadmap / Re: Commercial Use
« on: January 28, 2011, 08:51:27 pm »
I am hoping soon to begin contributing to this project, I really like LinuxMCE it has the potential to be REALLY GREAT and is already doing allot of great things, but I had a nightmare of a time getting it to work. I mean literally weeks it took me to get it setup and running ( I stuck it out even through the many times I wanted to put my fist through the monitor and toss the PC across the room ). I firmly believed LinuxMCE was exactly what I needed for the job, and it has proven itself to be exactly that.

I am an electrical engineer with over 30 years of programming in almost every language, I have some ideas to contribute to the project, hopefully in the near future I will have the time work up some code and submit, maybe at some future date being a major contributor.

Feature requests & roadmap / Re: Control PLC with LinuxMCE?
« on: January 28, 2011, 08:01:53 pm »
I think I can input a little on this subject, I am a senior electrical engineer for Fedex and have been working on industrial PLC systems for over 30 Years, I just recently setup a system of 15 MD's as a sort of HD billboard system that so far has been working very well.
I have been connecting this system to our PLC network so that it can respond to equipment status changes and to be able to tell when our equipment is running or not ( since while it's running there is far too much noise to hear ANY audio from the MD's at all - unless I used 500 watt amps at each location ).
We use ControlLogix PLC's here, they have TCP/IP and ControlNet interfaces which are used by the 28 PLC CPU's to communicate with each other and to provide User Graphic Display information. The PLC's also have an RS232 port which is what I decided would be best for my dcerouter to connect to the PLC system.
The serial port can be operated two ways as an OPC device which uses an industry standard protocol to query the PLC for data, or it can be run in an open user configuration - this is what I chose to use mainly due to the complexities of the OPC protocol and that I didn't need that level of communication.
What I have done is write a PLC Program ( relay logic ) that sends dcerouter type commands to the server using a GSD as the receiving end that converts the already text based commands to actual router commands, so far I have only run simple tests but all indications are that it will work perfectly.
The PLC program must when triggered by some event, produce a text output to linuxmce. it can also accept text input from linuxmce, I will most likely not be using it in that fashion since my billboard system does not produce any events that I wish the equipment to affected by.

I summary connecting linuxmce to a PLC via RS232 is definitely possible even without using a full OPC server. however I have seen several open source OPC servers out there maybe one could be used in linuxmce to give it built in PLC capabilities, I have to imagine there are more than a few people that could benefit from PLC type control.

Users / Re: Question about how to auto start multiple MD's on one Stream.
« on: November 11, 2010, 11:45:34 pm »
Never Mind I figured it out.......

Thanks !

Users / Re: Question about how to auto start multiple MD's on one Stream.
« on: November 11, 2010, 11:27:08 pm »
Ok !

I am having some trouble in specifying the Playlist file name.

As an example I made a test playlist named t1, when I use just t1 in the #13 Filename (string) it seems to think it's a directory.

How should I specify the filename syntax exactly? for say playlist t1?

Users / Re: Question about how to auto start multiple MD's on one Stream.
« on: November 11, 2010, 12:43:21 am »
Thanks I Will give that a try tomorrow in the AM.

If this works there is a very good chance it may get adopted in FedEx Ground Distribution HUBS nation wide.

Thanks Again !

Users / Question about how to auto start multiple MD's on one Stream.
« on: November 11, 2010, 12:25:20 am »
Let Me start out by giving a brief run down on my install

I am the senior technician at a FedEx Ground distribution HUB in California.
I have been using LinuxMCE at home ( 1 MD and 1 core/hybrid server ).

Here at the HUB we wanted to setup multiple flat screen TV's to display messages,pictures,etc the plan that management had was to
buy TV's with DVD players built in ( which is what they did ). They would burn multiple copies of a composed video and leave them playing.
I suggested that it could be done in a much BETTER way by using a network connected system with the ability to play media on demand and to have it played on multiple locations at the same time, this was much more than they could have hoped for and gave me the go ahead.

Here is where my LONG LONG journey began, I set out to setup a 15 MD system with LinuxMCE. To begin with let me say I am an old school programmer I started out on VAX 10's in the early 80's and am familiar with multiple programing languages,web programing,etc but I have worked mainly on Windows,web and embedded RISC systems almost no experience with Linux beyond the very basics.
So the project that should have taken weeks to setup actually took months, my choice to use Zotac MAG PC's as the MD's was my first undoing. I did manage to get them working but it turns out the the internal hardware that they use for HDMI,audio,WLAN,etc is just too
new for Kubuntu 8.10 as the manufacturers drivers start at 9.10 after MANY MANY MANY attempts at installing 3rd party drivers I gave up and used an external audio cable and HDMI to get picture and sound and gave up completely on WLAN.
At first my install attempts were from a downloaded CD image install which turned out to be flawed in some fashion, it took me MANY MANY install attempts before I was certain of this, at the time I did not know about installing online. My next install attempts were from the repo, let me point out also that I am inside a corporate network with a very tight proxy in Memphis. it took me some time to figure out how to get apt-get to find it's way around the proxy! and then there was the speed issue. We have a high gigabit fiber system internal to the building and an old school T1 line out - the online install took 18 hours - each attempt.
I did the online install many times for but one reason - I was mainly interested in the ability to play a stream on multiple MD's without any great need that they be perfectly synchronized ( most of the MD's are a great distance from each other ), but the first several installs did not seem to be able to do that.
I would get video on that MD and audio only on another if I moved the stream to that MD it would then show the video and the others would not, I battled with this for some time, since this was the central method of my system it had to be able to this. I nearly gave up and went out on the web looking for another solution I tried XBMC,VLC and some others, they all had issues and/or lacked the control that I wanted. I was about to tell Management that the nearly $20,000 on equipment and months of my time was for nothing and that they would in fact be using DVD's for their system. I gave it one more chance and did another install from repo -- THIS TIME IT WORKED.
I guess something was updated and/or changed and now I can play media on all 15 MD's and most of the time it is nearly in sync.

What I want to do is have multiple play list that start at predefined times and automatically start also on every MD at the same time -- again I say that it's not completely necessary that they be in perfect sync just that they are all playing the same stream at the same time. I figure a scenario is what I need to send the start play command to the other MD's but I am not 100% certain that is the correct way - or is there a simpler way that I am just not seeing ?

Also I did notice that I can get all 15 MD's almost perfectly sync'd if I cause them to skip back 2-4 seconds and resume play so I am thinking that including a command to cause an automatic skip back at the beginning of each new file would do a very reasonable job keeping the MD's sync'd up - how would be the best way to accomplish this ??

Thanks in advance for any assistance !

Pages: [1]