Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - F1forHELP

Pages: [1] 2 3
1
Output as requested

dcerouter_585:/home/joseph# apt-cache policy lmce-md-meta
lmce-md-meta:
  Installed: 2.0.0.46.201611190055+fee90f43
  Candidate: 2.0.0.46.201611190055+fee90f43
  Version table:
 *** 2.0.0.46.201611190055+fee90f43 0
        100 /var/lib/dpkg/status
dcerouter_585:/home/joseph#

I just tried to update again using apt-get update

dcerouter_585:/home/joseph# apt-get update
Ign http://deb.linuxmce.org precise Release.gpg
<snip>
Ign http://deb.linuxmce.org precise Release
<snip>
Ign http://deb.linuxmce.org precise/main i386 Packages/DiffIndex               
Ign http://deb.linuxmce.org precise/main TranslationIndex
<snip>
Hit http://deb.linuxmce.org precise/main i386 Packages                       
<snip>     
Ign http://deb.linuxmce.org precise/main Translation-en_US         
<snip>
Ign http://deb.linuxmce.org precise/main Translation-en             
<snip>
Fetched 1,494 kB in 4s (338 kB/s)

Based on the IGN, it looks like it is not seeing any changes in the repos.  My sources.list as set by the installer:

dcerouter_585:/etc/apt# cat sources.list
deb http://deb.linuxmce.org/ubuntu/ precise main
#deb http://deb.linuxmce.org/ precise main
deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

I don't want to go back to 10.04.  I could burn it down and try again.

2
Just logged into my server and there are 23 packages can be updated.

Issuing the apt-get update command

The following packages have been kept back:
  linux-generic-pae linux-headers-generic-lts-trusty linux-headers-generic-pae linux-image-generic-lts-trusty
  linux-image-generic-pae
The following packages will be upgraded:
  firefox ghostscript ghostscript-cups ghostscript-x imagemagick imagemagick-common libgs9 libgs9-common libmagickcore4
  libmagickcore4-extra libmagickwand4 perlmagick
12 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

I don't see any packages listed for LMCE

Tried running the Diskless_CreateTBZ.sh afterwards and still received the same error

Sun Dec  4 09:34:00 PST 2016 - Installing lmce-md-meta for device 28
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package lmce-md-meta
/usr/pluto/bin/Diskless_CreateTBZ.sh: line 170: /tmp/TeeMyOutputExitCode_28634: No such file or directory

I am surprised that the packages are not cached at /var/cache/apt/archives.  Looking after this latest update, the only packages that are cached are what was downloaded today.

Not being a bash programmer, could the packages be sourced from the local cache, if available, instead of being downloaded from the internet?

3
Thanks.  As I was thinking about it, I never looked to see if the files were in the download cache.

While it might not mean much, I would like to thank you and everyone else who has worked on and contributed to this project!

4
Downloaded the absolute latest image for the 12.04 image from http://linuxmce.iptp.org/snapshots/LMCE-1204-20161120232732-i386.iso and successfully installed.

ssh into the machine and apt-get update && apt-get upgrade to pull the latest packages

Because I have 4 media directors I executed

dcerouter_585:~# /usr/pluto/bin/Diskless_CreateTBZ.sh

It started

Sat Nov 26 07:00:07 PST 2016 - BEGIN: Host: ubuntu - precise - i386
Sat Nov 26 07:00:07 PST 2016 - BEGIN: Target: ubuntu - precise - i386
Sat Nov 26 07:00:07 PST 2016 - Creating chroot for MD creation at: /opt/Diskless_CreateTBZ.aK8KccP8A

Partway through the installer complained about missing firmware

W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-3.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168g-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8106e-1.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8411-2.fw for module r8169

It ends with

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 lmce-md-meta : Depends: pluto-orbitergen (>= 2.0.0.46) but it is not going to be installed
                Depends: pluto-orbitergen (< 2.0.0.47) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
/usr/pluto/bin/Diskless_CreateTBZ.sh: line 170: /tmp/TeeMyOutputExitCode_3050: No such file or directory

I have lmce-md-meta installed

dcerouter_585:/etc/apt# apt-get -f install lmce-md-meta
Reading package lists... Done
Building dependency tree       
Reading state information... Done
lmce-md-meta is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I have pluto-orbitergen installed

dcerouter_585:/etc/apt# dpkg -l | grep pluto-orbitergen
ii  pluto-orbitergen                               2.0.0.46.201611190055+fee90f43

I found the following post that kind of hints at the trouble http://forum.linuxmce.org/index.php?action=profile;u=46622;area=showposts;sa=topics;start=0 so I tried installing the packages manually.  When I attempt to reinstall the suggested packages I get

dcerouter_585:/etc/apt# apt-get -f install lmce-diskless-tools lmce-install-scripts pluto-boot-scripts pluto-hald pluto-orbitergen pluto-system-database pluto-website-admin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
pluto-boot-scripts is already the newest version.
pluto-orbitergen is already the newest version.
pluto-system-database is already the newest version.
pluto-website-admin is already the newest version.
pluto-hald is already the newest version.
lmce-install-scripts is already the newest version.
lmce-diskless-tools is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dcerouter_585:/etc/apt#

Any recommendations for going forward?

5
Users / Unrecognized file extension .m4v
« on: March 19, 2014, 06:01:36 am »
To kind of piggy back off of the Video File Format thread, I took my entire collection of LinuxMCE 8.10 ripped .dvd's (600+ movies and videos weighing in at 6.5Tb) and ran them through handbrake giving me a SUBSTANTIAL space savings (600+ movies and videos weighing in at 650Gb). 

I replaced my LMCE 8.10 server with a shiny new LMCE 10.04 server and built the rest of the network behind it.  I then copied my handbraked .m4v files to the appropriate /home/public/data/videos/$DriveID folder and waited.  Nothing ever populated on any of my orbiters.

If I go into the web admin / files and multimedia / media files sync, browse down the folder structure, I can see all of the files .m4v waiting to be added to the database.  If I manually add one with TMDB attributes, it does show up in the orbiter for all to play, but the corresponding .id3 file is not created.

I renamed one of the handbraked .m4v to .mp4 (because they are essentially the same container) on the core and BAM, it showed up in the web admin as added, and it was displayed generically on the first orbiter I checked.  Adding the TMDB attributes creates the corresponding .id3 file.

Renaming the files on the core from .m4v to .mp4 is an easy fix.

Hope this helps someone.

Joseph

6
Users / Re: Want to find a Core Server? What do you think of this?
« on: March 09, 2012, 09:29:30 am »
The base processor and memory are comparable to what I am currently running on my core.  To set it up as a core, you would need a second NIC at a minimum and quite probably a base line nVidia graphics card..  I haven't tried to build a core with a video card other than an nVidia so I don't know how far through the setup you would get.

So, depending on the expansion capabilities of the box (I tried a Dell chat but was disconnected), and what your resulting installation is suppose to look like, it might be a good starter core.

Joseph Hume
F1 for HELP

7
Users / Re: can no longer see media on freenas server
« on: March 01, 2012, 05:45:13 pm »
After the pluto-media init, did MCE find the device? and the shares?

8
Users / Re: Pandora - needs newer browser
« on: February 23, 2012, 03:07:02 am »
Sorry to resurrect such an old topic, but I recently updated three media directors from Firefox 7.0 to 10.0.2 and installed new on an additional media director.

There was an error with the extraction command.  It should read
# tar -jxvf firefox-10.0.2.tar.bz2 -C ./87/usr/lib
-- NOTE: ./xx/ is your media director number as seen from the Core at /usr/pluto/diskless

On the three existing media directors, I did not have to break and recreate the symlink ../xx/usr/bin/firefox -> ../lib/firefox/firefox.  It magically found and used the updated software.

On the new media director I did have to break and recreate the symlink using the same commands from above.

Standard disclaimers are still in effect.

Joseph Hume
F1 for HELP

9
Users / Re: Pandora - needs newer browser
« on: October 10, 2011, 05:21:16 am »
I upgraded the Firefox web browser on my Family Room media director and my daughter has been on it most all of this last week.  Playing youtube videos / facebook / myspace all seem to work as anticipated.  As near as I can tell, everything else on the media director works as it should.

Standard disclaimers apply...

Joseph Hume
F1 for HELP

10
Users / Re: Pandora - needs newer browser
« on: October 01, 2011, 08:58:22 pm »
I did upgrade Firefox about a week ago on the orbiter in my office using the directions previously supplied.  So far I have not found any issue with it.

I will upgrade my daughters media director and post my results.

Joseph Hume
F1 for HELP

11
Users / Re: Video Database Borked
« on: October 01, 2011, 10:29:00 am »
It looks like you might have added the root drive in the core and it is recursively detecting your movies via the /home/public => /mnt/device/xx mount point(s).  I had that happen to me once a few installs ago and I fixed it by removing the (Core Root) sda drive through the web admin.

Standard disclaimers apply.

Joseph Hume
F1 for HELP

12
Users / Re: Pandora - needs newer browser
« on: September 29, 2011, 07:53:16 am »
<snip> and keep firefox as it is. <snip>

Posde,

What could happen / break dramatically by upgrading Firefox?  When I was in looking at my system, I did see that it was symlinked around to the hilt so I hope my FF upgrade instructions are not detrimental...

Joseph Hume
F1 for HELP

13
Users / Re: Pandora - needs newer browser
« on: September 29, 2011, 07:48:17 am »
Being a command line junkie I recently upgraded the installed Firefox 3.x to 7.x on one of my media directors by going the following route

- Download the firefox-7.0.tar.gz on my core and staged the file at /usr/pluto/diskless
- Using the following command I extracted directly to a media director
# tar -C ./49/usr/lib -jxvf firefox-7.0.tar.bz2
-- NOTE: Your diskless image numbers will probably be different!!!
- Break existing  break existing firefox -> ../lib/firefox/firefox-3.0 symlink in ./49/usr/bin folder
# rm ./49/usr/bin/firefox
- Change to MD bin folder and create symlink pointing at new firefox launcher
# cd ./49/usr/bin
# ln -s ../lib/firefox/firefox firefox
- Verify anticipated operation
-- NOTE: Firefox will now go and hold full screen, and AdBlock will install and remember from session to session.  I don't know what is going to happen when the next rapid-fire FF update is released, but it should be fun to watch!

This is probably the most painful way to work, but from here it is easy to deploy to all media directors by simply modifying the ./49

I hope this helps someone.  Standard disclaimers apply.  Please learn and understand what the above commands actually do before attempting on your system.

Joseph Hume
F1 for HELP

10/01/2011 - Edited reflecting changing into ./xx/usr/bin to create symlink.  When attempting to create from /usr/pluto/diskless it didn't link as anticipated (probably due to my increasingly fat fingers)

14
Users / Re: flash player issue
« on: September 07, 2011, 08:41:49 am »
One idea that just floated to the top of my head as I was reading my posted reply, with multiple media directors why couldn't you symlink from diskless/##/.. back to a 'master' file so that updating one file would update all media directors simultaneously.

# ln -s /usr/lib/adobe-flashplugin/libflashplayer.so /usr/pluto/diskless/##/usr/lib/adobe-flashplugin/libflashplayer.so

Joseph Hume
F1 for HELP

Follow on: After issuing the above command and logging into a media director, it doesn't look like it will work because it appears to be a recursive(?) link.

root@moon44:/usr/lib/adobe-flashplugin# ls -l
lrwxrwxrwx 1 root root       44 Sep  7 00:00 libflashplayer.so -> /usr/lib/adobe-flashplugin/libflashplayer.so             

Trying to make it easy on myself...

Joseph Hume
F1 for HELP                                                         

15
Users / Re: flash player issue
« on: September 07, 2011, 08:31:50 am »
From memory I downloaded the .tar.gz for Linux from Adobe.com, extracted it, and moved it to /usr/pluto/diskless/##/usr/lib/adobe-flashplugin/libflashplayer.so because

dcerouter_1019065:~# ls -l /usr/pluto/diskless/##/usr/lib/mozilla/plugins/
lrwxrwxrwx 1 root root     37 2011-07-04 23:21 flashplugin-alternative.so -> /etc/alternatives/mozilla-flashplugin

dcerouter_1019065:~# ls -l /usr/pluto/diskless/##/etc/alternatives/mozilla-flashplugin
lrwxrwxrwx 1 root root 44 2011-07-04 23:21 /usr/pluto/diskless/83/etc/alternatives/mozilla-flashplugin -> /usr/lib/adobe-flashplugin/libflashplayer.so

dcerouter_1019065:~# ls -l /usr/pluto/diskless/##/usr/lib/adobe-flashplugin/
-rw-r--r-- 1 root root 12110428 2011-04-13 11:30 libflashplayer.so

With multiple media directors, I would perform the work on the DCERouter and change the /##/ to your actual media director numbers.

Standard disclaimers apply / YMMV

Joseph Hume
F1 for HELP

Pages: [1] 2 3