LinuxMCE Forums

General => Installation issues => Topic started by: ssjjpp on April 11, 2010, 12:31:46 pm

Title: RS-232 devices not working
Post by: ssjjpp on April 11, 2010, 12:31:46 pm
Hi Everyone...

I have just built a LMCE box and finally got an install done where most things seem to be working. Im running 8.10 beta 2.
I have a Sharp Aquos LC52D77X LCD TV and a Denon AVR-4306 receiver. I chose these and LMCE due to the RS232 support. I cannot get LMCE to recognise either device, which surprises me given other models from these manufacturers work straight off.

I really have no idea how to start approaching resolving this. Im using USB-RS232 cables. When I connect the devices LMCE displays the 'Running xxxx script' in the top left corner, but it just cycles through every script without success. I have also added them manually, using similar selections, but no commands can be sent to the devices.

If anyone can assist I will be very grateful, this functionality is the main differentiator for me in creating a properly integrated media centre.
Title: Re: RS-232 devices not working
Post by: wombiroller on April 12, 2010, 05:59:32 am
I don't have the same model, but the Denon 2307 has been plug and play for me.

I am surprised though that the Ethernet control doesn't work for the 4306. According to the Wiki is was used at LinuxTag 2008:

Maybe something has changed since the 0710? Assuming someone else out there has it though if this is the case.

Title: Re: RS-232 devices not working
Post by: tkmedia on April 12, 2010, 09:15:09 am
Make sure you have the correct pin-outs on your cables, the sharp requires a null modem or crossover cable.



Title: Re: RS-232 devices not working
Post by: bulek on April 12, 2010, 10:32:18 am
Try first to communicate with some terminal programs - directly to rs232 device. When this is working, switch to LMCE.
In my case I found out that cable was the problem...



Title: Re: RS-232 devices not working
Post by: ssjjpp on April 12, 2010, 11:28:16 am
Thanks for your replies.

Im using USB-Serial cables. Tonight I tried to use terminal applications, both on a Windows Laptop and Minicom on the LMCE box itself, neither of which seemed to produce any response on the Denon. I believe I have followed instructions correctly, including configuring the port. Denon website says the AMP is particular about how it receives commands from terminal applications, so I did as instructed and sent it via a 'paste clipboard to host', and also sent a txt file containing the command. Was trying PWSTANDBY as per this thread...

I also downloaded the RS232 doc from Denon. This AVR has Ethernet port which is capable of carrying the serial commands. I discovered it had to be connected via crossover if direct to pc, so tried that but aside from obtaining an IP etc from the LMCE box it wouldnt talk, and didnt run the detection scripts that I at least get when I use the USB>Serial cable.

Not sure if any of the above info helps...?

Title: Re: RS-232 devices not working
Post by: Techstyle on April 12, 2010, 07:30:58 pm
I have my Sharp screen attached via a USB--> RS232 adapter and then a Null modem or cross over serial cable RS232 to RS232 so using a USB port should still work.  I would think about checking if you USB-Serial cable is straight through and if it is try an adapter like this one (

My Sharp TV was Plug and Play by the way
Title: Re: RS-232 devices not working
Post by: ssjjpp on April 15, 2010, 12:08:55 pm
Thanks Techstyle and others....

I bought a Null Modem cable tonight and immediately this resolved the issue with detection of the TV. It recognises it as the LCxxD7U from memory, which is almost identical to my Australian model.

The unfortunate thing is it doesnt seem to be working when issued commands. I went into Webadmin and sent a few commands directly. Most produce no response, volume up and down bring the volume bar up but do not change the volume even when I enter a value of say 5 or 10 for the command to repeat.

I see there are log file options - would this be the next logical step in troubleshooting or should I manually tweak the commands? I was surprised to see the template for the Sharp doesnt include commands for PWR on or off...
Title: Re: RS-232 devices not working
Post by: Techstyle on April 15, 2010, 05:56:41 pm
If you are going to 'tweak' the commands create a new template otherwise you will change the template for everybody else if you submit it.  You could check your manual and the manual of the LCxxD7U to see if the commands are actually different.