LinuxMCE Forums

General => Users => Topic started by: pw44 on March 11, 2010, 07:09:12 pm

Title: AV connections not being controlled
Post by: pw44 on March 11, 2010, 07:09:12 pm
Hia,
after configuring my AV equipment, i notice that when i open a (UI -> Media) media like video or audio, the amplifier turns on, selects the correct input and it's ok, but when i select KX-390 (UI -> Media), the correct input is not selectd at the amplifier. Testing the AV Propertiesfor KX-390 and DSP-A1 at webadmin -> A/V Equipment, all the IR codes works well, including the input selector for the amplifier.
The other thing that i'm not being able to do is to power off the amplifier when stopping media. When orbiter starts, it turns the amplifier on. When media starts and the amplifier is off, IR code for turnning it on are sent and works. But how to turn it off withoput the need to stay up and doing it manually?
Does anyone experienced something like this?
Attached are the snapshots for connection and devices.
TIA,
Paulo
Title: Re: Connections not being controlled
Post by: jimbodude on March 11, 2010, 07:13:59 pm
I'm assuming you've reloaded the router since you added that pipe, right?

There is an open issue where the OSD resets the inputs.  Make sure to clear the On-screen menu.  Watch DCERouter.log (tail -f /var/log/pluto/DCERouter.log) and see if the proper commands are being sent to the AV devices.
Title: Re: Connections not being controlled
Post by: pw44 on March 11, 2010, 07:23:35 pm
Not only reloaded the router but also regen the orbiter.
Sorry, but i did not understand about making sure to clear the on-screen menu....
Title: Re: Connections not being controlled
Post by: jimbodude on March 11, 2010, 07:39:06 pm
http://svn.linuxmce.org/trac.cgi/ticket/549

If you don't see the menus on the screen, then this is not applicable to your situation.

Try watching the message log when you activate that device and see what it says.
Title: Re: Connections not being controlled
Post by: pw44 on March 12, 2010, 12:33:53 pm
Sorry,  i did a mistake. It's not controlling all. The only thing being controlled is the turn on the amplifier. As i left it on the LD input, it always was setted with the right input mode.
But after testing again, for several situations, i discovered that the inputs are not controlled (switched) at  all.
The codes are correct, because testing the A/V properties for the devices works well.
Would it be the case for opennig a ticket or is this a well known problem?
Regards.
Title: Re: AV connections not being controlled
Post by: jimbodude on March 16, 2010, 03:07:18 pm
It is neither, yet...  Look at the DCERouter.log and see what is going on.

I use the input switching all the time, so I know it works.  You may want to try to increase or decease the delays for sending commands in the device template.
Title: Re: AV connections not being controlled
Post by: pw44 on March 16, 2010, 10:48:50 pm
Delay problem. was set to 5000 ms, and i increased it to 7000. Worked, but with one pitfall:
It only works when after i regen the orbiter and reload the router.
Being the amp off, on UI, selecting media -> audio/video, the amp is turned on, but the input is NOT changed.
Being the amp off, being the orbiter regeneratd and orbiter reloaded, when it starts again, the amp is turned on AND the input changed.
Strange behavior.... and also no turn off "button"  on UI -> media -> floorplan.
Any hint?

Title: Re: AV connections not being controlled
Post by: jimbodude on March 17, 2010, 04:35:53 pm
I don't understand your problem...  Are you saying that if the amp is off and the router has recently been reloaded, then the amp turns on, but if the amp is off and the router has not been recently reloaded that the amp remains off?

How are you currently turning the amp off?  It sounds like you are confusing the LinuxMCE device's state.  You must NOT control power from your normal remotes - you must use LinixMCE's control system.  The same is true of the input selection if you don't have discrete input commands via IR or RS232.

The "off" button for your AV gear is called "Display Off".  It's under the power menu.  Use this to power everything off, otherwise the LinuxMCE device state will not match the state of the physical device.  This means LinuxMCE will think the device is "on" when it's actually "off", since "on" would be the last power command that was sent by LinuxMCE.
Title: Re: AV connections not being controlled
Post by: pw44 on March 17, 2010, 04:56:22 pm
Quote
I don't understand your problem...  Are you saying that if the amp is off and the router has recently been reloaded, then the amp turns on, but if the amp is off and the router has not been recently reloaded that the amp remains off?

No, what i'm saying is that after reload and regen, the amp turns on AND the correct input is selected.
That's ok.
If i change the input (.i.e from Laserdisc to Tuner), turn the amp off and play an audio or video file, the amp turns on but the input does not change to Laserdisc.

Quote
How are you currently turning the amp off?  It sounds like you are confusing the LinuxMCE device's state.  You must NOT control power from your normal remotes - you must use LinixMCE's control system.  The same is true of the input selection if you don't have discrete input commands via IR or RS232.

The amp is controlled only via IR (does not have RS-232 connection). So, it doesn't matter if it's on or off, the IR always sends the "turn on" code.

Quote
The "off" button for your AV gear is called "Display Off".  It's under the power menu.  Use this to power everything off, otherwise the LinuxMCE device state will not match the state of the physical device.  This means LinuxMCE will think the device is "on" when it's actually "off", since "on" would be the last power command that was sent by LinuxMCE

Ok, got it. But i was thinking that also turnning the play/view OFF would do it, or at least at floorplan.
It means that if i leave the TV on, with the screen saver running and no media paying, the amp should stay ON. Is this behavior right?

The code beginning with 0000 006f 0022 switches the input to Laserdisc and the code beginnig with 0000 006c 0022 turns on the amp.

So i think that when the orbiter is regenerated or the router is reloaded, the turn on and switch input codes are sent, but after that, when i start a media play/view, only the turn on code is sent.

Code: [Select]

05      03/16/10 18:41:45.898           #### Pre-Process Queue = 2 <0xb601ab90>                              
05      03/16/10 18:41:45.915           Infrared Code not found for Command 192. Will not be processed by IRBase. <0xb601ab90>                                                                                              
05      03/16/10 18:41:45.915           #### Pre-Process Queue = 3 <0xb601ab90>                              
05      03/16/10 18:41:45.915           #### Pre-Process Queue = 4 <0xb601ab90>                              
05      03/16/10 18:41:45.916           #### Pre-Process Queue = 5 <0xb601ab90>                              
05      03/16/10 18:41:45.931           _QueueProc Pre - 192 : 0 <0xb5819b90>                                
05      03/16/10 18:41:45.932           GSD-Sleep Pre 192 : 0 <0xb5819b90>                                    
05      03/16/10 18:41:53.558           #### Pre-Process Queue = 5 <0xb601ab90>                              
05      03/16/10 18:41:53.559           #### Pre-Process Queue = 6 <0xb601ab90>                              
05      03/16/10 18:41:54.975           GSD-Sleep Post 192 : 8500 <0xb5819b90>                                
05      03/16/10 18:41:54.975           _QueueProc Post - 192 : 8500 <0xb5819b90>                            
05      03/16/10 18:41:54.975           _QueueProc Pre - 91 : 0 <0xb5819b90>                                  
05      03/16/10 18:41:54.975           GSD-DispatchMessage - ignoring 91 because is useless. <0xb5819b90>    
05      03/16/10 18:41:54.975           _QueueProc Post - 91 : 2000 <0xb5819b90>                              
05      03/16/10 18:41:54.975           _QueueProc Pre - 192 : 0 <0xb5819b90>                                
05      03/16/10 18:41:54.975           GSD-Sleep Pre 192 : 0 <0xb5819b90>                                    
05      03/16/10 18:41:54.975           Could not find Infrared Code for Command 192. <0xb5819b90>            
05      03/16/10 18:41:55.727           #### Pre-Process Queue = 5 <0xb601ab90>                              
05      03/16/10 18:41:55.727           Infrared Code not found for Command 91. Will not be processed by IRBase. <0xb601ab90>                                                                                              
05      03/16/10 18:41:55.727           #### Pre-Process Queue = 6 <0xb601ab90>                              
05      03/16/10 18:41:57.526           #### Pre-Process Queue = 7 <0xb601ab90>                              
05      03/16/10 18:41:57.527           Infrared Code not found for Command 91. Will not be processed by IRBase. <0xb601ab90>                                                                                              
05      03/16/10 18:41:57.527           #### Pre-Process Queue = 8 <0xb601ab90>                              
05      03/16/10 18:42:01.975           GSD-Sleep Post 192 : 7000 <0xb5819b90>                                
05      03/16/10 18:42:01.975           _QueueProc Post - 192 : 7000 <0xb5819b90>                            
05      03/16/10 18:42:01.975           _QueueProc Pre - 192 : 0 <0xb5819b90>                                
05      03/16/10 18:42:01.975           GSD-DispatchMessage - ignoring 192 because is useless. <0xb5819b90>  
05      03/16/10 18:42:01.975           _QueueProc Post - 192 : 8500 <0xb5819b90>                            
05      03/16/10 18:42:01.975           _QueueProc Pre - 160 : 0 <0xb5819b90>                                
05      03/16/10 18:42:01.975           GSD-Sleep Pre 160 : 0 <0xb5819b90>                                    
05      03/16/10 18:42:04.545           GSD-Sleep Post 160 : 2000 <0xb5819b90>                                
05      03/16/10 18:42:04.545           _QueueProc Post - 160 : 2000 <0xb5819b90>                            
05      03/16/10 18:42:04.545           _QueueProc Pre - 192 : 0 <0xb5819b90>                                
05      03/16/10 18:42:04.545           GSD-Sleep Pre 192 : 0 <0xb5819b90>                                    
05      03/16/10 18:42:13.593           GSD-Sleep Post 192 : 8500 <0xb5819b90>                                
05      03/16/10 18:42:13.599           _QueueProc Post - 192 : 8500 <0xb5819b90>                            
05      03/16/10 18:42:13.600           _QueueProc Pre - 177 : 0 <0xb5819b90>                                
05      03/16/10 18:42:13.600           GSD-Sleep Pre 177 : 0 <0xb5819b90>                                    
05      03/16/10 18:42:13.618           #### Pre-Process Queue = 5 <0xb601ab90>                              
05      03/16/10 18:42:13.619           Infrared Code not found for Command 91. Will not be processed by IRBase. <0xb601ab90>                                                                                              
05      03/16/10 18:42:13.619           #### Pre-Process Queue = 6 <0xb601ab90>                              
05      03/16/10 18:42:13.640           Infrared Code not found for Command 193. Will not be processed by IRBase. <0xb601ab90>                                                                                              
05      03/16/10 18:42:13.640           #### Pre-Process Queue = 7 <0xb601ab90>                              
05      03/16/10 18:42:13.642           #### Pre-Process Queue = 8 <0xb601ab90>                              
05      03/16/10 18:42:13.642           Infrared Code not found for Command 91. Will not be processed by IRBase. <0xb601ab90>                                                                                              
05      03/16/10 18:42:13.642           #### Pre-Process Queue = 9 <0xb601ab90>                              
05      03/16/10 18:42:16.198           GSD-Sleep Post 177 : 2000 <0xb5819b90>                                
05      03/16/10 18:42:16.198           _QueueProc Post - 177 : 2000 <0xb5819b90>                            
05      03/16/10 18:42:16.198           _QueueProc Pre - 192 : 0 <0xb5819b90>                                
05      03/16/10 18:42:16.198           GSD-Sleep Pre 192 : 0 <0xb5819b90>                                    
05      03/16/10 18:42:24.952           #### Pre-Process Queue = 9 <0xb601ab90>                              
05      03/16/10 18:42:24.963           Infrared Code not found for Command 91. Will not be processed by IRBase. <0xb601ab90>                                                                                              
05      03/16/10 18:42:24.963           #### Pre-Process Queue = 10 <0xb601ab90>                              
05      03/16/10 18:42:25.245           GSD-Sleep Post 192 : 8500 <0xb5819b90>                                
05      03/16/10 18:42:25.246           _QueueProc Post - 192 : 8500 <0xb5819b90>                            
05      03/16/10 18:42:25.246           _QueueProc Pre - 91 : 0 <0xb5819b90>                                  
05      03/16/10 18:42:25.246           GSD-DispatchMessage - ignoring 91 because is useless. <0xb5819b90>    
05      03/16/10 18:42:25.246           _QueueProc Post - 91 : 2000 <0xb5819b90>                              
05      03/16/10 18:42:25.246           _QueueProc Pre - 192 : 0 <0xb5819b90>                                
05      03/16/10 18:42:25.246           GSD-Sleep Pre 192 : 0 <0xb5819b90>                                    
01      03/16/10 18:42:25.673           UsbUirt transmit failed sending 0000 006c 0022 0002 0156 00aa 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0040 0016 0040 0016 0015 0016 05e9 0156 0055 0016 0e40! <0xb5819b90>                                                                                    
05      03/16/10 18:42:34.175           GSD-Sleep Post 192 : 8500 <0xb5819b90>                                
05      03/16/10 18:42:34.175           _QueueProc Post - 192 : 8500 <0xb5819b90>                            
05      03/16/10 18:42:34.175           _QueueProc Pre - 91 : 0 <0xb5819b90>                                  
05      03/16/10 18:42:34.175           GSD-DispatchMessage - ignoring 91 because is useless. <0xb5819b90>    
05      03/16/10 18:42:34.175           _QueueProc Post - 91 : 2000 <0xb5819b90>                              
05      03/16/10 18:42:34.175           _QueueProc Pre - 192 : 0 <0xb5819b90>                                
05      03/16/10 18:42:34.175           GSD-Sleep Pre 192 : 0 <0xb5819b90>                                    
01      03/16/10 18:42:34.534           UsbUirt transmit failed sending 0000 006c 0022 0002 0156 00aa 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0040 0016 0040 0016 0015 0016 05e9 0156 0055 0016 0e40! <0xb5819b90>                                                                                    
05      03/16/10 18:42:43.037           GSD-Sleep Post 192 : 8500 <0xb5819b90>                                
05      03/16/10 18:42:43.038           _QueueProc Post - 192 : 8500 <0xb5819b90>                            
05      03/16/10 18:42:43.038           _QueueProc Pre - 91 : 0 <0xb5819b90>                                  
05      03/16/10 18:42:43.038           GSD-DispatchMessage - ignoring 91 because is useless. <0xb5819b90>    
05      03/16/10 18:42:43.038           _QueueProc Post - 91 : 2000 <0xb5819b90>                              
05      03/16/10 18:42:43.038           _QueueProc Pre - 193 : 0 <0xb5819b90>                                
05      03/16/10 18:42:43.038           GSD-Sleep Pre 193 : 0 <0xb5819b90>                                    
05      03/16/10 18:42:43.038           Could not find Infrared Code for Command 193. <0xb5819b90>            
05      03/16/10 18:42:50.037           GSD-Sleep Post 193 : 7000 <0xb5819b90>                                
05      03/16/10 18:42:50.037           _QueueProc Post - 193 : 7000 <0xb5819b90>                            
05      03/16/10 18:42:50.037           _QueueProc Pre - 192 : 0 <0xb5819b90>                                
05      03/16/10 18:42:50.037           GSD-DispatchMessage - ignoring 192 because is useless. <0xb5819b90>  
05      03/16/10 18:42:50.038           _QueueProc Post - 192 : 8500 <0xb5819b90>                            
05      03/16/10 18:42:50.038           _QueueProc Pre - 91 : 0 <0xb5819b90>                                  
05      03/16/10 18:42:50.038           GSD-DispatchMessage - ignoring 91 because is useless. <0xb5819b90>    
05      03/16/10 18:42:50.038           _QueueProc Post - 91 : 2000 <0xb5819b90>                              
05      03/16/10 18:42:50.038           _QueueProc Pre - 192 : 0 <0xb5819b90>                                
05      03/16/10 18:42:50.038           GSD-Sleep Pre 192 : 0 <0xb5819b90>                                    
01      03/16/10 18:42:50.394           UsbUirt transmit failed sending 0000 006c 0022 0002 0156 00aa 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0040 0016 0040 0016 0015 0016 05e9 0156 0055 0016 0e40! <0xb5819b90>                                                                                    
05      03/16/10 18:42:58.894           GSD-Sleep Post 192 : 8500 <0xb5819b90>                                
05      03/16/10 18:42:58.901           _QueueProc Post - 192 : 8500 <0xb5819b90>                            
05      03/16/10 18:42:58.901           _QueueProc Pre - 91 : 0 <0xb5819b90>                                  
05      03/16/10 18:42:58.901           GSD-DispatchMessage - ignoring 91 because is useless. <0xb5819b90>    
05      03/16/10 18:42:58.901           _QueueProc Post - 91 : 2000 <0xb5819b90>                              
05      03/16/10 18:43:03.907           #### Pre-Process Queue = 1 <0xb601ab90>                              
05      03/16/10 18:43:03.910           _QueueProc Pre - 89 : 0 <0xb5819b90>                                  
05      03/16/10 18:43:03.910           GSD-Sleep Pre 89 : 0 <0xb5819b90>                                    
01      03/16/10 18:43:04.286           UsbUirt transmit failed sending 0000 006f 0022 0002 0150 00ab 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0040 0016 0015 0016 0040 0016 0040 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0040 0016 0015 0016 0015 0016 0040 0016 0040 0016 0040 0016 0015 0016 05d4 0150 0055 0016 0e09! <0xb5819b90>                                                                                    
05      03/16/10 18:43:04.286           GSD-Sleep Post 89 : 0 <0xb5819b90>
05      03/16/10 18:43:04.286           _QueueProc Post - 89 : 0 <0xb5819b90>
05      03/16/10 18:43:05.614           #### Pre-Process Queue = 1 <0xb601ab90>
05      03/16/10 18:43:05.638           _QueueProc Pre - 90 : 0 <0xb5819b90>
05      03/16/10 18:43:05.638           GSD-Sleep Pre 90 : 0 <0xb5819b90>
01      03/16/10 18:43:06.009           UsbUirt transmit failed sending 0000 006f 0022 0002 0150 00ab 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0015 0016 0015 0016 0015 0016 0040 0016 0040 0016 0015 0016 0015 0016 0015 0016 0040 0016 0040 0016 0040 0016 0015 0016 05d4 0150 0055 0016 0e09! <0xb5819b90>
05      03/16/10 18:43:06.009           GSD-Sleep Post 90 : 0 <0xb5819b90>
05      03/16/10 18:43:06.010           _QueueProc Post - 90 : 0 <0xb5819b90>
01      03/16/10 19:04:43.670           UsbUirt transmit failed sending 0000 006c 0022 0002 0156 00aa 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0040 0016 0040 0016 0015 0016 05e9 0156 0055 0016 0e40! <0xb601ab90>
01      03/16/10 19:04:49.110           UsbUirt transmit failed sending 0000 006c 0022 0002 0156 00aa 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0040 0016 0040 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0040 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0015 0016 0040 0016 0040 0016 0015 0016 05e9 0156 0055 0016 0e40! <0xb601ab90>
Title: Re: AV connections not being controlled
Post by: jimbodude on March 17, 2010, 05:32:37 pm
No, what i'm saying is that after reload and regen, the amp turns on AND the correct input is selected.
That's ok.
If i change the input (.i.e from Lasedisc to Tuner), turn the amp off and play an audio or video file, the amp turns on but the input does not change to Laserdisc.
It sounds like you need to increase the "Number of miliseconds to wait for the device to warm up after sending a code to turn the power on" setting on the device template.

If that doesn't do it, please detail exactly what steps you are taking to run into this issue.  I want to know what buttons you are pushing and where they are for each step.  Something like this:
Code: [Select]
1) reload orbiter from web admin
2) activate "Live TV Digital Cable" scenario from n810 orbiter - this causes TV to turn on and input is switched to AV3
3) Turn off TV using "Display Off" on on-screen orbiter
4) ... etc


The amp is controlled only via IR (does not have RS-232 connection). So, it doesn't matter if it's on or off, the IR always sends the "turn on" code.

Are you saying that you have separate and different On and Off IR codes?  The bottom line is this - if LinuxMCE thinks a device is in the proper state (power and input selection) then it will not send any IR commands.  If you don't have separate On and Off codes because your A/V gear doesn't support it, then On and Off look the same to the equipment, so the state will be confused.  The same is true for input selection if you don't have discrete input codes.  This is why you should avoid using your IR remote controls to control your AV devices.

Ok, got it. But i was thinking that also turnning the play/view OFF would do it, or at least at floorplan.
It means that if i leave the TV on, with the screen saver running and no media paying, the amp should stay ON. Is this behavior right?
LinuxMCE supports either behavior.

The default is to leave A/V gear on (displaying the on-screen menu and screen saver) for a specified amount of idle time.  If that time is exceeded, then everything is automatically powered down.  You can configure the time on the "Orbiters" page in the web admin (Wizard --> Devices --> Orbiters, "Seconds before power off" setting).  This setting has no effect for Orbiters other than "on-screen" orbiters, by the way.

The other mode will power everything down as soon as playback has ended.  Activate this by un-checking the "Leave Monitor on for OSD" setting on the Orbiter's device page (Wizard --> Devices --> Orbiters, Advanced, "Leave Monitor on for OSD" setting).

You will have to reload the router and possibly regen the orbiter for these changes to take effect.
Title: Re: AV connections not being controlled
Post by: pw44 on March 17, 2010, 09:11:50 pm
Quote
If that doesn't do it, please detail exactly what steps you are taking to run into this issue.  I want to know what buttons you are pushing and where they are for each step.  Something like this:
Code:

1) reload orbiter from web admin -> amp turns on AND input selector switched to laserdisc (so, it's not the delay after power on issue).
2) activate Video scenario from hybrid orbiter - TV = Monitor, so it's turned on.
3) Turn media off - amp remains on.
4) i stay up, go to amp, change input and turn amp manually off (no IR remote used).
4) activate Video scenario from hybrid orbiter - amp remains off
5) select a file to play - amp remains off
6) hit play on OSD menu - amp turns on, but does not changes input.


Quote
Are you saying that you have separate and different On and Off IR codes?  The bottom line is this - if LinuxMCE thinks a device is in the proper state (power and input selection) then it will not send any IR commands.  If you don't have separate On and Off codes because your A/V gear doesn't support it, then On and Off look the same to the equipment, so the state will be confused.  The same is true for input selection if you don't have discrete input codes.  This is why you should avoid using your IR remote controls to control your AV devices.

It seams so. The physical device (amp) only have one power button, but it's remote have two (system power on and standby) and hitting system power turns it on, hitting it again, does nothing, and hitting standby turns it off, so, it seams to be two different codes, one for power on and other for power off. and testing this under AV Properties (webadmin - AV equipement) it works. And for all these tests, the original remote is not being used, only the IR USB-UIRT interface from linuxmce.
All the codes used where picked at http://www.remotecentral.com/cgi-bin/codes/yamaha/dsp-a1/.

Quote
Ok, got it. But i was thinking that also turnning the play/view OFF would do it, or at least at floorplan.
It means that if i leave the TV on, with the screen saver running and no media paying, the amp should stay ON. Is this behavior right?
LinuxMCE supports either behavior.

The default is to leave A/V gear on (displaying the on-screen menu and screen saver) for a specified amount of idle time.  If that time is exceeded, then everything is automatically powered down.  You can configure the time on the "Orbiters" page in the web admin (Wizard --> Devices --> Orbiters, "Seconds before power off" setting).  This setting has no effect for Orbiters other than "on-screen" orbiters, by the way.

The other mode will power everything down as soon as playback has ended.  Activate this by un-checking the "Leave Monitor on for OSD" setting on the Orbiter's device page (Wizard --> Devices --> Orbiters, Advanced, "Leave Monitor on for OSD" setting).

You will have to reload the router and possibly regen the orbiter for these changes to take effect.

I will set Seconds before power off to 600 (10 minutes) and test the various combinations you described.

The main issue is why the remote send the power on code and not the input switch code when media scenario is selected and a file (video or audio) is set to play.

Title: Re: AV connections not being controlled
Post by: jimbodude on March 17, 2010, 09:29:10 pm
1) reload orbiter from web admin -> amp turns on AND input selector switched to laserdisc (so, it's not the delay after power on issue).
2) activate Video scenario from hybrid orbiter - TV = Monitor, so it's turned on.
3) Turn media off - amp remains on.
4) i stay up, go to amp, change input and turn amp manually off (no IR remote used).
4) activate Video scenario from hybrid orbiter - amp remains off
5) select a file to play - amp remains off
6) hit play on OSD menu - amp turns on, but does not changes input.

This is not a clear description of what you are doing...  Step 1 is telling me that as soon as you reload the router, the amp turns on... That's just not right.  Step 4 - where does this occur?  Are you using the buttons on the amp, the amp's remote, or some scenario...  I can't tell you what is wrong if you can't tell me what you are doing to make things happen.

For every time you click a mouse button, press a button on the amp, press a button on a remote, or select something on an orbiter make a numbered step that tells me a) what device you're interacting with (IR remote, web admin, on-screen orbiter, etc)  b) what button you pressed  c) what happens  d) what you expected to happen if it did not happen.

It seams so. The physical device (amp) only have one power button, but it's remote have two (system power on and standby) and hitting system power turns it on, hitting it again, does nothing, and hitting standby turns it off

These are discrete power codes.
Title: Re: AV connections not being controlled
Post by: pw44 on March 17, 2010, 09:58:13 pm
step 1) Unfortunately, belive it or not, i stay up, switch the input to tuner, turn the amp off, on OSD click on Quick Reload Router, OSD goes away, messages from router are shown, screens are rebuild, and when OSD shows up again, amp is turned on and input switched to the right one (laserdisc). I am doing theses testson my core/hybrid, because my diskless MD is note ready yest....
The same result when quick regen orbiter and reload router from webadmin.

step 4) everything working, i stay up from my sofa, and turn the amp off (pressing the on/off button). Then i go back to my sofa, and on OSD, select Media -> Video (or Audio) and select the file to play, an OSD menu (play stop move delete) apppears, i select play, and... the amp is turned on but the input is not selected to laserdisc, remaining at the audio source where i left.

You tell me it's wrong... ok, but i really don't know what is to be done.... to fix it...

Yes,  discrete codes.
Title: Re: AV connections not being controlled
Post by: jimbodude on March 17, 2010, 10:43:23 pm
Ok... I'm not sure why the amp powers on when you reload the router - we'll come back to that.

The reason the inputs aren't switching sounds like it is exactly what I stated before.  LinuxMCE thinks the amp is still on the correct input, so it's not changing it.

Try this procedure and tell me what happens with the amp at each step.  Don't touch the amp after step 1 - use only the orbiter.
1) Shut the amp off and reload the DCE router
2) If the amp is on, then select "Display Off" from the Power menu (might be under Advanced, I forget)
3) Select the Video or Audio scenario, select a piece of media, and play it
4) Stop the media, returning to the OSD and screen saver
5) Repeat 2 through 4
6) Activate the scenario which you expect to use the other input on the amp
7) Stop the media
8) Repeat 2 through 4

If the amp has a tuner, we should edit the device template to reflect that.  This way LinuxMCE will create the proper scenarios to use the tuner automatically.  We'll come back to that also.
Title: Re: AV connections not being controlled
Post by: pw44 on March 19, 2010, 04:25:17 pm
Thx...
as you suggested:
1) Shut the amp off and reload the DCE router
-- after the DCE router reloaded, amp was turned on and correct input selected by USBUIRT.
2) If the amp is on, then select "Display Off" from the Power menu (might be under Advanced, I forget)
-- it's under Advanced -> POWER - Display Off = amp off. When the OSD Menu is called again, amp is turned on (it seams that it also calls Display ON)
3) Select the Video or Audio scenario, select a piece of media, and play it
-- ok... as the amp is on (because of display on) it plays. 
4) Stop the media, returning to the OSD and screen saver
-- media stop, OSD and screen saver, amp remains on
5) Repeat 2 through 4
-- done 4 times, same results.
6) Activate the scenario which you expect to use the other input on the amp
-- scenario selected - my Cassete tape. Nothing happens. I guess that the scenario is created, but there is no remote or menu... (webamin -> Av Equipment -> KX-390 -> AV Properties -> IR Codes test - all works)
7) Stop the media
-- media stop, amp remains on.
Title: Re: AV connections not being controlled
Post by: jimbodude on March 19, 2010, 05:59:18 pm
I'm assuming the KX-390 is your cassette deck.  Did you make that template?
Title: Re: AV connections not being controlled
Post by: pw44 on March 19, 2010, 06:52:10 pm
Yes, used the manufacturer Yamaha #318, Device Cat. Cassete Decks < AV #104, Apply Filter, Your model is not on the list -> Add device template, answered the questions, and cut and past the hex codes for it.
on the OSD, there is the menu entry KX-390, and Audio, Video, TV, Hulu Player, Games, Floorplan.
But when i select KX-390, nothing happens, no menu, no amp input swicth, nothing.. is a dead entry..
Did the same for my tuner, but Device Cat. Radio < AV # 134, but for this one, not even the entry was created at scenarios.
There is something missing, but i'm not figuring out what.....
Title: Re: AV connections not being controlled
Post by: jimbodude on March 19, 2010, 09:59:35 pm
Remove the devices, reload the router, and go through the setup wizard.  This will clear out all the audio pipes, get everything configured perfectly, reload the router properly, and regenerate all the orbiter screens correctly.  If you still have problems after that... then we'll have to dig a bit.
Title: Re: AV connections not being controlled
Post by: pw44 on March 22, 2010, 10:00:27 pm
I will do it this week, after a full backup with partimage (just in case something goes wrong :) ) and will turn back with the results.
Thx
Title: Re: AV connections not being controlled
Post by: pw44 on March 24, 2010, 01:54:55 am
Hi Jimbodude,
i did as suggested, and did not work.
First i went trough the Setup Wizard - Media.
Selected my KX-390 as Cassete Deck and my TX-950 as Amp/..../Tuner < AV
For my KX-390 nothing was created and for the TX-950 an OTARradio was created and clicking on it, input was changed to tuner on amp. Ok, but no way to tune up or down.
Deleted all the AV and went trough Setup Wizard again, selecting my TX-950 from the tuner entry (tuner / Yamaha / TX-950 - the database entries were preserved)
Now, instead of having an entry for my KX-390, the entry for it is behing the Hulu Player entry.
And calling hulu player now fails. No entry for my TX-950.
There is another weird problem. After deleting the AV Equipment and running Setup Wizard, all the entries in the AV Properties (hex codes) were duplicated and got wrong codes, so volume up and downn, i.e. doesn't work anymore. I have now 2 power on, two power off, two volume up, two volume down, etc..... will have to reenter ALL the hex codes again and delete the duplicate entries.....
Any help is welcome.
TIA,
Paulo
Title: Re: AV connections not being controlled
Post by: jimbodude on March 24, 2010, 02:34:32 pm
Are you sure that your packages are up to date?  You're using 0810, right?  I thought all the IR code issues were pretty much solved...

Your disappearing scenarios may be resulted to an issue I found a while back, but did not document:
http://svn.linuxmce.org/trac.cgi/ticket/664
Title: Re: AV connections not being controlled
Post by: pw44 on March 24, 2010, 03:05:21 pm
I using 0180, with the latest updates and upgrades.
The IR codes were solved, but something screwed the database.
When i created, i.e, the template for my DSP-A1, i selected manufacturer Yamaha, Category Dev Amp,Receiver.... and applying the filter, one Yamaha receiver was displayed. So, i choosed not in list, and created a template for the DSP-A1. Some codes were correct, others not, there was missing functions, and so i created all, with all the correct codes.
When i deleted the devices and went to setup wizard, all the av devices were created. no problem. but checking the AV Properties, all the codes were doubled, and the hex codes were mostly wrong.
The same happended for the tuner and for the tape deck.
Oh Jezz.... why do this happens? A screwed template.... after so much work to define it.... working so fine under AV Properties for the device..... running setup wizard seams to ruined it......  i'm feeling like a jerk...........
Title: Re: AV connections not being controlled
Post by: jimbodude on March 24, 2010, 03:55:21 pm
Remove all the devices with new templates, revert all your changes using sqlCVS, and start from scratch.  Revert changes in the dce and ir repositories.  You should not edit codes that you are using from an existing code set, as that will affect all devices using that code set.  I believe there is a warning dialog about it at some point.

Update sqlCVS dce and ir repositories - each individually - so that you can check in your changes later without conflicts.  Create a new template with a new code set, enter your codes, and create a new device.
Title: Re: AV connections not being controlled
Post by: pw44 on March 24, 2010, 05:20:27 pm
Ok, could you please detail the steps in to do it?
Or could i use myphpadmin, locate all entrie for DSP-A1, TX-950 and KX-390 and remove them?
Regarding sqlCVS, dce and repositories, which are the steps to revert the the changes for AV, without affecting other configurations, like telecom or security (ip camera)?
As i understand, i will need to create a code set for each of the new created devices... is it true?
TIA
Title: Re: AV connections not being controlled
Post by: jimbodude on March 24, 2010, 06:00:25 pm
...Never edit the database directly - do not use phpmyadmin.

Delete the devices by looking them up in the device tree in the web admin and selecting "Delete Device" from the device page.

Revert changes from sqlCVS by selecting Advanced --> sqlCVS --> Diff.  Check off "ir", "dce", and everything under them.  Press Diff at the bottom.  Select all changes.  Press Revert at the bottom.  Repeat to make sure there are no outstanding changes.

This will revert ALL template changes that have not been committed to the central sqlCVS repository.

Update sqlCVS by selecting Advanced --> sqlCVS --> Update.  Check "ir" and everything under it.  Press Update at the bottom.  Repeat for "dce"
Title: Re: AV connections not being controlled
Post by: pw44 on March 24, 2010, 06:46:46 pm
...Never edit the database directly - do not use phpmyadmin.

Ok.

Quote
Delete the devices by looking them up in the device tree in the web admin and selecting "Delete Device" from the device page.

Ok.

Quote
Revert changes from sqlCVS by selecting Advanced --> sqlCVS --> Diff.  Check off "ir", "dce", and everything under them.  Press Diff at the bottom.  Select all changes.  Press Revert at the bottom.  Repeat to make sure there are no outstanding changes.

all are unchecked. do you mean check all under ir and dce and then next and then revert?

Quote
This will revert ALL template changes that have not been committed to the central sqlCVS repository.

Update sqlCVS by selecting Advanced --> sqlCVS --> Update.  Check "ir" and everything under it.  Press Update at the bottom.  Repeat for "dce"

after this all is done, how do i create a new, clean template for those devices, not refering to an existing  pronto codeset template?

BTW, where can i find a description for the pronto codesets already existing or grab one, because i know there are ready pronto sets for my dsp-a1, but in pronto format (not in hex)?

TIA
Title: Re: AV connections not being controlled
Post by: jimbodude on March 24, 2010, 07:06:36 pm
all are unchecked. do you mean check all under ir and dce and then next and then revert?
Yes, check ir, dce, and everything under each.

after this all is done, how do i create a new, clean template for those devices, not refering to an existing  pronto codeset template?
...The same way you created the broken one, except don't select an existing code set.

BTW, where can i find a description for the pronto codesets already existing or grab one, because i know there are ready pronto sets for my dsp-a1, but in pronto format (not in hex)?
I don't understand your question...  There are websites the provide the codes, or LinuxMCE can learn them from your remote.  LinuxMCE needs pronto format codes, not hex.
Title: Re: AV connections not being controlled
Post by: pw44 on March 24, 2010, 07:19:26 pm
Quote
I don't understand your question...  There are websites the provide the codes, or LinuxMCE can learn them from your remote.  LinuxMCE needs pronto format codes, not hex.

.CCF files?
Title: Re: AV connections not being controlled
Post by: pw44 on March 24, 2010, 08:41:57 pm
Quote
Revert changes from sqlCVS by selecting Advanced --> sqlCVS --> Diff.  Check off "ir", "dce", and everything under them.  Press Diff at the bottom.  Select all changes.  Press Revert at the bottom.  Repeat to make sure there are no outstanding changes.

This will revert ALL template changes that have not been committed to the central sqlCVS repository.

Ok. did it twice


Quote
Update sqlCVS by selecting Advanced --> sqlCVS --> Update.  Check "ir" and everything under it.  Press Update at the bottom.  Repeat for "dce"

Click NEXT. Nothing happens. No next screen for Update. :(
Title: Re: AV connections not being controlled
Post by: jimbodude on March 24, 2010, 08:58:31 pm
Make sure your browser is set to allow popups.  Repeat the whole process if it is not.
Title: Re: AV connections not being controlled
Post by: pw44 on March 25, 2010, 02:00:33 am
Hi Jimbodude,
did it all, and created new templates for the devices, defining a new codeset name for each. All the codes works well, but there are still problems:
1) having hulu player and kx-390 - menu entry show both kx-390 under hulu player.
2) disabling the hulu player entry (media scnenario), kx-390 appears, but no buttons or any screen.
3) tx-950 defined as radio (OTA radio), input on amp is changed to tuner (it takes around 10 seconds), and there is a menu, showing Off, Direct A/V, Resned A/V codes, Random (very dimmed), Audio Options, Random and Menu. None of this entries does something and when passing the mouse over Random (the one below menu) it turns to a big random icon with no access to menu.
4) changing source to TV or audio or video turns the input on the amp to laserdisc almost imediately.
Questions:
1) is there any frontend for tapedeck (with buttons or any menu)?
2)should a tuner be defined as OTA radio, and in this case should it also be a menu for it?
3) when the OSD source is changed to TV, an incorrect DSP mode is selectd. How to define which DSP mode for a source (audio, video, tv, etc) shall be selected?
4) my remote has 12 buttons for DSP selection, each of them with 2 or 3 modes. Hitting buttom 1 i get Concert Hall 1 - Hall A in Europe. Hitting buttom 1 twice i get Concert Hall 1 - Hall B in europe, hitting buttom 1 three tiimes, i get Concert Hall 1 - Hall C in Europe. Hitting buttom 12 i get Prologic Normal, hitting buttom 12 twice i get Prologic Enhanced, so buttom 1 has three DSP modes, button 12 has two DSP modes. Is there a way to fine tune it, defining the modes under AV Properties and doubling the IR hex codes. or must it be done in nother way?

The Yamaha devices where created by webadmin (from scratch not using any of the pre stored codesets).
TIA