LinuxMCE Forums

General => Users => Topic started by: wierdbeard65 on February 15, 2010, 11:37:33 pm

Title: Kernel Panic with e100 NIC
Post by: wierdbeard65 on February 15, 2010, 11:37:33 pm
Hi!

Ok, I have an old Compaq box that I'm trying to get working as my first MD. If I boot it from my Kubuntu 8.10 Live CD and to an LSMOD I see that it is using the e100 driver. It connects to the network and it can ping DCE Router.

If I pxe boot it, though, I get a kernel panic of the "cannot open /tmp/net-eth0.conf" variety.

I have followed the wiki (http://wiki.linuxmce.com/index.php/Unrecognized_NIC) on unknown nics and added e100 to /etc/initramfs-tools-interactor/modules. I regenerated initrd (the script /usr/pluto/bin/Diskless_BuildDefaultImage.sh doesn't exist, so I used
Code: [Select]
mkinitramfs -d /etc/initramfs-tools-interactor/ -o /tftpboot/default/initrdI tried unpacking initrd and looking at the modules file in it e100 is there.

I have no idea where to go from here. Any suggestions?
Title: Re: Kernel Panic with e100 NIC
Post by: wierdbeard65 on February 16, 2010, 08:08:53 pm
*Bump*

Ok, I know I only posted this last night, but SWMBO is away for a couple of days (comes back tomorrow) and I was hoping to have my MD up and running when she gets back. Running out of time! ;)

Anyone have any ideas on this one?

TIA
Title: Re: Kernel Panic with e100 NIC
Post by: wierdbeard65 on February 20, 2010, 09:54:24 pm
Can anyone help????  :-\
Title: Re: Kernel Panic with e100 NIC
Post by: phenigma on February 20, 2010, 11:42:11 pm
Has the core created a directory for the media director under /usr/pluto/diskless/## yet?

If the core has created the diskless directory for the media director then the tftp server will serve up /tftpboot/##/vmlinuz  & /tftpboot/##/initrd.img which are symlinked to /usr/pluto/diskless/##/boot/vmlinuz and /usr/pluto/diskless/##/boot/initrd.img rather than the kernel in the /tftpboot/default directory.  So if the /usr/pluto/diskless/## folder exists copy your new kernels from /tftpboot/default to /usr/pluto/diskless/##/boot/ and try the boot again.

I'm grasping....

J.
Title: Re: Kernel Panic with e100 NIC
Post by: wierdbeard65 on February 21, 2010, 01:39:59 am
Thanks for the response!

No, the directory hasn't appeared yet. The MD has yet to boot fully (and thus create the directory structure). I'm therefor working with the default vmlinuz and initrd files  ???