LinuxMCE Forums

General => Installation issues => Topic started by: huh on December 04, 2009, 02:07:31 am

Title: Beta 2 pulic keys
Post by: huh on December 04, 2009, 02:07:31 am
On my Revo, it looks like- when the MD is booting- that the 195 packages are installed, but am only able to get UI1 to work.  Under the restricted drivers, I do not see that the nvidia drivers are installed.  Then, I SSHed in to run apt-get update and apt-get dist-upgrade and got this:

Anyone else see something similar?  I think this is a new topic- if not, I missed it in my search.

Err universe/contrib Packages
  404 Not Found [IP: 80]
Fetched 389B in 1s (206B/s)
W: GPG error: intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 43C5D7EA63702FD3
W: GPG error: intrepid Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2EBC26B60C5A2783
W: Failed to fetch  404 Not Found [IP: 80]

W: Failed to fetch  404 Not Found [IP: 80]

W: Failed to fetch  404 Not Found [IP: 80]

E: Some index files failed to download, they have been ignored, or old ones used instead.
Title: Re: Beta 2 pulic keys
Post by: mythtified on December 04, 2009, 03:30:57 am
I experienced that with the avenard repo
Title: Re: Beta 2 pulic keys
Post by: MANDINGO on December 04, 2009, 03:33:20 am
yeh it took me awhile on mine also but what you have to do is go into kde and enable the nvidia drivers 195 that way and then your set...

and to get the keys follow my post here
Title: Re: Beta 2 pulic keys
Post by: pedplar on December 04, 2009, 03:54:04 am
Same thing here, added the missing keys, I had 2 of them. apt-get update, apt-get dist-upgrade still only 180 listed in the restricted drivers.
Title: Re: Beta 2 pulic keys
Post by: mythtified on December 04, 2009, 12:55:36 pm
have a look at the following page (  I have not tried it yet but the above suggestions did not completely work for me.

Note:  I am in the process of doing this now.  So far so good.  You will not need the entire article just the part about "Verify apt's list of repositories."  Do not add the line "deb stable  main" since it seems to already be there. 
nosilla_99 pointed me in this direction.  I will report back how this worked once the upgrade completes.
Title: Re: Beta 2 pulic keys
Post by: mythtified on December 04, 2009, 02:10:28 pm
While running the upgrade I had a admin login box appear.  I entered my password and the upgrade, the end i think, quit with an error message: Sorry, the package "lmce-mythtv-scripts" failed to install or upgrade.

Out of curiosity I ran apt-get dist-upgrade again and got the following:

dcerouter_1004839:/etc/apt# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
  libmyth-0.22-0: Depends: libvdpau1 (>= 0.3) but it is not installed
E: Unmet dependencies. Try using -f.

I believe this has already been documented but i have no time to look for it now.  Yes I know this is probably taken care of in the new install script but I don't want to lose everything i have set up so far.
Title: Re: Beta 2 pulic keys
Post by: mythtified on December 05, 2009, 10:03:27 pm
Well I decided to reload my test server with Kubuntu0810 and run the beta2 installer to see how well that worked.  I will say that going this route is immensly smoother than upgrading from beta1.  The installer ran and installed as expected with no problems.  I did the reboot and eventually got to the avwizard.  I got through that and it proceeded to load the core services and seemed to fail on regenerating the orbiter.  I never got to the setup wizard.  I left it alone for quite a while on two seperate occasions.  I read something in the wiki about two network cards and making sure that eth0 is the one on the public side.  This got me to thinking since I am testing with a single card.  I know it would be better with two.  I switched to a console window, logged in, and typed ifconfig.  Nothing was returned.  I then changed directories to /etc/network and looked at the file interfaces.  The machine tried to pull an ip from my dhcp server and did not finish configuring.  It pulled just the ip made it static and did not configure the sub net mask or gateway.  I edited the interfaces file and entered an ip address that was outside my dhcp range, along with both the sub net mask and gateway.  I confirmed that my resolv.conf had a dns entry then rebooted.  Once the system started to reload the the orbiter finished regeneratiing and the setup wizard started.  I completed the setup wizard, the router has restarted, and the orbiter is regenerating.  I now have an operational test install.  So I guess that if you get to a point where the install quits and goes to a blank screen then you may want to make sure that your nic was configured completely.
Title: Re: Beta 2 pulic keys
Post by: huh on December 13, 2009, 07:24:58 pm
Not sure if this is still applicable- I haven't rebuilt the machine since I first posted this, and have largely ignored the error, but I used these commands to add the keys- YMMV.

wget -q -O- | sudo apt-key add -
wget && sudo apt-key add ubuntu-repos.key
Title: Re: Beta 2 pulic keys
Post by: freaky on December 13, 2009, 09:02:20 pm
@ mythtified:

How did you config your network card? I'm pretty new to Linux, so hopefully you can explain this for an idiot :-)

got the same problem, installed Kubuntu0810, ran the beta2 installer, did the reboot and made my setup in the avwizard. After rebooting it generates lots of stuff until it stops and I just have the mousepointer on the screen. I can open the console, but it can't get any connection when I make an apt-get update - I think my problem is similar to yours, I just don't know how to edit the files and what I need to write in my console....

Thanks so far
Title: Re: Beta 2 pulic keys
Post by: mythtified on December 14, 2009, 12:53:04 am
That is strange.  I had been playing with the installers on several occasions over a period of about a week and my last attempt at a fresh install resulted in a good install without having to edit my interface file.  Any way, start by opening a terminal window on the core/hybrid (by pressing ctl shift f2 this will switch you to a terminal window), type cd /etc/network at the command line, and press enter.  This will change your current directory to /etc/network.  Within this directory you will find a file called interfaces.  Verify that the file needs to be edited.  Type cat interfaces.  This will display the contents of the interfaces file.  On my machine the file displayed the following:

auto lo
           iface lo inet loopback

auto eth0
iface eth0 inet static
auto eth0:1
iface eth0:1 inet static

Originally I was using a single network card in my test installation.  I have since added a second card.  This could have been part of my problem but I am not sure.  If you have no netmask or gateway entry in your interfaces file then you will need to add them.  I used vi to edit the file but it is very difficult to use if you have not used it before.  You should have pico on your system.  Type sudo pico interfaces.  Enter your password when prompted.  This will display a full screen editor that is fairly easy to use.  As you can see there was nothing entered for my netmask or gateway entries.  The ip address, in my case, was a problem since it is listed as static and it is from the range of dhcp addresses on my network.  Just add the necessary information, change the ip address if needed, save the file, and then exit the editor.  Reboot your machine. 
Title: Re: Beta 2 pulic keys
Post by: freaky on December 14, 2009, 07:05:53 pm
Thanks alot! I'm not sure if it solved my problem, I was changing the ip into a static ip in my network (eth0), saving the file and after I write sudo apt-get update it starts Regenerating the Orbiter again. I will see if it does more then that.

What is the eth0:1 adress for? I just have 1 Network Card inside (onboard ASUS P5QL-EM), but it shows me the 2 adresses just like yours did.

And thanks again for explaining editing a file to an idiot - thats much easier then I thought - aslong as you know how to do it ;-)
Title: Re: Beta 2 pulic keys
Post by: mythtified on December 15, 2009, 01:57:56 am
The eth0:1, is a virtual network card created by LMCE.  Since LMCE is mainly a router/firewall, if there is not a second physical network card in your machine LMCE creates one.  In order for LMCE to work properly, network booting diskless worstations for example, it will create a protected network on the existing physical network.  The only problem with this setup is that it will try to assign ip addresses from its dhcp server.  If you already have an existing dhcp server on the same physical segment then there will be a conflict with unpredictable results.  So if your intention is to just run your LMCE setup with just the core/hybrid and do nothing else then turn off the dhcp server in the LMCE machine.  If you intend to use LMCE to its fullest or prefer to continue using your existing dhcp server, then add the second network card, they are rather inexpensive these days.  If you decide to add the second card I believe I have seen a wiki article describing how to go from a single network card to dual network card system or just add the second card and reinstall.  I will leave it to you to find the article on your own.
Title: Re: Beta 2 pulic keys
Post by: freaky on December 15, 2009, 09:25:10 am
Ok, I understand. I finally got my machine running now and It already wanted to give an ip adress to one of the notebooks in the network. But no problem, giving steady IPs to all the computers in the network should solve the Problem for now. Actually, I want to use the machine as a stand alone, to get used to it, but later I want some more in Kitchen, Basement and Bathroom. But one after another....

The UI is really great and I hope I get it working like I want to. After the Problem I solved with your help I have to configure the mythtv setup with my hauppage DVBs Card. I already had this running on 0710 on a very old machine for testing, so I hope to get this thing running soon. I already found some informations about it - If someone need to get the hauppage running, maybe this helps you out:

It's always hard to get something like this running on a system I never worked with (Linux). But it's absoltutely the best MediaCenter I have seen. And belive me, I have tried some of them....