LinuxMCE Forums

General => Users => Topic started by: macaronij on September 29, 2009, 06:57:39 am

Title: Need help whit tv card
Post by: macaronij on September 29, 2009, 06:57:39 am
Hi all, i can t get my ati tv wonder to be find in linuxmce 710
first of all, sorry about my english!

when i put lspci i get
03:07.0 Multimedia controller: Philips Semiconductors SAA7130 Video Broadcast Decoder (rev 01)

so it seems to detect it wrong (ati tv uses bttv)

root@dcerouter:~# lsmod |grep saa
saa7134               148308  0
video_buf              30084  2 saa7134,bttv
compat_ioctl32         11136  2 saa7134,bttv
ir_kbd_i2c             11536  1 saa7134
ir_common              38916  3 saa7134,bttv,ir_kbd_i2c
videodev               31360  2 saa7134,bttv
v4l2_common            21888  4 saa7134,bttv,compat_ioctl32,videodev
v4l1_compat            15364  3 saa7134,bttv,videodev
i2c_core               30208  7 saa7134,bttv,i2c_algo_bit,tveeprom,ir_kbd_i2c,nvidia,i2c_nforce2

i tried to rmmod saa7130 but it don t find it,
so i search in /proc/modules and find

saa7134 148308 0 - Live 0xffffffff88e70000
bttv 216692 0 - Live 0xffffffff88e3a000
...
video_buf 30084 2 saa7134,bttv, Live 0xffffffff88b75000
...
videodev 31360 2 saa7134,bttv, Live 0xffffffff88b36000
v4l2_common 21888 4 saa7134,bttv,compat_ioctl32,videodev, Live 0xffffffff88b2f0$
....

i can remove saa7130 but lspci show the same
i can load modprobe bttv but lspci keep showing the same and mythtv doesnt find the ati

I hope anyone can help me

another little thing, when i boot i need to change "quiet splash" for "all_generic_ide" or boot fails, how can i make a change to don t have to do it evry time
Title: Re: Need help whit tv card
Post by: Zaerc on September 29, 2009, 04:43:51 pm
Hi all, i can t get my ati tv wonder to be find in linuxmce 710
first of all, sorry about my english!

when i put lspci i get
03:07.0 Multimedia controller: Philips Semiconductors SAA7130 Video Broadcast Decoder (rev 01)

so it seems to detect it wrong (ati tv uses bttv)

root@dcerouter:~# lsmod |grep saa
saa7134               148308  0
video_buf              30084  2 saa7134,bttv
compat_ioctl32         11136  2 saa7134,bttv
ir_kbd_i2c             11536  1 saa7134
ir_common              38916  3 saa7134,bttv,ir_kbd_i2c
videodev               31360  2 saa7134,bttv
v4l2_common            21888  4 saa7134,bttv,compat_ioctl32,videodev
v4l1_compat            15364  3 saa7134,bttv,videodev
i2c_core               30208  7 saa7134,bttv,i2c_algo_bit,tveeprom,ir_kbd_i2c,nvidia,i2c_nforce2

i tried to rmmod saa7130 but it don t find it,
so i search in /proc/modules and find

saa7134 148308 0 - Live 0xffffffff88e70000
bttv 216692 0 - Live 0xffffffff88e3a000
...
video_buf 30084 2 saa7134,bttv, Live 0xffffffff88b75000
...
videodev 31360 2 saa7134,bttv, Live 0xffffffff88b36000
v4l2_common 21888 4 saa7134,bttv,compat_ioctl32,videodev, Live 0xffffffff88b2f0$
....

i can remove saa7130 but lspci show the same
i can load modprobe bttv but lspci keep showing the same and mythtv doesnt find the ati

I hope anyone can help me

Try: modprobe -r saa7134 instead.

another little thing, when i boot i need to change "quiet splash" for "all_generic_ide" or boot fails, how can i make a change to don t have to do it evry time

Edit /boot/grub/menu.lst and append "all_generic_ide" to the appropriate "kernel" line.
Title: Re: Need help whit tv card
Post by: macaronij on September 29, 2009, 09:14:44 pm
when it boot, i can add a tuner in mythtv, but it has the saa7130 driver, so i can t see the tv (/dev/video0)

root@dcerouter:~# modprobe -r saa7134
root@dcerouter:~# modprobe bttv card=39
root@dcerouter:~# lspci
...
03:07.0 Multimedia controller: Philips Semiconductors SAA7130 Video Broadcast Decoder (rev 01)

then i tried in mythtv and it don t find the tv tuner (don t find video/vbi device )

do i have to create a /dev/video1 or something asotiated to the bttv driver?
Title: Re: Need help whit tv card
Post by: macaronij on October 01, 2009, 06:32:03 pm
Any ideas? i have ask in kubuntu forums and they said the problem is in the kernel too old

this is my first linuxmce build and i'm in a early stage, what do you think about trying the 810 alpha2 version? i read it comes whit newer kernel and drivers. is it harder to install/configure? is it very unstable?

Title: Re: Need help whit tv card
Post by: totallymaxed on October 01, 2009, 06:36:01 pm
Any ideas? i have ask in kubuntu forums and they said the problem is in the kernel too old

this is my first linuxmce build and i'm in a early stage, what do you think about trying the 810 alpha2 version? i read it comes whit newer kernel and drivers. is it harder to install/configure? is it very unstable?



Or just purchase a card that is supported.

Andrew
Title: Re: Need help whit tv card
Post by: macaronij on October 01, 2009, 06:51:17 pm
where i get that list? i need an analog card, the problem is that i m in argentina, i tryed some that you mention in the wiki but they are discontinued, and they won t import something old.
Title: Re: Need help whit tv card
Post by: totallymaxed on October 01, 2009, 07:29:24 pm
where i get that list? i need an analog card, the problem is that i m in argentina, i tryed some that you mention in the wiki but they are discontinued, and they won t import something old.

What TV standard do you use? NTSC or PAL?...Do you have any digital TV yet? ...if yes what kind DVB or ATSC?

Andrew
Title: Re: Need help whit tv card
Post by: macaronij on October 01, 2009, 07:52:43 pm
PAL-N  and no digital tv
(but if the card can receive pal-n AND ntsc much better)
Title: Re: Need help whit tv card
Post by: totallymaxed on October 02, 2009, 01:35:19 am
PAL-N  and no digital tv
(but if the card can receive pal-n AND ntsc much better)

Hi again,

Well we use this card for analog capture using the Composite in and for DVB-T to. The analog capture has a hardware MPEG2 encoder so the performance is very good. We have not tested the analog PAL TV tuner at all do i cant comment on that aspect;

http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-1300 (http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-1300)

http://www.hauppauge.co.uk/site/products/data_hvr1300.html (http://www.hauppauge.co.uk/site/products/data_hvr1300.html)

We also have a v4l package that you could install that will support this card - PM me here on the forum with your email address and i will send it to you.

All the best

Andrew
Title: Re: Need help whit tv card
Post by: macaronij on October 05, 2009, 05:11:29 pm
ok, i have done a big mistake. i post it here just in case someone get in the same problem
googling a little you can find that the ati tv wonder has b8t8 chipset (that work whit bttv module) but my kernel loaded saa7134 (that works whit phillips 7130/7134 chipset)
the problem wasn t the kernel, but the manufacturer: they just changed the chipset!!
so much wasted time...