LinuxMCE Forums

General => Installation issues => Topic started by: dcfnet on August 24, 2009, 04:48:03 pm

Title: Lost Internal Network
Post by: dcfnet on August 24, 2009, 04:48:03 pm
Hello,

Was up and running. Had HDHomeRun setup and NAS-Dlink-D343 on internal network. Can't Ping either.

Output of Netstat -r:

david@dcerouter:/$ netstat -r
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.170.0   *               255.255.255.0   U         0 0          0 eth0
208.67.217.0    *               255.255.255.0   U         0 0          0 eth1
link-local      *               255.255.0.0     U         0 0          0 eth0
239.0.0.0       *               255.0.0.0       U         0 0          0 eth1
default         192.168.170.1   0.0.0.0         UG        0 0          0 eth0
david@dcerouter:/$

...I find no place where the 208.67.217.0 Network is configured. The Network Interfaces in MCE Admin are correct as well as /etc/network/interfaces

Please advise... Thanks!

David
Title: Re: Lost Internal Network
Post by: tkmedia on August 24, 2009, 05:39:00 pm
Try disabling and re-enabling the firewall . If it works you may need to repeat after reboot.

Is your external network connection on eth1 by chance?


Tim
Title: Re: Lost Internal Network
Post by: dcfnet on August 24, 2009, 09:05:31 pm

Thanks! Disable and re-enabling FW did it after reboot. But, the Netstat -r still reveals the same output. No, ETH0 is the external network interface. ETH1 is configured 192.168.80.1
Title: Re: Lost Internal Network
Post by: colinjones on August 24, 2009, 11:11:56 pm
the routing table suggests that you have changed the internal network from 192.168.80.0/24 which is what it needs to be to 192.168.170.0/24 which will not work.

Assuming that your NAS and home run are on your internal network and have 192.168.80.x IP addresses, that is why you cannot ping them... the routing table has no subnet for that network and so will send your pings to the Internet. BTW, your eth1 is clearly configured on the Internet side, and eth0 on the internal side, which will be causing you problems as well.