LinuxMCE Forums

General => Installation issues => Topic started by: parkinos on June 03, 2009, 09:17:48 pm

Title: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: parkinos on June 03, 2009, 09:17:48 pm
I have recently installed Kubuntu 8.10 and run the instruction for installing using the alpha 2.22 installer.  After completing the installation and rebooting the computer the AV Wizard runs fine.  After the AVWizard finishes I get a black or gray screen with a mouse cursor on it.  Sometimes I get a popup message complaining that the remote server cannot be reached.  I believe this issue is related to having Asterix enabled.  I can do a ctrl+alt+F1 and tail the logs.  From the logs I see the following message over and over:

1   06/03/09 10:19:43   21 (spawning-device)   Starting... 50
1   06/03/09 10:19:43   21 (spawning-device)   Found /usr/pluto/bin/LaunchOrbiter.sh
1   06/03/09 10:19:43   LaunchOrbiter (server)   Number of desktops found: 8 ; desktops activated
1   06/03/09 10:19:43   LaunchOrbiter (server)   Primary desktop: 6 and secondary desktop 7
3   06/03/09 10:19:54   21 (spawning-device)   Device died... count=50/50 dev=21
3   06/03/09 10:20:04   21 (spawning-device)   Aborting restart of device 21...

After it attempts to start device 21 50 times it gives up and I see nothing further in the pluto.log or DCERouter.log.  I have tried re-installing LinuxMCE multiple times and the results are always the same.  This computer was being used with LinuxMCE 710, and the only issue I had was with the display resolution.  Here is some system information:

AMD X2 3800+
ASUS A8N-SLI Premium
EVGA GeForce 8800 GT (Using Restricted Drivers provided by Kubuntu 180.11 I believe)
46" Samsung LCD TV
2 GB RAM

Please note that I am still able to access KDE just fine, if I press ctrl+alt+backspace, then use startx or sudo kdm at the command prompt.  Once in KDE everything seems to work fine.  I should also note that this install was originally done with a Ubuntu CD and KDE was added after install and Gnome was removed.  This was due to the fact that I could not get Kubuntu 8.1 to install from CD or DVD.  I would be willing to do a re-install of Kubuntu if I could find an iso source that works  ;)  I should also note that the Web interface is accessible, but only by accessing it from the Core through KDE.  I can provide any logs that may be needed and have already copied all of the files in /var/log/pluto.  Any help would be greatly appreciated.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: posde on June 03, 2009, 10:05:16 pm
Please check in your /var/log/mce* log file that there are no error messages regarding problems downloading stuff. I assume you do have two wired network cards, and you are using eth0 to connect to the outside world, and you did install using the Kubuntu 810 Desktop CD
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: parkinos on June 03, 2009, 11:16:29 pm
Posde,

I checked my /var/log/mce* files and only saw installation logs.  I looked through the most recent log file and did not see any issues downloading any packages.

I do have 2 network cards, but currently only have one connected.  I have tried with both connected and had the same issues.  I should note that I have never had any luck pinging or browsing to either interface of this computer.  But from this computer I am able to ping the router and other computers on the network.  I don't know if this is network setup or firewall issue, but I found it very strange.

As for the installation...
I used a Ubuntu 810 installation CD, added KDE and removed Gnome.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: posde on June 03, 2009, 11:45:45 pm
parkinos,

to have a succesful 810 installation the following things need to happen:

* Install Kubuntu 810 using the Kubuntu 810 Desktop CD
* Make sure eth0 is your connection to the internet
* Download the new-installer script as highlighted in the wiki and follow the instructions in the wiki.

Following the above steps has always given me successful installs. Whenever *I* used different ways, the success rate was minimal.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: parkinos on June 04, 2009, 12:38:14 am
Do you know of a Kubuntu 810 CD or DVD ISO that works correctly?

I have burnt about 6 copies and each one had issues, it has been extremely frustrating to say the least.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: Pnuts on June 04, 2009, 12:49:43 am
You will want the CD. After downloading it, verify the md5sum of the iso file. Then burn it at a slow speed (less prone to errors). Once burned, boot it and have it check itself for errors, you should be ok to install at this point.

Here is a link to DL the one you need: http://mirrors.gigenet.com/ubuntu/kubuntu/8.10/kubuntu-8.10-desktop-i386.iso

This is the md5sum of the CD: 82c02dc7386dfb6858a9ec09a5059e1e
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: colinjones on June 04, 2009, 12:54:23 am
For emphasis ... note Possy was saying the Kubuntu 0810 Desktop CD, as there are other versions. Also, use i386 not AMD64. And as Pnuts says, the slowest possible burn speed is critical.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: parkinos on June 04, 2009, 01:00:49 am
Yep, I noted all of those things, and that's what I've been trying to get working, with very limited success.  I have a x86_64 DVD that works fine, but have had major issues with the i386 CD.  I even verified the MD5 checksum.  I'm going to download the CD and put it on a USB drive and try that.  If that doesn't work I'll burn the CD at 1x, I guess.  Thanks for the quick replies.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: simon_b on June 04, 2009, 12:13:11 pm
parkinos,


* Make sure eth0 is your connection to the internet


Possy, what about the case, i have. Mine eth1 is connected to the internet, and the eth0 is for the inside network.

Since eth0 is GB NIC and eth1 100MB NIC, i really do not want to change it, since I will have some 5+ MD's connected to the core...

I had pretty same issues like parkinos, maybe due to the reason, given by you...
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: patmankn on June 04, 2009, 01:06:15 pm
simon_b,

the alpha-install script is quite picky with the network interfaces. This means eth0 HAS to be the internet connection,
eth1 the internal network. i screwed up my first install, not knowing of the eth0/1 thing... took me quite a while, as i usually assume, LMCE and its Devs are smarter than me, and figured out the case long before got to the point.
You can easily change the network aliases (eth1 <=>eth0) within /etc/udev/rules.d/70-persistent-net.rules. just use your beloved editor of choice and edit this file.
Heres a link, showing what excatly has to be done.
http://techpulp.com/2009/05/how-to-change-the-order-of-network-card-detection-in-linux/ (http://techpulp.com/2009/05/how-to-change-the-order-of-network-card-detection-in-linux/)

Cheers Patrick

Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: posde on June 04, 2009, 02:10:54 pm
parkinos,

* Make sure eth0 is your connection to the internet

Possy, what about the case, i have. Mine eth1 is connected to the internet, and the eth0 is for the inside network.

Swap cables for the installation, and after everything is settled down, go into the web admin and swap internal and external again, as well as swap cables back.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: colinjones on June 04, 2009, 04:34:45 pm
or even just

sudo nano /etc/iftab

enter the linuxmce password and then edit the file to correct the eth order based on MAC addresses (just swap them), save the file and reboot!
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: posde on June 04, 2009, 06:13:42 pm
or even just

sudo nano /etc/iftab

enter the linuxmce password and then edit the file to correct the eth order based on MAC addresses (just swap them), save the file and reboot!

I do not think, that this kind of advise is helpful for anyone trying to get started.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: Pnuts on June 04, 2009, 06:29:13 pm
parkinos,

* Make sure eth0 is your connection to the internet

Possy, what about the case, i have. Mine eth1 is connected to the internet, and the eth0 is for the inside network.

Swap cables for the installation, and after everything is settled down, go into the web admin and swap internal and external again, as well as swap cables back.

This is what I did a few weeks back on a clean installation. Works very well.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: Zaerc on June 04, 2009, 06:58:17 pm
or even just

sudo nano /etc/iftab

enter the linuxmce password and then edit the file to correct the eth order based on MAC addresses (just swap them), save the file and reboot!

I do not think, that this kind of advise is helpful for anyone trying to get started.

Not to mention the fact that the /etc/iftab file is no longer used.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: parkinos on June 04, 2009, 10:41:23 pm
Alright, well I was finally able to get an 810 CD install to work.  Every CD that I burned even at my slowest speed possible (10x) would have the same issue.  I was getting the following error:

Buffer I/O error on device sr0, logical block (can't remember block number)

So I checked the CD for errors on my Windows XP laptop.  Which was still getting the error, but continued anyway, eventually the test finished and the CD was fine.  So I went and tried it on my already installed 810 HTPC.  No matter what route I took, I always got that error, which would dump me to the initramfs.  I also tried passing the all_generic_ide parameter to the installer, as I have read this fixes the issue.  Needless to say, this did not fix the issue.

How I resolved the issue:
From the main installation menu I selected "Install Kubuntu" and once the Kubuntu loading screen appeared, I hit Ctrl+Alt+F1.  This dumped me to the console and I was able to see what was going on.  In this mode the error happened a number of times, but continued on to load KDE.  After KDE was loaded I was able to successfully install Kubuntu, and eventually was able to install LinuxMCE.

I had a hunch that the way I had installed 810 may have been the cause of the problem and I guess that it was.  Thanks for all of the support, everything seems to be working well so far...
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: posde on June 05, 2009, 08:32:40 am
A small note regarding installation of Kubuntu 810 Desktop: I always use a USB stick for my installs. My main workstation has Ubuntu on it, and Ubuntu has a nice little utility under System/Administration to create a USB startup disk.

That way, I did not have a problem installing Kubuntu and LinuxMCE 810 on an Asus B202.

I try to limit my use of optical disks these days.
Title: Re: LinuxMCE 8.10 alpha 2.22 installation issues
Post by: shakeel on September 05, 2009, 11:10:28 pm
Okay, I had the issue of the gray or black screen coming up and then the system complained that there was a transparency issue and it seemed like my computer hardware was not capable of running UI2 properly and so I looked at all of the forums but wasn't able to fix the problem.  I finally did find an answer to my issue as it turns out.  The problem was that the system would install the latest version of the nvidia driver which is 180 and that did not want to work with my system. 

I am using the ASUS M3N78-EM motherboard with onboard Nvidia 8300 graphics.

To fix my problem I used EnvyNG.  I started my system in recovery mode and got to the command prompt. 

At the command prompt I typed:

apt-get install enyng-qt

I then started up KDE using KDE START.

In KDE I went to my start menu/applications/system/EnyNG.

After entering my root password I got into EnvyNG which shows the different drivers that I can use and recommends the best one.  For the Nvidia drivers, it gave me the choice of 180.11-Oubuntu1~intrepid1 (the latest), 177.82-Oubuntu0.1 (slightly older), 173.14.12-1-Oubuntu5.1 (even older) and a few others.  For my system it recommends 177 but I used it and I also used 180 and both of them gave me the gray or black screens.  I had to use the 173 driver and my UI2 worked.  EnvyNG automatically uninstalls the wrong driver, installs the right driver, and then configures KDE's resolution to be optimum for my system. 

At this point reboot and then go through the AVWizard again and your system should be up and running.

I hope this helps!!  I hope this is the right thread to place this in.