LinuxMCE Forums

General => Installation issues => Topic started by: Stutch on October 23, 2008, 06:28:40 am

Title: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 23, 2008, 06:28:40 am
Hello again.  First of all, please forgive me for the long post.  I am very passionate about getting this system working so that I can help others. 
I've been troubleshooting this particular problem for 3 months now and I am running out of ideas.  When attempting to watch movies (ripped to the core system) on my diskless media devices, playback stutters periodically.  Considering that my intention is to move my entire DVD Library to this core system, the performance is absolutely critical.  Being an IT Infrastructure professional, I took a pretty hard core approach to correcting this issue.  (I like buying big toys.)

First, I thought maybe it was a disk access speed issue, so I dedicated four 250 GB drives in a hardware raid 10 configuration for the Linux MCE OS.  I then created a separate (hardware) raid 5 LUN for my media.  This resulted in no improvement on the media directors during playback; however they do seem to boot up quicker. 

Next I replaced my Linksys Gigabit switch with a Cisco Catalyst 3550 (Layer 3) Gigabit Switch and a few cat 6 certified patch cables to plug the systems directly into the switch.  I did see notable improvement after this change.  Movie play back still stutters on occasion, but it is far less severe. 

I have a core set up and running like a scalded dog, the config is below:

Motherboard: MSI Platinum AM2
RAID controller: 3Ware PCI-Express x16 SATA II Controller Card RAID
Processor: AMD Phenom 9950 2.6 GHz Quad Core
Memory: Crucial Ballistix 4gig memory
Case: Norco RPC-4020 4U
Power Supply: Antec TruePower Quattro 1000W
Video Card: MSI Video Card Nvidia Chipset
NIC: Intel Gigabit Ethernet
Hard Drives:
System: Western Digital Caviar 250GB X 4 Raid 10 configuration
Data: Western Digital Caviar 1TB X 8 Raid 5 configuration

Here are my current Media Directors:
Media Directors:
-1 MSI Media Live x64
-3 Generic PC x86(Testing)

What I think may help is increasing the MTU size for the media network.  I can do that easily enough on the switch, however, what would I need to do on the core /media directors?
Would this even help me?
Is there something else that I may be missing that could cause my video playback preformance issues?
I love you guys.
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: colinjones on October 23, 2008, 06:55:40 am
It seems very unlikely that bandwidth or settings like MTU are implicated given the infrastructure you have!

Have you tried plugging a media director directly into the internal NIC with a patch cable? Presumably they don't stutter when you play them on the core?

Can you temporarily plug a HDD into one of the MDs, transfer the files there and play locally?

Worst case, you could try sniffing the traffic and making sure that there are no missed ACKs or that neither side is generating RSTs that might interrupt the TCP flow...
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: niz23 on October 23, 2008, 02:10:08 pm
Stutch.
Hello again.  First of all, please forgive me for the long post.  I am very passionate about getting this system working so that I can help others. 
I've been troubleshooting this particular problem for 3 months now and I am running out of ideas.  When attempting to watch movies (ripped to the core system) on my diskless media devices, playback stutters periodically.  Considering that my intention is to move my entire DVD Library to this core

Shortened....


I had this behavior earlier with some of my nForce based motherboards.
When you see your video problem do the screen freeze for short while?

Look in dmesg. Run "dmesg" from a shell prompt right after you have had the video problem.
What is in the rows at the end?
Do yo see loop/iteration text?

At least one of my nForce based MBs had the irq for graphics and ethernet hardwired to the same physical interrupt line.
There is also some known problems with nForce ethernet chips.

/niz23
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 23, 2008, 06:45:36 pm
Oops, that is not the motherboard in use on my core.  I forgot that ended up replacing it due to wanting the 4 16x PCI express slots for future raid expandability...  I am actually using the K9A2 Platinum 790FX AM2+ ATX Motherboard http://global.msi.com.tw/index.php?func=proddesc&prod_no=1332 (http://global.msi.com.tw/index.php?func=proddesc&prod_no=1332)

Colinjones - As far as playing DVDs on the core, I can't get the sound to work; it has the integrated Realtek ALC883 which doesn't seem to work at all.  I wasn't too concerned about this fact though since this system is my core.  I would have to get the sound working on it to do an appropriate test on movie playback quality.  In that case, is there an easy way to get my sound working?  I will also attempt a crossover cable directly to my media device and see if that works (God help me if it does.).  I have played DVD's locally on the media device internal DVD players without issue, but I haven't tried coping the DVD to the local system.  I can see how that test would help eliminate the network as an issue.  I'll give it a shot as well.  I'm still green to the Linux world, which is a problem for me.  I'll look at dmesg to see what is going on, and post it on here as I'll have no clue what I am looking at. :)

Niz23- I will have to see if the whole system freezes or just the playback.  I’m thinking it is just the playback though. The internal NIC on my core is in use on the public facing network.  I have a separate gigabit NIC in place for my internal 192.168.80.0/24 network.  Would that eliminate the issue with the shared IRQ for the Nic and video card?  Also the issue is on both the Intel and AMD based media directors, so I assume your concern is with the Core being an nForce based motherboards.

Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: colinjones on October 23, 2008, 09:19:25 pm
You probably won't even need the cross over as most NICs do auto MDI-X these days.

Are you using SPDIF on the core? If so, try alsamixer at the command line and check that the IEC958 level isn't muted, that is a common cause of no sound when using optical or coax sound
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 23, 2008, 09:56:10 pm
I'm just using good old alalog sound at the moment.  Or at least that is what Im trying to use.  I have a simple pair of pc speakers plugged into her at the moment.
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: johanr on October 23, 2008, 10:01:25 pm
plugged the speakers into her? *giggle* sorry..

hehe, I like the approach  ;D cisco 3550 at home :o
have you modded it as well to be little less noisier?

What is occasionally? every 20 minutes or 5 minutes?
Always same place in the movie?

HW:
Well just a thought from my side, Are you doing anything else at the same time that needs processing at the core?
Since I am not a daily linux user I can't recommend a program/app to run but how about monitoring cpu and memory for a longer period and then review when this happens if it has to do with cpu/mem

Network:
Have you checked the network traffic with for example wireshark for dropped packages, package delay or similar?
Set it up so you do port mirroring on the interface towards the core and then review it later. Even better do a merge cap of two files like interface to the core and the interface to the media directors.

I also don't think increasing the package size will help. Off course, the bigger the better(in some cases)

edit.
You are using Raid5 for the media data?
 From performance perspective I belieive Raid 0 or 1 would be better. Can this maybe be the cause?

-johan
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: hari on October 23, 2008, 10:21:16 pm
nice switch. I assume we are talking about the C3550-48? Can you post the config of the switch and the duplex settings of your clients? (mii-tool or ethtool)

btw, the 1500 MTU should be fine on 100mbit. If you have the 12T variant, using jumbo frames on the gig ports could be an option. But you don't need that for DVD streaming :-)
Also check the port counters for errors.

The intel is a e100 or e1000? a "cat /proc/interrupts" would be interesting, too..

best regards,
Hari
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 23, 2008, 10:30:00 pm
Didn't you know, when you start plugging $4000 into a server, it develops a gender?  And it has to be a woman, because it drives me F"ing crazy, and yet I keep coming back for more.  ::)

Yes a 3550 is an extremely loud switch.  But we have a (almost full) 72" server rack in the basement that houses all of this stuff so that it can be sealed off from the rest of the house. Thus noise is not an issue.  I am a Cisco guy at heart, so it wasn't difficult to justify the purchase (Ebay ~ $600).

HW: Nope, the core is just that, a filthy huge machine dedicated to a single purpose in life.  It is running LMCE and that is it.  I could use help with monitoring resources though, as I am not well versed in Linux either.  I even turned off the (Autostart Media Director) so that it is only running as a core.

Network:  This is what I am going to try tonight, I'll set up port mirroring and see what is going on.  

Raid: I chose raid 5 to maximize my storage capacity, while still allowing for redundancy.  Raid 0 is out since it offers no protection in the event of a lost drive.  I could use raid 1 or 10, but then I go from having 7TB of storage to 4TB.  I have given this a bunch of thought, and if I don't see anything using the packet sniffer, I guess that is what I will try next.
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 23, 2008, 10:42:12 pm
Hari- I have a WS-C3550-12G It is a 12 port gigabit switch capable of both fiber and RJ45 connectivity.  I even have my eye on a few fiber nics to try on the core...

http://cgi.ebay.com/Cisco-WS-C3550-12G-Gigabit-Switch-10-x-GBIC-2-Copper-GE_W0QQitemZ260303411174QQcmdZViewItem?hash=item260303411174&_trkparms=72%3A1205%7C39%3A1%7C66%3A2%7C65%3A12%7C240%3A1318&_trksid=p3286.c0.m14  (http://cgi.ebay.com/Cisco-WS-C3550-12G-Gigabit-Switch-10-x-GBIC-2-Copper-GE_W0QQitemZ260303411174QQcmdZViewItem?hash=item260303411174&_trkparms=72%3A1205%7C39%3A1%7C66%3A2%7C65%3A12%7C240%3A1318&_trksid=p3286.c0.m14)

 I'll have the rest of that infor for you as soon as I get home.  I agree that DVD streaming should not require jumbo frames, but at the same time, I can't ignore the preformance gain that I saw after installing it.

Johanr- The freezing up is randam, and is less frequent with the Cisco switch in place.
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: johanr on October 23, 2008, 11:00:56 pm
yep, I am soon about to start drewling.. Fiber..
 wish I had the same opportunity to go the same route :)
Good luck troubleshooting tonight. Hope you find something.
-johan
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: niz23 on October 23, 2008, 11:47:16 pm
Stutch.
Oops, that is not the motherboard in use on my core.  I forgot that ended up replacing it due to wanting the 4 16x PCI express slots for future raid expandability...  I am actually using the K9A2 Platinum 790FX AM2+ ATX Motherboard http://global.msi.com.tw/index.php?func=proddesc&prod_no=1332 (http://global.msi.com.tw/index.php?func=proddesc&prod_no=1332)


Niz23- I will have to see if the whole system freezes or just the playback.  I’m thinking it is just the playback though. The internal NIC on my core is in use on the public facing network.  I have a separate gigabit NIC in place for my internal 192.168.80.0/24 network.  Would that eliminate the issue with the shared IRQ for the Nic and video card?  Also the issue is on both the Intel and AMD based media directors, so I assume your concern is with the Core being an nForce based motherboards.


Ok. IRQ is probably not your problem then.
Still. Check dmesg when the issue occur.

/niz23
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 24, 2008, 01:31:38 am
Ok, is there a quick way for me to allow access via SSH and web to access the Core on its public side?  That will give me a quick way to grab the config for you.
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 24, 2008, 02:06:15 am
Below is the current config of my 3550 switch.  There are a few modifications that I made that I can point out.

Quote
test3550#show config
Using 1784 out of 393216 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test3550
!
enable secret 5 $1$pJkJ$L5DQXi1e5t.7vXaG9IstH1
enable password cisco1
!
no aaa new-model
ip subnet-zero
!
!
!
crypto pki trustpoint TP-self-signed-598334592
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-598334592
 revocation-check none
 rsakeypair TP-self-signed-598334592
!
!
crypto pki certificate chain TP-self-signed-598334592
 certificate self-signed 01 nvram:IOS-Self-Sig#3201.cer
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface GigabitEthernet0/1
 switchport mode access
 bandwidth 10000000
 delay 1
 spanning-tree portfast
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface GigabitEthernet0/3
 switchport mode dynamic desirable
!
interface GigabitEthernet0/4
 switchport mode dynamic desirable
!
interface GigabitEthernet0/5
 switchport mode dynamic desirable
!
interface GigabitEthernet0/6
 switchport mode dynamic desirable
!
interface GigabitEthernet0/7
 switchport mode dynamic desirable
!
interface GigabitEthernet0/8
 switchport mode dynamic desirable
!
interface GigabitEthernet0/9
 switchport mode dynamic desirable
!
interface GigabitEthernet0/10
 switchport mode dynamic desirable
!
interface GigabitEthernet0/11
 switchport mode access
 duplex full
 spanning-tree portfast
!
interface GigabitEthernet0/12
 switchport mode access
 bandwidth 10000000
 speed 1000
 duplex full
!
interface Vlan1
 ip address 192.168.80.254 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
line vty 0 4
 password cisco1
 login
line vty 5 15
 password cisco1
 login
!
end[/b]

The server currently sits on interface 0/12. 

interface GigabitEthernet0/12
 switchport mode access (This tells the switch the a computer is attached to this port, vs another switch or router.)
 bandwidth 10000000 (This manually sets the port to allow the use of maximum bandwith.)
speed 1000 (You guessed it.  This is tells the switch to run at 1000MB/sec)
duplex full (Run at full duplex).

My test media extender lives on port 0/11
interface GigabitEthernet0/11
 switchport mode access
 duplex full
 spanning-tree portfast (this is essential for PXE clients as it disables the 45 second port diagnostic and spanning tree checks that each port typically goes through when a new device comes on line.)

no service password-encryption (in the terminal configuration of a cisco switch, (config t) you can specify whether or not to encrypt all passwords.)

Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: colinjones on October 24, 2008, 03:30:54 am
you have your bandwidth set to 10Mb...?
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: niz23 on October 24, 2008, 08:04:51 am
Stutch.
Ok, is there a quick way for me to allow access via SSH and web to access the Core on its public side?  That will give me a quick way to grab the config for you.

Easiest way. Browse to webadmin.
Under configuration|network you can enable/disable the internal firewall.
Thats the easiest way to activate access on public side.

Beware if your public side is directly attached to your DSL/internet router.
If it is not then I guess your internet router have a firewall configured.

there is also some options to open up just some ports on this page.

/niz23
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: hari on October 24, 2008, 12:32:12 pm

 switchport mode access (This tells the switch the a computer is attached to this port, vs another switch or router.)

not exactly. This tells the switch to not use 802.11q

Quote
bandwidth 10000000 (This manually sets the port to allow the use of maximum bandwith.)
wrong. This does not affect the bandwith of the port but adjust metrics for routing protocols.

Quote
spanning-tree portfast (this is essential for PXE clients as it disables the 45 second port diagnostic and spanning tree checks that each port typically goes through when a new device comes on line.)
this has nothing to do with port diagnostics. Btw, the default settings for spanning tree are 50second (2x15s+20s).

from my point of view the switch config looks fine. Any results from the port counters?

best regards,
Hari
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 24, 2008, 02:45:08 pm
you have your bandwidth set to 10Mb...?
No. Bandwidth = (10000000/raw bandwidth measured in Kb/s)
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 24, 2008, 02:48:26 pm

 switchport mode access (This tells the switch the a computer is attached to this port, vs another switch or router.)

not exactly. This tells the switch to not use 802.11q

Quote
bandwidth 10000000 (This manually sets the port to allow the use of maximum bandwith.)
wrong. This does not affect the bandwith of the port but adjust metrics for routing protocols.

Quote
spanning-tree portfast (this is essential for PXE clients as it disables the 45 second port diagnostic and spanning tree checks that each port typically goes through when a new device comes on line.)
this has nothing to do with port diagnostics. Btw, the default settings for spanning tree are 50second (2x15s+20s).

from my point of view the switch config looks fine. Any results from the port counters?

best regards,
Hari


When I attempted to disable the firewall I got an ugly web error on the system.  I'm going to reload it and see if I Can get around that problem.  after that, I will post for you what I see.
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Zaerc on October 24, 2008, 08:48:42 pm
Stutch.
Ok, is there a quick way for me to allow access via SSH and web to access the Core on its public side?  That will give me a quick way to grab the config for you.

Easiest way. Browse to webadmin.
Under configuration|network you can enable/disable the internal firewall.
Thats the easiest way to activate access on public side.

Beware if your public side is directly attached to your DSL/internet router.
If it is not then I guess your internet router have a firewall configured.

there is also some options to open up just some ports on this page.

/niz23

Better to just only open port 22 for ssh, and everything else can be tunneled using ssh.
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: johanr on October 24, 2008, 09:04:35 pm
As hari says, there is not much to go wrong with the config.
 I would however recommend (sorry for sounding like a besserwisser/messerschmidt or whatever) to use Auto(speed,dup) on all the active ports. I have not seen the Cisco devices having the jumping link problem anymore.

If you want spanning tree to be faster, start using Rstp instead or even Mstp. The convergence times will be much faster..
For bandwith, you have already set it to 1000. If you want to control bandwith you do it with Qos policing  :P NOT Recommended however... (have seen major issues/bugs using that on several C devices(7204,7609,3550) in previous ios 12.2 releases, probarbly corrected now but I would not give it a try just because if the history.

Now show us the fresh 'sh int'  i.e. clear the interfaces and don't mess with the cables then let run for quite a while watching movies. and some wireshark results would be nice as well =)

 :)

-johan
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 24, 2008, 09:35:42 pm
It was raw paranoia that caused me to force the speed & duplex setting as well as the other settings on the switch to begin with.  I’ve been screwing with this issue for months; following numerous threads in this forum that I had hoped would help me to resolve my issue.   I should not need an enterprise class switch to stream movies… and yet, here I am. (Not complaining!)

Furthermore, I won’t need to mess around with QoS as this switch is dedicated to just the internal media network.  ;D
I will take your suggestion and reset the port settings for  speed and duplex.   This was just another example of me needing to verify that I was getting the speed that I was expecting.  I had already discovered cat5  patch cables that were not rated for gig speeds causing me headaches.

So for the sh int, do you need me to grab this a few times while a movie is running?  Do you just need it off the core, or the media device as well.  I’ll do sniffing as well.
I appreciate the assistance from all of you. 

You are all on the Christmas list now.
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: johanr on October 24, 2008, 09:59:17 pm
haha, paranoia is good  ;D

Don't forget to update the Core and MD with the same settings(speed, dup) though

sh int afterwards is fine. for both of the interfaces. Lots of Runts and drops are not good.
Take a quick look in the syslog as well just to make sure(that all is ok with the 3550).

Not sure how to do a similar in linux though =/ but that will give some hints if this is related to the network which I actually doubt.

(hari posted some nice commands to be run as well)

Btw, I assume you have everything on the inside of the Core, as recommended ?

Is it easy for you to move(copy) the same Movie to the hdd of the Core and view it from there as well?

Just to easily eliminate eventual troublecausers.
Also I posted a while ago about twitchy playback and got the recommendation to not use alpha blending.. Try changing that.(in case you are)

Good Luck!
-johan
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 24, 2008, 10:17:57 pm
haha, paranoia is good  ;D

Don't forget to update the Core and MD with the same settings(speed, dup) though
I will reset all ports on the 3550 to the default configuration as suggested, but I'll leave the portfast enabled on the client ports.

Quote
sh int afterwards is fine. for both of the interfaces. Lots of Runts and drops are not good.
Take a quick look in the syslog as well just to make sure(that all is ok with the 3550).

Not sure how to do a similar in linux though =/ but that will give some hints if this is related to the network which I actually doubt.

(hari posted some nice commands to be run as well)

I plan to reload the server again tonight and try both Hari, and your suggestions. 

Quote
Btw, I assume you have everything on the inside of the Core, as recommended?
If you are referring to media directors and all that stuff being on the correct side of the core, then yes.  I have followed all recommendations as closely as possible on my configuration. 

Quote
Is it easy for you to move(copy) the same Movie to the hdd of the Core and view it from there as well?

Just to easily eliminate eventual troublecausers.
All my movies exist on the core.  I use the media directors as well as the core itself to rip movies.  I guess I am not sure what you mean?

Quote
Also I posted a while ago about twitchy playback and got the recommendation to not use alpha blending.. Try changing that.(in case you are)
I was a passionate viewer of that thread! :) as I had hoped that it would also uncover my issue. Immediately after it was suggested, I had turned off the alpha blending, but did not see any improvement.  I cried a little inside. :'(





Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 25, 2008, 01:54:25 am
Results from show interface after the first hiccup.  More to come.

Quote
test3550#show int gigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000f.23a9.dc81 (bia 000f.23a9.dc81)
  MTU 2000 bytes, BW 10000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseTX
  input flow-control is off, output flow-control is on
  ARP type: ARPA, ARP Timeout 04:00:00
  1000BaseT module (WS-G5483) in GBIC slot.
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 902000 bits/sec, 681 packets/sec
  5 minute output rate 8491000 bits/sec, 972 packets/sec
     560193 packets input, 124061300 bytes, 0 no buffer
     Received 122 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 41 multicast, 0 pause input
     0 input packets with dribble condition detected
     768301 packets output, 827748511 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
test3550#show int gigabitEthernet 0/12
GigabitEthernet0/12 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000f.23a9.dc8c (bia 000f.23a9.dc8c)
  MTU 2000 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 2/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is on
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 9211000 bits/sec, 1241 packets/sec
  5 minute output rate 1378000 bits/sec, 983 packets/sec
     988008 packets input, 910853215 bytes, 0 no buffer
     Received 7563 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     800396 packets output, 178362238 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 25, 2008, 02:56:37 am
I started a packet capture after the movie was going for a bit.  The following is what I see after the movie studders for a moment:

mii-tool shows the following:
Quote
eth0: negotiated 100baseTx-FD, link ok
eth1: negotiated 100baseTx-FD flow-control, link ok
My core is running gigabit though, so shouldn't this show up as such?

cat/proc/interrrupts on the core shows:
Quote
dcerouter_1:~# cat /proc/interrupts
           CPU0       CPU1       CPU2       CPU3
  0:       5040       5664     271228   22644729   IO-APIC-edge      timer
  1:          0          0          0         10   IO-APIC-edge      i8042
  8:          0          0          0          0   IO-APIC-edge      rtc
  9:          0          0          0          1   IO-APIC-fasteoi   acpi
 12:          2          1         76       8192   IO-APIC-edge      i8042
 14:         30         73       8956     453140   IO-APIC-edge      ide0
 16:          0          0          0        293   IO-APIC-fasteoi   ohci_hcd:usb1, HDA Intel
 17:       1070       1177     214978   51339817   IO-APIC-fasteoi   ohci_hcd:usb2, ohci_hcd:usb4, eth0
 18:       1089       1017      49495    4670493   IO-APIC-fasteoi   ohci_hcd:usb3, ohci_hcd:usb5, nvidia
 19:         94        251      47362    3870708   IO-APIC-fasteoi   ehci_hcd:usb6, 3w-9xxx
 21:          8         10       1396     141982   IO-APIC-fasteoi   eth1
 22:          0          0          0          0   IO-APIC-fasteoi   ahci
 23:          0          0          0          3   IO-APIC-fasteoi   ohci1394
NMI:          0          0          0          0
LOC:   22926590   22926525   22926544   22926509
ERR:          0

show int gi0/12 (core) and gi0/1 (Media Device)
Quote

test3550#show interfaces gigabitEthernet 0/12
GigabitEthernet0/12 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000f.23a9.dc8c (bia 000f.23a9.dc8c)
  MTU 2000 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 2/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is on
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 10436000 bits/sec, 1331 packets/sec
  5 minute output rate 1100000 bits/sec, 1004 packets/sec
     5266411 packets input, 741758640 bytes, 0 no buffer
     Received 60087 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 20 multicast, 0 pause input
     0 input packets with dribble condition detected
     4062890 packets output, 629197124 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
test3550#show interfaces gigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 000f.23a9.dc81 (bia 000f.23a9.dc81)
  MTU 2000 bytes, BW 10000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Full-duplex, 1000Mb/s, link type is auto, media type is 1000BaseTX
  input flow-control is off, output flow-control is on
  ARP type: ARPA, ARP Timeout 04:00:00
  1000BaseT module (WS-G5483) in GBIC slot.
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 651000 bits/sec, 684 packets/sec
  5 minute output rate 9693000 bits/sec, 1044 packets/sec
     2814020 packets input, 396925632 bytes, 0 no buffer
     Received 158 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 57 multicast, 0 pause input
     0 input packets with dribble condition detected
     4146275 packets output, 377667857 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
test3550#

Wireshark is a bit huge, so I'll try and sort it to what looks to be the issue.
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: hari on October 25, 2008, 08:20:12 am
I started a packet capture after the movie was going for a bit.  The following is what I see after the movie studders for a moment:

mii-tool shows the following:
Quote
eth0: negotiated 100baseTx-FD, link ok
eth1: negotiated 100baseTx-FD flow-control, link ok
My core is running gigabit though, so shouldn't this show up as such?
yes, it should. Replug the cable (or shut/unshut the switchport) and see if autoneg works. Worst case you have to use fixed settings (Use "ethtool -s ethX speed 1000 duplex full" on the linux side and revert to the old duplex/speed settings on the switchport)

Please show me the ifconfig output of the NICs on the linux hosts.

best regards,
Hari
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 25, 2008, 05:58:33 pm
Here is the ifconfig output pf the NICs on the linux core:

Quote
dcerouter_1:/home/linuxmce# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1D:92:B6:99:6B
          inet addr:192.168.80.1  Bcast:192.168.80.255  Mask:255.255.255.0
          inet6 addr: fe80::21d:92ff:feb6:996b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7359526 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9313628 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1442576109 (1.3 GB)  TX bytes:6700041446 (6.2 GB)
          Interrupt:17 Base address:0x8000

eth1      Link encap:Ethernet  HWaddr 00:0E:0C:A2:23:D3
          inet addr:192.168.0.56  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20e:cff:fea2:23d3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:165369 errors:0 dropped:0 overruns:0 frame:0
          TX packets:128543 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:192231471 (183.3 MB)  TX bytes:19128842 (18.2 MB)
          Base address:0xe400 Memory:febc0000-febe0000

I can't get the results from the media director though because it apparently doesn't use the same password for su that the core is using?
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: freymann on October 25, 2008, 07:27:47 pm
I can't get the results from the media director though because it apparently doesn't use the same password for su that the core is using?

On the core, issue a:

sudo -i

and then just

ssh moon##

to the MD... Get the Media Director's number from the web admin...
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: Stutch on October 25, 2008, 07:41:34 pm
Outstanding.  Here is the Media Director ifconfig result:

Quote
root@moon72:~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1D:92:0F:44:D8
          inet addr:192.168.80.3  Bcast:192.168.80.255  Mask:255.255.255.0
          inet6 addr: fe80::21d:92ff:fe0f:44d8/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:392239 errors:141 dropped:0 overruns:0 frame:141
          TX packets:307922 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:409797850 (390.8 MB)  TX bytes:95461943 (91.0 MB)
          Interrupt:20 Base address:0x8000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1368 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1368 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:88740 (86.6 KB)  TX bytes:88740 (86.6 KB)
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: hari on October 25, 2008, 11:05:39 pm
match MTU (2000 on the switchport vs 1500 on linux, use 1500 everywhere for now) and duplex. I'd assume the framing errors shown in the ifconfig output relate to that.

best regards,
Hari
Title: Re: Ripped DVD Playback Preformance Issues- Network maybe?
Post by: johanr on October 26, 2008, 12:19:25 am
All my movies exist on the core.  I use the media directors as well as the core itself to rip movies.  I guess I am not sure what you mean?

Ok, my bad. I thought you where using an external hdd for the movies.

Weird that the Core and MD doesn't accept the speed or wants slower speed to be used.
And the 3550 doesn't seem to bother..

By clearing the interfaces I meant the clear counters interface .... command

Is it me that needs to do my homework or shouldn't the eth0 at the core be external ?
 I know I have read something about that and that it was recomended because of how the dcerouter was "designed" to work.

Lets see what can be found from the wireshark.

Thank's hari for the commands.
 I am writing it all down for future use. Just don't understand the output(what to look for) of cat/proc/interrupts

-johan