LinuxMCE Forums

General => Installation issues => Topic started by: gaspala on October 23, 2008, 02:45:49 am

Title: 110 baud rate for Olevia 537H LCD
Post by: gaspala on October 23, 2008, 02:45:49 am
Hi,

I have Olevia 537H LCD that has a serial port. This TV accepts commands from serial port at 115200 baud rate. However, the initial "power on" command needs to be sent at 110 baud rate. I have verified this functionality using Windows XP.

/usr/pluto/bin/TestSerialPort command does not accept 110 as a baud rate.

Is there any other way to send data on serial port at 110 baud rate ?

Your help is very much appreciated.
Title: Re: 110 baud rate for Olevia 537H LCD
Post by: tschak909 on October 23, 2008, 03:58:20 pm
110 bps?!?!?!?!

that's an old teletype transmission rate for TDD's!

what the...

-Thom
Title: Re: 110 baud rate for Olevia 537H LCD
Post by: PeteK on October 26, 2008, 03:43:29 pm
Do you have the ICD for this TV?  I've got a 232T that takes everything at 115K.  Can you post a copy of the ICD?

Thanks,
-Peter
Title: Re: 110 baud rate for Olevia 537H LCD
Post by: gaspala on October 27, 2008, 07:31:22 pm
I am not sure what you mean by ICD.
Title: Re: 110 baud rate for Olevia 537H LCD
Post by: Monkgs on October 30, 2008, 02:04:01 pm
Hi,

I have Olevia 537H LCD that has a serial port. This TV accepts commands from serial port at 115200 baud rate. However, the initial "power on" command needs to be sent at 110 baud rate. I have verified this functionality using Windows XP.

/usr/pluto/bin/TestSerialPort command does not accept 110 as a baud rate.

Is there any other way to send data on serial port at 110 baud rate ?

Your help is very much appreciated.


The Olevia 537H manual doesn't mention anything about sending the power on command at 110 baud. My Olevia 747i didn't require anything like that. Perhaps you need to play with your codes a little. This model seems to be pretty funny, requiring an initial sequence of characters to negotiate the port speed and then pauses in between ever two bytes.

From what I understand of the manual a basic power on sequence would look like this:

0x02 0x00 0x00 0x13 0x01 0x00 <delay 8ms> 0x50 0xBE <delay 8ms> 0x50 0xEF <delay 8ms> 0x50 0x25 <delay 8ms> 0x50 0x00 <delay 8ms> 0x50 0x29

You can take a look at the device template I made for the Olevia 747i. Yours will probably be similar. http://wiki.linuxmce.org/index.php/Olevia_700_Series_LCDs (http://wiki.linuxmce.org/index.php/Olevia_700_Series_LCDs)