LinuxMCE Forums

General => Installation issues => Topic started by: nxqd on August 03, 2008, 12:15:07 am

Title: Unable to Install, tried EVERYTHING... HELP!
Post by: nxqd on August 03, 2008, 12:15:07 am
I have been at this for weeks, read all to forum and wiki pages and tried just about every combination of hardware and software changes to make this work but I still can't get a working LinuxMCE system on my computer. PLEASE HELP ME! :(

My Specs:
abit n76hd (onboard Nic 10/100000, onboard nvidia 8200gs with DVI, HDMI and VGA, onboard sound, etc etc) BIOS up to date
2.7 AMD X2 (dual core) 64 bit
4gb ram, 120gb IDE and 750 SATA, Hauppage150 tuner, Atheros Wifi 802.11g PCI card.
ATI Radeon PCI graphics card (256 or 512 dont know)
Nvidia 8500 GT PCI Express card

To preface this machine runs Vista, blech :( just fine with no problems. Kubuntu 8.04 works PERFECTLY on it with ALL onboard video, sound and nic operating perfectly. OSX86 Kalyway also works great as well if you are interested. I have tried MythTV and its various distrobutions but I really want the features and functions that MCE offers so begins my quest... Here is what I have done so far with the results I got:

1) Tried installing to the SATA (and IDE) drive via the downloaded (and MD5 checked) DVD iso burned at 1x with the onboard HDMI (and tested with DVI, VGA and DVI with VGA converter) my bios appears correctly and I am able to choose memory test (checks out fine) and select the install LinuxMCE AMD64 version, I select this and my screen goes dark, I have waited for <15 minutes and nothing ever appears on screen.

2)Installed the ATI PCI card, I am able to see the installation screen and can install to my IDE drive, SATA drive is not seen at all, DVD installs correctly and I am able to progress through the AV Wizard but I can only get UI1 to work. I install Nvidia drivers and reboot, AV Wizard never starts up again, X is unable to start message appears onscreen. Xorg.conf file checks out fine with no errors and nothing out of the ordinary that I could see.  This works, but I cannot see the new UI (becuase its ATI) nor does my onboard NIC, sound or of course Nvidia card work. Wifi card does work. Kubuntu 8.04 sees all my stuff fine so I believe this is due to a more updated kernel in the later version of Kubuntu. Closer, but disappointing...

3) Install Kubuntu 7.10 bare from kubuntu website. Again SATA drive, onboard NIC, sound and nvidia not recognized. Updated and installed nvidia drivers tested them rebooted and everything works. Downloaded (and MD5 checked) the AMD64 iso files from as well as Kubuntu AMD64 7.10 iso (also MD5 checked). Tried installing via the CD, both LinuxMCE isos check out fine but the Kubuntu is unable to cache, I have tried Kubuntu 7.10 x86 and AMD64 versions with the same result. Perhaps there is a Installer approved 7.10 iso that someone could point me towards, I am downloading direct of the kubuntu website, wala wala washington USA ftp site.

4) Purchased a Nvidia 8500 GT PCI express card thinking that perhaps it wouldnt see the onboard but a external one would work better. Same results as #1 each way I try it. It should be noted that My abit motherboard and this card work together to provide better graphics support (I have tested with this function turned off and on in my bios). DVD installer goes to a black screen after I choose to install. Tested via the VGA and DVI port and with a DVI/VGA adapter.

I am confident I can get the onboard sound, nic and sata working once I actually have a usable system with the nvidia drivers. If ANYONE has any ideas or insight as to how I can get this running with UI2 through my nvidia onboard I would be most appreciative. Thanks!
Title: Re: Unable to Install, tried EVERYTHING... HELP!
Post by: justdeb on August 03, 2008, 02:36:22 am
Whilst i am no expert in this forum - i have loaded lmce so many times due to things i was breaking - due to lack if experience. I have never got the DVD to work - don't know why so i did it all by CD. Whilst it is longer it works fine. Can you tell me the steps u take after installing kbuntu? (ie changing video card, audio settings) When u install the first cd what happens?

Title: Re: Unable to Install, tried EVERYTHING... HELP!
Post by: colinjones on August 04, 2008, 04:16:52 am
It does sound like you are having problems with very recent mobo hardware and specifically the onboard graphics.

You don't mention what you did when you installed the ATI or nVidia cards to select them. If you just plug them in and start up, then it definitely will not select them and just use the onboard graphics which would certainly explain why you are getting identical symptoms no matter which graphics chipset you (think) you are using...

Option 1 is to disable the onboard graphics in the BIOS. NOTE: merely telling it that the graphics card (ATI or nVidia) are primary is not enough, you have to actually disable the chipset and some BIOSs do not have that option!

Option 2 is to change the chipset X is using manually, but that kind of requires that the install has completed first!

If it is just a graphics problem then you can still complete the install first, but it will be in the dark! Really, you only need to hit a few keys to kick it off - perhaps someone can detail them for you if they happen to be doing an install right now? I don't want to because it would be from memory.... :) just be sure the drive is blank with no partitions you want to keep

The install will take at least 40 mins, and you should see lots of HDD activity. You will know it has finished when it ejects the DVD. At that point you hit Enter to reboot. Normally, it would boot up into the AVWizard - you want this to happen so that X has at least created the xorg.conf file - as you can't see anything you will just have to leave it for a good 10mins to make sure it got that far, then reset the machine. Once the BIOS completes the Power ON Self Test, you will see the GRUB boot program about to load the kernel with a ~2 second count down. Hit Esc to go into the GRUB boot menu (quickly reset or power cycle the machine if you miss it).

You can now choose the recovery mode. It will load the kernel in single user mode and give you a command line. Do an lspci and look for your graphics card and onboard chipset. Each will have a PCI Bus ID number, eg 0:0:18 and 2:0:1

Now edit your xorg.conf file and look for the device section - it specifies the PCI BusID parameter - if my theory is correct, then it will have the ID for the onboard chipset still. You need to edit it for the card's ID instead.

This will potentially still leave you with no display between the BIOS POST completing and X starting up, but at least you should be able to continue from there. If you do have a Primary graphics setting in your BIOS, and no disable option, then do at least set that, as that should solve this "hole in the middle" issue as well.
Title: Re: Unable to Install, tried EVERYTHING... HELP!
Post by: nxqd on August 04, 2008, 05:30:05 pm
As far as the actual installation, I tell my BIOS to init the ATI PCI card FIRST, this allows me to see everything on screen and install with no problems, however I can just use UI1. Once I have a working machine via UI1 I can install the Nvidia driver, reconfigure X, reboot, disable the ATI card and from here I SHOULD get to see Kubuntu OR LinuxMCE wizard via my Nvidia, nothing appears. I have also reconfigured my xorg.conf.pluto.avwizardr file to reflect the nvidia driver.

My problem is not getting the actual distro installed, its getting it installed using Nvidia (if all I wanted was UI1 with the ATI I would be done).

I will give those steps a shot and see if they offer any different results.

!!If ANYONE could point me to a AMD64 Kubuntu 7.10 ISO that WORKS with the CD install please point me to it, the error I get while installing via CD appear to be an invalid CD ISO (MD5 checks out fine)

Also, is there a 'preffered' nvidia driver over nvidia-glx-new or the nvidia drivers located on the nvidia site for AMD64 ( I have tried both with 0 sucess)

Also Also, is there a better method to reconfiguring xorg.conf OTHER than use nvidia-xconfig?

Title: Re: Unable to Install, tried EVERYTHING... HELP!
Post by: colinjones on August 05, 2008, 07:14:58 am
Yes, use a text editor like Joe or even vi - I would not use the config tool from nVidia as you have no idea what it is going to do and the file is big enough that you could easily miss a small but important change. I only ever use Joe - you have complete control and there are rarely more than 3-4 lines that need changing anyway, even if you are customising your own modelines....
Title: Re: Unable to Install, tried EVERYTHING... HELP!
Post by: seth on August 05, 2008, 01:18:15 pm

Just my 2 cents. I have tried the AMD64 install with many versions. I have since then reverted back to the standard x86/i386 install. For the little bit of performance you  may or may not gain, in the long run the x86 version just works. I initially kept returning to the AMD64 version, with each release, as I wanted my USB-UIRT to work w/out blaster dongles. I have posted the fix in the wiki to get it to work again with the x86 versions.

Traditionally hardware, and software support is very limited with AMD64 releases, initially, until more of the devs get their hands on unique hardware. So for now to save some trouble, money on beer, and your hair, try the x86 version.

Just give it a go  ;)



Title: Re: Unable to Install, tried EVERYTHING... HELP!
Post by: nxqd on August 10, 2008, 12:01:38 am
Well seth, you may have done it. I downloaded the i386 DVD and burned it, booted off it just now and can report that my onboard Nvidia video card is working right off the bat (GREAT sign). I am doing a complete installation right now and will report my findings...