LinuxMCE Forums

General => Users => Topic started by: lightman on July 12, 2008, 12:46:40 am

Title: Cannot access linuxmce samba shares from XP machines.
Post by: lightman on July 12, 2008, 12:46:40 am
Hello.
I have been reading all I could find about this, and playing with smb.conf but no luck... so I decide to ask for help :)

I'm trying to access from the XP machines the /home from the linuxmce machine so I can upload content.

I edited smb.conf and added:
Code: [Select]
workgroup = HOME
comment = Linux Media Center
security = SHARE
guest ok = yes

Leave the rest as It was, and sometimes I can see the share from the XP machines but when i try to enter it says: you don't have access to this resource.

Now it never asks for password, so I'm not sure if this is the problem.

I have a home network, with a linksys router, and all the machines conected to the lan (Linuxmce included), I even tried to use the IP obtained via DHCP from the router with no sucess. (\\192.168.0.144 for ex, frm the run box in xp).

any ideas?, I am missing something?, maybe a firewall blocking it?, but if there is a firewall why can I see the samba name in the workgroup?.

thanks in advance.
Light
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: hari on July 12, 2008, 12:57:38 am
why do you want to use share level security?

best regards,
Hari
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: agentsmith on July 12, 2008, 01:05:38 am
Hey Light,

I was able to get to mine with the following settings:
Firewall Disabled:  from the admin site Advanced > Network > Firewall Rules and check the box that says "Firewall Disabled"
Added the following to my smb.conf under the [public] section
Code: [Select]
        public = yes
        guest ok = Yes
        browseable = Yes

I still get the login box but just entered in linuxmce for the username and entered the password I set at setup.
Hope this helps
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: lightman on July 12, 2008, 01:16:41 am
why do you want to use share level security?

best regards,
Hari
Hello Hari, thanks for answer.

Because It's on a LAN and It's a home network so it's suppose to be secure :D  (I don't want to have to add users and passwords, just allow everyone on the LAN to access the media files for R/W. mainly because I thought that it would be difficult to do it otherwise) anyway it doesn't work so I can take it out :) at this point i don't care if I have to use password or not, just want to have access the the /home so I can upload content :)

Quote from: agentsmith
Hey Light,

I was able to get to mine with the following settings:
Firewall Disabled:  from the admin site Advanced > Network > Firewall Rules and check the box that says "Firewall Disabled"

Thanks agentsmith!!, that was it!, I didn't know from "where" turn off the firewall.

I can see the shares now, but in Read only, and still doesn't ask for a password :( so I cannot upload anything.

what could that be?, should I chmod the entire /home for public group?, would that allow me to upload something?.

thanks!
Light
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: tschak909 on July 12, 2008, 01:37:50 am
Why are you people butchering your setups?!

(1) make sure you have the appropriate network setup, two NIC cards, your core is the center of the network, handling firewall, dhcp, gateway.. make sure your other pc's are on the internal NIC card.

(2) when logging into the dcerouter share, use the username and password you use to log into the web admin

very simple, guys.
stop fucking up your setups.

-Thom
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: colinjones on July 12, 2008, 02:04:43 am
To expand on Thom's comments:

If your PCs are on your "internal" network, then the firewall is NOT relevant, the internal NIC is open access - do not disable your firewall!

If your PCs are on your "external" network, then add a firewall rule to allow access. Port 445/TCP - again, do not disable your firewall - what is the point? This is the sledgehammer approach.

After that, use the credentials as Thom outlined...
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: lightman on July 12, 2008, 04:53:56 am
Why are you people butchering your setups?!

(1) make sure you have the appropriate network setup, two NIC cards, your core is the center of the network, handling firewall, dhcp, gateway.. make sure your other pc's are on the internal NIC card.

(2) when logging into the dcerouter share, use the username and password you use to log into the web admin

very simple, guys.
stop fucking up your setups.

-Thom


Hi tschak909

You cannot expect that I will modify the way things works in my house because suits the needs of the equipment, it's the other way around, equipment should reflect the need of the user.

I have specially made servers that works from 12VDC, same as the router, swtiches, VOIP interfases and 100% of communication devices in my home because here brownouts are commonday issues, so i cannot use this equipment to act as a router, not to mention the services I'm already hosting that would require to modify LMCE to do what I do today with the router (dyndns, ftp server, VPN server, asterisk with an already working dialplan, etc).

If there is no easy way to make it work without passwords, I'll use username and passwords, that's something I can live with :D but there is no way that I will put an expensive machine that draws more than 300W, 24hs active, just because the setup was made that way, when I can do better with 10% of that power and operate on batteries when power goes out and leaves LMCE to do what I think it's made to do, a Media center machine, not a server/gateway.

EDIT: Maybe I can disable DHCPd, and modify network settings, so I can operate on the "default LAN side of LMCE" but I would to modify routes anyway so It can connect to the internet using the lan side, thinking about this, maybe it's easier the way I already done it, disabling the firewall, anyway there is no point having a firewall when I already have a very good one, i don't know what of the two options do you think that will make "less mess" to this box :D hehe
thanks
Light
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: tschak909 on July 12, 2008, 04:57:38 am
but this system ISN'T just a media center, it's a smart home solution. Why don't you either:

(1) use it the way it's meant to be used, or
(2) help us adapt it to other use cases

oh wait, i forgot, you obviously know better than what we're doing, because you're throwing a sledgehammer through the samba installation and setting it to security=share....

-Thom
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: golgoj4 on July 12, 2008, 05:02:19 am
Why are you people butchering your setups?!

(1) make sure you have the appropriate network setup, two NIC cards, your core is the center of the network, handling firewall, dhcp, gateway.. make sure your other pc's are on the internal NIC card.

(2) when logging into the dcerouter share, use the username and password you use to log into the web admin

very simple, guys.
stop fucking up your setups.

-Thom


Hi tschak909

You cannot expect that I will modify the way things works in my house because suits the needs of the equipment, it's the other way around, equipment should reflect the need of the user.

I have specially made servers that works from 12VDC, same as the router, swtiches, VOIP interfases and 100% of communication devices in my home because here brownouts are commonday issues, so i cannot use this equipment to act as a router, not to mention the services I'm already hosting that would require to modify LMCE to do what I do today with the router (dyndns, ftp server, VPN server, asterisk with an already working dialplan, etc).

If there is no easy way to make it work without passwords, I'll use username and passwords, that's something I can live with :D but there is no way that I will put an expensive machine that draws more than 300W, 24hs active, just because the setup was made that way, when I can do better with 10% of that power and operate on batteries when power goes out and leaves LMCE to do what I think it's made to do, a Media center machine, not a server/gateway.

EDIT: Maybe I can disable DHCPd, and modify network settings, so I can operate on the "default LAN side of LMCE" but I would to modify routes anyway so It can connect to the internet using the lan side, thinking about this, maybe it's easier the way I already done it, disabling the firewall, anyway there is no point having a firewall when I already have a very good one, i don't know what of the two options do you think that will make "less mess" to this box :D hehe
thanks
Light

wow. did ya see the video? maybe read some docs? Sounds like your using the wrong tool for the job your attempting to do.

Square Peg, Round Hole, you do the math. :-\
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: lightman on July 12, 2008, 05:12:53 am
but this system ISN'T just a media center, it's a smart home solution. Why don't you either:

(1) use it the way it's meant to be used, or
(2) help us adapt it to other use cases

oh wait, i forgot, you obviously know better than what we're doing, because you're throwing a sledgehammer through the samba installation and setting it to security=share....

-Thom
First off, man, sorry if I offend you, It wasn't my goal at all, just speaking my mind, and maybe a little loud, sorry for that :)

Option 2 is not a bad idea, I will be glad to help, but I need A LOT of hours with this to be ready to help in some way :), but i will love to.

You are right, the difference is that it was meant to be a smart home solution, and I try to have just a Media Center, i don't need the rest, when I saw the video, I just focus on what interested to me, and that was a media center.

I wish I know that much, but not even close, I'm a hardware guy :D i understand machine code and electronics very well, I can barely handle C, anything more "high level" and I'm completely lost :(

again sorry if I piss some of you off, it wasn't my intention, just wanna make things work :)
Light
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: tschak909 on July 12, 2008, 05:14:03 am
then please. Try it our way.

our way actually works, believe it or not.

-Thom
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: agentsmith on July 12, 2008, 08:34:47 am
Hey Thom,

Thanks for the info.  I didn't mean to suggest an option that would start folks duking it out on the net.  Let me first admit that I'm a noob and have been trying to learn so that I can contribute more than mayhem, not quite there yet.  I don't want to tick anyone off any more, but could you help me understand why it is that it's so important that LinuxMCE be the DHCP server for the whole house?  Is it just because it is a "whole house automation" system?  Don't get mad, I'm not questioning anything, just want to understand and yes if there is a doc I missed feel free to point it out and I'm all over it.

Thanks to all you guys that make this project happen, I Love it and I'm in for life, if ever I can help lemme know. :P
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: totallymaxed on July 12, 2008, 09:52:36 am
Hey Thom,

Thanks for the info.  I didn't mean to suggest an option that would start folks duking it out on the net.  Let me first admit that I'm a noob and have been trying to learn so that I can contribute more than mayhem, not quite there yet.  I don't want to tick anyone off any more, but could you help me understand why it is that it's so important that LinuxMCE be the DHCP server for the whole house?  Is it just because it is a "whole house automation" system?  Don't get mad, I'm not questioning anything, just want to understand and yes if there is a doc I missed feel free to point it out and I'm all over it.

Thanks to all you guys that make this project happen, I Love it and I'm in for life, if ever I can help lemme know. :P

Why not try the Wiki ;-)

Look here; http://wiki.linuxmce.org/index.php/DHCP_Plug_and_Play (http://wiki.linuxmce.org/index.php/DHCP_Plug_and_Play)

This is only the 500'th thread that touches on this stuff... and to Thom has been faithfully responding in most of those threads! LinuxMCE was designed from the ground up to work this way... if you dont like that then you can always re-code it (its open source ;-) ) or use another software solution.

Andrew
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: colinjones on July 12, 2008, 04:30:30 pm
wow andrew, this is the first time I've ever seen you get tetchy :)

He's (and Thom's) right Mr Smith... the subject is v old so forgive me if I seem abrupt, but been saying the same thing for such a long time, and the wiki and forums do have such a lot of info on this stuff....  there really are so many reasons for it, and whilst it is easy to say "I don't want to do it that way" (although I note that you aren't saying that, you just want to understand) When so much has been put into using the current infrastructure because it allows so many things to work, when others come along and try to re-engineer the system ... that's fine... but at the same time expecting support in the process is a bit much.

My approach is, either accept it the way it was designed to work, or learn how to change it (its open source after all!) It is easy to criticise, but I wouldn't do that with anything at least until I understand the basics of why things were done the way they were. Doesn't mean that they can't be done better, but I don't presume to know that until I understand it better ;)
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: agentsmith on July 14, 2008, 03:15:00 pm
Makes perfect sense, sorry for adding to the frustration but on that note, thanks for taking the time to explain.  I'll be sure to review the docs.
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: Enigmus on August 14, 2008, 09:03:43 pm
Why are you people butchering your setups?!

(1) make sure you have the appropriate network setup, two NIC cards, your core is the center of the network, handling firewall, dhcp, gateway.. make sure your other pc's are on the internal NIC card.

(2) when logging into the dcerouter share, use the username and password you use to log into the web admin

very simple, guys.
stop fucking up your setups.

-Thom


Actually this is a problem for me.  The DCErouter Share does not use the usernames and passwords for Samba Shares by default.  It appears to user Pluto_<Username> and the passwords are unset.  I have to manually set the password with smbpasswd.  When any of the LinuxMCE systems restart I have to reset the passwords.  Does anyone know how to correct this?  I'm using .710 64bit on the core.  Thanks.
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: colinjones on August 15, 2008, 01:04:11 am
No you don't need to do that. If you have done it, then Windows is probably remembering something. Delete any shares you have connected to (even ones that don't have a drive letter associated with them). Make sure your PCs are in the LinuxMCE workgroup and reboot. Then just browse through Network Neighbourhood down until you get to the LinuxMCE workgroup, expand that and you will see all the shares, expand them, etc, etc....
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: Enigmus on August 15, 2008, 05:46:54 pm
Ok, and I use <username> rather then Pluto_<Username>?
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: colinjones on August 15, 2008, 11:19:52 pm
I have never been prompted for user name and password for the samba shares, I just browse straight in, no problem. I assumed that was normal.
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: Enigmus on August 18, 2008, 10:08:09 pm
BTW, Thank you for lending me a hand on this Colin.

Can you think of anything else that you do differently on your setup?  I am still having the same issues.  This is what I have done.  I have changed the Workgroup on my XP system to linuxmce and I have attempted to access shares on the Core system.  It still does not let me connect without a username or password and it does not respond to either my <username> or Pluto_<Username> without me setting the smbpasswd on the core system.  The password clears every time the core or any of the diskless MDs restarts.

If anyone has any suggestions, I'm open to them. :)

Thanks.
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: colinjones on August 18, 2008, 10:49:57 pm
Sorry, haven't really done anything in that space, and my password for Windows is different than LMCE, although the username is the same "colin", seems unlikely but Windows sometimes tries to authenticate as the "current user", if LMCE doesn't require the password to match due to some weird permissions (something similar happens accessing XP's shares) then perhaps that's how mine is getting it - but seems a very long shot! Windows firewall isn't on is it?
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: rodercot on August 19, 2008, 12:01:07 pm
 When I access any windows machine with an lmce share THAT IS NOT dcerouter (core) on windows, I need no password if I access the dcerouter computer share from windows for the first time in a session windows asks for a user and pass - This is the password that lmce gave you for accessing your private directories, webadmin, phone messages etc.. It works everytime I use it but only need once per reboot on the windows machine and only if I access the core computer share(dcerouter) Which I hardly EVER do from within windows, I usually use a putty for this.

 All my pc's and xbox's and Blu-Ray LG BH200 drive are on the internal network with one laptop on the external.

 rgds,

 Dave
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: Enigmus on August 21, 2008, 11:58:16 am
Rodercot,

  Your talking about the default samba user not any user you created, right?
Title: Re: Cannot access linuxmce samba shares from XP machines.
Post by: Enigmus on December 29, 2008, 04:59:48 pm
Ok, for anyone interested I have resolved my issue.  Apparently, the SMB/CIFs part of the linuxmce does not like special characters in passwords.  If you use a password with special characters (like: #$%^&*@!) it will work in the web interface and everywhere else except with the SMB/CIFs shares.  Simply changing the password in Linuxmce and on your windows system to simple alpha numerical characters will solve the issue.