LinuxMCE Forums

General => Installation issues => Topic started by: nikrolls on June 14, 2008, 06:19:50 am

Title: 710RC2 CD Caching Issue
Post by: nikrolls on June 14, 2008, 06:19:50 am
Hi there,

I've been trying to install LinuxMCE 710 RC2 from CDs for a little while now, to no avail. Installation from DVD works fine, but I'm not a big fan of the Kubuntu setup it uses. I've installed Kubuntu 710 from the LiveCD, made sure the settings (primarily WiFi) are right, and went to install LMCE from the CDs following the installation instructions on the Wiki. However I always come up with the error "Could not cache LMCE CD 1". There is plenty of space (160GB), I've made sure there are full permissions on all of the ISOs, and still it doesn't work. I've included the log, hopefully someone here will have an idea of what I can do.

Code: [Select]
/usr/pluto/deb-cache /tmp/selfextract.JJ6207
Use of uninitialized value in require at controllib.pl line 13.
Use of uninitialized value in require at controllib.pl line 13.
Can't locate dpkg-gettext.pl in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl . /usr/lib/dpkg ) at controllib.pl line 13.
Compilation failed in require at ./dpkg-scanpackages line 15.

I have four logs from four different installation attempts and they are all identical, apart from the selfextract suffix. There's quite possibly something obvious staring everyone in the face (missing package, maybe?), but I don't know enough about it to figure it out.

Cheers for your help.
Title: Re: 710RC2 CD Caching Issue
Post by: SalK on June 14, 2008, 12:35:33 pm
Hi!

I also has this problem. My disk is 6.5 gb and my iso files are on another disk. I used cd version because I dont want my hd to be erased. I have checked for badblocks and retried the installation many times. As for nikrolls I have exact same problems every time. Could someone please help us! Here is my log:

"salk@salk-laptop:~$ cat /var/log/mce-installer-1212873675.log
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-sample-media_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-sdl-helpers_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-serializeclass_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-shiftstate_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-simplephone_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-skins-basic_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-slimserver-plugin_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-sound-card-scripts_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-sql2cpp_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-src-vloopback_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-std-plugins_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-system-database_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-test-serial-port_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-tira-wrapper_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-tribunetv_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-updatemedia_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-usb-uirt-0038_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-wavetrend-reader_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-vdr_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-website-admin_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-windowsce-libraries_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-vipshared_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-vloopback_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-voicemail-monitor_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-xine-player_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-xml-data-plugin_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-x-scripts_2.0.0.44.0804112200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/pluto-zwave-lighting_2.0.0.44.0804202200_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/qt3-dev-tools_3%3a3.3.8really3.3.7-0ubuntu11_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/samba_3.0.26a-1ubuntu2_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/samba-common_3.0.26a-1ubuntu2_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/slimserver_6.5.4_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/smbclient_3.0.26a-1ubuntu2_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/spcp8x5_0.2_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/swig_1.3.31-1ubuntu3_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/tcl8.4_8.4.15-1build1_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/tee-pluto_1.0_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/transcode_2%3a1.0.2-0.8ubuntu5_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/ttf-dejavu_2.19-1ubuntu3_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/ttf-freefont_20060501cvs-12_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/ttf-kochi-gothic_1.0.20030809-4ubuntu2_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/ubuntu-mythtv-frontend_0.20.2-3lmce710.0_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/ushare_0.9.6-1_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/vdr_1.6.0-1-LMCE0710-7_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/vdr-dev_1.6.0-1-LMCE0710-7_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/vdr-plugin-control_0.0.2a-35-lmce07.10-7_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/vdr-plugin-xineliboutput_1.0.0~rc2-cvs-LMCE0710-8_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/vim-runtime_1%3a7.1-056+2ubuntu2_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/vlc_0.8.6.release.c-0ubuntu5_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/vlc-nox_0.8.6.release.c-0ubuntu5_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/xfonts-100dpi_1%3a1.0.0-3_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/xfonts-75dpi_1%3a1.0.0-3_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/xfonts-base_1%3a1.0.0-4_all.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/xfwm4_4.4.1-2ubuntu2_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/xineliboutput-fbfe_1.0.0~rc2-cvs-LMCE0710-8_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/xineliboutput-sxfe_1.0.0~rc2-cvs-LMCE0710-8_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/xine-ui_0.99.5-2build1_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/xserver-xorg-core_2%3a1.3.0.0.dfsg-12ubuntu8_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/zaptel-modules-2.6.22-14-generic_1.4.3~dfsg-2ubuntu1+2.6.22-14.46_i386.deb": In/ut-fel
cp: läser "/tmp/tmp.ogLhBO6457/deb-cache/zenity_2.20.0-0ubuntu1_i386.deb": In/ut-fel
salk@salk-laptop:~$"
Title: Re: 710RC2 CD Caching Issue
Post by: pigdog on June 14, 2008, 03:47:04 pm
Hi,

Have you copied the .iso disks (CD1,CD2,Kubuntu) to your hard drive?

If not look for a post called "Installing LMCE on a standalone Core".

Hope this helps.

Cheers.
Title: Re: 710RC2 CD Caching Issue
Post by: SalK on June 14, 2008, 04:18:04 pm
I have copied iso files to another harddrive than the one I am installing to. But I have also tried install from cd. I have also made my partition bigger 6.5 gb. I have also run badblocks. Nothing worked.  :(

Would you mind placeing a link to the post you refer to as I cant find it?
Title: Re: 710RC2 CD Caching Issue
Post by: pigdog on June 14, 2008, 05:07:34 pm
Sure,

http://forum.linuxmce.org/index.php?topic=5318.0

Hope this helps.
Title: Re: 710RC2 CD Caching Issue
Post by: Zaerc on June 14, 2008, 08:52:18 pm
First off, 6.5 Gig is nowhere near big enough, try >20G at least.

Also always check the MD5sums on ISOs you download.
Title: Re: 710RC2 CD Caching Issue
Post by: nikrolls on June 15, 2008, 10:18:26 am
MD5sums are perfect, and I've had the same issue with multiple downloads. All ISOs are on the hard-drive -- the same physical drive as being installed on -- and different partitions all give the same error. I'm following the instructions from the Wiki for installing from CD images on the hard-drive (the same as the post referenced, but without using a disc in the beginning).

Code: [Select]
*** VTE ***: Failed to load terminal capabil'
ln: creating symbolic link `/etc/apt/apt.cons
Ign file: ./ Release.gpg
Ign file: ./ Translation-en_NZ           
Ign file: ./ Release                     
Ign file: ./ Packages                     
Hit http://packages.medibuntu.org gutsy Releg
Ign http://packages.medibuntu.org gutsy/freeZ
Ign http://packages.medibuntu.org gutsy/non-Z
Hit http://packages.medibuntu.org gutsy Relee
Hit http://packages.medibuntu.org gutsy/frees
Hit http://packages.medibuntu.org gutsy/non-s
Reading package lists... Done

It stays like the above for a little while, then throws up a few more lines and quits before I get a chance to copy them down, giving me the error 'Could not cache LMCE CD1'. The logs are still all the same, except for one which was different because I chose a bad mirror:

Code: [Select]
--- start mce wizard data ---
c_deviceType=2
c_netIfaceNo=2
c_netExtName='wlan0'
c_netExtIP='10.1.1.4'
c_netExtMask='255.0.0.0'
c_netExtGateway='10.1.1.1'
c_netExtDNS1='10.1.1.1'
c_netExtDNS2='10.1.1.1'
c_netExtUseDhcp=1
c_runDhcpServer=1
c_netIntName='eth0'
c_netIntIPN='192.168.80'
c_startupType=1
c_installType=1
c_installMirror='http://mirrors.kernel.org/ubuntu/'
c_netExtKeep='true'
c_installUI=0
c_linuxmceCdFrom=2
c_linuxmceCdIsoPath='/home/tv/LinuxMCE-CDs-i386-rc2/LinuxMCE-CD1-i386-rc2.iso'
c_ubuntuExtraCdFrom=2
c_ubuntuExtraCdPath='/home/tv/LinuxMCE-CDs-i386-rc2/LinuxMCE-CD2-i386-rc2.iso'
c_ubuntuLiveCdFrom=2
c_ubuntuLiveCdPath='/home/tv/kubuntu-7.10-desktop-i386.iso'
c_installDvdCss=0
--- end mce wizard data ---
ln: creating symbolic link `/etc/apt/apt.conf.d/99offline': File exists
Ign file: ./ Release.gpg
Ign file: ./ Translation-en_NZ
Ign file: ./ Release
Ign file: ./ Packages
Hit http://packages.medibuntu.org gutsy Release.gpg
Ign http://packages.medibuntu.org gutsy/free Translation-en_NZ
Ign http://packages.medibuntu.org gutsy/non-free Translation-en_NZ
Hit http://packages.medibuntu.org gutsy Release
Hit http://packages.medibuntu.org gutsy/free Packages
Hit http://packages.medibuntu.org gutsy/non-free Packages
Reading package lists...
MESSAGE: Generating Default Config File
MESSAGE: Installing MySQL Server
Ign file: ./ Release.gpg
Ign file: ./ Translation-en_NZ
Ign file: ./ Release
Ign file: ./ Packages
Hit http://packages.medibuntu.org gutsy Release.gpg
Ign http://packages.medibuntu.org gutsy/free Translation-en_NZ
Ign http://packages.medibuntu.org gutsy/non-free Translation-en_NZ
Hit http://packages.medibuntu.org gutsy Release
Hit http://packages.medibuntu.org gutsy/free Packages
Hit http://packages.medibuntu.org gutsy/non-free Packages
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
E: Couldn't find package mysql-server

ERROR : Failed to install mysql server
Title: Re: 710RC2 CD Caching Issue
Post by: SalK on June 15, 2008, 01:21:43 pm
First off, 6.5 Gig is nowhere near big enough, try >20G at least.

Also always check the MD5sums on ISOs you download.

About that I just have to say I think thats not a thing you should have to try. After all installations people must have done that should be a thing available for read on LinuxMCE homepage. For me, new to Linux, its not obvious that some problems depend on lack of diskspace and that I think is an issue for new users.

If you say 20G you mean a standard installation would need that or with some media included?

About the MD5sums I have checked that and I have also tested the Kubuntu cd before installing.
Title: Re: 710RC2 CD Caching Issue
Post by: SalK on June 15, 2008, 01:33:19 pm
I have now solved my problem and managed to get through the "Could not cache cd". Important to remember is that it wanted to cache also when I used isos.

Because nikrolls and I seem to have somewhere the same problem and I guess more people will have I thought I share what I have done with you.


I hope it helps someone because its been a mess and I dont want any new to LinuxMCE be scared away because of those silly problems!
Title: Re: 710RC2 CD Caching Issue
Post by: nikrolls on June 16, 2008, 07:28:09 am
Changing the mirror seemed to get further for me, but then the mirror threw up an error. All the other mirrors I tried gave me the caching issue. I'll go through a few more and see if it helps, also I'll burn off the CDs as well as trying to mount them as virtual drives. If I can get through it like you did I'll change this to solved.
Title: Re: 710RC2 CD Caching Issue
Post by: Zaerc on June 16, 2008, 12:02:51 pm
What version of Kubuntu are we installing on here?  And is it pristine, or are modifications made and/or updates done prior to installing lmce?
Title: Re: 710RC2 CD Caching Issue
Post by: chubby bat on July 09, 2008, 08:37:26 am
HI all.

I am having the same problem as the previous post.
I have all the iso images in documents folder in home.

This is the error I get when I try to install. Could anyone help? I am running Kubuntu 8.04 and have the iso of kubuntu 7.10 on the hard drive.


/usr/pluto/deb-cache /tmp/selfextract.eK8468
Use of uninitialized value in require at controllib.pl line 13.
Use of uninitialized value in require at controllib.pl line 13.
Can't locate dpkg-gettext.pl in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl . /usr/lib/dpkg ) at controllib.pl line 13.
Compilation failed in require at ./dpkg-scanpackages line 15.

ERROR : Could not cache LMCE CD 1
Title: Re: 710RC2 CD Caching Issue
Post by: chubby bat on July 09, 2008, 01:46:29 pm
I have just reinstalled kubuntu 7.10 fresh install no updates.
I tried caching cd 1 and it gioves me the error - failure to cache cd 1.
Title: Re: 710RC2 CD Caching Issue
Post by: pigdog on July 09, 2008, 04:11:42 pm
Hi,

When you say you reinstalled Kubuntu 7.10 does that mean you wiped the HDD and intalled only 7.10?

Your earlier post said you were running Kubuntu 8.04 and had the 7.10 iso's on the hard drive.  8.04 isn't a good idea.

Also did you check your md5sums when you made your disks?

After you made your clean install of 7.10 did you then copy your md5sum verified iso files on the hard drive?

Have you tried burning your disks at a slower write speed?
Title: Re: 710RC2 CD Caching Issue
Post by: chubby bat on July 10, 2008, 02:19:05 am
Hi pigdog.

thanks for the quick reply. My linux guru mate is in the states at the moment so I am flying a little blind.

Originally I had hardy heron and read that I could not install mce so I did upgrade D and installed kubuntu (so it was 8.04).
I thought that might be bad but gave it a go anyway. Downloaded the discs off the web.
Each ISO had a checksum with it. During installation I pointed to the ISO on the hard drive.

What do i need to do to check the checksum?
Anyway I did a clean install - restarted the box with Kubuntu 7.10 in and installed over the top of what was there before.
Now I get the error cannot cache the cd1.

I am not sure if burning at a slower speed will fix it as previously the issue was that it could not cache however that was an ISO on the hard drive (not copied from CD) and this time it is from a CD (burned) but the issue is the same - cache issue.

I appreciate your help looking into this.
Title: Re: 710RC2 CD Caching Issue
Post by: pigdog on July 10, 2008, 03:46:18 am
Doing a md5sum (an equal CRC value between the original and the copy is the simplest way to explain it-for me anyway) is important to verifying the iso was properly downloaded.

You can do it (md5sum)from Kubuntu, you can do it from windows, please look around on how to do it.

Maybe someone can give you a link... I've got to run at the moment.

Burning at a lower speed can help reduce write (CRC) errors.

You can burn disks, they can check out but if you are using a SATA CD/DVD drive to install, things can be really inconsistent with Kubuntu on how it works.
Title: Re: 710RC2 CD Caching Issue
Post by: chubby bat on July 10, 2008, 08:31:49 am
Ok so I found info on doing the md5 sum.
Did it on the iso on the hdd in terminal but not sure how to verify the md5sum on the cd.
Have tried copyiong the iso to hard drive but now i get this error...
cp: cannot stat `/tmp/tmp.fVMkiY7636/deb-cache/*.deb': No such file or directory
Title: Re: 710RC2 CD Caching Issue
Post by: Zaerc on July 10, 2008, 04:29:00 pm
Copy all 3 ISOs, 1 kubuntu 7.10 + 2 lmce 0710 to your kubuntu install.  Make sure the checksums are identical to the ones listed here: http://www.linuxmce.org/news.php?id=25#comments (also check the kubuntu ISO md5 checksum against the one on their site). 

Then follow the instructions here: http://wiki.linuxmce.org/index.php/Installation_Guide#Installing_mce-installer_from_command_prompt to get started. 

When lateron you are prompted for the CDs point the installer to the ISO images on the local harddrive instead.
Title: Re: 710RC2 CD Caching Issue
Post by: chubby bat on July 11, 2008, 05:07:33 am
thanks guys for all your help.

I am downloading the dvd iso today to see if I have more luck.
Title: Re: 710RC2 CD Caching Issue
Post by: chubby bat on July 12, 2008, 03:16:25 am
dvd instal success thanks for all the help.