LinuxMCE Forums

General => Users => Topic started by: Rukus on May 16, 2008, 10:23:57 pm

Title: Lircd.conf question.
Post by: Rukus on May 16, 2008, 10:23:57 pm
Hello all,

Does anyone know how can I change the lircd.conf to allow me to use the "More" button on my MCE USB2 remote to change tuner inputs?

Below are the contents of the current file:

# RC-6 config file
# source:
# used by: Philips
# Philips Media Center Edition remote control
# For use with the USB MCE ir receiver
# Dan Conti dconti|
# Updated with codes for MCE 2005 Remote additional buttons
# *, #, Teletext, Red, Green, Yellow & Blue Buttons
# Note: TV power button transmits no code until programmed.
# Updated 12th September 2005
# Graham Auld - mce|
# Radio, Print, RecTV are only available on the HP Media Center remote control

begin remote

name mceusb
bits 16
eps 30
aeps 100

header 2667 889
one 444 444
zero 444 444
pre_data_bits 21
pre_data 0x37FF0
gap 105000
toggle_bit 22
rc6_mask 0x100000000

begin codes

Blue 0x00007ba1
Yellow 0x00007ba2
Green 0x00007ba3
Red 0x00007ba4
Teletext 0x00007ba5

# starts at af
Radio 0x00007baf
Print 0x00007bb1
Videos 0x00007bb5
Pictures 0x00007bb6
RecTV 0x00007bb7
Music 0x00007bb8
TV 0x00007bb9
# no ba - d8

Guide 0x00007bd9
LiveTV 0x00007bda
DVD 0x00007bdb
Back 0x00007bdc
OK 0x00007bdd
Right 0x00007bde
Left 0x00007bdf
Down 0x00007be0
Up 0x00007be1

Star 0x00007be2
Hash 0x00007be3

Replay 0x00007be4
Skip 0x00007be5
Stop 0x00007be6
Pause 0x00007be7
Record 0x00007be8
Play 0x00007be9
Rewind 0x00007bea
Forward 0x00007beb
ChanDown 0x00007bec
ChanUp 0x00007bed
VolDown 0x00007bee
VolUp 0x00007bef
More 0x00007bf0
Mute 0x00007bf1
Home 0x00007bf2
Power 0x00007bf3
Enter 0x00007bf4
Clear 0x00007bf5
Nine 0x00007bf6
Eight 0x00007bf7
Seven 0x00007bf8
Six 0x00007bf9
Five 0x00007bfa
Four 0x00007bfb
Three 0x00007bfc
Two 0x00007bfd
One 0x00007bfe
Zero 0x00007bff

end codes

end remote

I tried adding the following to the bottom of the file, but no results.

prog = mythtv
button = More
config = Y
Title: Re: Lircd.conf question.
Post by: Rukus on May 17, 2008, 02:09:00 am
Well some progress has been made, with some help from the folks at the Ubuntu forum.  I tried updating my lircd.conf with the new info, but it didn't seem to have any effect.  Not sure if it is the contents in the file, or if I'm not in the right directory.  Can anyone give me some help?