LinuxMCE Forums

General => Installation issues => Topic started by: Elitoh on March 31, 2008, 07:17:27 pm

Title: Dell SX270 and UI2
Post by: Elitoh on March 31, 2008, 07:17:27 pm
I have a Dell SX270 and installed beta 4 using UI2. It was a tough road there. I was told that this little guy  wouldn't support the UI2. In most cases it does but in some cases it doesn't. In the begining UI2 would lock up in a matter of seconds when it came up. I wasn't sure why. I read some posts about Flickr so I disabled it and still kept freezing I disabled MythTV from the admin page. UI2 was functional. I copied some movies on to a usb hard drive and the first 2 worked greate I could use the UI to get to the movies and play them. I copied one more movie and then went to the video option to play it and it locked up yet again. Here are the specs of the computer.

P4 2.8ht
2 gigs pc3200 ram
40 gig hard
Uses the Intel 865g video chipset.
On board video mem is set to max (8 MB)

Again everything works fine up until I try to watch a copied movie. The funny thing is if I use another orbiter (WM 2003 ppc) it will play the movie just fine. I can do pretty much everything with the PPC orbiter.

Any help would greatly be appreciated.
My thanks in advance.
Title: Re: Dell SX270 and UI2
Post by: Zaerc on March 31, 2008, 07:33:45 pm
Ummm... could it perhaps be that maybe your hardware really is not able to handle UI2 properly?
Title: Re: Dell SX270 and UI2
Post by: Elitoh on March 31, 2008, 08:48:48 pm
I'd like to accept that answer but the video card does support opengl and they system is above the system requirements. I am not using alpha blending. Again it only came down to some media for example right now I have 2 movies and if I delete one of them and reboot the core, I can see the movie in the list and play it no problems. Again I noticed that when I do ls -l in /mnt/device/33/movies all the content is root root not root public... could anyone tell me how to change this? Could it be what is causing it to do what it is doing. Everything else works fine. Im sure it could be something with LMCE itself it is beta
Title: Re: Dell SX270 and UI2
Post by: chaos1965 on March 31, 2008, 09:01:30 pm
Regarding the video issue, I don't think you understand what he's trying to say.  There are tons of cards out there that support OpenGL, but only a handful of them are going to work with LMCE.  Also, it's actually not LMCE's problem either, it's more of a Linux in general issue.  You see, the video drivers that are available for linux determines how well it's going to work with Linux.  And the only company out there putting forth any effort in stable, reliable, effecient linux drivers is NVidia.  Hence why everyone recommends going with Nvidia cards.

Concerning the permissions of your share, did you click "not use" and "make all public" or the other?
I would recommend deleting the device from the webadmin page and allow it to re-detect and reconfigure the share.


Try setting the permissions manually.
Code: [Select]
chown -R linuxmce:public /mnt/device/33
Title: Re: Dell SX270 and UI2
Post by: Elitoh on March 31, 2008, 10:00:46 pm
I apologize if my reply seemed rude or if I misunderstood. What I meant by my last post was that the video card should be fine I would think because it only fails during certain circumstances. In this case for some reason I am getting mysql errors and a bunch other errors. I just recently installed it and not sure why I would get all the erros. I do Agree about the drivers comment. Again the other error that I get is that the external drive disappears(or unmounts) and thats when it freezes. Should I put the drive in fstab? I noticed that LMCE creates a symbolic link in /home/public/....... but the mount point is /mnt/devices/. Also, I did at it to public and made sure it was used all the time. Thanks again for the help.
Title: Re: Dell SX270 and UI2
Post by: chaos1965 on March 31, 2008, 11:13:56 pm
The mounting of drives and shares is being handled by the autofs daemon.  I do not know all that much about this feature, but it seems to me that the autofs daemon unmounts filesystems after some time of inactivity.  This could be the source of your unmounting... since it locks your system up when it happens, then just need to configure autofs not to unmount on inactivity.

I could be WAY off here too, like I said, I know jack about autofs.
Title: Re: Dell SX270 and UI2
Post by: Elitoh on April 01, 2008, 12:33:13 am
Another Finding.... when I went through the setup (the Initial green screen setup) I chose UI2 (medium not alpha) when I finish setting up the core it actually does do transparency. Is there any way to disable transparency??
Title: Re: Dell SX270 and UI2
Post by: Elitoh on April 01, 2008, 07:12:34 pm
I think I got everything pretty much working along with UI2(medium). Don't know exactly why but here is what I did if anyone is interested. I reinstalled LMCE again. Ran through the AVsetup. When it came to devices and media setup I created my user and choose the basics cause I don't have a lot of the other hardware(zwave, alarm, etc. ) When it came time to choose mythtv or vdr I choose vdr. I setup the rest of the other packages for media and then I reboot. When It came up the first time it worked fine. I disabled flickr from the admin page. Then ssh'd into the system to get rid of the flickr images that it downloads. Also made sure that there was nothing for Mythtv enabled. Everything is working so far I have copied a good amount of media to the core and it doesn't freeze when trying to view the list or play the media.

The reason I wanted to succeed with this system is because it is really small and can pretty much go anywhere. There are a lot of limitations on this system but I got it for free and had this in mind since I got it. Its a great system if you just want to use it as an M/D. Its a pain as a core cause of what you have to do. Thanks for the help.