LinuxMCE Forums

General => Users => Topic started by: Rukus on February 14, 2008, 04:18:12 pm

Title: MythTV freezing while watching TV.
Post by: Rukus on February 14, 2008, 04:18:12 pm
Hello all,

I'm currently running LMCE 7.10 Beta, and I've come across a problem while trying to watch TV.   Every time Myth loads up I'm able to watch TV for about 30 seconds and then it completely freezes up. Now this is just Myth freezing, not my system.  I know Myth is CPU hog, but I didn't know it was this bad.  Is anyone else having this problem?

CPU:
AMD Athlon X2 6000 3.0GHz
Title: Re: MythTV freezing while watching TV.
Post by: geoffrey on February 14, 2008, 05:45:19 pm
yes, it has been the subject of several threads.  If I remember correctly the problem is a glitch in MythTV that was brought to light by the LMCE interface. 

and I have found that if I turn off mythtv and then start it back up when it freezes it works, well that is until the next freeze which in my case has been from anywhere from 2 seconds to several hours.
Title: Re: MythTV freezing while watching TV.
Post by: Rukus on February 14, 2008, 07:38:52 pm
Weird.  I take it no one has come up with a workaround?
Title: Re: MythTV freezing while watching TV.
Post by: Xirg on February 14, 2008, 07:51:53 pm
Actually its a bug in IVTV (at least thats the problem with my box)

its called the DMA bug and should have been fixed in IVTV version 0.6 but i still have freezes in my mythtv and im running version 1.03.

Please correct me if im wrong

//Xirg
Title: Re: MythTV freezing while watching TV.
Post by: niz23 on February 14, 2008, 08:39:29 pm
I have this problem too.

Have brought this issue to danielk.

As a comparison my mythbuntu 64-bit runs for 3-4 weeks before I reboot it. mostly not because of instability, it´s upgrade and patches.
And myth frontend only use 6% cpu on my AMD 4400 dual-core.

I have the same hardware setup for lmce0710b3 64-bit and there myth-frontend use about 35-40% cpu.
It´s weird since both systems have exactly the same hardware.

I have even swapped harddrives just to make sure there is nothing wrong with my hardware for lmce.

Just my cents to this problem.

A couple of weeks ago I tryed to debug myth-frontend when it hangs.
It seem that it does not crash or lock up. It for some reason is unable to display anything.
Have no clue why.

Can ivtv have anything to do with this as suggested earlier in this thread?
Where did get that info from?

I have not compared if mythbuntu and lmce0710 use the same ivtv version.
Maybe something to try if they differ, unless the lmce team have done changes in ivtv.

/niz23
Title: Re: MythTV freezing while watching TV.
Post by: Xirg on February 14, 2008, 09:02:12 pm
Well im no expert.

My problems are the same as the stuff from these links:

http://www.mythtv.org/wiki/index.php/IVTV#My_console.2Flog_is_full_of_messages_about_IVTV_DMA_errors_and_some_of_my_recordings_are_truncated.21

and heres the IVTV mailing list archive on the subject.

http://www.gossamer-threads.com/lists/engine?list=ivtv&do=search_results&search_forum=all&search_string=IVTV+dma&search_type=AND
Title: Re: MythTV freezing while watching TV.
Post by: Rukus on February 14, 2008, 09:08:25 pm
Quick update.  I've been watching tv using my pcHDTV 5500 and it's been running like a champ.  I'm going to try tweaking my Hauppage card settings, and hopefully that'll work.  I'll post my findings.