LinuxMCE Forums

General => Developers => Topic started by: ddamron on February 13, 2008, 11:37:46 pm

Title: Insteon PLM Updates for X10 Bidi Support
Post by: ddamron on February 13, 2008, 11:37:46 pm
I found a few bugs in the X10 support of the PLM Ruby code.

My opologies to everyone out there trying to use a PLM to control X10.

I have fixed the problem, but before I update the wiki with the new code, I'm going to implement dimming capability to X10.

The X10 Dimming capability will only be 1-way, as the devices do not report status.

However, any transmitted X10 signals on the powerline ARE sensed and reported back to lmce.

In a nutshell:

What will NOT work:  local control of a device cannot be sensed.
What WILL work:  If you use a REMOTE controller, or a motion sensor, etc, that TRANSMITS commands, they will be received.

HTH, I'll keep you posted.

Best regards,

Dan
Title: Re: Insteon PLM Updates for X10 Bidi Support
Post by: ddamron on February 14, 2008, 01:56:15 am
Ok, rudimentary X10 dimming has been implemented.  I don't know if it works, I don't have an X10 device to test with.

X10 control from an orbiter is now fixed.

Wiki is updated.

http://wiki.linuxmce.org/index.php/Insteon_-_Setting_Up_PLM_Template

all the best!

Dan
Title: Re: Insteon PLM Updates for X10 Bidi Support
Post by: golgoj4 on February 14, 2008, 02:27:51 am
your awesome dude. thanks for this.
Title: Re: Insteon PLM Updates for X10 Bidi Support
Post by: ddamron on February 14, 2008, 04:54:19 am
Not a problem Golgoj4!

Are you using a PLM?

I'd like to know if people are using the PLM, and if so, what problems they encounter.

This feedback will help me diagnose problems, and make the installation easier.

Regards,

Dan