LinuxMCE Forums

General => Users => Topic started by: super on January 30, 2008, 09:27:11 am

Title: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on January 30, 2008, 09:27:11 am
I was able to install 0710 b3 on my HTPC, but when it boots up, the login is displayed only for a second and disappears. Is this a problem with the driver? I have the ASUS nvidia 8600 GT card and have hooked this up to a Sharp Aquos 1080p TV using a DVI to HDMI cable. Is the nvidia 8xxx series supported in LMCE 0710?

Any suggestions on how I can get around this? Do I get LMCE working on a regular monitor display first and then try it out with the TV display? Please let me know.

Thanks!

super
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: Marie.O on February 02, 2008, 11:35:19 am
The login always just flashes by. And yes, it might well be a problem with the video driver.

After the login, it should switch to a graphical view of things. There seems to be a problem there. Try attaching a regular computer display to the VGA out (if you have one), and see if that helps.

rgds
Oliver
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: fibres on February 02, 2008, 02:11:27 pm
Could be the setup wizard is loading and selecting the vga output instead of the dvi one.

Try pressing the 1 key on keyboard i think it is to slect the DVI out.

Regards
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 10, 2008, 09:26:36 am
Has anyone gotten LMCE working with nVidia 8600 GT graphics card yet? It would help immensely to know if anyone has made it work with nVidia 8600 series and how they got past the display issues. These cards are current not future, so I would imagine a pretty large install base with these cards.

I tried hooking my machine to a computer monitor, and got the same results (blank screen after the kubuntu splash screen), so I am pretty sure this is a display driver issue.

I want to know if the DVD install will even work on this, or should I go the CD route (install kubuntu first, then LMCE etc.) Thanks in advance for any responses.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: geoffrey on February 10, 2008, 09:45:06 am
While setting up and troubleshooting my DVI connection I found it very useful to have a VGA monitor connected at the same time.  When the DI was not displaying anything I always had the VGA to see what was going on.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 10, 2008, 09:52:15 am
While setting up and troubleshooting my DVI connection I found it very useful to have a VGA monitor connected at the same time.  When the DI was not displaying anything I always had the VGA to see what was going on.

Thanks, but my graphics card has 2 DVI connections, so no VGA here. Does anyone know where to find LMCE 0710 b3 standalone CD? I am trying separate installs of kubuntu 0710 and LMCE since the DVD installation does not work for me.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: colinjones on February 10, 2008, 01:56:12 pm
Super - you haven't said whether you followed the advice you have already received in this thread!

When LMCE starts up, it defaults to VGA. So if you have no VGA monitor attached or in your case no VGA output, then you will see no picture.

PRESS 1 on the keyboard once the screen goes blank (give it 10 seconds before you do this, and 10 seconds afterwards to settle down) this will select your DVI. Also use 6-0 on the keyboard to choose different resolutions to ensure that your monitor can handle the resolution you are on. Again give it several seconds to settle down.

Please try doing some searches for 2 DVI outputs, and 8600 - I have read something before about dual DVI on the forums. Yes, even if the drivers do not give the full acceleration or all the features of your card, you should certainly be able at least to get it displaying something! Try using 0710 beta 3 as this has the latest nVidia drivers. Otherwise, you will have to do some searches to find out how to install the new drivers manually from the text command line. (hint - start by hitting CTRL-ALT-F2)
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 10, 2008, 05:36:55 pm
Colin, I have tried holding down the shift key to get AVWizard to start and then pressing the 1 key to get it to select DVI output, then selecting 0 for 1080p output. I tried this both on the TV and a computer monitor.

Will try it once again according to your instructions. I will also search for dual DVI on the forums. Searching for 8600 did not yield useful results if I remember.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: colinjones on February 10, 2008, 11:22:58 pm
I think the dual output maybe causing you problems, but there are other things as well. Try this thread -

http://forum.linuxmce.org/index.php?topic=3784.0
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 12, 2008, 07:34:20 am
Thanks Colin,

I swapped the 8600 GT with the 7600 GS graphics card from another computer, and got to the A/V Wizard. Curious thing though, in the selections, I cannot seem to select the 1080p resolution even at 50 Hz (The TV complains about invalid signal). My TV is Sharp Acquos 1080p and I get 1080p from my DVD on the other HDMI input. I chose the 720p in A/V Wizard and was able to install LMCE perfectly. I got the flickr screensaver, played some DVDs and CDs. About the 1080p I know this has something to do with the graphics driver. Can anyone confirm?

Now when I restart, it gets stuck on the kubuntu splash screen. Does anyone know how to get to the quiet option with no splash screen? The TV says that it is getting a 1080p input. I had selected 720p in the A/V Wizard since 1080p was not working. Anyway I will keep playing around with it to resolve this. Any help would be appreciated of course.

***************Edit: ************************
I found out the cause for this problem. I had plugged in a second drive, and kubuntu  bootup was saying that '/dev/sda1' could not be found. How do I get it to bootup with the first drive after adding the second drive? My plan was to store all music, movies etc. on the second drive. That way even if I reinstall the final version for 0710, my media would be safe on the second drive. Does anyone know how to do this? I will start a separate thread on this.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: Rukus on February 12, 2008, 01:37:41 pm
Super,

When you added the 7600 GS did you have to change any drivers, or did it work once you added it to your box?
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: lightsoul on February 12, 2008, 03:35:29 pm
i have the same problem with two type of Nvidia cards, the only way you can overcome this problem is to downgrade your display option, while booting press and hold shift key and the configuration will come up, then chose the first item in the list where (static images).

there is more problem now in 710
can't use U2
playing video file is sucks
no seeking forward
feel nothing improved since 704
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: Rukus on February 12, 2008, 04:11:07 pm
There's got to be a way to make it work, the static image kills the whole experience.  I had my box working using DVI to HDMI and at 1080p res. I had the alpha blending UI running, but the screen kept blinking.  I have an GeForce 8600 GTS.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 13, 2008, 05:13:17 am
I did a reinstall but the driver was the same generic 'nv' driver not the proprietary 'nvidia' driver. I changed the driver to the proprietary 'nvidia' driver and am having display problems again. Will update this thread on what happens today. Alpha blending with UI2 was working quite well on 7600 GS. I played some DVDs and the playback was pretty good (ocassional glitches hardly noticeable), but this was all at 720p NOT 1080p. My next step is to get to 1080p resolution. Maybe I need to setup the latest driver first and then run A/V Wizard?
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: Rukus on February 13, 2008, 07:27:00 pm
Well I have almost everything working, just need to connect my media drives that house my movies and recordings.  I borrowed a s-video to component/composite dongle get a 720p output.  It's not 1080i, but it'll have to do for now. The dongle comes with most nvidia cards, but if your does not you can buy one for about $7 at http://www.fasterclock.com/SearchResults.asp?Search=compupack.  I'm using the 'nvidia' drivers and it seems to be working fine. 
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 19, 2008, 03:25:32 am
Well, my saga of getting the display to work continues. I get the alpha blending with 720p working with Sharp Acquos 46" TV on the 7600GS with HDMI. But I want 1080p, and that's where the problem lies. I tried installing the latest drivers 169.09 from nvidia using Envy, but got the blank display after rebooting.

Anyone successfully got 1080p on a Sharp Acquos TV (Model: LC-46D62U) with one of the newer nvidia cards? Can someone post their xorg.conf file? That would help me out a lot.

When I rebooted, for some reason I could not get the A/V wizard, so I think LMCE is expecting 720p, but the newer nvidia driver could be providing 1080p. Could that be the problem?

Should I first install kubuntu only and then install LMCE? LMCE installs nvidia-glx for me and does not let me select 1080p in the setup (I can only select 720p with 4:3 TV even though my TV is 16:9 1080p)

Any help is appreciated here. Thanks.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: RichardP on February 19, 2008, 07:39:32 am
Well, my saga of getting the display to work continues. I get the alpha blending with 720p working with Sharp Acquos 46" TV on the 7600GS with HDMI. But I want 1080p, and that's where the problem lies. I tried installing the latest drivers 169.09 from nvidia using Envy, but got the blank display after rebooting.

Anyone successfully got 1080p on a Sharp Acquos TV (Model: LC-46D62U) with one of the newer nvidia cards? Can someone post their xorg.conf file? That would help me out a lot.

When I rebooted, for some reason I could not get the A/V wizard, so I think LMCE is expecting 720p, but the newer nvidia driver could be providing 1080p. Could that be the problem?

Should I first install kubuntu only and then install LMCE? LMCE installs nvidia-glx for me and does not let me select 1080p in the setup (I can only select 720p with 4:3 TV even though my TV is 16:9 1080p)

Any help is appreciated here. Thanks.

I'm assuming you're using DVI even on the replacement card? My experience is only with the two latest beta's, so take this with a pinch of salt if you are using something else...

After you upgrade the nVidia drivers, the xorg.conf will have been replaced, and the output will most likely be sent to the VGA adapter. Check the xorg.conf, logging in from one of the text terminals (Ctrl-Alt-3 is what I use, for various reasons)

Getting your 1080p working - edit the xorg conf by hand, or use the nVidia utility. You want to make sure you are using the right connector - if you have two DVI connectors, they will be DFP-0 and DFP-1 (I think). Then you want to make sure you have EDID turned on. Once this is done, start up the X system - it's not important whether it works successfully or not.

Once that is done, go and have a read of /var/log/Xorg.0.log and you will be able to see what your card supports, what your TV supports and where the two can meet.

Best Regards,
RichardP.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 21, 2008, 12:38:04 am
RichardP,

Thanks for your advice. Can you elaborate on a few points? Sorry I am a newbie and hardly know anything about the structure of xorg.conf.

>>After you upgrade the nVidia drivers, the xorg.conf will have been replaced, and the output will most likely be sent to the VGA adapter. Check the xorg.conf, logging in from one of the text terminals (Ctrl-Alt-3 is what I use, for various reasons)

Question: What line in the xorg.conf will tell me whether VGA or DVI is being used?

Getting your 1080p working - edit the xorg conf by hand, or use the nVidia utility. You want to make sure you are using the right connector - if you have two DVI connectors, they will be DFP-0 and DFP-1 (I think). Then you want to make sure you have EDID turned on. Once this is done, start up the X system - it's not important whether it works successfully or not.

Question: How do I turn on EDID? and where will I find which DVI connector is being used?

Thanks in advance
super
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: colinjones on February 21, 2008, 01:13:42 am
Super

Not sure about VGA, but you should find DFP mentioned the Device section - Option "ConnectedMonitor" "DFP" for 2 outputs I am assuming that DFP-0 and DFP-1 will be mentioned somewhere. Certainly in the log file (/var/log/Xorg.0.log) this is the format.

For EDID you can put Option "UseEDID" "true" (actually change it from false as it probably already exists) - but in my xorg files this option has always been in both the Device and Screen sctions. Don't know which takes precedence so I do both.

Also, I add the line Option "UseEDIDDPI" "false" in both sections as well. My TV reports the wrong size screen (very common) and so when X calculates the font DPI it is way off and my fonts are unreadable. This fixes it as it assumes the standard 100 DPI. Or you could use Option "UseDPI" "100" I think...
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 21, 2008, 04:11:24 am
Thanks Colin,

I figured out how to turn the EDID on, by searching on other forums. That did the trick and I am on 1080p now with alpha blending. I have tried DVD playback and it has been pretty good (occasional glitch here and there). I will start transferring my media library to LMCE now.

Thanks for the font tip, my fonts are currently unreadable too. Will try your option out in xorg.conf.

We need a good section on xorg.conf. I will see if I can start something and you guys can add to it.

BTW, can you send me your xorg.conf file? I don't seem to have the ConnectedMonitor section in mine.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: colinjones on February 21, 2008, 10:12:36 pm
My xorg is probably not ideal and probably includes some experimental stuff I added that didn't break it and I forgot to remove! But here you go:

Code: [Select]
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
        Identifier      "Generic Keyboard"
        Driver          "kbd"
        Option          "CoreKeyboard"
        Option          "XkbRules"      "xorg"
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "us"
EndSection

Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/input/mice"
        Option          "Protocol"              "ImPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Emulate3Buttons"       "true"
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "stylus"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "stylus"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "eraser"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "eraser"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver          "wacom"
        Identifier      "cursor"
        Option          "Device"        "/dev/input/wacom"
        Option          "Type"          "cursor"
        Option          "ForceDevice"   "ISDV4"         # Tablet PC ONLY
EndSection

Section "Device"
        Identifier      "nVidia Corporation NVIDIA Default Card"
        Driver          "nvidia"
        BusID           "PCI:0:18:0"
        Option "XvmcUsesTextures" "true"
        Option "renderAccel" "true"
        Option "NoDDCValue"
        Option "UseEDID" "true"
        Option "UseEDIDDPI" "false"
        Option "ExactModeTimingsDVI" "true"
        Option "NoLogo" "true"
        Option "NoBandWidthTest" "true"
        Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
        Option "DynamicTwinView" "false"
        Option "AllowGLXWithComposite" "true"
        Option "AddARGBGLXVisuals" "true"
        Option          "ConnectedMonitor" "DFP"
EndSection

Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "DPMS"
        Modeline        "1920x1080" 138.5 1920 1968 2000 2080 1080 1082 1087 1111
        HorizSync       20-500
        VertRefresh     59-61
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Device          "nVidia Corporation NVIDIA Default Card"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Modes           "1920x1080"
                Virtual         1920 1080
        EndSubSection
        Option "XvmcUsesTextures" "true"
        Option "renderAccel" "true"
        Option "NoDDCValue"
        Option "UseEDID" "true"
        Option "UseEDIDDPI" "false"
        Option "ExactModeTimingsDVI" "true"
        Option "NoLogo" "true"
        Option "NoBandWidthTest" "true"
        Option "ModeValidation" "NoDFPNativeResolutionCheck, NoEdidMaxPClkCheck, NoMaxPClkCheck, AllowInterlacedModes, AllowNon60HzDFPModes"
        Option "DynamicTwinView" "false"
        Option "AllowGLXWithComposite" "true"
        Option "AddARGBGLXVisuals" "true"
        Option  "TVStandard"    "HD1080p"
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"

# Uncomment if you have a wacom tablet
#       InputDevice     "stylus"        "SendCoreEvents"
#       InputDevice     "cursor"        "SendCoreEvents"
#       InputDevice     "eraser"        "SendCoreEvents"
EndSection
Section "Extensions"
        Option "Composite" "false"
        Option "RENDER" "true"
EndSection
Section "Module"
        Load "glx"
        Load "dri"
EndSection
Section "DRI"
        Mode 0666
EndSection
linuxmce@dcerouter:~$
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: RichardP on February 22, 2008, 06:52:43 am

Thanks Colin,

I figured out how to turn the EDID on, by searching on other forums. That did the trick and I am on 1080p now with alpha blending. I have tried DVD playback and it has been pretty good (occasional glitch here and there). I will start transferring my media library to LMCE now.

Thanks for the font tip, my fonts are currently unreadable too. Will try your option out in xorg.conf.

We need a good section on xorg.conf. I will see if I can start something and you guys can add to it.

BTW, can you send me your xorg.conf file? I don't seem to have the ConnectedMonitor section in mine.

Glad you're running. Sorry I've been off the forum for a couple of days. For the font size, first try having EDID set your values automatically with:
Option "UseEDIDDPI" "true"
If this is already on, check the values in the Xorg.0.log to see what they are. Once you know that, turn it off, as Colin has done. (I'm assuming, since you've succesfully turned on EDID, that you're now comfortable editing your xorg.conf). Then set a DPI value of that makes sense for your monitor (usually around 96 each way for a high-def monitor). So what you should have is something like:
Section "Monitor"
  Option   "UseEdidDpi" "false"
  Option   "DPI" "96 x 96"

Good luck.
Best Regards,
RichardP.


Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: 1audio on February 22, 2008, 07:02:46 am
The 1080p modeline looks off. Some monitors won't work with that number. The MythTV modeline database has the correct CEA 1080p modeline that should work with any 1080p display. The xorg log will show the modeline actually used, which would have come from the EDID if its on. Some displays are very picky about digital timing and will reject an incorrect timing.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: colinjones on February 22, 2008, 07:45:18 am
1audio - were you talking about my modeline?

The problem I am having at the moment is that my TV refuses to do 1080p50 - the modeline in that xorg is 1080p60, but I live in Australia so TV (at least) is 50Hz, and I suspect that this could be the cause of my ongoing pain with video jerkiness and apparent "low frame rate".

The only 1080p50 mode I have got to work so far causes the picture to overscan hugely - and the whole point of paying for a 1080p set is to use it at native resolution! Whenever I try to tweak the timings it gets to a point and then comes up that the mode is not supported.... This is nonsense, its well within the pixcel clock's capabilities, etc, and it would be pretty pointless selling the set with that limitation in a market that uses 50Hz. Plus I'm sure that if I connected a Bluray player or something it would do 1080p50. When I use the modeline that overscans (I think that was from the MythTV modeline database but I'm not sure where I found it - could you send the link to the one you are talking about?) and hit the info button on the TV it actually confirms it is 1080p50 as opposed to the modeline above which says 1080p60...

Samsung are useless, they didn't even know where to start! I'm completely stuck now - no idea what to try next, paid huge amounts for this TV, and don't seem to be able to find a modeline that works for 1080p50....
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: 1audio on February 22, 2008, 08:27:18 am
The problem may be getting the display and the video card to cooperate.
 I would try:
Option "ModeValidation" "AllowNon60HzDFPModes"

I looked for a copy of the CEA 861 specs but I have lost mine somewhere. The Myth data base is all 60 Hz but there is a 50 Hz spec.

Read through the Xorg log, it should play back the formats the display supports if edid is on.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: Zaerc on February 22, 2008, 03:07:34 pm
...
We need a good section on xorg.conf. I will see if I can start something and you guys can add to it.
...

http://wiki.linuxmce.org/index.php/Display_Drivers#Configuration
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 23, 2008, 08:15:57 am
Colin,

You may want to look at this URL: http://home.att.net/~Tom.Horsley/easy-linux.html
Although it is for Fedora, it goes through tweaking the display frequencies. Maybe useful.
Also try using the command cvt -r -v and plugging those values into the Modeline.

RichardP,
Thanks for your advice. I set my EDID on in xorg.conf, looked at my /var/log/Xorg.0.log, got the timings, plugged them into the modeline value in xorg.conf and that did the trick.

super
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: RichardP on February 24, 2008, 04:09:37 am
Colin,

You may want to look at this URL: http://home.att.net/~Tom.Horsley/easy-linux.html
Although it is for Fedora, it goes through tweaking the display frequencies. Maybe useful.
Also try using the command cvt -r -v and plugging those values into the Modeline.

RichardP,
Thanks for your advice. I set my EDID on in xorg.conf, looked at my /var/log/Xorg.0.log, got the timings, plugged them into the modeline value in xorg.conf and that did the trick.

super

Nice one... glad to be of help. If you can, can you post your values in the Wiki hardware database - it may help someone with a similar problem.

Colin, what Super says opens a whole new can of worms. Suppose your EDID is reporting the correct values, as we are reading in the log, but X is not using those values. Super's method may work for you - fully turn on EDID, record the values, then plug the values into the xorg.conf.

Just curious - if you're running at 60 hertz, have you tried playing an NTSC video to see if the tearing is reduced?

Best Regards,
RichardP

Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: super on February 24, 2008, 05:48:20 am
I must have spoken too soon...last night the 1080p was working. Today morning when I fire up the LMCE machine, I get 'Invalid Video Signal' on my Sharp Aquos. I thought I had everything figured out. Also, now I don't get the onscreen menus on my TV (like adjusting brightness, contrast, volume etc.) Need to do some digging around to figure this out...just when I thought everything was going ok...oh well, back to the grind.

Any suggestions are welcome. Will update this thread with my results.

RichardP,
will update the hardware Wiki when I get this running in a stable manner

super
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: Zaerc on February 24, 2008, 08:40:09 pm
Probably because lmce rewrote your xorg.conf and replaced the modelines.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: RichardP on February 25, 2008, 03:02:43 am
I must have spoken too soon...last night the 1080p was working. Today morning when I fire up the LMCE
...

Any suggestions are welcome. Will update this thread with my results.


Whoops - forgot to warn you. After you get your xorg.conf right, copy it over the Pluto version in the same directory. At certain times, the xorg.conf gets overwritten with the Pluto copy. I'm not sure when it happens - I know one of the times is when AVWizard starts, but there may be other times as well.

I generally keep a copy off the machine as well, together with several other files, so that anytime the machine is nuked or upgraded, I have copies.
Title: Re: Display problem with nVidia 8600GT card on 1080p TV
Post by: dopey on April 07, 2008, 07:36:57 am
The problems discussed didn't really relate to the video card, but rather the TV. That video card actually runs very well in Linux.

The only video card issue is that was discussed is a universal problem. Currently LMCE hardcodes which DVI port to use and has hardcoded modelines that don't work with all TVs. I have to put in a manually created modeline for my TV (the TV won't report the correct timings, either). For my other TV I must turn on EDID (actually on by default, but LMCE disables it) and remove the LMCE modeline.

FYI, if LMCE didn't hardcode which DVI port to use in Xorg.conf, Xorg and the nVidia drivers would select whichever port was currently active.