LinuxMCE Forums

General => Installation issues => Topic started by: cliff on January 16, 2008, 04:49:09 am

Title: windows shares
Post by: cliff on January 16, 2008, 04:49:09 am
I've been up and down with linuxmce for a while from saying I'll never start it again to building 5 media directors.  Things are working well except for one thing.  I still have to deal with windows for several reasons.  One has a raid with two terabytes of storage and a bunch of media files.  I've renamed everything to be d:\video\*.* or d:\photos\*.* or whatever in order to keep the path short.  Everythiing is shared.  The corehybrid finds the shares.  But finds only the files in the shared document folder on c drive and none off of the raid.  I know its something simple it always is, but I can't find it. 
Title: Re: windows shares
Post by: tkmedia on January 16, 2008, 04:55:57 am
Can you browse to it under KDE go to konqueror and type smb://ipaddress
Title: Re: windows shares
Post by: colinjones on January 16, 2008, 05:36:13 am
Are you telling it to add the shares using the LinuxMCE folder structure, when it prompts you? If so, it won't find files in the folders you listed as it is looking for the data/public/audio, etc folder structure. You should be combining all your media rather than splitting it up under separate shares - ideally. Let LMCE manage it.

It should create the folder structure if it doesn't find it, and it will be empty, thus no files in LMCE. If this is what is happening, just move your media files under the appropriate folder structure it creates. If it doesn't even create the folder structure, then ensure that LMCE has write access to the share/folders.
Title: Re: windows shares
Post by: mog on January 16, 2008, 02:37:11 pm
Make sure you don't have spaces in the share names.
Title: Re: windows shares
Post by: cliff on January 17, 2008, 04:41:48 am
It added the files in the regular shared documents folder on drive C of the windows machine.  It does not add the files under the raid (E under windows).  Sharing on the raid is enabled with allow users to change the files enabled as well.  All videos on on E are individual files (not in folders).  Music and photos are in folders by artist and month respectively.  smb returns nothing.  I'm trying to avoid a reinstall because a couple of media directors are already set up.  However I will as a last resort.  Is there a way delete the shares off of the Master Media Director and let the media director try to find them again? 
Title: Re: windows shares
Post by: colinjones on January 17, 2008, 07:10:54 am
You didn't respond on my points about how you added the share - this is the most critical piece. If you told it to use LMCE structure when it asked you, then it won't find anything outside that specific folder structure.

This is the option you should be using anyway. If the folders don't exist, it will create them - look for the folder "Public" under your share after you tell it to use the share. If it is already there with folders underneath, then just relocate your media into the appropriate folder under Public, and it will start finding them in a few minutes.

If you want to remove the Windows machine and start again, you can do this from the Web Admin console on the Kubuntu desktop. Find the machine in question and delete it. I think you can prompt it to find it again by reloading the router, or perhaps reboot the Windows machine so that DHCP pnp sees it again.
Title: Re: windows shares
Post by: cliff on January 18, 2008, 05:44:21 am
I see what you are saying and I have found the public folder and subfolders for video etc.  Moving the the files into this folder would be the easy solution, but I added the raid to an existing windows installation with a small C drive.  Hence the public folders are on a drive with a 100 gb and the media files are on a raid of 750 gb.  I guess it time to rebuild.
Title: Re: windows shares
Post by: tkmedia on January 18, 2008, 04:34:32 pm
Why don't you just create a new windows share pointing to your raid.
When you add it just make all content public and do not choose the option to use Linuxmce folder structure.