LinuxMCE Forums

General => Users => Topic started by: nite_man on October 30, 2007, 10:20:34 pm

Title: Strange problem with running 20_DenonReceiver.sh
Post by: nite_man on October 30, 2007, 10:20:34 pm
Today I found strange problem related with running script 20_DenonReceiver.sh. It's started continuously and after each 5 minutes router was reloaded. Here is a piece of DCERouter.log:

Code: [Select]
08      10/30/07 22:06:16.628             Parameter 13(Filename): 20_DenonReceiver.sh <0xb071fb90>
10      10/30/07 22:08:43.380           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4160 checking detection 20_DenonReceiver.sh <0x876cfb90>
08      10/30/07 22:11:53.716             Parameter 9(Text): Running detection script: 20_DenonReceiver.sh <0x9cefab90>
08      10/30/07 22:11:53.734             Parameter 13(Filename): /usr/pluto/pnp/20_DenonReceiver.sh <0x9bef8b90>
08      10/30/07 22:11:53.734             Parameter 50(Name): PNP Detection 4160 20_DenonReceiver.sh <0x9bef8b90>
08      10/30/07 22:11:53.734             Parameter 51(Arguments): 14   4160    pci0000:00/0000:00:0a.0+2       20_DenonReceiver.sh        <0x9bef8b90>
08      10/30/07 22:11:53.734             Parameter 94(SendOnFailure): 0 14 1 806 224 4160 13 "20_DenonReceiver.sh" 18 FAIL <0x9bef8b90>
08      10/30/07 22:11:53.734             Parameter 95(SendOnSuccess): 0 14 1 806 224 4160 13 "20_DenonReceiver.sh" 18 OK <0x9bef8b90>
10      10/30/07 22:11:53.754           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4160 now running 20_DenonReceiver.sh <0x876cfb90>
01      10/30/07 22:12:55.224           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4160 script 20_DenonReceiver.sh PK_DHCPDevice 23 timed out <0x876cfb90>
08      10/30/07 22:15:05.216             Parameter 13(Filename): 20_DenonReceiver.sh <0xabf18b90>
10      10/30/07 22:17:41.185           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4240 checking detection 20_DenonReceiver.sh <0x87727b90>
08      10/30/07 22:20:51.459             Parameter 13(Filename): /usr/pluto/pnp/20_DenonReceiver.sh <0x9bf50b90>
08      10/30/07 22:20:51.459             Parameter 50(Name): PNP Detection 4240 20_DenonReceiver.sh <0x9bf50b90>
08      10/30/07 22:20:51.459             Parameter 51(Arguments): 14   4240    pci0000:00/0000:00:0a.0+2       20_DenonReceiver.sh        <0x9bf50b90>
08      10/30/07 22:20:51.459             Parameter 94(SendOnFailure): 0 14 1 806 224 4240 13 "20_DenonReceiver.sh" 18 FAIL <0x9bf50b90>
08      10/30/07 22:20:51.459             Parameter 95(SendOnSuccess): 0 14 1 806 224 4240 13 "20_DenonReceiver.sh" 18 OK <0x9bf50b90>
08      10/30/07 22:20:51.465             Parameter 9(Text): Running detection script: 20_DenonReceiver.sh <0x9c751b90>
10      10/30/07 22:20:51.518           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4240 now running 20_DenonReceiver.sh <0x87727b90>
01      10/30/07 22:21:52.890           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4240 script 20_DenonReceiver.sh PK_DHCPDevice 23 timed out <0x87727b90>
08      10/30/07 22:24:03.470             Parameter 13(Filename): 20_DenonReceiver.sh <0xaf777b90>
10      10/30/07 22:26:42.154           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4320 checking detection 20_DenonReceiver.sh <0x86fd1b90>
08      10/30/07 22:29:52.751             Parameter 13(Filename): /usr/pluto/pnp/20_DenonReceiver.sh <0x9bffbb90>
08      10/30/07 22:29:52.751             Parameter 50(Name): PNP Detection 4320 20_DenonReceiver.sh <0x9bffbb90>
08      10/30/07 22:29:52.751             Parameter 51(Arguments): 14   4320    pci0000:00/0000:00:0a.0+2       20_DenonReceiver.sh        <0x9bffbb90>
08      10/30/07 22:29:52.751             Parameter 94(SendOnFailure): 0 14 1 806 224 4320 13 "20_DenonReceiver.sh" 18 FAIL <0x9bffbb90>
08      10/30/07 22:29:52.752             Parameter 95(SendOnSuccess): 0 14 1 806 224 4320 13 "20_DenonReceiver.sh" 18 OK <0x9bffbb90>
10      10/30/07 22:29:52.773           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4320 now running 20_DenonReceiver.sh <0x86fd1b90>
08      10/30/07 22:29:52.777             Parameter 9(Text): Running detection script: 20_DenonReceiver.sh <0x9c7fcb90>
01      10/30/07 22:30:54.193           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4320 script 20_DenonReceiver.sh PK_DHCPDevice 23 timed out <0x86fd1b90>
08      10/30/07 22:33:04.259             Parameter 13(Filename): 20_DenonReceiver.sh <0xae32db90>
10      10/30/07 22:35:35.662           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4400 checking detection 20_DenonReceiver.sh <0x875f7b90>
08      10/30/07 22:38:46.005             Parameter 13(Filename): /usr/pluto/pnp/20_DenonReceiver.sh <0x9bf4bb90>
08      10/30/07 22:38:46.005             Parameter 50(Name): PNP Detection 4400 20_DenonReceiver.sh <0x9bf4bb90>
08      10/30/07 22:38:46.005             Parameter 51(Arguments): 14   4400    pci0000:00/0000:00:0a.0+2       20_DenonReceiver.sh        <0x9bf4bb90>
08      10/30/07 22:38:46.006             Parameter 94(SendOnFailure): 0 14 1 806 224 4400 13 "20_DenonReceiver.sh" 18 FAIL <0x9bf4bb90>
08      10/30/07 22:38:46.006             Parameter 95(SendOnSuccess): 0 14 1 806 224 4400 13 "20_DenonReceiver.sh" 18 OK <0x9bf4bb90>
08      10/30/07 22:38:46.020             Parameter 9(Text): Running detection script: 20_DenonReceiver.sh <0x9cf4db90>
10      10/30/07 22:38:46.071           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4400 now running 20_DenonReceiver.sh <0x875f7b90>
01      10/30/07 22:39:47.446           PnpQueue::Process_Detect_Stage_Running_Detction_Scripts queue 4400 script 20_DenonReceiver.sh PK_DHCPDevice 23 timed out <0x875f7b90>

Any idea why it happened?
Title: Re: Strange problem with running 20_DenonReceiver.sh
Post by: PeteK on October 30, 2007, 10:30:48 pm
Can you give us a few more details on your setup?  I assume you have a Denon receiver device created?  If not, it looks like something that might be run by the AV wizard trying to figure out if you have a known receiver type attached.

-Pete K
Title: Re: Strange problem with running 20_DenonReceiver.sh
Post by: nite_man on October 30, 2007, 10:49:51 pm
I don't have Denon receiver. Moreover, I don't have any receivers. Usually, 20_DenonReceiver.sh run every time but only once right after boot. so, I have no idea why it started to run continuously.
Title: Re: Strange problem with running 20_DenonReceiver.sh
Post by: alx9r on May 21, 2008, 06:17:44 am
I had a similar problem with my Sharp Aquos LC-42D64U.  Here's how I solved it: After connecting the RS232 cable for TV control and letting it autodetect, I selected "No, this is not the correct TV" and manually selected the Sharp Acquos LCxxD6U/LCxxD7u. This seems to disable the auto-detection for the port that the TV is connected to. 
Title: Re: Strange problem with running 20_DenonReceiver.sh
Post by: nite_man on May 29, 2008, 10:42:11 am
Thanks for your suggestion, alx9r. It sounds reasonable :) BWT, you have really cool installation! Thanks for sharing this!